* Fri Jan 11 2008 Joe Orton <jorton@redhat.com> 5.2.5-5
- ext/date: use system timezone database
This commit is contained in:
parent
7c0af4f2cd
commit
a5c5fb30dc
254
php-5.2.5-systzdata.patch
Normal file
254
php-5.2.5-systzdata.patch
Normal file
@ -0,0 +1,254 @@
|
||||
--- php-5.2.5/ext/date/lib/timelib.m4.systzdata
|
||||
+++ php-5.2.5/ext/date/lib/timelib.m4
|
||||
@@ -78,3 +78,17 @@ stdlib.h
|
||||
|
||||
dnl Check for strtoll, atoll
|
||||
AC_CHECK_FUNCS(strtoll atoll strftime)
|
||||
+
|
||||
+PHP_ARG_WITH(system-tzdata, for use of system timezone data,
|
||||
+[ --with-system-tzdata[=DIR] to specify use of system timezone data],
|
||||
+no, no)
|
||||
+
|
||||
+if test "$PHP_SYSTEM_TZDATA" != "no"; then
|
||||
+ AC_DEFINE(HAVE_SYSTEM_TZDATA, 1, [Define if system timezone data is used])
|
||||
+
|
||||
+ if test "$PHP_SYSTEM_TZDATA" != "yes"; then
|
||||
+ AC_DEFINE_UNQUOTED(HAVE_SYSTEM_TZDATA_PREFIX, "$PHP_SYSTEM_TZDATA",
|
||||
+ [Define for location of system timezone data])
|
||||
+ fi
|
||||
+fi
|
||||
+
|
||||
--- php-5.2.5/ext/date/lib/parse_tz.c.systzdata
|
||||
+++ php-5.2.5/ext/date/lib/parse_tz.c
|
||||
@@ -20,6 +20,16 @@
|
||||
|
||||
#include "timelib.h"
|
||||
|
||||
+#ifdef HAVE_SYSTEM_TZDATA
|
||||
+#include <sys/mman.h>
|
||||
+#include <sys/stat.h>
|
||||
+#include <limits.h>
|
||||
+#include <fcntl.h>
|
||||
+#include <unistd.h>
|
||||
+
|
||||
+#include "php_scandir.h"
|
||||
+#endif
|
||||
+
|
||||
#include <stdio.h>
|
||||
|
||||
#ifdef HAVE_LOCALE_H
|
||||
@@ -31,7 +41,10 @@
|
||||
#else
|
||||
#include <strings.h>
|
||||
#endif
|
||||
+
|
||||
+#ifndef HAVE_SYSTEM_TZDATA
|
||||
#include "timezonedb.h"
|
||||
+#endif
|
||||
|
||||
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
|
||||
# if defined(__LITTLE_ENDIAN__)
|
||||
@@ -206,6 +219,195 @@ void timelib_dump_tzinfo(timelib_tzinfo
|
||||
}
|
||||
}
|
||||
|
||||
+#ifdef HAVE_SYSTEM_TZDATA
|
||||
+
|
||||
+#ifdef HAVE_SYSTEM_TZDATA_PREFIX
|
||||
+#define ZONEINFO_PREFIX HAVE_SYSTEM_TZDATA_PREFIX
|
||||
+#else
|
||||
+#define ZONEINFO_PREFIX "/usr/share/zoneinfo"
|
||||
+#endif
|
||||
+
|
||||
+static const timelib_tzdb *timezonedb_system = NULL;
|
||||
+
|
||||
+/* Filter out some non-tzdata files and the posix/right databases, if
|
||||
+ * present. */
|
||||
+static int index_filter(const struct dirent *ent)
|
||||
+{
|
||||
+ return strcmp(ent->d_name, ".") != 0
|
||||
+ && strcmp(ent->d_name, "..") != 0
|
||||
+ && strcmp(ent->d_name, "posix") != 0
|
||||
+ && strcmp(ent->d_name, "posixrules") != 0
|
||||
+ && strcmp(ent->d_name, "right") != 0
|
||||
+ && strstr(ent->d_name, ".tab") == NULL;
|
||||
+}
|
||||
+
|
||||
+/* Create the zone identifier index by trawling the filesystem. */
|
||||
+static void create_zone_index(timelib_tzdb *db)
|
||||
+{
|
||||
+ size_t dirstack_size, dirstack_top;
|
||||
+ size_t index_size, index_next;
|
||||
+ timelib_tzdb_index_entry *db_index;
|
||||
+ char **dirstack;
|
||||
+
|
||||
+ /* LIFO stack to hold directory entres to scan; each slot is a
|
||||
+ * directory name relative to the zoneinfo prefix. */
|
||||
+ dirstack_size = 32;
|
||||
+ dirstack = malloc(dirstack_size * sizeof *dirstack);
|
||||
+ dirstack_top = 1;
|
||||
+ dirstack[0] = strdup("");
|
||||
+
|
||||
+ /* Index array. */
|
||||
+ index_size = 64;
|
||||
+ db_index = malloc(index_size * sizeof *db_index);
|
||||
+ index_next = 0;
|
||||
+
|
||||
+ do {
|
||||
+ struct dirent **ents;
|
||||
+ char name[PATH_MAX], *top;
|
||||
+ int count;
|
||||
+
|
||||
+ /* Pop the top stack entry, and iterate through its contents. */
|
||||
+ top = dirstack[--dirstack_top];
|
||||
+ snprintf(name, sizeof name, ZONEINFO_PREFIX "/%s", top);
|
||||
+
|
||||
+ count = php_scandir(name, &ents, index_filter, php_alphasort);
|
||||
+
|
||||
+ while (count > 0) {
|
||||
+ struct stat st;
|
||||
+ const char *leaf = ents[count - 1]->d_name;
|
||||
+
|
||||
+ snprintf(name, sizeof name, ZONEINFO_PREFIX "/%s/%s",
|
||||
+ top, leaf);
|
||||
+
|
||||
+ if (strlen(name) && stat(name, &st) == 0) {
|
||||
+ /* Name, relative to the zoneinfo prefix. */
|
||||
+ const char *root = top;
|
||||
+
|
||||
+ if (root[0] == '/') root++;
|
||||
+
|
||||
+ snprintf(name, sizeof name, "%s%s%s", root,
|
||||
+ *root ? "/": "", leaf);
|
||||
+
|
||||
+ if (S_ISDIR(st.st_mode)) {
|
||||
+ if (dirstack_top == dirstack_size) {
|
||||
+ dirstack_size *= 2;
|
||||
+ dirstack = realloc(dirstack,
|
||||
+ dirstack_size * sizeof *dirstack);
|
||||
+ }
|
||||
+ dirstack[dirstack_top++] = strdup(name);
|
||||
+ }
|
||||
+ else {
|
||||
+ if (index_next == index_size) {
|
||||
+ index_size *= 2;
|
||||
+ db_index = realloc(db_index,
|
||||
+ index_size * sizeof *db_index);
|
||||
+ }
|
||||
+
|
||||
+ db_index[index_next].id = strdup(name);
|
||||
+ db_index[index_next++].pos = 0;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ free(ents[--count]);
|
||||
+ }
|
||||
+
|
||||
+ free(ents);
|
||||
+ free(top);
|
||||
+ } while (dirstack_top);
|
||||
+
|
||||
+ db->index = db_index;
|
||||
+ db->index_size = index_next;
|
||||
+
|
||||
+ free(dirstack);
|
||||
+}
|
||||
+
|
||||
+/* Return the mmap()ed tzfile if found, else NULL. On success, the
|
||||
+ * length of the mapped data is placed in *length. */
|
||||
+static char *map_tzfile(const char *timezone, size_t *length)
|
||||
+{
|
||||
+ char fname[PATH_MAX];
|
||||
+ struct stat st;
|
||||
+ char *p;
|
||||
+ int fd;
|
||||
+
|
||||
+ if (strstr(timezone, "..") != NULL) {
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
+ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
|
||||
+
|
||||
+ fd = open(fname, O_RDONLY);
|
||||
+ if (fd == -1) {
|
||||
+ return NULL;
|
||||
+ } else if (fstat(fd, &st) != 0 || st.st_size < 21) {
|
||||
+ close(fd);
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
+ *length = st.st_size;
|
||||
+ p = mmap(NULL, st.st_size, PROT_READ, MAP_SHARED, fd, 0);
|
||||
+ close(fd);
|
||||
+
|
||||
+ return p != MAP_FAILED ? p : NULL;
|
||||
+}
|
||||
+
|
||||
+const timelib_tzdb *timelib_builtin_db(void)
|
||||
+{
|
||||
+ if (timezonedb_system == NULL) {
|
||||
+ timelib_tzdb *tmp = malloc(sizeof *tmp);
|
||||
+
|
||||
+ tmp->version = "0.system";
|
||||
+ tmp->data = NULL;
|
||||
+ create_zone_index(tmp);
|
||||
+ timezonedb_system = tmp;
|
||||
+ }
|
||||
+
|
||||
+ return timezonedb_system;
|
||||
+}
|
||||
+
|
||||
+const timelib_tzdb_index_entry *timelib_timezone_builtin_identifiers_list(int *count)
|
||||
+{
|
||||
+ *count = timezonedb_system->index_size;
|
||||
+ return timezonedb_system->index;
|
||||
+}
|
||||
+
|
||||
+int timelib_timezone_id_is_valid(char *timezone, const timelib_tzdb *tzdb)
|
||||
+{
|
||||
+ char fname[PATH_MAX];
|
||||
+
|
||||
+ if (strstr(timezone, "..") != NULL) {
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
+ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
|
||||
+
|
||||
+ return access(fname, R_OK) == 0 ? 1 : 0;
|
||||
+}
|
||||
+
|
||||
+timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
|
||||
+{
|
||||
+ char *tzf, *orig;
|
||||
+ timelib_tzinfo *tmp;
|
||||
+ size_t len;
|
||||
+
|
||||
+ orig = map_tzfile(timezone, &len);
|
||||
+ if (orig == NULL) {
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
+ tmp = timelib_tzinfo_ctor(timezone);
|
||||
+
|
||||
+ tzf = orig + 20;
|
||||
+ read_header(&tzf, tmp);
|
||||
+ read_transistions(&tzf, tmp);
|
||||
+ read_types(&tzf, tmp);
|
||||
+
|
||||
+ munmap(orig, len);
|
||||
+
|
||||
+ return tmp;
|
||||
+}
|
||||
+#else /* !HAVE_SYSTEM_TZDATA */
|
||||
+
|
||||
static int seek_to_tz_position(const unsigned char **tzf, char *timezone, const timelib_tzdb *tzdb)
|
||||
{
|
||||
int left = 0, right = tzdb->index_size - 1;
|
||||
@@ -279,6 +481,7 @@ timelib_tzinfo *timelib_parse_tzfile(cha
|
||||
|
||||
return tmp;
|
||||
}
|
||||
+#endif
|
||||
|
||||
static ttinfo* fetch_timezone_offset(timelib_tzinfo *tz, timelib_sll ts, timelib_sll *transition_time)
|
||||
{
|
8
php.spec
8
php.spec
@ -6,7 +6,7 @@
|
||||
Summary: The PHP HTML-embedded scripting language
|
||||
Name: php
|
||||
Version: 5.2.5
|
||||
Release: 4
|
||||
Release: 5
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -32,6 +32,7 @@ Patch25: php-4.3.9-metaphone.patch
|
||||
# Functional changes
|
||||
Patch30: php-5.0.4-dlopen.patch
|
||||
Patch31: php-5.2.4-easter.patch
|
||||
Patch32: php-5.2.5-systzdata.patch
|
||||
|
||||
# Fixes for tests
|
||||
Patch50: php-5.2.4-tests-dashn.patch
|
||||
@ -360,6 +361,7 @@ into applications to provide PHP scripting language support.
|
||||
|
||||
%patch30 -p1 -b .dlopen
|
||||
%patch31 -p1 -b .easter
|
||||
%patch32 -p1 -b .systzdata
|
||||
|
||||
%patch50 -p1 -b .tests-dashn
|
||||
%patch51 -p1 -b .tests-wddx
|
||||
@ -477,6 +479,7 @@ ln -sf ../configure
|
||||
--without-sqlite \
|
||||
--with-libxml-dir=%{_prefix} \
|
||||
--with-xml \
|
||||
--with-system-tzdata \
|
||||
$*
|
||||
if test $? != 0; then
|
||||
tail -500 config.log
|
||||
@ -718,6 +721,9 @@ rm files.* macros.php
|
||||
%files mssql -f files.mssql
|
||||
|
||||
%changelog
|
||||
* Fri Jan 11 2008 Joe Orton <jorton@redhat.com> 5.2.5-5
|
||||
- ext/date: use system timezone database
|
||||
|
||||
* Fri Dec 28 2007 Joe Orton <jorton@redhat.com> 5.2.5-4
|
||||
- rebuild for libc-client bump
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user