update to 5.2.7
This commit is contained in:
parent
29b358ac74
commit
a0a966d3fb
@ -1,4 +1 @@
|
||||
php-5.2.3
|
||||
clog
|
||||
*.tar.gz
|
||||
*.rpm
|
||||
php-5.2.7.tar.bz2
|
||||
|
@ -1,55 +0,0 @@
|
||||
--- php-5.2.4/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
||||
+++ php-5.2.4/ext/standard/tests/file/bug26615.phpt
|
||||
@@ -7,9 +7,9 @@ variables_order=E
|
||||
$out = array();
|
||||
$status = -1;
|
||||
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
||||
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
|
||||
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
|
||||
} else {
|
||||
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
|
||||
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
|
||||
}
|
||||
print_r($out);
|
||||
?>
|
||||
--- php-5.2.4/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
||||
+++ php-5.2.4/ext/standard/tests/file/proc_open01.phpt
|
||||
@@ -9,7 +9,7 @@ if ($php === false) {
|
||||
die("no php executable defined");
|
||||
}
|
||||
$proc = proc_open(
|
||||
- $php,
|
||||
+ $php . " -n",
|
||||
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
|
||||
$pipes
|
||||
);
|
||||
--- php-5.2.4/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
||||
+++ php-5.2.4/ext/standard/tests/file/bug26938.phpt
|
||||
@@ -6,14 +6,14 @@ $out = array();
|
||||
$status = -1;
|
||||
$php = getenv('TEST_PHP_EXECUTABLE');
|
||||
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
||||
- exec($php . ' -r \''
|
||||
+ exec($php . ' -n -r \''
|
||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||
. 'foreach($lengths as $length) {'
|
||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||
. ' print "\n";'
|
||||
. '}\'', $out, $status);
|
||||
} else {
|
||||
- exec($php . ' -r "'
|
||||
+ exec($php . ' -n -r "'
|
||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||
. 'foreach($lengths as $length) {'
|
||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||
--- php-5.2.4/Makefile.global.tests-dashn
|
||||
+++ php-5.2.4/Makefile.global
|
||||
@@ -63,7 +63,7 @@ install-headers:
|
||||
done; \
|
||||
fi
|
||||
|
||||
-PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
|
||||
+PHP_TEST_SETTINGS = -n -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
|
||||
PHP_TEST_SHARED_EXTENSIONS = ` \
|
||||
if test "x$(PHP_MODULES)" != "x"; then \
|
||||
for i in $(PHP_MODULES)""; do \
|
11
php-5.2.7-tests-dashn.patch
Normal file
11
php-5.2.7-tests-dashn.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- php-5.2.7/Makefile.global.orig 2008-12-05 07:37:27.000000000 +0100
|
||||
+++ php-5.2.7/Makefile.global 2008-12-05 07:37:55.000000000 +0100
|
||||
@@ -67,7 +67,7 @@
|
||||
done; \
|
||||
fi
|
||||
|
||||
-PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
|
||||
+PHP_TEST_SETTINGS = -n -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
|
||||
PHP_TEST_SHARED_EXTENSIONS = ` \
|
||||
if test "x$(PHP_MODULES)" != "x"; then \
|
||||
for i in $(PHP_MODULES)""; do \
|
18
php.spec
18
php.spec
@ -7,13 +7,13 @@
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.2.6
|
||||
Release: 7
|
||||
Version: 5.2.7
|
||||
Release: 1%{?dist}
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
|
||||
Source0: http://www.php.net/distributions/php-%{version}.tar.gz
|
||||
Source0: http://www.php.net/distributions/php-%{version}.tar.bz2
|
||||
Source1: php.conf
|
||||
Source2: php.ini
|
||||
Source3: macros.php
|
||||
@ -36,7 +36,7 @@ Patch31: php-5.2.4-easter.patch
|
||||
Patch32: php-5.2.6-systzdata.patch
|
||||
|
||||
# Fixes for tests
|
||||
Patch50: php-5.2.4-tests-dashn.patch
|
||||
Patch50: php-5.2.7-tests-dashn.patch
|
||||
Patch51: php-5.0.4-tests-wddx.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -327,7 +327,7 @@ support for using the tidy library to PHP.
|
||||
%package mssql
|
||||
Summary: MSSQL database module for PHP
|
||||
Group: Development/Languages
|
||||
Requires: php-common = %{version}-%{release}
|
||||
Requires: php-common = %{version}-%{release}, php-pdo
|
||||
BuildRequires: freetds-devel
|
||||
|
||||
%description mssql
|
||||
@ -530,6 +530,7 @@ build --enable-force-cgi-redirect \
|
||||
--with-pdo-mysql=shared,%{_prefix} \
|
||||
--with-pdo-pgsql=shared,%{_prefix} \
|
||||
--with-pdo-sqlite=shared,%{_prefix} \
|
||||
--with-pdo-dblib=shared,%{_prefix} \
|
||||
--enable-json=shared \
|
||||
--enable-zip=shared \
|
||||
--with-readline \
|
||||
@ -613,7 +614,7 @@ install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
|
||||
for mod in pgsql mysql mysqli odbc ldap snmp xmlrpc imap \
|
||||
mbstring ncurses gd dom xsl soap bcmath dba xmlreader xmlwriter \
|
||||
pdo pdo_mysql pdo_pgsql pdo_odbc pdo_sqlite json zip \
|
||||
dbase mcrypt mhash tidy mssql pspell; do
|
||||
dbase mcrypt mhash tidy pdo_dblib mssql pspell; do
|
||||
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${mod}.ini <<EOF
|
||||
; Enable ${mod} extension module
|
||||
extension=${mod}.so
|
||||
@ -631,6 +632,7 @@ cat files.dom files.xsl files.xml{reader,writer} > files.xml
|
||||
cat files.mysqli >> files.mysql
|
||||
|
||||
# Split out the PDO modules
|
||||
cat files.pdo_dblib >> files.mssql
|
||||
cat files.pdo_mysql >> files.mysql
|
||||
cat files.pdo_pgsql >> files.pgsql
|
||||
cat files.pdo_odbc >> files.odbc
|
||||
@ -729,6 +731,10 @@ rm files.* macros.php
|
||||
%files pspell -f files.pspell
|
||||
|
||||
%changelog
|
||||
* Fri Dec 05 2008 Remi Collet <Fedora@FamilleCollet.com> 5.2.7-1
|
||||
- update to 5.2.7
|
||||
- enable pdo_dblib driver in php-mssql
|
||||
|
||||
* Mon Nov 24 2008 Joe Orton <jorton@redhat.com> 5.2.6-7
|
||||
- tweak Summary, thanks to Richard Hughes
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user