update to 5.6.7RC1, for Koschei
This commit is contained in:
parent
bb646a4440
commit
9e7e41a91b
1
.gitignore
vendored
1
.gitignore
vendored
@ -41,3 +41,4 @@ php-5.5.*.xz
|
|||||||
/php-5.6.5-strip.tar.xz
|
/php-5.6.5-strip.tar.xz
|
||||||
/php-5.6.6RC1-strip.tar.xz
|
/php-5.6.6RC1-strip.tar.xz
|
||||||
/php-5.6.6-strip.tar.xz
|
/php-5.6.6-strip.tar.xz
|
||||||
|
/php-5.6.7RC1-strip.tar.xz
|
||||||
|
40
php-odbc.patch
Normal file
40
php-odbc.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
From 89f86119d612d539a4ec189aff4d3c077cb608a1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Remi Collet <remi@php.net>
|
||||||
|
Date: Sun, 8 Mar 2015 07:34:51 +0100
|
||||||
|
Subject: [PATCH] Fix odbc build as shared
|
||||||
|
|
||||||
|
Broken since a41aa46759d20e23af92df00b917ca66c6102412
|
||||||
|
---
|
||||||
|
ext/odbc/config.m4 | 9 +++++----
|
||||||
|
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/ext/odbc/config.m4 b/ext/odbc/config.m4
|
||||||
|
index f79c461..9555efd 100644
|
||||||
|
--- a/ext/odbc/config.m4
|
||||||
|
+++ b/ext/odbc/config.m4
|
||||||
|
@@ -99,6 +99,11 @@ AC_DEFUN([PHP_ODBC_FIND_EMPRESS_BCS_LIBS],[
|
||||||
|
dnl
|
||||||
|
dnl configure options
|
||||||
|
dnl
|
||||||
|
+
|
||||||
|
+PHP_ARG_WITH(odbcver,,
|
||||||
|
+[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
|
||||||
|
+ Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
|
||||||
|
+
|
||||||
|
if test -z "$ODBC_TYPE"; then
|
||||||
|
PHP_ARG_WITH(adabas,,
|
||||||
|
[ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
|
||||||
|
@@ -490,10 +495,6 @@ PHP_ARG_WITH(dbmaker,,
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
-PHP_ARG_WITH(odbcver,,
|
||||||
|
-[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
|
||||||
|
- Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
|
||||||
|
-
|
||||||
|
if test "no" != "$PHP_ODBCVER"; then
|
||||||
|
if test "$PHP_ODBCVER" != "0"; then
|
||||||
|
AC_DEFINE_UNQUOTED(ODBCVER, $PHP_ODBCVER, [ The highest supported ODBC version ])
|
||||||
|
--
|
||||||
|
2.1.4
|
||||||
|
|
25
php.spec
25
php.spec
@ -57,11 +57,11 @@
|
|||||||
%global db_devel libdb-devel
|
%global db_devel libdb-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#global rcver RC1
|
%global rcver RC1
|
||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.6.6
|
Version: 5.6.7
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# All files licensed under PHP version 3.01, except
|
# All files licensed under PHP version 3.01, except
|
||||||
# Zend is licensed under Zend
|
# Zend is licensed under Zend
|
||||||
@ -113,6 +113,7 @@ Patch46: php-5.6.3-fixheader.patch
|
|||||||
Patch47: php-5.6.3-phpinfo.patch
|
Patch47: php-5.6.3-phpinfo.patch
|
||||||
|
|
||||||
# Upstream fixes (100+)
|
# Upstream fixes (100+)
|
||||||
|
Patch100: php-odbc.patch
|
||||||
|
|
||||||
# Security fixes (200+)
|
# Security fixes (200+)
|
||||||
|
|
||||||
@ -716,6 +717,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
|||||||
%patch47 -p1 -b .phpinfo
|
%patch47 -p1 -b .phpinfo
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
|
%patch100 -p1 -b .odbc
|
||||||
|
|
||||||
# security patches
|
# security patches
|
||||||
|
|
||||||
@ -1184,9 +1186,9 @@ install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php.d
|
|||||||
%if %{with_zts}
|
%if %{with_zts}
|
||||||
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d
|
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d
|
||||||
%endif
|
%endif
|
||||||
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
|
install -m 755 -d $RPM_BUILD_ROOT%{_sharedstatedir}/php
|
||||||
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
|
install -m 700 -d $RPM_BUILD_ROOT%{_sharedstatedir}/php/session
|
||||||
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
|
install -m 700 -d $RPM_BUILD_ROOT%{_sharedstatedir}/php/wsdlcache
|
||||||
|
|
||||||
# PHP-FPM stuff
|
# PHP-FPM stuff
|
||||||
# Log
|
# Log
|
||||||
@ -1346,8 +1348,8 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
|||||||
%if %{with_zts}
|
%if %{with_zts}
|
||||||
%{_httpd_moddir}/libphp5-zts.so
|
%{_httpd_moddir}/libphp5-zts.so
|
||||||
%endif
|
%endif
|
||||||
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
|
%attr(0770,root,apache) %dir %{_sharedstatedir}/php/session
|
||||||
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
|
%attr(0770,root,apache) %dir %{_sharedstatedir}/php/wsdlcache
|
||||||
%config(noreplace) %{_httpd_confdir}/php.conf
|
%config(noreplace) %{_httpd_confdir}/php.conf
|
||||||
%config(noreplace) %{_httpd_modconfdir}/10-php.conf
|
%config(noreplace) %{_httpd_modconfdir}/10-php.conf
|
||||||
%{_httpd_contentdir}/icons/php.gif
|
%{_httpd_contentdir}/icons/php.gif
|
||||||
@ -1367,7 +1369,7 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
|||||||
%dir %{_libdir}/php-zts
|
%dir %{_libdir}/php-zts
|
||||||
%dir %{_libdir}/php-zts/modules
|
%dir %{_libdir}/php-zts/modules
|
||||||
%endif
|
%endif
|
||||||
%dir %{_localstatedir}/lib/php
|
%dir %{_sharedstatedir}/php
|
||||||
%dir %{_datadir}/php
|
%dir %{_datadir}/php
|
||||||
|
|
||||||
%files cli
|
%files cli
|
||||||
@ -1396,8 +1398,8 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
|||||||
%files fpm
|
%files fpm
|
||||||
%doc php-fpm.conf.default
|
%doc php-fpm.conf.default
|
||||||
%license fpm_LICENSE
|
%license fpm_LICENSE
|
||||||
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
|
%attr(0770,root,apache) %dir %{_sharedstatedir}/php/session
|
||||||
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
|
%attr(0770,root,apache) %dir %{_sharedstatedir}/php/wsdlcache
|
||||||
%config(noreplace) %{_httpd_confdir}/php.conf
|
%config(noreplace) %{_httpd_confdir}/php.conf
|
||||||
%config(noreplace) %{_sysconfdir}/php-fpm.conf
|
%config(noreplace) %{_sysconfdir}/php-fpm.conf
|
||||||
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
|
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
|
||||||
@ -1473,6 +1475,9 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 8 2015 Remi Collet <remi@fedoraproject.org> 5.6.7-0.1.RC1
|
||||||
|
- update to 5.6.7RC1
|
||||||
|
|
||||||
* Thu Feb 19 2015 Remi Collet <remi@fedoraproject.org> 5.6.6-1
|
* Thu Feb 19 2015 Remi Collet <remi@fedoraproject.org> 5.6.6-1
|
||||||
- Update to 5.6.6
|
- Update to 5.6.6
|
||||||
http://www.php.net/releases/5_6_6.php
|
http://www.php.net/releases/5_6_6.php
|
||||||
|
Loading…
Reference in New Issue
Block a user