* Wed Dec 5 2007 Joe Orton <jorton@redhat.com> 5.2.5-2
- update to 5.2.5
This commit is contained in:
parent
c64073fb1d
commit
9b5e1c5950
@ -1,3 +1,4 @@
|
|||||||
php-5.2.3
|
php-5.2.3
|
||||||
clog
|
clog
|
||||||
php-5.2.4.tar.gz
|
*.tar.gz
|
||||||
|
*.rpm
|
||||||
|
@ -1,41 +0,0 @@
|
|||||||
--- php-5.2.2/ext/pdo/pdo_stmt.c.pdosym
|
|
||||||
+++ php-5.2.2/ext/pdo/pdo_stmt.c
|
|
||||||
@@ -37,38 +37,6 @@
|
|
||||||
#include "zend_interfaces.h"
|
|
||||||
#include "php_memory_streams.h"
|
|
||||||
|
|
||||||
-#if COMPILE_DL_PDO
|
|
||||||
-/* {{{ content from zend_arg_defs.c:
|
|
||||||
- * since it is a .c file, it won't be installed for use by PECL extensions, so we include it here. */
|
|
||||||
-ZEND_BEGIN_ARG_INFO(first_arg_force_ref, 0)
|
|
||||||
- ZEND_ARG_PASS_INFO(1)
|
|
||||||
-ZEND_END_ARG_INFO()
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-ZEND_BEGIN_ARG_INFO(second_arg_force_ref, 0)
|
|
||||||
- ZEND_ARG_PASS_INFO(0)
|
|
||||||
- ZEND_ARG_PASS_INFO(1)
|
|
||||||
-ZEND_END_ARG_INFO()
|
|
||||||
-
|
|
||||||
-ZEND_BEGIN_ARG_INFO(third_arg_force_ref, 0)
|
|
||||||
- ZEND_ARG_PASS_INFO(0)
|
|
||||||
- ZEND_ARG_PASS_INFO(0)
|
|
||||||
- ZEND_ARG_PASS_INFO(1)
|
|
||||||
-ZEND_END_ARG_INFO()
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-ZEND_BEGIN_ARG_INFO(fourth_arg_force_ref, 0)
|
|
||||||
- ZEND_ARG_PASS_INFO(0)
|
|
||||||
- ZEND_ARG_PASS_INFO(0)
|
|
||||||
- ZEND_ARG_PASS_INFO(0)
|
|
||||||
- ZEND_ARG_PASS_INFO(1)
|
|
||||||
-ZEND_END_ARG_INFO()
|
|
||||||
-
|
|
||||||
-ZEND_BEGIN_ARG_INFO(all_args_by_ref, 1)
|
|
||||||
-ZEND_END_ARG_INFO()
|
|
||||||
-/* }}} */
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#define PHP_STMT_GET_OBJ \
|
|
||||||
pdo_stmt_t *stmt = (pdo_stmt_t*)zend_object_store_get_object(getThis() TSRMLS_CC); \
|
|
||||||
if (!stmt->dbh) { \
|
|
9
php.spec
9
php.spec
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Summary: The PHP HTML-embedded scripting language
|
Summary: The PHP HTML-embedded scripting language
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.2.4
|
Version: 5.2.5
|
||||||
Release: 3
|
Release: 2
|
||||||
License: PHP
|
License: PHP
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
URL: http://www.php.net/
|
URL: http://www.php.net/
|
||||||
@ -26,7 +26,6 @@ Patch9: php-5.2.4-embed.patch
|
|||||||
# Fixes for extension modules
|
# Fixes for extension modules
|
||||||
Patch21: php-5.2.4-odbc.patch
|
Patch21: php-5.2.4-odbc.patch
|
||||||
Patch22: php-4.3.11-shutdown.patch
|
Patch22: php-4.3.11-shutdown.patch
|
||||||
Patch23: php-5.2.2-pdosym.patch
|
|
||||||
Patch24: php-5.2.3-macropen.patch
|
Patch24: php-5.2.3-macropen.patch
|
||||||
Patch25: php-4.3.9-metaphone.patch
|
Patch25: php-4.3.9-metaphone.patch
|
||||||
|
|
||||||
@ -356,7 +355,6 @@ into applications to provide PHP scripting language support.
|
|||||||
|
|
||||||
%patch21 -p1 -b .odbc
|
%patch21 -p1 -b .odbc
|
||||||
%patch22 -p1 -b .shutdown
|
%patch22 -p1 -b .shutdown
|
||||||
%patch23 -p1 -b .pdosym
|
|
||||||
%patch24 -p1 -b .macropen
|
%patch24 -p1 -b .macropen
|
||||||
%patch25 -p1 -b .metaphone
|
%patch25 -p1 -b .metaphone
|
||||||
|
|
||||||
@ -720,6 +718,9 @@ rm files.* macros.php
|
|||||||
%files mssql -f files.mssql
|
%files mssql -f files.mssql
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 5 2007 Joe Orton <jorton@redhat.com> 5.2.5-2
|
||||||
|
- update to 5.2.5
|
||||||
|
|
||||||
* Mon Oct 15 2007 Joe Orton <jorton@redhat.com> 5.2.4-3
|
* Mon Oct 15 2007 Joe Orton <jorton@redhat.com> 5.2.4-3
|
||||||
- correct pcre BR version (#333021)
|
- correct pcre BR version (#333021)
|
||||||
- restore metaphone fix (#205714)
|
- restore metaphone fix (#205714)
|
||||||
|
Loading…
Reference in New Issue
Block a user