php 5.6.3RC1
- disable opcache.fast_shutdown in default config - enable phpdbg_webhelper new extension (in php-dbg)
This commit is contained in:
parent
54d7f4a86e
commit
9a3a87d0ac
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ php-5.5.*.xz
|
||||
/php-5.6.1RC1-strip.tar.xz
|
||||
/php-5.6.1-strip.tar.xz
|
||||
/php-5.6.2-strip.tar.xz
|
||||
/php-5.6.3RC1-strip.tar.xz
|
||||
|
@ -48,7 +48,7 @@ opcache.max_accelerated_files=4000
|
||||
;opcache.load_comments=1
|
||||
|
||||
; If enabled, a fast shutdown sequence is used for the accelerated code
|
||||
opcache.fast_shutdown=1
|
||||
;opcache.fast_shutdown=0
|
||||
|
||||
; Allow file existence override (file_exists, etc.) performance feature.
|
||||
;opcache.enable_file_override=0
|
||||
|
@ -1,43 +0,0 @@
|
||||
--- ext/standard/tests/strings/setlocale_variation2.phpt.orig 2014-06-11 16:10:00.259326468 +0200
|
||||
+++ ext/standard/tests/strings/setlocale_variation2.phpt 2014-06-11 16:16:14.396138997 +0200
|
||||
@@ -52,6 +52,7 @@
|
||||
//try different locale names
|
||||
$failure_locale = array();
|
||||
$success_count = 0;
|
||||
+$expected = 0;
|
||||
|
||||
echo "-- Test setlocale() with all available locale in the system --\n";
|
||||
// gather all locales installed in the system(stored $all_system_locales),
|
||||
@@ -61,6 +62,10 @@
|
||||
if(setlocale(LC_ALL,$value )){
|
||||
$success_count++;
|
||||
}
|
||||
+ else if ($value == 'no_NO.ISO-8859-1') {
|
||||
+ // ignore this one, see rhbz #971416
|
||||
+ $expected++;
|
||||
+ }
|
||||
else{
|
||||
//failure values are put in to an array $failure_locale
|
||||
$failure_locale[] = $value;
|
||||
@@ -69,11 +74,11 @@
|
||||
|
||||
echo "No of locales found on the machine = ".count($all_system_locales)."\n";
|
||||
echo "No of setlocale() success = ".$success_count."\n";
|
||||
-echo "Expected no of failures = 0\n";
|
||||
+echo "Expected no of failures = $expected\n";
|
||||
echo "Test ";
|
||||
// check if there were any failure of setlocale() function earlier, if any
|
||||
// failure then dump the list of failing locales
|
||||
-if($success_count != count($all_system_locales)){
|
||||
+if(($success_count + $expected) != count($all_system_locales)){
|
||||
echo "FAILED\n";
|
||||
echo "Names of locale() for which setlocale() failed ...\n";
|
||||
var_dump($failure_locale);
|
||||
@@ -89,6 +94,6 @@
|
||||
-- Test setlocale() with all available locale in the system --
|
||||
No of locales found on the machine = %d
|
||||
No of setlocale() success = %d
|
||||
-Expected no of failures = 0
|
||||
+Expected no of failures = %d
|
||||
Test PASSED
|
||||
Done
|
@ -1,39 +0,0 @@
|
||||
diff -up ./ext/pcre/tests/bug37911.phpt.pcre834 ./ext/pcre/tests/bug37911.phpt
|
||||
--- ./ext/pcre/tests/bug37911.phpt.pcre834 2014-03-26 14:10:18.285452752 +0100
|
||||
+++ ./ext/pcre/tests/bug37911.phpt 2014-03-26 14:10:40.028526763 +0100
|
||||
@@ -37,5 +37,5 @@ array(3) {
|
||||
string(4) "blub"
|
||||
}
|
||||
|
||||
-Warning: preg_replace_callback(): Compilation failed: group name must start with a non-digit at offset %d in %sbug37911.php on line %d
|
||||
+Warning: preg_replace_callback(): Numeric named subpatterns are not allowed in %sbug37911.php on line %d
|
||||
NULL
|
||||
diff -up ./ext/pcre/tests/grep2.phpt.pcre834 ./ext/pcre/tests/grep2.phpt
|
||||
--- ./ext/pcre/tests/grep2.phpt.pcre834 2014-03-26 14:08:26.583072531 +0100
|
||||
+++ ./ext/pcre/tests/grep2.phpt 2014-03-26 14:09:09.345218089 +0100
|
||||
@@ -40,12 +40,6 @@ array(1) {
|
||||
string(1) "1"
|
||||
}
|
||||
bool(true)
|
||||
-array(3) {
|
||||
- [5]=>
|
||||
- string(1) "a"
|
||||
- ["xyz"]=>
|
||||
- string(2) "q6"
|
||||
- [6]=>
|
||||
- string(3) "h20"
|
||||
+array(0) {
|
||||
}
|
||||
-bool(false)
|
||||
+bool(true)
|
||||
diff -up ./ext/pcre/tests/match_flags3.phpt.pcre834 ./ext/pcre/tests/match_flags3.phpt
|
||||
--- ./ext/pcre/tests/match_flags3.phpt.pcre834 2014-03-26 14:06:48.792739665 +0100
|
||||
+++ ./ext/pcre/tests/match_flags3.phpt 2014-03-26 14:07:31.820886128 +0100
|
||||
@@ -42,5 +42,5 @@ array(1) {
|
||||
}
|
||||
}
|
||||
|
||||
-Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset %d in %smatch_flags3.php on line %d
|
||||
+Warning: preg_match(): Numeric named subpatterns are not allowed in %smatch_flags3.php on line %d
|
||||
bool(false)
|
||||
diff -up ./ext/standard/tests/strings/setlocale_variation2.phpt.pcre834 ./ext/standard/tests/strings/setlocale_variation2.phpt
|
@ -1,60 +0,0 @@
|
||||
From 0d776ef87b7b0c1e970c424cc5dcdf4cd6f500ac Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Wed, 24 Sep 2014 10:34:55 +0200
|
||||
Subject: [PATCH] Fix bug #68074 Allow to use system cipher list instead of
|
||||
hardcoded value
|
||||
|
||||
---
|
||||
ext/openssl/config0.m4 | 6 ++++++
|
||||
ext/openssl/xp_ssl.c | 9 ++++++---
|
||||
2 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/ext/openssl/config0.m4 b/ext/openssl/config0.m4
|
||||
index a97114f..701e488 100644
|
||||
--- a/ext/openssl/config0.m4
|
||||
+++ b/ext/openssl/config0.m4
|
||||
@@ -8,6 +8,9 @@ PHP_ARG_WITH(openssl, for OpenSSL support,
|
||||
PHP_ARG_WITH(kerberos, for Kerberos support,
|
||||
[ --with-kerberos[=DIR] OPENSSL: Include Kerberos support], no, no)
|
||||
|
||||
+PHP_ARG_WITH(system-ciphers, whether to use system default cipher list instead of hardcoded value,
|
||||
+[ --with-system-ciphers OPENSSL: Use system default cipher list instead of hardcoded value], no, no)
|
||||
+
|
||||
if test "$PHP_OPENSSL" != "no"; then
|
||||
PHP_NEW_EXTENSION(openssl, openssl.c xp_ssl.c, $ext_shared)
|
||||
PHP_SUBST(OPENSSL_SHARED_LIBADD)
|
||||
@@ -25,4 +28,7 @@ if test "$PHP_OPENSSL" != "no"; then
|
||||
], [
|
||||
AC_MSG_ERROR([OpenSSL check failed. Please check config.log for more information.])
|
||||
])
|
||||
+ if test "$PHP_SYSTEM_CIPHERS" != "no"; then
|
||||
+ AC_DEFINE(USE_OPENSSL_SYSTEM_CIPHERS,1,[ Use system default cipher list instead of hardcoded value ])
|
||||
+ fi
|
||||
fi
|
||||
diff --git a/ext/openssl/xp_ssl.c b/ext/openssl/xp_ssl.c
|
||||
index de9e991..2f81dc7 100644
|
||||
--- a/ext/openssl/xp_ssl.c
|
||||
+++ b/ext/openssl/xp_ssl.c
|
||||
@@ -1476,13 +1476,16 @@ int php_openssl_setup_crypto(php_stream *stream,
|
||||
}
|
||||
|
||||
GET_VER_OPT_STRING("ciphers", cipherlist);
|
||||
+#ifndef USE_OPENSSL_SYSTEM_CIPHERS
|
||||
if (!cipherlist) {
|
||||
cipherlist = OPENSSL_DEFAULT_STREAM_CIPHERS;
|
||||
}
|
||||
- if (SSL_CTX_set_cipher_list(sslsock->ctx, cipherlist) != 1) {
|
||||
- return FAILURE;
|
||||
+#endif
|
||||
+ if (cipherlist) {
|
||||
+ if (SSL_CTX_set_cipher_list(sslsock->ctx, cipherlist) != 1) {
|
||||
+ return FAILURE;
|
||||
+ }
|
||||
}
|
||||
-
|
||||
if (FAILURE == set_local_cert(sslsock->ctx, stream TSRMLS_CC)) {
|
||||
return FAILURE;
|
||||
}
|
||||
--
|
||||
2.1.0
|
||||
|
31
php.spec
31
php.spec
@ -57,12 +57,12 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
#global rcver RC1
|
||||
%global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.6.2
|
||||
Release: 1%{?dist}
|
||||
Version: 5.6.3
|
||||
Release: 0.1.RC1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -90,6 +90,7 @@ Source14: nginx-php.conf
|
||||
# Configuration files for some extensions
|
||||
Source50: opcache.ini
|
||||
Source51: opcache-default.blacklist
|
||||
Source52: phpdbg_webhelper.ini
|
||||
|
||||
# Build fixes
|
||||
Patch5: php-5.2.0-includedir.patch
|
||||
@ -114,15 +115,10 @@ Patch46: php-5.4.9-fixheader.patch
|
||||
Patch47: php-5.4.9-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-bug68074.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
# Fixes for tests (300+)
|
||||
# Revert changes for pcre < 8.34
|
||||
Patch301: php-5.6.0-oldpcre.patch
|
||||
# see https://bugzilla.redhat.com/971416
|
||||
Patch302: php-5.6.0-noNO.patch
|
||||
|
||||
|
||||
BuildRequires: bzip2-devel, curl-devel >= 7.9
|
||||
@ -189,6 +185,7 @@ executing PHP scripts, /usr/bin/php, and the CGI interface.
|
||||
Group: Development/Languages
|
||||
Summary: The interactive PHP debugger
|
||||
Requires: php-common%{?_isa} = %{version}-%{release}
|
||||
Provides: php-phpdbg_webhelper, php-phpdbg_webhelper%{?_isa}
|
||||
|
||||
%description dbg
|
||||
The php-dbg package contains the interactive PHP debugger.
|
||||
@ -719,16 +716,10 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .bug68074
|
||||
|
||||
# security patches
|
||||
|
||||
# Fixes for tests
|
||||
%if 0%{?fedora} < 21
|
||||
# Only apply when system libpcre < 8.34
|
||||
%patch301 -p1 -b .pcre834
|
||||
%endif
|
||||
%patch302 -p0 -b .971416
|
||||
|
||||
|
||||
# Prevent %%doc confusion over LICENSE files
|
||||
@ -820,6 +811,7 @@ echo "d /run/php-fpm 755 root root" >php-fpm.tmpfiles
|
||||
|
||||
# Some extensions have their own configuration file
|
||||
cp %{SOURCE50} 10-opcache.ini
|
||||
cp %{SOURCE52} 20-phpdbg_webhelper.ini
|
||||
|
||||
|
||||
%build
|
||||
@ -908,6 +900,7 @@ build --libdir=%{_libdir}/php \
|
||||
--enable-pcntl \
|
||||
--enable-opcache \
|
||||
--enable-phpdbg \
|
||||
--enable-phpdbg-webhelper=shared \
|
||||
--with-imap=shared --with-imap-ssl \
|
||||
--enable-mbstring=shared \
|
||||
--enable-mbregex \
|
||||
@ -1277,6 +1270,9 @@ EOF
|
||||
EOF
|
||||
done
|
||||
|
||||
# This extension is NTS only, for use with phpdbg
|
||||
cp -p 20-phpdbg_webhelper.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.d/20-phpdbg_webhelper.ini
|
||||
|
||||
# The dom, xsl and xml* modules are all packaged in php-xml
|
||||
cat files.dom files.xsl files.xml{reader,writer} files.wddx \
|
||||
files.simplexml >> files.xml
|
||||
@ -1402,6 +1398,8 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
%{_bindir}/phpdbg
|
||||
%doc sapi/phpdbg/{README.md,CREDITS}
|
||||
%{_mandir}/man1/phpdbg.1*
|
||||
%attr(755,root,root) %{_libdir}/php/modules/phpdbg_webhelper.so
|
||||
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/php.d/20-phpdbg_webhelper.ini
|
||||
|
||||
%files fpm
|
||||
%doc php-fpm.conf.default
|
||||
@ -1484,6 +1482,11 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 29 2014 Remi Collet <rcollet@redhat.com> 5.6.3-0.1.RC1
|
||||
- php 5.6.3RC1
|
||||
- disable opcache.fast_shutdown in default config
|
||||
- enable phpdbg_webhelper new extension (in php-dbg)
|
||||
|
||||
* Thu Oct 16 2014 Remi Collet <remi@fedoraproject.org> 5.6.1-1
|
||||
- Update to PHP 5.6.2
|
||||
http://php.net/releases/5_6_2.php
|
||||
|
6
phpdbg_webhelper.ini
Normal file
6
phpdbg_webhelper.ini
Normal file
@ -0,0 +1,6 @@
|
||||
; Enable 'phpdbg_webhelper' extension module
|
||||
extension=phpdbg_webhelper.so
|
||||
|
||||
; Configuration
|
||||
;phpdbg.auth = ''
|
||||
;phpdbg.path = ''
|
Loading…
Reference in New Issue
Block a user