update to 5.6.0RC4
This commit is contained in:
parent
620b02eb7d
commit
9a35acd5b4
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@ php-5.5.*.xz
|
||||
/php-5.6.0RC1-strip.tar.xz
|
||||
/php-5.6.0RC2-strip.tar.xz
|
||||
/php-5.6.0RC3-strip.tar.xz
|
||||
/php-5.6.0RC4-strip.tar.xz
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up php-5.6.0RC1/ext/standard/var_unserializer.c.mock php-5.6.0RC1/ext/standard/var_unserializer.c
|
||||
--- php-5.6.0RC1/ext/standard/var_unserializer.c.mock 2014-06-19 03:26:09.000000000 +0200
|
||||
+++ php-5.6.0RC1/ext/standard/var_unserializer.c 2014-06-23 18:51:04.702265786 +0200
|
||||
@@ -22,6 +22,7 @@
|
||||
#include "php.h"
|
||||
#include "ext/standard/php_var.h"
|
||||
#include "php_incomplete_class.h"
|
||||
+#include "Zend/zend_interfaces.h"
|
||||
|
||||
/* {{{ reference-handling for unserializer: var_* */
|
||||
#define VAR_ENTRIES_MAX 1024
|
||||
@@ -394,7 +395,7 @@ static inline long object_common1(UNSERI
|
||||
|
||||
(*p) += 2;
|
||||
|
||||
- if (ce->serialize == NULL) {
|
||||
+ if (ce->serialize == NULL || ce->unserialize == zend_user_unserialize || ZEND_INTERNAL_CLASS != ce->type) {
|
||||
object_init_ex(*rval, ce);
|
||||
} else {
|
||||
/* If this class implements Serializable, it should not land here but in object_custom(). The passed string
|
10
php.spec
10
php.spec
@ -57,12 +57,12 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
%global rcver RC3
|
||||
%global rcver RC4
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.6.0
|
||||
Release: 0.5.%{rcver}%{?dist}
|
||||
Release: 0.6.%{rcver}%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -110,8 +110,6 @@ Patch45: php-5.4.8-ldap_r.patch
|
||||
Patch46: php-5.4.9-fixheader.patch
|
||||
# drop "Configure command" from phpinfo output
|
||||
Patch47: php-5.4.9-phpinfo.patch
|
||||
# temporary fix (from 5.4/5.5) for unserialize/mock
|
||||
Patch48: php-5.6.0-mock.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
|
||||
@ -708,7 +706,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
||||
%endif
|
||||
%patch46 -p1 -b .fixheader
|
||||
%patch47 -p1 -b .phpinfo
|
||||
%patch48 -p1 -b .mock
|
||||
|
||||
# upstream patches
|
||||
|
||||
@ -1469,6 +1466,9 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 14 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.6.RC4
|
||||
- php 5.6.0RC4
|
||||
|
||||
* Thu Jul 31 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.5.RC3
|
||||
- fpm requires httpd >= 2.4.10 for proxy support in SetHandler
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user