* Sun Sep 16 2007 Joe Orton <jorton@redhat.com> 5.2.4-2
- update to 5.2.4
This commit is contained in:
parent
f9892523da
commit
975ebd97a6
@ -1,2 +1,3 @@
|
|||||||
php-5.2.3
|
php-5.2.3
|
||||||
clog
|
clog
|
||||||
|
php-5.2.4.tar.gz
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
|
|
||||||
Make sure odbc.so is linked against -lodbc etc.
|
|
||||||
|
|
||||||
--- php-4.3.1/ext/odbc/config.m4.odbc 2002-11-12 17:31:39.000000000 +0000
|
|
||||||
+++ php-4.3.1/ext/odbc/config.m4 2003-05-16 09:54:22.000000000 +0100
|
|
||||||
@@ -429,6 +429,8 @@
|
|
||||||
ODBC_TYPE=unixODBC
|
|
||||||
AC_DEFINE(HAVE_UNIXODBC,1,[ ])
|
|
||||||
AC_MSG_RESULT(yes)
|
|
||||||
+ ODBC_SHARED_LIBADD="-lodbc -lodbcpsql"
|
|
||||||
+ PHP_SUBST(ODBC_SHARED_LIBADD)
|
|
||||||
else
|
|
||||||
AC_MSG_RESULT(no)
|
|
||||||
fi
|
|
@ -1,91 +0,0 @@
|
|||||||
--- php-5.1.4/configure.in.gnusrc
|
|
||||||
+++ php-5.1.4/configure.in
|
|
||||||
@@ -39,6 +39,8 @@
|
|
||||||
|
|
||||||
AC_CONFIG_HEADER(main/php_config.h)
|
|
||||||
|
|
||||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
|
||||||
+
|
|
||||||
MAJOR_VERSION=5
|
|
||||||
MINOR_VERSION=1
|
|
||||||
RELEASE_VERSION=4
|
|
||||||
--- php-5.1.4/ext/standard/file.c.gnusrc
|
|
||||||
+++ php-5.1.4/ext/standard/file.c
|
|
||||||
@@ -118,7 +118,6 @@
|
|
||||||
|
|
||||||
#ifdef HAVE_FNMATCH
|
|
||||||
#ifndef _GNU_SOURCE
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#endif
|
|
||||||
#include <fnmatch.h>
|
|
||||||
#endif
|
|
||||||
--- php-5.1.4/ext/interbase/interbase.c.gnusrc
|
|
||||||
+++ php-5.1.4/ext/interbase/interbase.c
|
|
||||||
@@ -24,7 +24,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
--- php-5.1.4/ext/zlib/zlib_fopen_wrapper.c.gnusrc
|
|
||||||
+++ php-5.1.4/ext/zlib/zlib_fopen_wrapper.c
|
|
||||||
@@ -19,7 +19,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_zlib.h"
|
|
||||||
--- php-5.1.4/ext/pdo_firebird/firebird_driver.c.gnusrc
|
|
||||||
+++ php-5.1.4/ext/pdo_firebird/firebird_driver.c
|
|
||||||
@@ -22,7 +22,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_ini.h"
|
|
||||||
--- php-5.1.4/main/php.h.gnusrc
|
|
||||||
+++ php-5.1.4/main/php.h
|
|
||||||
@@ -30,6 +30,7 @@
|
|
||||||
#define PHP_HAVE_STREAMS
|
|
||||||
#define YYDEBUG 0
|
|
||||||
|
|
||||||
+#include "php_config.h"
|
|
||||||
#include "php_version.h"
|
|
||||||
#include "zend.h"
|
|
||||||
#include "zend_qsort.h"
|
|
||||||
--- php-5.1.4/main/streams/memory.c.gnusrc
|
|
||||||
+++ php-5.1.4/main/streams/memory.c
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
/* Memory streams use a dynamic memory buffer to emulate a stream.
|
|
||||||
--- php-5.1.4/main/streams/streams.c.gnusrc
|
|
||||||
+++ php-5.1.4/main/streams/streams.c
|
|
||||||
@@ -21,7 +21,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
||||||
--- php-5.1.4/main/streams/cast.c.gnusrc
|
|
||||||
+++ php-5.1.4/main/streams/cast.c
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
@ -1,10 +0,0 @@
|
|||||||
--- php-5.2.3/sapi/apache2handler/sapi_apache2.c.brigade
|
|
||||||
+++ php-5.2.3/sapi/apache2handler/sapi_apache2.c
|
|
||||||
@@ -634,6 +634,7 @@
|
|
||||||
if (!parent_req) {
|
|
||||||
php_apache_request_dtor(r TSRMLS_CC);
|
|
||||||
ctx->request_processed = 1;
|
|
||||||
+ brigade = apr_brigade_create(r->pool, r->connection->bucket_alloc);
|
|
||||||
bucket = apr_bucket_eos_create(r->connection->bucket_alloc);
|
|
||||||
APR_BRIGADE_INSERT_TAIL(brigade, bucket);
|
|
||||||
|
|
@ -1,41 +0,0 @@
|
|||||||
diff -up php-5.2.3/sapi/embed/config.m4.embed php-5.2.3/sapi/embed/config.m4
|
|
||||||
--- php-5.2.3/sapi/embed/config.m4.embed 2005-05-07 04:51:53.000000000 +0200
|
|
||||||
+++ php-5.2.3/sapi/embed/config.m4 2007-08-10 13:46:30.000000000 +0200
|
|
||||||
@@ -11,7 +11,7 @@ AC_ARG_ENABLE(embed,
|
|
||||||
case $enableval in
|
|
||||||
yes|shared)
|
|
||||||
PHP_EMBED_TYPE=shared
|
|
||||||
- INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(prefix)/lib; \$(INSTALL) -m 0755 $SAPI_SHARED \$(INSTALL_ROOT)\$(prefix)/lib"
|
|
||||||
+ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(libdir); \$(INSTALL) -m 0755 libs/libphp5-$PHP_VERSION.$SHLIB_DL_SUFFIX_NAME \$(INSTALL_ROOT)\$(libdir); \$(LN_S) libphp5-$PHP_VERSION.$SHLIB_DL_SUFFIX_NAME \$(INSTALL_ROOT)\$(libdir)/libphp5.$SHLIB_DL_SUFFIX_NAME"
|
|
||||||
;;
|
|
||||||
static)
|
|
||||||
PHP_EMBED_TYPE=static
|
|
||||||
diff -up php-5.2.3/Makefile.global.embed php-5.2.3/Makefile.global
|
|
||||||
--- php-5.2.3/Makefile.global.embed 2007-08-10 13:19:04.000000000 +0200
|
|
||||||
+++ php-5.2.3/Makefile.global 2007-08-10 13:27:27.000000000 +0200
|
|
||||||
@@ -14,7 +14,7 @@ all: $(all_targets)
|
|
||||||
build-modules: $(PHP_MODULES)
|
|
||||||
|
|
||||||
libphp5.la: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
|
|
||||||
- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
|
|
||||||
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) -release $(PHP_VERSION) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
|
|
||||||
-@$(LIBTOOL) --silent --mode=install cp libphp5.la $(phptempdir)/libphp5.la >/dev/null 2>&1
|
|
||||||
|
|
||||||
libs/libphp5.bundle: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
|
|
||||||
@@ -25,13 +25,9 @@ install: $(all_targets) $(install_target
|
|
||||||
install-sapi: $(OVERALL_TARGET)
|
|
||||||
@echo "Installing PHP SAPI module: $(PHP_SAPI)"
|
|
||||||
-@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
|
|
||||||
- -@if test ! -r $(phptempdir)/libphp5.$(SHLIB_DL_SUFFIX_NAME); then \
|
|
||||||
- for i in 0.0.0 0.0 0; do \
|
|
||||||
- if test -r $(phptempdir)/libphp5.$(SHLIB_DL_SUFFIX_NAME).$$i; then \
|
|
||||||
- $(LN_S) $(phptempdir)/libphp5.$(SHLIB_DL_SUFFIX_NAME).$$i $(phptempdir)/libphp5.$(SHLIB_DL_SUFFIX_NAME); \
|
|
||||||
- break; \
|
|
||||||
- fi; \
|
|
||||||
- done; \
|
|
||||||
+ -@if test ! -r $(phptempdir)/libphp5.$(SHLIB_DL_SUFFIX_NAME) -a \
|
|
||||||
+ -r $(phptempdir)/libphp5-$(PHP_VERSION).$(SHLIB_DL_SUFFIX_NAME); then \
|
|
||||||
+ $(LN_S) $(phptempdir)/libphp5-$(PHP_VERSION).$(SHLIB_DL_SUFFIX_NAME) $(phptempdir)/libphp5.$(SHLIB_DL_SUFFIX_NAME); \
|
|
||||||
fi
|
|
||||||
@$(INSTALL_IT)
|
|
||||||
|
|
@ -1,9 +1,6 @@
|
|||||||
|
--- php-5.2.4/main/logos.h.easter
|
||||||
Remove 7K of April's Fool.
|
+++ php-5.2.4/main/logos.h
|
||||||
|
@@ -491,386 +491,3 @@ static const unsigned char php_logo[] =
|
||||||
--- php-5.2.0/main/logos.h.easter
|
|
||||||
+++ php-5.2.0/main/logos.h
|
|
||||||
@@ -491,386 +491,3 @@
|
|
||||||
102, 63, 251, 220, 139, 16, 65, 26, 16, 112,
|
102, 63, 251, 220, 139, 16, 65, 26, 16, 112,
|
||||||
21, 116, 187, 251, 221, 240, 142, 119, 188, 3,
|
21, 116, 187, 251, 221, 240, 142, 119, 188, 3,
|
||||||
1, 0, 59, 0 };
|
1, 0, 59, 0 };
|
||||||
@ -390,9 +387,9 @@ Remove 7K of April's Fool.
|
|||||||
- 7, 4, 129, 5, 84, 208, 62, 158, 185, 154,
|
- 7, 4, 129, 5, 84, 208, 62, 158, 185, 154,
|
||||||
- 8, 177, 5, 80, 208, 153, 172, 25, 155, 178,
|
- 8, 177, 5, 80, 208, 153, 172, 25, 155, 178,
|
||||||
- 57, 155, 180, 41, 148, 1, 1, 0, 59, 0 };
|
- 57, 155, 180, 41, 148, 1, 1, 0, 59, 0 };
|
||||||
--- php-5.2.0/main/php_logos.c.easter
|
--- php-5.2.4/main/php_logos.c.easter
|
||||||
+++ php-5.2.0/main/php_logos.c
|
+++ php-5.2.4/main/php_logos.c
|
||||||
@@ -56,7 +56,6 @@
|
@@ -56,7 +56,6 @@ int php_init_info_logos(void)
|
||||||
return FAILURE;
|
return FAILURE;
|
||||||
|
|
||||||
php_register_info_logo(PHP_LOGO_GUID , "image/gif", php_logo , sizeof(php_logo));
|
php_register_info_logo(PHP_LOGO_GUID , "image/gif", php_logo , sizeof(php_logo));
|
||||||
@ -400,32 +397,11 @@ Remove 7K of April's Fool.
|
|||||||
php_register_info_logo(ZEND_LOGO_GUID , "image/gif", zend_logo , sizeof(zend_logo));
|
php_register_info_logo(ZEND_LOGO_GUID , "image/gif", zend_logo , sizeof(zend_logo));
|
||||||
|
|
||||||
return SUCCESS;
|
return SUCCESS;
|
||||||
--- php-5.2.0/ext/standard/basic_functions.c.easter
|
--- php-5.2.4/ext/standard/info.c.easter
|
||||||
+++ php-5.2.0/ext/standard/basic_functions.c
|
+++ php-5.2.4/ext/standard/info.c
|
||||||
@@ -1742,10 +1742,6 @@
|
@@ -1058,21 +1058,7 @@ PHP_FUNCTION(phpcredits)
|
||||||
ZEND_END_ARG_INFO()
|
|
||||||
|
|
||||||
static
|
|
||||||
-ZEND_BEGIN_ARG_INFO(arginfo_php_egg_logo_guid, 0)
|
|
||||||
-ZEND_END_ARG_INFO()
|
|
||||||
-
|
|
||||||
-static
|
|
||||||
ZEND_BEGIN_ARG_INFO(arginfo_zend_logo_guid, 0)
|
|
||||||
ZEND_END_ARG_INFO()
|
|
||||||
|
|
||||||
@@ -3116,7 +3112,6 @@
|
|
||||||
PHP_FE(phpcredits, arginfo_phpcredits)
|
|
||||||
PHP_FE(php_logo_guid, arginfo_php_logo_guid)
|
|
||||||
PHP_FE(php_real_logo_guid, arginfo_php_real_logo_guid)
|
|
||||||
- PHP_FE(php_egg_logo_guid, arginfo_php_egg_logo_guid)
|
|
||||||
PHP_FE(zend_logo_guid, arginfo_zend_logo_guid)
|
|
||||||
PHP_FE(php_sapi_name, arginfo_php_sapi_name)
|
|
||||||
PHP_FE(php_uname, arginfo_php_uname)
|
|
||||||
--- php-5.2.0/ext/standard/info.c.easter
|
|
||||||
+++ php-5.2.0/ext/standard/info.c
|
|
||||||
@@ -1046,21 +1046,7 @@
|
|
||||||
*/
|
*/
|
||||||
PHPAPI char *php_logo_guid()
|
PHPAPI char *php_logo_guid(void)
|
||||||
{
|
{
|
||||||
- char *logo_guid;
|
- char *logo_guid;
|
||||||
-
|
-
|
||||||
@ -435,7 +411,7 @@ Remove 7K of April's Fool.
|
|||||||
- the_time = time(NULL);
|
- the_time = time(NULL);
|
||||||
- ta = php_localtime_r(&the_time, &tmbuf);
|
- ta = php_localtime_r(&the_time, &tmbuf);
|
||||||
-
|
-
|
||||||
- if ((ta->tm_mon==3) && (ta->tm_mday==1)) {
|
- if (ta && (ta->tm_mon==3) && (ta->tm_mday==1)) {
|
||||||
- logo_guid = PHP_EGG_LOGO_GUID;
|
- logo_guid = PHP_EGG_LOGO_GUID;
|
||||||
- } else {
|
- } else {
|
||||||
- logo_guid = PHP_LOGO_GUID;
|
- logo_guid = PHP_LOGO_GUID;
|
||||||
@ -446,7 +422,7 @@ Remove 7K of April's Fool.
|
|||||||
|
|
||||||
}
|
}
|
||||||
/* }}} */
|
/* }}} */
|
||||||
@@ -1091,18 +1077,6 @@
|
@@ -1103,18 +1089,6 @@ PHP_FUNCTION(php_real_logo_guid)
|
||||||
}
|
}
|
||||||
/* }}} */
|
/* }}} */
|
||||||
|
|
||||||
@ -465,8 +441,8 @@ Remove 7K of April's Fool.
|
|||||||
/* {{{ proto string zend_logo_guid(void)
|
/* {{{ proto string zend_logo_guid(void)
|
||||||
Return the special ID used to request the Zend logo in phpinfo screens*/
|
Return the special ID used to request the Zend logo in phpinfo screens*/
|
||||||
PHP_FUNCTION(zend_logo_guid)
|
PHP_FUNCTION(zend_logo_guid)
|
||||||
--- php-5.2.0/ext/standard/info.h.easter
|
--- php-5.2.4/ext/standard/info.h.easter
|
||||||
+++ php-5.2.0/ext/standard/info.h
|
+++ php-5.2.4/ext/standard/info.h
|
||||||
@@ -51,7 +51,6 @@
|
@@ -51,7 +51,6 @@
|
||||||
#endif /* HAVE_CREDITS_DEFS */
|
#endif /* HAVE_CREDITS_DEFS */
|
||||||
|
|
||||||
@ -475,7 +451,7 @@ Remove 7K of April's Fool.
|
|||||||
#define ZEND_LOGO_GUID "PHPE9568F35-D428-11d2-A769-00AA001ACF42"
|
#define ZEND_LOGO_GUID "PHPE9568F35-D428-11d2-A769-00AA001ACF42"
|
||||||
#define PHP_CREDITS_GUID "PHPB8B5F2A0-3C92-11d3-A3A9-4C7B08C10000"
|
#define PHP_CREDITS_GUID "PHPB8B5F2A0-3C92-11d3-A3A9-4C7B08C10000"
|
||||||
|
|
||||||
@@ -62,7 +61,6 @@
|
@@ -62,7 +61,6 @@ PHP_FUNCTION(phpcredits);
|
||||||
PHP_FUNCTION(php_logo_guid);
|
PHP_FUNCTION(php_logo_guid);
|
||||||
PHP_FUNCTION(php_real_logo_guid);
|
PHP_FUNCTION(php_real_logo_guid);
|
||||||
PHP_FUNCTION(zend_logo_guid);
|
PHP_FUNCTION(zend_logo_guid);
|
||||||
@ -483,3 +459,24 @@ Remove 7K of April's Fool.
|
|||||||
PHP_FUNCTION(php_sapi_name);
|
PHP_FUNCTION(php_sapi_name);
|
||||||
PHP_FUNCTION(php_uname);
|
PHP_FUNCTION(php_uname);
|
||||||
PHP_FUNCTION(php_ini_scanned_files);
|
PHP_FUNCTION(php_ini_scanned_files);
|
||||||
|
--- php-5.2.4/ext/standard/basic_functions.c.easter
|
||||||
|
+++ php-5.2.4/ext/standard/basic_functions.c
|
||||||
|
@@ -1753,10 +1753,6 @@ ZEND_BEGIN_ARG_INFO(arginfo_php_real_log
|
||||||
|
ZEND_END_ARG_INFO()
|
||||||
|
|
||||||
|
static
|
||||||
|
-ZEND_BEGIN_ARG_INFO(arginfo_php_egg_logo_guid, 0)
|
||||||
|
-ZEND_END_ARG_INFO()
|
||||||
|
-
|
||||||
|
-static
|
||||||
|
ZEND_BEGIN_ARG_INFO(arginfo_zend_logo_guid, 0)
|
||||||
|
ZEND_END_ARG_INFO()
|
||||||
|
|
||||||
|
@@ -3135,7 +3131,6 @@ zend_function_entry basic_functions[] =
|
||||||
|
PHP_FE(phpcredits, arginfo_phpcredits)
|
||||||
|
PHP_FE(php_logo_guid, arginfo_php_logo_guid)
|
||||||
|
PHP_FE(php_real_logo_guid, arginfo_php_real_logo_guid)
|
||||||
|
- PHP_FE(php_egg_logo_guid, arginfo_php_egg_logo_guid)
|
||||||
|
PHP_FE(zend_logo_guid, arginfo_zend_logo_guid)
|
||||||
|
PHP_FE(php_sapi_name, arginfo_php_sapi_name)
|
||||||
|
PHP_FE(php_uname, arginfo_php_uname)
|
39
php-5.2.4-embed.patch
Normal file
39
php-5.2.4-embed.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- php-5.2.4/sapi/embed/config.m4.embed
|
||||||
|
+++ php-5.2.4/sapi/embed/config.m4
|
||||||
|
@@ -12,7 +12,7 @@ if test "$PHP_EMBED" != "no"; then
|
||||||
|
case "$PHP_EMBED" in
|
||||||
|
yes|shared)
|
||||||
|
PHP_EMBED_TYPE=shared
|
||||||
|
- INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(prefix)/lib; \$(INSTALL) -m 0755 $SAPI_SHARED \$(INSTALL_ROOT)\$(prefix)/lib"
|
||||||
|
+ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(libdir); \$(INSTALL) -m 0755 libs/libphp$(PHP_MAJOR_VERSION).$PHP_VERSION.$SHLIB_DL_SUFFIX_NAME \$(INSTALL_ROOT)\$(libdir); \$(LN_S) libphp$(PHP_MAJOR_VERSION).$PHP_VERSION.$SHLIB_DL_SUFFIX_NAME \$(INSTALL_ROOT)\$(libdir)/libphp$(PHP_MAJOR_VERSION).$SHLIB_DL_SUFFIX_NAME"
|
||||||
|
;;
|
||||||
|
static)
|
||||||
|
PHP_EMBED_TYPE=static
|
||||||
|
--- php-5.2.4/Makefile.global.embed
|
||||||
|
+++ php-5.2.4/Makefile.global
|
||||||
|
@@ -14,7 +14,7 @@ all: $(all_targets)
|
||||||
|
build-modules: $(PHP_MODULES)
|
||||||
|
|
||||||
|
libphp$(PHP_MAJOR_VERSION).la: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
|
||||||
|
- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
|
||||||
|
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) -release $(PHP_VERSION) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
|
||||||
|
-@$(LIBTOOL) --silent --mode=install cp $@ $(phptempdir)/$@ >/dev/null 2>&1
|
||||||
|
|
||||||
|
libs/libphp$(PHP_MAJOR_VERSION).bundle: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
|
||||||
|
@@ -25,13 +25,9 @@ install: $(all_targets) $(install_target
|
||||||
|
install-sapi: $(OVERALL_TARGET)
|
||||||
|
@echo "Installing PHP SAPI module: $(PHP_SAPI)"
|
||||||
|
-@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
|
||||||
|
- -@if test ! -r $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(SHLIB_DL_SUFFIX_NAME); then \
|
||||||
|
- for i in 0.0.0 0.0 0; do \
|
||||||
|
- if test -r $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(SHLIB_DL_SUFFIX_NAME).$$i; then \
|
||||||
|
- $(LN_S) $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(SHLIB_DL_SUFFIX_NAME).$$i $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(SHLIB_DL_SUFFIX_NAME); \
|
||||||
|
- break; \
|
||||||
|
- fi; \
|
||||||
|
- done; \
|
||||||
|
+ -@if test ! -r $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(SHLIB_DL_SUFFIX_NAME) -a \
|
||||||
|
+ -r $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(PHP_VERSION).$(SHLIB_DL_SUFFIX_NAME); then \
|
||||||
|
+ $(LN_S) $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(PHP_VERSION).$(SHLIB_DL_SUFFIX_NAME) $(phptempdir)/libphp$(PHP_MAJOR_VERSION).$(SHLIB_DL_SUFFIX_NAME); \
|
||||||
|
fi
|
||||||
|
@$(INSTALL_IT)
|
||||||
|
|
102
php-5.2.4-gnusrc.patch
Normal file
102
php-5.2.4-gnusrc.patch
Normal file
@ -0,0 +1,102 @@
|
|||||||
|
--- php-5.2.4/Zend/zend_language_parser.c.gnusrc
|
||||||
|
+++ php-5.2.4/Zend/zend_language_parser.c
|
||||||
|
@@ -356,6 +356,8 @@
|
||||||
|
#include "zend_API.h"
|
||||||
|
#include "zend_constants.h"
|
||||||
|
|
||||||
|
+#include <string.h>
|
||||||
|
+
|
||||||
|
|
||||||
|
#define YYERROR_VERBOSE
|
||||||
|
#define YYSTYPE znode
|
||||||
|
--- php-5.2.4/main/streams/streams.c.gnusrc
|
||||||
|
+++ php-5.2.4/main/streams/streams.c
|
||||||
|
@@ -21,7 +21,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
--- php-5.2.4/main/streams/cast.c.gnusrc
|
||||||
|
+++ php-5.2.4/main/streams/cast.c
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
--- php-5.2.4/main/streams/memory.c.gnusrc
|
||||||
|
+++ php-5.2.4/main/streams/memory.c
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
PHPAPI int php_url_decode(char *str, int len);
|
||||||
|
--- php-5.2.4/main/php.h.gnusrc
|
||||||
|
+++ php-5.2.4/main/php.h
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#define PHP_HAVE_STREAMS
|
||||||
|
#define YYDEBUG 0
|
||||||
|
|
||||||
|
+#include "php_config.h"
|
||||||
|
#include "php_version.h"
|
||||||
|
#include "zend.h"
|
||||||
|
#include "zend_qsort.h"
|
||||||
|
--- php-5.2.4/ext/standard/file.c.gnusrc
|
||||||
|
+++ php-5.2.4/ext/standard/file.c
|
||||||
|
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
||||||
|
|
||||||
|
#ifdef HAVE_FNMATCH
|
||||||
|
#ifndef _GNU_SOURCE
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#endif
|
||||||
|
#include <fnmatch.h>
|
||||||
|
#endif
|
||||||
|
--- php-5.2.4/ext/pdo_firebird/firebird_driver.c.gnusrc
|
||||||
|
+++ php-5.2.4/ext/pdo_firebird/firebird_driver.c
|
||||||
|
@@ -22,7 +22,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_ini.h"
|
||||||
|
--- php-5.2.4/ext/zlib/zlib_fopen_wrapper.c.gnusrc
|
||||||
|
+++ php-5.2.4/ext/zlib/zlib_fopen_wrapper.c
|
||||||
|
@@ -19,7 +19,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_zlib.h"
|
||||||
|
--- php-5.2.4/ext/interbase/interbase.c.gnusrc
|
||||||
|
+++ php-5.2.4/ext/interbase/interbase.c
|
||||||
|
@@ -24,7 +24,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
--- php-5.2.4/configure.in.gnusrc
|
||||||
|
+++ php-5.2.4/configure.in
|
||||||
|
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||||
|
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||||
|
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||||
|
|
||||||
|
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||||
|
+
|
||||||
|
dnl Setting up the PHP version based on the information above.
|
||||||
|
dnl -------------------------------------------------------------------------
|
||||||
|
|
@ -1,9 +1,6 @@
|
|||||||
|
--- php-5.2.4/acinclude.m4.norpath
|
||||||
Really don't enable any RPATHs if --disable-rpath is given.
|
+++ php-5.2.4/acinclude.m4
|
||||||
|
@@ -432,6 +432,7 @@ AC_DEFUN([PHP_EVAL_INCLINE],[
|
||||||
--- php-5.0.4/acinclude.m4.norpath
|
|
||||||
+++ php-5.0.4/acinclude.m4
|
|
||||||
@@ -833,6 +833,7 @@
|
|
||||||
dnl internal, don't use
|
dnl internal, don't use
|
||||||
AC_DEFUN([_PHP_ADD_LIBPATH_GLOBAL],[
|
AC_DEFUN([_PHP_ADD_LIBPATH_GLOBAL],[
|
||||||
PHP_RUN_ONCE(LIBPATH, $1, [
|
PHP_RUN_ONCE(LIBPATH, $1, [
|
||||||
@ -11,15 +8,11 @@ Really don't enable any RPATHs if --disable-rpath is given.
|
|||||||
test -n "$ld_runpath_switch" && LDFLAGS="$LDFLAGS $ld_runpath_switch$1"
|
test -n "$ld_runpath_switch" && LDFLAGS="$LDFLAGS $ld_runpath_switch$1"
|
||||||
LDFLAGS="$LDFLAGS -L$1"
|
LDFLAGS="$LDFLAGS -L$1"
|
||||||
PHP_RPATHS="$PHP_RPATHS $1"
|
PHP_RPATHS="$PHP_RPATHS $1"
|
||||||
@@ -852,7 +853,11 @@
|
@@ -451,6 +452,7 @@ AC_DEFUN([PHP_ADD_LIBPATH],[
|
||||||
_PHP_ADD_LIBPATH_GLOBAL([$ai_p])
|
|
||||||
],[
|
],[
|
||||||
if test "$ext_shared" = "yes"; then
|
if test "$ext_shared" = "yes"; then
|
||||||
+ if test "x$PHP_RPATH" = "xno"; then
|
$2="-L$ai_p [$]$2"
|
||||||
+ $2="-L$ai_p [$]$2"
|
+ test "x$PHP_RPATH" != "xno" && \
|
||||||
+ else
|
test -n "$ld_runpath_switch" && $2="$ld_runpath_switch$ai_p [$]$2"
|
||||||
$2="$ld_runpath_switch$ai_p -L$ai_p [$]$2"
|
|
||||||
+ fi
|
|
||||||
else
|
else
|
||||||
_PHP_ADD_LIBPATH_GLOBAL([$ai_p])
|
_PHP_ADD_LIBPATH_GLOBAL([$ai_p])
|
||||||
fi
|
|
11
php-5.2.4-odbc.patch
Normal file
11
php-5.2.4-odbc.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- php-5.2.4/ext/odbc/config.m4.odbc
|
||||||
|
+++ php-5.2.4/ext/odbc/config.m4
|
||||||
|
@@ -423,6 +423,8 @@ PHP_ARG_WITH(unixODBC,,
|
||||||
|
PHP_ODBC_CHECK_HEADER(sqlext.h)
|
||||||
|
AC_DEFINE(HAVE_UNIXODBC,1,[ ])
|
||||||
|
AC_MSG_RESULT([$ext_output])
|
||||||
|
+ ODBC_SHARED_LIBADD="-lodbc -lodbcpsql"
|
||||||
|
+ PHP_SUBST(ODBC_SHARED_LIBADD)
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
@ -1,14 +1,6 @@
|
|||||||
|
--- php-5.2.4/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
||||||
Pass -n to php when running tests, to ensure that the system inidir
|
+++ php-5.2.4/ext/standard/tests/file/bug26615.phpt
|
||||||
and hence the installed (old) shared extensions are not loaded.
|
@@ -7,9 +7,9 @@ variables_order=E
|
||||||
|
|
||||||
- when running run-tests.php itself
|
|
||||||
- passed to run-tests.php to ensure it's passed when running each test case
|
|
||||||
- in cases where the PHP executable is run by a test case
|
|
||||||
|
|
||||||
--- php-5.2.2/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
|
||||||
+++ php-5.2.2/ext/standard/tests/file/bug26615.phpt
|
|
||||||
@@ -7,9 +7,9 @@
|
|
||||||
$out = array();
|
$out = array();
|
||||||
$status = -1;
|
$status = -1;
|
||||||
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
||||||
@ -20,9 +12,9 @@ and hence the installed (old) shared extensions are not loaded.
|
|||||||
}
|
}
|
||||||
print_r($out);
|
print_r($out);
|
||||||
?>
|
?>
|
||||||
--- php-5.2.2/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
--- php-5.2.4/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
||||||
+++ php-5.2.2/ext/standard/tests/file/proc_open01.phpt
|
+++ php-5.2.4/ext/standard/tests/file/proc_open01.phpt
|
||||||
@@ -9,7 +9,7 @@
|
@@ -9,7 +9,7 @@ if ($php === false) {
|
||||||
die("no php executable defined");
|
die("no php executable defined");
|
||||||
}
|
}
|
||||||
$proc = proc_open(
|
$proc = proc_open(
|
||||||
@ -31,9 +23,9 @@ and hence the installed (old) shared extensions are not loaded.
|
|||||||
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
|
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
|
||||||
$pipes
|
$pipes
|
||||||
);
|
);
|
||||||
--- php-5.2.2/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
--- php-5.2.4/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
||||||
+++ php-5.2.2/ext/standard/tests/file/bug26938.phpt
|
+++ php-5.2.4/ext/standard/tests/file/bug26938.phpt
|
||||||
@@ -6,14 +6,14 @@
|
@@ -6,14 +6,14 @@ $out = array();
|
||||||
$status = -1;
|
$status = -1;
|
||||||
$php = getenv('TEST_PHP_EXECUTABLE');
|
$php = getenv('TEST_PHP_EXECUTABLE');
|
||||||
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
||||||
@ -50,14 +42,14 @@ and hence the installed (old) shared extensions are not loaded.
|
|||||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||||
. 'foreach($lengths as $length) {'
|
. 'foreach($lengths as $length) {'
|
||||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||||
--- php-5.2.2/Makefile.global.tests-dashn
|
--- php-5.2.4/Makefile.global.tests-dashn
|
||||||
+++ php-5.2.2/Makefile.global
|
+++ php-5.2.4/Makefile.global
|
||||||
@@ -79,7 +79,7 @@
|
@@ -63,7 +63,7 @@ install-headers:
|
||||||
TEST_PHP_EXECUTABLE=$(top_builddir)/$(SAPI_CLI_PATH) \
|
done; \
|
||||||
TEST_PHP_SRCDIR=$(top_srcdir) \
|
|
||||||
CC="$(CC)" \
|
|
||||||
- $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php $(TESTS); \
|
|
||||||
+ $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php -n $(TESTS); \
|
|
||||||
else \
|
|
||||||
echo "ERROR: Cannot run tests without CLI sapi."; \
|
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
-PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
|
||||||
|
+PHP_TEST_SETTINGS = -n -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
|
||||||
|
PHP_TEST_SHARED_EXTENSIONS = ` \
|
||||||
|
if test "x$(PHP_MODULES)" != "x"; then \
|
||||||
|
for i in $(PHP_MODULES)""; do \
|
19
php.spec
19
php.spec
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Summary: The PHP HTML-embedded scripting language
|
Summary: The PHP HTML-embedded scripting language
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.2.3
|
Version: 5.2.4
|
||||||
Release: 9
|
Release: 2
|
||||||
License: PHP
|
License: PHP
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
URL: http://www.php.net/
|
URL: http://www.php.net/
|
||||||
@ -16,25 +16,25 @@ Source1: php.conf
|
|||||||
Source2: php.ini
|
Source2: php.ini
|
||||||
Source3: macros.php
|
Source3: macros.php
|
||||||
|
|
||||||
Patch1: php-5.1.4-gnusrc.patch
|
Patch1: php-5.2.4-gnusrc.patch
|
||||||
Patch2: php-4.3.3-install.patch
|
Patch2: php-4.3.3-install.patch
|
||||||
Patch3: php-5.0.4-norpath.patch
|
Patch3: php-5.2.4-norpath.patch
|
||||||
Patch5: php-5.0.2-phpize64.patch
|
Patch5: php-5.0.2-phpize64.patch
|
||||||
Patch8: php-5.2.0-includedir.patch
|
Patch8: php-5.2.0-includedir.patch
|
||||||
Patch9: php-5.2.3-embed.patch
|
Patch9: php-5.2.4-embed.patch
|
||||||
|
|
||||||
# Fixes for extension modules
|
# Fixes for extension modules
|
||||||
Patch21: php-4.3.1-odbc.patch
|
Patch21: php-5.2.4-odbc.patch
|
||||||
Patch22: php-4.3.11-shutdown.patch
|
Patch22: php-4.3.11-shutdown.patch
|
||||||
Patch23: php-5.2.2-pdosym.patch
|
Patch23: php-5.2.2-pdosym.patch
|
||||||
Patch24: php-5.2.3-macropen.patch
|
Patch24: php-5.2.3-macropen.patch
|
||||||
|
|
||||||
# Functional changes
|
# Functional changes
|
||||||
Patch30: php-5.0.4-dlopen.patch
|
Patch30: php-5.0.4-dlopen.patch
|
||||||
Patch31: php-5.0.0-easter.patch
|
Patch31: php-5.2.4-easter.patch
|
||||||
|
|
||||||
# Fixes for tests
|
# Fixes for tests
|
||||||
Patch50: php-5.0.4-tests-dashn.patch
|
Patch50: php-5.2.4-tests-dashn.patch
|
||||||
Patch51: php-5.0.4-tests-wddx.patch
|
Patch51: php-5.0.4-tests-wddx.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -716,6 +716,9 @@ rm files.* macros.php
|
|||||||
%files mssql -f files.mssql
|
%files mssql -f files.mssql
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Sep 16 2007 Joe Orton <jorton@redhat.com> 5.2.4-2
|
||||||
|
- update to 5.2.4
|
||||||
|
|
||||||
* Sun Sep 2 2007 Joe Orton <jorton@redhat.com> 5.2.3-9
|
* Sun Sep 2 2007 Joe Orton <jorton@redhat.com> 5.2.3-9
|
||||||
- rebuild for fixed APR
|
- rebuild for fixed APR
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user