update to 7.2.1RC1
This commit is contained in:
parent
307ba820ef
commit
952ff17391
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ php-7.1.*.xz
|
|||||||
/php-7.2.0RC5.tar.xz
|
/php-7.2.0RC5.tar.xz
|
||||||
/php-7.2.0RC6.tar.xz
|
/php-7.2.0RC6.tar.xz
|
||||||
/php-7.2.0.tar.xz
|
/php-7.2.0.tar.xz
|
||||||
|
/php-7.2.1RC1.tar.xz
|
||||||
|
@ -1,89 +0,0 @@
|
|||||||
From 00500c425ba895f1b3591ace3ccd5ee125307559 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Remi Collet <remi@remirepo.net>
|
|
||||||
Date: Mon, 13 Nov 2017 09:55:10 +0100
|
|
||||||
Subject: [PATCH] Fixed bug #75514 mt_rand returns value outside [$min,$max]+
|
|
||||||
on 32-bit
|
|
||||||
|
|
||||||
---
|
|
||||||
ext/standard/mt_rand.c | 4 ++--
|
|
||||||
ext/standard/tests/math/bug75514.phpt | 12 ++++++++++++
|
|
||||||
2 files changed, 14 insertions(+), 2 deletions(-)
|
|
||||||
create mode 100644 ext/standard/tests/math/bug75514.phpt
|
|
||||||
|
|
||||||
diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
|
|
||||||
index 2335a92..6669cbc 100644
|
|
||||||
--- a/ext/standard/mt_rand.c
|
|
||||||
+++ b/ext/standard/mt_rand.c
|
|
||||||
@@ -294,7 +294,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
|
|
||||||
* rand() allows min > max, mt_rand does not */
|
|
||||||
PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
|
|
||||||
{
|
|
||||||
- zend_long n;
|
|
||||||
+ uint32_t n;
|
|
||||||
|
|
||||||
if (BG(mt_rand_mode) == MT_RAND_MT19937) {
|
|
||||||
return php_mt_rand_range(min, max);
|
|
||||||
@@ -302,7 +302,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
|
|
||||||
|
|
||||||
/* Legacy mode deliberately not inside php_mt_rand_range()
|
|
||||||
* to prevent other functions being affected */
|
|
||||||
- n = (zend_long)php_mt_rand() >> 1;
|
|
||||||
+ n = php_mt_rand() >> 1;
|
|
||||||
RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
|
|
||||||
|
|
||||||
return n;
|
|
||||||
diff --git a/ext/standard/tests/math/bug75514.phpt b/ext/standard/tests/math/bug75514.phpt
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..af97b6d
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/ext/standard/tests/math/bug75514.phpt
|
|
||||||
@@ -0,0 +1,12 @@
|
|
||||||
+--TEST--
|
|
||||||
+Bug #75514 mt_rand returns value outside [$min,$max]
|
|
||||||
+--FILE--
|
|
||||||
+<?php
|
|
||||||
+mt_srand(0, MT_RAND_PHP);
|
|
||||||
+var_dump(mt_rand(0,999999999), mt_rand(0,999));
|
|
||||||
+?>
|
|
||||||
+===Done===
|
|
||||||
+--EXPECT--
|
|
||||||
+int(448865905)
|
|
||||||
+int(592)
|
|
||||||
+===Done===
|
|
||||||
--
|
|
||||||
2.9.5
|
|
||||||
|
|
||||||
From 2b071028973782ed87e7038e56d47e9897be804a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Remi Collet <remi@php.net>
|
|
||||||
Date: Tue, 28 Nov 2017 17:42:43 +0100
|
|
||||||
Subject: [PATCH] better fix for #75514
|
|
||||||
|
|
||||||
---
|
|
||||||
ext/standard/mt_rand.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
|
|
||||||
index 0a76ab8..46f52db 100644
|
|
||||||
--- a/ext/standard/mt_rand.c
|
|
||||||
+++ b/ext/standard/mt_rand.c
|
|
||||||
@@ -260,7 +260,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
|
|
||||||
* rand() allows min > max, mt_rand does not */
|
|
||||||
PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
|
|
||||||
{
|
|
||||||
- uint32_t n;
|
|
||||||
+ int64_t n;
|
|
||||||
|
|
||||||
if (BG(mt_rand_mode) == MT_RAND_MT19937) {
|
|
||||||
return php_mt_rand_range(min, max);
|
|
||||||
@@ -268,7 +268,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
|
|
||||||
|
|
||||||
/* Legacy mode deliberately not inside php_mt_rand_range()
|
|
||||||
* to prevent other functions being affected */
|
|
||||||
- n = php_mt_rand() >> 1;
|
|
||||||
+ n = (int64_t)php_mt_rand() >> 1;
|
|
||||||
RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
|
|
||||||
|
|
||||||
return n;
|
|
||||||
--
|
|
||||||
2.1.4
|
|
||||||
|
|
11
php.spec
11
php.spec
@ -61,13 +61,13 @@
|
|||||||
%global db_devel libdb-devel
|
%global db_devel libdb-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global upver 7.2.0
|
%global upver 7.2.1
|
||||||
#global rcver RC6
|
%global rcver RC1
|
||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: %{upver}%{?rcver:~%{rcver}}
|
Version: %{upver}%{?rcver:~%{rcver}}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
# All files licensed under PHP version 3.01, except
|
# All files licensed under PHP version 3.01, except
|
||||||
# Zend is licensed under Zend
|
# Zend is licensed under Zend
|
||||||
# TSRM is licensed under BSD
|
# TSRM is licensed under BSD
|
||||||
@ -114,7 +114,6 @@ Patch46: php-7.2.0-fixheader.patch
|
|||||||
Patch47: php-5.6.3-phpinfo.patch
|
Patch47: php-5.6.3-phpinfo.patch
|
||||||
|
|
||||||
# Upstream fixes (100+)
|
# Upstream fixes (100+)
|
||||||
Patch100: 0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
|
|
||||||
|
|
||||||
# Security fixes (200+)
|
# Security fixes (200+)
|
||||||
|
|
||||||
@ -728,7 +727,6 @@ low-level PHP extension for the libsodium cryptographic library.
|
|||||||
%patch47 -p1 -b .phpinfo
|
%patch47 -p1 -b .phpinfo
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p1 -b .upstream
|
|
||||||
|
|
||||||
# security patches
|
# security patches
|
||||||
|
|
||||||
@ -1522,6 +1520,9 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 13 2017 Remi Collet <remi@remirepo.net> - 7.2.1~RC1-1
|
||||||
|
- update to 7.2.1RC1
|
||||||
|
|
||||||
* Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 7.2.0-3
|
* Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 7.2.0-3
|
||||||
- Rebuild for ICU 60.1
|
- Rebuild for ICU 60.1
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (php-7.2.0.tar.xz) = 828d38727edde0dbc6483add6cdc21d33527b887bffaedad2d7f53e25d58a6f661ac341a23db02741bc37248d161aaffd72026dd8ef85ac851594c127d6c0133
|
SHA512 (php-7.2.1RC1.tar.xz) = bfab5564bb514ed9f3281b7a6480fd93e675380c840674c30b12817ba77523dd1abcc26d178223db14770f2e83404b8fe45daf81ab75aca53a20f53177c0df8c
|
||||||
|
Loading…
Reference in New Issue
Block a user