update to 8.1.8RC1
This commit is contained in:
parent
92601500d9
commit
88b84ffce0
2
.gitignore
vendored
2
.gitignore
vendored
@ -30,3 +30,5 @@ php-7.*.xz.asc
|
||||
/php-8.1.7RC1.tar.xz.asc
|
||||
/php-8.1.7.tar.xz
|
||||
/php-8.1.7.tar.xz.asc
|
||||
/php-8.1.8RC1.tar.xz
|
||||
/php-8.1.8RC1.tar.xz.asc
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 2eb2f9d74f22bf35a4915ec95afc53a47ebf1af9 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@remirepo.net>
|
||||
Date: Thu, 2 Jun 2022 08:05:22 +0200
|
||||
Subject: [PATCH] Fix GH-8685 mbstring requires pcre
|
||||
|
||||
---
|
||||
ext/mbstring/mbstring.c | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ext/mbstring/mbstring.c b/ext/mbstring/mbstring.c
|
||||
index 48f22a682a19..4a4088aed3fb 100644
|
||||
--- a/ext/mbstring/mbstring.c
|
||||
+++ b/ext/mbstring/mbstring.c
|
||||
@@ -161,9 +161,18 @@ static const php_mb_nls_ident_list php_mb_default_identify_list[] = {
|
||||
|
||||
/* }}} */
|
||||
|
||||
+/* {{{ mbstring_deps[] */
|
||||
+static const zend_module_dep mbstring_deps[] = {
|
||||
+ ZEND_MOD_REQUIRED("pcre")
|
||||
+ ZEND_MOD_END
|
||||
+};
|
||||
+/* }}} */
|
||||
+
|
||||
/* {{{ zend_module_entry mbstring_module_entry */
|
||||
zend_module_entry mbstring_module_entry = {
|
||||
- STANDARD_MODULE_HEADER,
|
||||
+ STANDARD_MODULE_HEADER_EX,
|
||||
+ NULL,
|
||||
+ mbstring_deps,
|
||||
"mbstring",
|
||||
ext_functions,
|
||||
PHP_MINIT(mbstring),
|
9
php.spec
9
php.spec
@ -64,8 +64,8 @@
|
||||
%bcond_with imap
|
||||
%bcond_without lmdb
|
||||
|
||||
%global upver 8.1.7
|
||||
#global rcver RC1
|
||||
%global upver 8.1.8
|
||||
%global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
@ -121,7 +121,6 @@ Patch45: php-7.4.0-ldap_r.patch
|
||||
Patch47: php-8.1.0-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-mbstring.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -722,7 +721,6 @@ in pure PHP.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .up
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1542,6 +1540,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 21 2022 Remi Collet <remi@remirepo.net> - 8.1.8~RC1-1
|
||||
- update to 8.1.8RC1
|
||||
|
||||
* Wed Jun 8 2022 Remi Collet <remi@remirepo.net> - 8.1.7-1
|
||||
- Update to 8.1.7 - http://www.php.net/releases/8_1_7.php
|
||||
- add upstream patch to initialize pcre before mbstring
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-8.1.7.tar.xz) = 1d72db220f3485310e02b67c41dd6434c26b7118f673ba7f425ff6b79cc96c86fc45bfe9c90b302d719eb9b7a5334f363a92ac309c367aacc93ab31a72a63c45
|
||||
SHA512 (php-8.1.7.tar.xz.asc) = 9c34d74718261ed2a3375bb06a1e4d68b71d091c12558868bd0ab0325a5046e88af0b8a09fc4035169d681f98b14e108c04ea24053d7d80ca4a0cee5510054fa
|
||||
SHA512 (php-8.1.8RC1.tar.xz) = 11a9c4c144a0f7707bc280335b82e8c6cd21d70f846aa7c3a3b3ad8b0dad05b2e3942f7cc2e2e983464819a83ecfc5cb7d7201fcb0b015c60ee48b3a5a178fe7
|
||||
SHA512 (php-8.1.8RC1.tar.xz.asc) = 8c9fbedbb4c09368c70ab2bdaa444e4502438b349373df5cea0b324fd41bfa03d21b3dc85d0bf809800eb27c21b6064e1ef3da13da0344d75da3adcf266bf491
|
||||
|
Loading…
Reference in New Issue
Block a user