Update to 7.3.8 - http://www.php.net/releases/7_3_8.php
This commit is contained in:
parent
2f08402869
commit
6ebb5420fd
@ -1,62 +0,0 @@
|
||||
From f3e71b3b730eabc2b12871b3a19dad815219bcb9 Mon Sep 17 00:00:00 2001
|
||||
From: Nikita Popov <nikita.ppv@gmail.com>
|
||||
Date: Tue, 16 Jul 2019 11:08:27 +0200
|
||||
Subject: [PATCH] Fixed bug #78297
|
||||
|
||||
(cherry picked from commit 8a19fe29de77d7477d59db472dd6aadabd5ac249)
|
||||
---
|
||||
NEWS | 5 +++++
|
||||
sapi/phpdbg/phpdbg_list.c | 1 +
|
||||
sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
|
||||
3 files changed, 22 insertions(+)
|
||||
create mode 100644 sapi/phpdbg/tests/bug78297.phpt
|
||||
|
||||
diff --git a/NEWS b/NEWS
|
||||
index ae6a3c5405d8..76e8f830a0bb 100644
|
||||
--- a/NEWS
|
||||
+++ b/NEWS
|
||||
@@ -1,5 +1,10 @@
|
||||
PHP NEWS
|
||||
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
|
||||
+?? ??? ????, PHP 7.3.8
|
||||
+
|
||||
+- Phpdbg:
|
||||
+ . Fixed bug #78297 (Include unexistent file memory leak). (Nikita)
|
||||
+
|
||||
18 Jul 2019, PHP 7.3.8RC1
|
||||
|
||||
- Core:
|
||||
diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
|
||||
index aab641cb5606..a9b0f4b815cf 100644
|
||||
--- a/sapi/phpdbg/phpdbg_list.c
|
||||
+++ b/sapi/phpdbg/phpdbg_list.c
|
||||
@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
|
||||
} else {
|
||||
zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
|
||||
}
|
||||
+ return NULL;
|
||||
}
|
||||
|
||||
data.buf = estrndup(bufptr, len);
|
||||
diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
|
||||
new file mode 100644
|
||||
index 000000000000..47b13ad60544
|
||||
--- /dev/null
|
||||
+++ b/sapi/phpdbg/tests/bug78297.phpt
|
||||
@@ -0,0 +1,16 @@
|
||||
+--TEST--
|
||||
+Bug #78297: Include unexistent file memory leak
|
||||
+--PHPDBG--
|
||||
+r
|
||||
+q
|
||||
+--FILE--
|
||||
+<?php
|
||||
+include "does_not_exist.php";
|
||||
+--EXPECTF--
|
||||
+[Successful compilation of %s]
|
||||
+prompt>
|
||||
+Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
|
||||
+
|
||||
+Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
|
||||
+[Script ended normally]
|
||||
+prompt>
|
7
php.spec
7
php.spec
@ -60,7 +60,7 @@
|
||||
%endif
|
||||
|
||||
%global upver 7.3.8
|
||||
%global rcver RC1
|
||||
#global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
@ -112,7 +112,6 @@ Patch46: php-7.2.4-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-bug78297.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -732,7 +731,6 @@ low-level PHP extension for the libsodium cryptographic library.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .78297
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1573,6 +1571,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 30 2019 Remi Collet <remi@remirepo.net> - 7.3.8-1
|
||||
- Update to 7.3.8 - http://www.php.net/releases/7_3_8.php
|
||||
|
||||
* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.3.8~RC1-1
|
||||
- update to 7.3.8RC1
|
||||
- add upstream patch for #78297
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (php-7.3.8RC1.tar.xz) = 83cf25160c925cebabbd743db40f000427a77fb93740fa6221c96339ca492c99f71221ba3e750d7a02b4aa6f65249565fe3dcdaab2f789e5abfac5a6a4bbb1a3
|
||||
SHA512 (php-7.3.8.tar.xz) = 9e9e13845350f3d4a8a80c3e2fe8291996e2749b2c862261b96346c01e5e24640cb81adad5e3b7668b56b2266c1fcbb713e8c38da4f9aa474f5f632f91378a8d
|
||||
|
Loading…
Reference in New Issue
Block a user