better patch
This commit is contained in:
parent
c802620f71
commit
6d4134510c
@ -1,17 +1,27 @@
|
|||||||
|
From 78247eb2209b14c3c1273189dfa2615e2df21214 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Remi Collet <remi@remirepo.net>
|
||||||
|
Date: Mon, 7 Oct 2019 16:31:09 +0200
|
||||||
|
Subject: [PATCH] add librt for opcache
|
||||||
|
|
||||||
|
---
|
||||||
|
ext/opcache/config.m4 | 6 ++++++
|
||||||
|
1 file changed, 6 insertions(+)
|
||||||
|
|
||||||
diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
|
diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
|
||||||
index a388dd787b..6876d37c08 100644
|
index a388dd787b67..931e27b010f5 100644
|
||||||
--- a/ext/opcache/config.m4
|
--- a/ext/opcache/config.m4
|
||||||
+++ b/ext/opcache/config.m4
|
+++ b/ext/opcache/config.m4
|
||||||
@@ -2,7 +2,7 @@ PHP_ARG_ENABLE([opcache],
|
@@ -13,6 +13,9 @@ PHP_ARG_ENABLE([huge-code-pages],
|
||||||
[whether to enable Zend OPcache support],
|
|
||||||
[AS_HELP_STRING([--disable-opcache],
|
|
||||||
[Disable Zend OPcache support])],
|
|
||||||
- [yes])
|
|
||||||
+ [shared])
|
|
||||||
|
|
||||||
PHP_ARG_ENABLE([huge-code-pages],
|
if test "$PHP_OPCACHE" != "no"; then
|
||||||
[whether to enable copying PHP CODE pages into HUGE PAGES],
|
|
||||||
@@ -248,6 +248,9 @@ int main() {
|
+ dnl Always build as shared extension
|
||||||
|
+ ext_shared=yes
|
||||||
|
+
|
||||||
|
if test "$PHP_HUGE_CODE_PAGES" = "yes"; then
|
||||||
|
AC_DEFINE(HAVE_HUGE_CODE_PAGES, 1, [Define to enable copying PHP CODE pages into HUGE PAGES (experimental)])
|
||||||
|
fi
|
||||||
|
@@ -248,6 +251,9 @@ int main() {
|
||||||
Optimizer/zend_dump.c,
|
Optimizer/zend_dump.c,
|
||||||
shared,,-DZEND_ENABLE_STATIC_TSRMLS_CACHE=1,,yes)
|
shared,,-DZEND_ENABLE_STATIC_TSRMLS_CACHE=1,,yes)
|
||||||
|
|
||||||
|
4
php.spec
4
php.spec
@ -882,7 +882,7 @@ pushd build-cgi
|
|||||||
|
|
||||||
build --libdir=%{_libdir}/php \
|
build --libdir=%{_libdir}/php \
|
||||||
--enable-pcntl \
|
--enable-pcntl \
|
||||||
--enable-opcache=shared \
|
--enable-opcache \
|
||||||
--enable-phpdbg \
|
--enable-phpdbg \
|
||||||
%if %{with_imap}
|
%if %{with_imap}
|
||||||
--with-imap=shared --with-imap-ssl \
|
--with-imap=shared --with-imap-ssl \
|
||||||
@ -1011,7 +1011,7 @@ build --includedir=%{_includedir}/php-zts \
|
|||||||
--disable-cgi \
|
--disable-cgi \
|
||||||
--with-config-file-scan-dir=%{_sysconfdir}/php-zts.d \
|
--with-config-file-scan-dir=%{_sysconfdir}/php-zts.d \
|
||||||
--enable-pcntl \
|
--enable-pcntl \
|
||||||
--enable-opcache=shared \
|
--enable-opcache \
|
||||||
%if %{with_imap}
|
%if %{with_imap}
|
||||||
--with-imap=shared --with-imap-ssl \
|
--with-imap=shared --with-imap-ssl \
|
||||||
%endif
|
%endif
|
||||||
|
Loading…
Reference in New Issue
Block a user