update to 7.3.8RC1
add upstream patch for #78297 main package now recommends commonly used extensions (json, mbstring, opcache, pdo, xml)
This commit is contained in:
parent
98b4f820c1
commit
5a9da92807
62
php-bug78297.patch
Normal file
62
php-bug78297.patch
Normal file
@ -0,0 +1,62 @@
|
||||
From f3e71b3b730eabc2b12871b3a19dad815219bcb9 Mon Sep 17 00:00:00 2001
|
||||
From: Nikita Popov <nikita.ppv@gmail.com>
|
||||
Date: Tue, 16 Jul 2019 11:08:27 +0200
|
||||
Subject: [PATCH] Fixed bug #78297
|
||||
|
||||
(cherry picked from commit 8a19fe29de77d7477d59db472dd6aadabd5ac249)
|
||||
---
|
||||
NEWS | 5 +++++
|
||||
sapi/phpdbg/phpdbg_list.c | 1 +
|
||||
sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
|
||||
3 files changed, 22 insertions(+)
|
||||
create mode 100644 sapi/phpdbg/tests/bug78297.phpt
|
||||
|
||||
diff --git a/NEWS b/NEWS
|
||||
index ae6a3c5405d8..76e8f830a0bb 100644
|
||||
--- a/NEWS
|
||||
+++ b/NEWS
|
||||
@@ -1,5 +1,10 @@
|
||||
PHP NEWS
|
||||
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
|
||||
+?? ??? ????, PHP 7.3.8
|
||||
+
|
||||
+- Phpdbg:
|
||||
+ . Fixed bug #78297 (Include unexistent file memory leak). (Nikita)
|
||||
+
|
||||
18 Jul 2019, PHP 7.3.8RC1
|
||||
|
||||
- Core:
|
||||
diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
|
||||
index aab641cb5606..a9b0f4b815cf 100644
|
||||
--- a/sapi/phpdbg/phpdbg_list.c
|
||||
+++ b/sapi/phpdbg/phpdbg_list.c
|
||||
@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
|
||||
} else {
|
||||
zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
|
||||
}
|
||||
+ return NULL;
|
||||
}
|
||||
|
||||
data.buf = estrndup(bufptr, len);
|
||||
diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
|
||||
new file mode 100644
|
||||
index 000000000000..47b13ad60544
|
||||
--- /dev/null
|
||||
+++ b/sapi/phpdbg/tests/bug78297.phpt
|
||||
@@ -0,0 +1,16 @@
|
||||
+--TEST--
|
||||
+Bug #78297: Include unexistent file memory leak
|
||||
+--PHPDBG--
|
||||
+r
|
||||
+q
|
||||
+--FILE--
|
||||
+<?php
|
||||
+include "does_not_exist.php";
|
||||
+--EXPECTF--
|
||||
+[Successful compilation of %s]
|
||||
+prompt>
|
||||
+Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
|
||||
+
|
||||
+Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
|
||||
+[Script ended normally]
|
||||
+prompt>
|
21
php.spec
21
php.spec
@ -59,13 +59,13 @@
|
||||
%global with_lmdb 0
|
||||
%endif
|
||||
|
||||
%global upver 7.3.7
|
||||
#global rcver RC3
|
||||
%global upver 7.3.8
|
||||
%global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -112,6 +112,7 @@ Patch46: php-7.2.4-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-bug78297.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -160,7 +161,14 @@ Provides: mod_php = %{version}-%{release}
|
||||
Requires: php-common%{?_isa} = %{version}-%{release}
|
||||
# For backwards-compatibility, require php-cli for the time being:
|
||||
Requires: php-cli%{?_isa} = %{version}-%{release}
|
||||
# httpd have threaded MPM by default
|
||||
Recommends: php-fpm%{?_isa} = %{version}-%{release}
|
||||
# as "php" is now mostly a meta-package, commonly used extensions
|
||||
Recommends: php-json%{?_isa} = %{version}-%{release}
|
||||
Recommends: php-mbstring%{?_isa} = %{version}-%{release}
|
||||
Recommends: php-opcache%{?_isa} = %{version}-%{release}
|
||||
Recommends: php-pdo%{?_isa} = %{version}-%{release}
|
||||
Recommends: php-xml%{?_isa} = %{version}-%{release}
|
||||
# To ensure correct /var/lib/php/session ownership:
|
||||
Requires(pre): httpd-filesystem
|
||||
# php engine for Apache httpd webserver
|
||||
@ -724,6 +732,7 @@ low-level PHP extension for the libsodium cryptographic library.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .78297
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1564,6 +1573,12 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.3.8~RC1-1
|
||||
- update to 7.3.8RC1
|
||||
- add upstream patch for #78297
|
||||
- main package now recommends commonly used extensions
|
||||
(json, mbstring, opcache, pdo, xml)
|
||||
|
||||
* Wed Jul 3 2019 Remi Collet <remi@remirepo.net> - 7.3.7-2
|
||||
- Update to 7.3.7 - http://www.php.net/releases/7_3_7.php
|
||||
- disable opcache.huge_code_pages in default configuration
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (php-7.3.7.tar.xz) = 583a28aa346c3322998bfda81bf00f2f2b84ff1e2311f0877288d7d4f02639e953e9bd8cb59372cd4bec9aeffa3ec00375c4b03a3ee8ec1db05a095a28164908
|
||||
SHA512 (php-7.3.8RC1.tar.xz) = 83cf25160c925cebabbd743db40f000427a77fb93740fa6221c96339ca492c99f71221ba3e750d7a02b4aa6f65249565fe3dcdaab2f789e5abfac5a6a4bbb1a3
|
||||
|
Loading…
Reference in New Issue
Block a user