add upstream patch for oniguruma 6.8.1, FTBFS #1562583
This commit is contained in:
parent
c1c19a884b
commit
5a4411f412
31
php-upstream.patch
Normal file
31
php-upstream.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From 4072b2787074ee8e247a6639585b49e10c5a55fe Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Christoph M. Becker" <cmbecker69@gmx.de>
|
||||||
|
Date: Tue, 20 Mar 2018 16:35:39 +0100
|
||||||
|
Subject: [PATCH] Fix #76113: mbstring does not build with Oniguruma 6.8.1
|
||||||
|
|
||||||
|
As of Oniguruma 6.8.1, the regex structure has been moved from the
|
||||||
|
public `oniguruma.h` to the private `regint.h`. Thus, it is no longer
|
||||||
|
possible to directly access the struct's members, and actually, there
|
||||||
|
is no need to, since there are respective accessor functions available
|
||||||
|
at least of 2.3.1.
|
||||||
|
---
|
||||||
|
NEWS | 2 ++
|
||||||
|
ext/mbstring/php_mbregex.c | 2 +-
|
||||||
|
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/ext/mbstring/php_mbregex.c b/ext/mbstring/php_mbregex.c
|
||||||
|
index a5a6cd0..7a70c63 100644
|
||||||
|
--- a/ext/mbstring/php_mbregex.c
|
||||||
|
+++ b/ext/mbstring/php_mbregex.c
|
||||||
|
@@ -452,7 +452,7 @@ static php_mb_regex_t *php_mbregex_compile_pattern(const char *pattern, int patl
|
||||||
|
OnigUChar err_str[ONIG_MAX_ERROR_MESSAGE_LEN];
|
||||||
|
|
||||||
|
rc = zend_hash_str_find_ptr(&MBREX(ht_rc), (char *)pattern, patlen);
|
||||||
|
- if (!rc || rc->options != options || rc->enc != enc || rc->syntax != syntax) {
|
||||||
|
+ if (!rc || onig_get_options(rc) != options || onig_get_encoding(rc) != enc || onig_get_syntax(rc) != syntax) {
|
||||||
|
if ((err_code = onig_new(&retval, (OnigUChar *)pattern, (OnigUChar *)(pattern + patlen), options, enc, syntax, &err_info)) != ONIG_NORMAL) {
|
||||||
|
onig_error_code_to_str(err_str, err_code, &err_info);
|
||||||
|
php_error_docref(NULL, E_WARNING, "mbregex compile err: %s", err_str);
|
||||||
|
--
|
||||||
|
2.1.4
|
||||||
|
|
5
php.spec
5
php.spec
@ -110,6 +110,7 @@ Patch46: php-7.2.4-fixheader.patch
|
|||||||
Patch47: php-5.6.3-phpinfo.patch
|
Patch47: php-5.6.3-phpinfo.patch
|
||||||
|
|
||||||
# Upstream fixes (100+)
|
# Upstream fixes (100+)
|
||||||
|
Patch100: php-upstream.patch
|
||||||
|
|
||||||
# Security fixes (200+)
|
# Security fixes (200+)
|
||||||
|
|
||||||
@ -709,6 +710,7 @@ low-level PHP extension for the libsodium cryptographic library.
|
|||||||
%patch47 -p1 -b .phpinfo
|
%patch47 -p1 -b .phpinfo
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
|
%patch100 -p1 -b .upstream
|
||||||
|
|
||||||
# security patches
|
# security patches
|
||||||
|
|
||||||
@ -1550,6 +1552,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 3 2018 Remi Collet <remi@remirepo.net> - 7.2.4-2
|
||||||
|
- add upstream patch for oniguruma 6.8.1, FTBFS #1562583
|
||||||
|
|
||||||
* Sun Apr 01 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 7.2.4-2
|
* Sun Apr 01 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 7.2.4-2
|
||||||
- Rebuild against oniguruma 6.8.1
|
- Rebuild against oniguruma 6.8.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user