refresh patch for https://bugs.php.net/75514
This commit is contained in:
parent
3fba584aeb
commit
5553b889e6
@ -53,3 +53,37 @@ index 0000000..af97b6d
|
||||
--
|
||||
2.9.5
|
||||
|
||||
From 2b071028973782ed87e7038e56d47e9897be804a Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Tue, 28 Nov 2017 17:42:43 +0100
|
||||
Subject: [PATCH] better fix for #75514
|
||||
|
||||
---
|
||||
ext/standard/mt_rand.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
|
||||
index 0a76ab8..46f52db 100644
|
||||
--- a/ext/standard/mt_rand.c
|
||||
+++ b/ext/standard/mt_rand.c
|
||||
@@ -260,7 +260,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
|
||||
* rand() allows min > max, mt_rand does not */
|
||||
PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
|
||||
{
|
||||
- uint32_t n;
|
||||
+ int64_t n;
|
||||
|
||||
if (BG(mt_rand_mode) == MT_RAND_MT19937) {
|
||||
return php_mt_rand_range(min, max);
|
||||
@@ -268,7 +268,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
|
||||
|
||||
/* Legacy mode deliberately not inside php_mt_rand_range()
|
||||
* to prevent other functions being affected */
|
||||
- n = php_mt_rand() >> 1;
|
||||
+ n = (int64_t)php_mt_rand() >> 1;
|
||||
RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
|
||||
|
||||
return n;
|
||||
--
|
||||
2.1.4
|
||||
|
||||
|
5
php.spec
5
php.spec
@ -67,7 +67,7 @@
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -1522,6 +1522,9 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 7.2.0-2
|
||||
- refresh patch for https://bugs.php.net/75514
|
||||
|
||||
* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 7.2.0-1
|
||||
- update to 7.2.0 GA
|
||||
- add upstream patch for https://bugs.php.net/75514
|
||||
|
Loading…
Reference in New Issue
Block a user