* Fri Aug 10 2007 Joe Orton <jorton@redhat.com> 5.2.3-6
- fix build with new glibc - fix License
This commit is contained in:
parent
d0fdda9ffc
commit
534a341039
36
php-5.2.3-macropen.patch
Normal file
36
php-5.2.3-macropen.patch
Normal file
@ -0,0 +1,36 @@
|
||||
--- php-5.2.3/ext/dba/dba.c.macropen
|
||||
+++ php-5.2.3/ext/dba/dba.c
|
||||
@@ -930,7 +930,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
- if (error || hptr->open(info, &error TSRMLS_CC) != SUCCESS) {
|
||||
+ if (error || (hptr->open)(info, &error TSRMLS_CC) != SUCCESS) {
|
||||
dba_close(info TSRMLS_CC);
|
||||
php_error_docref2(NULL TSRMLS_CC, Z_STRVAL_PP(args[0]), Z_STRVAL_PP(args[1]), E_WARNING, "Driver initialization failed for handler: %s%s%s", hptr->name, error?": ":"", error?error:"");
|
||||
FREENOW;
|
||||
--- php-5.2.3/ext/dba/dba_db3.c.macropen
|
||||
+++ php-5.2.3/ext/dba/dba_db3.c
|
||||
@@ -91,7 +91,7 @@
|
||||
|
||||
if ((err=db_create(&dbp, NULL, 0)) == 0) {
|
||||
dbp->set_errcall(dbp, php_dba_db3_errcall_fcn);
|
||||
- if ((err=dbp->open(dbp, info->path, NULL, type, gmode, filemode)) == 0) {
|
||||
+ if ((err=(dbp->open)(dbp, info->path, NULL, type, gmode, filemode)) == 0) {
|
||||
dba_db3_data *data;
|
||||
|
||||
data = pemalloc(sizeof(*data), info->flags&DBA_PERSISTENT);
|
||||
--- php-5.2.3/ext/dba/dba_db4.c.macropen
|
||||
+++ php-5.2.3/ext/dba/dba_db4.c
|
||||
@@ -99,9 +99,9 @@
|
||||
dbp->set_errcall(dbp, php_dba_db4_errcall_fcn);
|
||||
if (
|
||||
#if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
|
||||
- (err=dbp->open(dbp, 0, info->path, NULL, type, gmode, filemode)) == 0) {
|
||||
+ (err=(dbp->open)(dbp, 0, info->path, NULL, type, gmode, filemode)) == 0) {
|
||||
#else
|
||||
- (err=dbp->open(dbp, info->path, NULL, type, gmode, filemode)) == 0) {
|
||||
+ (err=(dbp->open)(dbp, info->path, NULL, type, gmode, filemode)) == 0) {
|
||||
#endif
|
||||
dba_db4_data *data;
|
||||
|
10
php.spec
10
php.spec
@ -6,8 +6,8 @@
|
||||
Summary: The PHP HTML-embedded scripting language
|
||||
Name: php
|
||||
Version: 5.2.3
|
||||
Release: 5
|
||||
License: The PHP License v3.01
|
||||
Release: 6
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
|
||||
@ -26,6 +26,7 @@ Patch8: php-5.2.0-includedir.patch
|
||||
Patch21: php-4.3.1-odbc.patch
|
||||
Patch22: php-4.3.11-shutdown.patch
|
||||
Patch23: php-5.2.2-pdosym.patch
|
||||
Patch24: php-5.2.3-macropen.patch
|
||||
|
||||
# Functional changes
|
||||
Patch30: php-5.0.4-dlopen.patch
|
||||
@ -342,6 +343,7 @@ database server which supports TDS can be accessed.
|
||||
%patch21 -p1 -b .odbc
|
||||
%patch22 -p1 -b .shutdown
|
||||
%patch23 -p1 -b .pdosym
|
||||
%patch24 -p1 -b .macropen
|
||||
|
||||
%patch30 -p1 -b .dlopen
|
||||
%patch31 -p1 -b .easter
|
||||
@ -678,6 +680,10 @@ rm files.* macros.php
|
||||
%files mssql -f files.mssql
|
||||
|
||||
%changelog
|
||||
* Fri Aug 10 2007 Joe Orton <jorton@redhat.com> 5.2.3-6
|
||||
- fix build with new glibc
|
||||
- fix License
|
||||
|
||||
* Mon Jul 16 2007 Joe Orton <jorton@redhat.com> 5.2.3-5
|
||||
- define php_extdir in macros.php
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user