v7.3.4RC1
This commit is contained in:
parent
243036137a
commit
5216fc158b
@ -1,29 +0,0 @@
|
||||
From 19a44ffb7be91344550fa700830b8e62a73031ba Mon Sep 17 00:00:00 2001
|
||||
From: Anatol Belski <ab@php.net>
|
||||
Date: Thu, 28 Feb 2019 12:48:47 +0100
|
||||
Subject: [PATCH] Sync with behavior change in OpenSSL 1.1.1b
|
||||
|
||||
A behavior change in revealed by some openssl_decrypt() based test,
|
||||
where an encrypt API is used with a decrypt context. The EVP_Cipher*
|
||||
functions will automatically choose the right operation depending on the
|
||||
context passed.
|
||||
---
|
||||
ext/openssl/openssl.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
|
||||
index 871a30c..7df5072 100644
|
||||
--- a/ext/openssl/openssl.c
|
||||
+++ b/ext/openssl/openssl.c
|
||||
@@ -6494,7 +6494,7 @@ static int php_openssl_cipher_update(const EVP_CIPHER *cipher_type,
|
||||
{
|
||||
int i = 0;
|
||||
|
||||
- if (mode->is_single_run_aead && !EVP_EncryptUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
|
||||
+ if (mode->is_single_run_aead && !EVP_CipherUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
|
||||
php_openssl_store_errors();
|
||||
php_error_docref(NULL, E_WARNING, "Setting of data length failed");
|
||||
return FAILURE;
|
||||
--
|
||||
2.1.4
|
||||
|
22
php.ini
22
php.ini
@ -305,6 +305,7 @@ serialize_precision = -1
|
||||
; open_basedir, if set, limits all file operations to the defined directory
|
||||
; and below. This directive makes most sense if used in a per-directory
|
||||
; or per-virtualhost web server configuration file.
|
||||
; Note: disables the realpath cache
|
||||
; http://php.net/open-basedir
|
||||
;open_basedir =
|
||||
|
||||
@ -337,6 +338,7 @@ disable_classes =
|
||||
; Determines the size of the realpath cache to be used by PHP. This value should
|
||||
; be increased on systems where PHP opens many files to reflect the quantity of
|
||||
; the file operations performed.
|
||||
; Note: if open_basedir is set, the cache is disabled
|
||||
; http://php.net/realpath-cache-size
|
||||
;realpath_cache_size = 4096k
|
||||
|
||||
@ -589,7 +591,7 @@ html_errors = On
|
||||
; to syslog. Only used when error_log is set to syslog.
|
||||
;syslog.ident = php
|
||||
|
||||
; The syslog facility is used to specify what type of program is logging
|
||||
; The syslog facility is used to specify what type of program is logging
|
||||
; the message. Only used when error_log is set to syslog.
|
||||
;syslog.facility = user
|
||||
|
||||
@ -598,9 +600,10 @@ html_errors = On
|
||||
; control characters. If your logger accepts everything, then no filtering
|
||||
; is needed at all.
|
||||
; Allowed values are:
|
||||
; ascii (only base ASCII characters)
|
||||
; no_ctrl (all characters except control characters)
|
||||
; ascii (all printable ASCII characters and NL)
|
||||
; no-ctrl (all characters except control characters)
|
||||
; all (all characters)
|
||||
; http://php.net/syslog.filter
|
||||
;syslog.filter = ascii
|
||||
|
||||
;windows.show_crt_warning
|
||||
@ -889,7 +892,7 @@ default_socket_timeout = 60
|
||||
; For example:
|
||||
;
|
||||
; extension=mysqli
|
||||
;
|
||||
;
|
||||
; When the extension library to load is not located in the default extension
|
||||
; directory, You may specify an absolute path to the library file:
|
||||
;
|
||||
@ -971,8 +974,19 @@ cli_server.color = On
|
||||
;intl.use_exceptions = 0
|
||||
|
||||
[sqlite3]
|
||||
; Directory pointing to SQLite3 extensions
|
||||
; http://php.net/sqlite3.extension-dir
|
||||
;sqlite3.extension_dir =
|
||||
|
||||
; SQLite defensive mode flag (only available from SQLite 3.26+)
|
||||
; When the defensive flag is enabled, language features that allow ordinary
|
||||
; SQL to deliberately corrupt the database file are disabled. This forbids
|
||||
; writing directly to the schema, shadow tables (eg. FTS data tables), or
|
||||
; the sqlite_dbpage virtual table.
|
||||
; https://www.sqlite.org/c3ref/c_dbconfig_defensive.html
|
||||
; (for older SQLite versions, this flag has no use)
|
||||
;sqlite3.defensive = 1
|
||||
|
||||
[Pcre]
|
||||
; PCRE library backtracking limit.
|
||||
; http://php.net/pcre.backtrack-limit
|
||||
|
11
php.spec
11
php.spec
@ -58,13 +58,13 @@
|
||||
%global with_lmdb 0
|
||||
%endif
|
||||
|
||||
%global upver 7.3.3
|
||||
#global rcver RC1
|
||||
%global upver 7.3.4
|
||||
%global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -111,7 +111,6 @@ Patch46: php-7.2.4-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-openssl111.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -713,7 +712,6 @@ low-level PHP extension for the libsodium cryptographic library.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .up
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1558,6 +1556,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Mar 19 2019 Remi Collet <remi@remirepo.net> - 7.3.4~RC1-1
|
||||
- update to 7.3.4RC1
|
||||
|
||||
* Mon Mar 18 2019 Remi Collet <remi@fedoraproject.org> - 7.3.3-2
|
||||
- rebuild for libargon2 new soname
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (php-7.3.3.tar.xz) = bad5fa35f5962fa23dbe01fe85f76ce80e431cf2f9719284c082bb1fa32af26407407a97d3bf999165a6158f83a9669e3dd641f6d70028ec644b74a414fb803d
|
||||
SHA512 (php-7.3.4RC1.tar.xz) = e3a4c978bb56ae7f64c43592e436cafee1f2ce595b6712c8e5f43f894bc4e8c3171248f808e0fd0b3eda9a232841aa0f2b63e19f70735d06b9e76df9b6c10ca7
|
||||
|
Loading…
Reference in New Issue
Block a user