Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/php.git#0bebc430041c73db64b13aa9f3b165030a485454
This commit is contained in:
parent
32cfa6ae8d
commit
4f95d29bee
@ -1,30 +0,0 @@
|
||||
From 067f7e4150d8f9bddf6b198c9c7826565ee549b0 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Thu, 28 Jan 2021 16:24:39 +0100
|
||||
Subject: [PATCH] Fix #80682 opcache doesn't honour pcre.jit option
|
||||
|
||||
---
|
||||
ext/opcache/zend_accelerator_blacklist.c | 10 ++++++----
|
||||
1 file changed, 6 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/ext/opcache/zend_accelerator_blacklist.c b/ext/opcache/zend_accelerator_blacklist.c
|
||||
index 889fcabd7988..5c6bd76821a5 100644
|
||||
--- a/ext/opcache/zend_accelerator_blacklist.c
|
||||
+++ b/ext/opcache/zend_accelerator_blacklist.c
|
||||
@@ -185,10 +185,12 @@ static void zend_accel_blacklist_update_regexp(zend_blacklist *blacklist)
|
||||
return;
|
||||
}
|
||||
#ifdef HAVE_PCRE_JIT_SUPPORT
|
||||
- if (0 > pcre2_jit_compile(it->re, PCRE2_JIT_COMPLETE)) {
|
||||
- /* Don't return here, even JIT could fail to compile, the pattern is still usable. */
|
||||
- pcre2_get_error_message(errnumber, pcre_error, sizeof(pcre_error));
|
||||
- zend_accel_error(ACCEL_LOG_WARNING, "Blacklist JIT compilation failed, %s\n", pcre_error);
|
||||
+ if (PCRE_G(jit)) {
|
||||
+ if (0 > pcre2_jit_compile(it->re, PCRE2_JIT_COMPLETE)) {
|
||||
+ /* Don't return here, even JIT could fail to compile, the pattern is still usable. */
|
||||
+ pcre2_get_error_message(errnumber, pcre_error, sizeof(pcre_error));
|
||||
+ zend_accel_error(ACCEL_LOG_WARNING, "Blacklist JIT compilation failed, %s\n", pcre_error);
|
||||
+ }
|
||||
}
|
||||
#endif
|
||||
/* prepare for the next iteration */
|
14
php.spec
14
php.spec
@ -37,7 +37,7 @@
|
||||
%bcond_with modphp
|
||||
%bcond_without zts
|
||||
%bcond_without firebird
|
||||
%bcond_without imap
|
||||
%bcond_with imap
|
||||
%bcond_without freetds
|
||||
%bcond_without sodium
|
||||
%bcond_without pspell
|
||||
@ -55,13 +55,13 @@
|
||||
%bcond_with tidy
|
||||
%endif
|
||||
|
||||
%global upver 7.4.15
|
||||
%global upver 7.4.16
|
||||
#global rcver RC2
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -108,7 +108,6 @@ Patch45: php-7.4.0-ldap_r.patch
|
||||
Patch47: php-7.4.8-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-bug80682.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -733,7 +732,6 @@ in pure PHP.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .bug80682
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1539,6 +1537,12 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Mar 2 2021 Remi Collet <remi@remirepo.net> - 7.4.16-1
|
||||
- Update to 7.4.16 - http://www.php.net/releases/7_4_16.php
|
||||
|
||||
* Wed Feb 24 2021 Remi Collet <remi@remirepo.net> - 7.4.15-3
|
||||
- drop php-imap, fix #1929640
|
||||
|
||||
* Mon Feb 08 2021 Pavel Raiskup <praiskup@redhat.com> - 7.4.15-2
|
||||
- rebuild for libpq ABI fix rhbz#1908268
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-7.4.15.tar.xz) = 51a815852c08518d6706fc719e3bafd214889580cc5ca0e5049ae7e8f6173e83b9486bc9a69afd1ea4ab1778bb2879bd917595cd04cbcc50b182a10230f08175
|
||||
SHA512 (php-7.4.15.tar.xz.asc) = d5502e77753888a4b5d98b6f3cd01ae7e7a7b94700375017e0783ba19462c117e12bd156b51462d426c1101c318be0ef9fa04d5b5eed476fc4d686693896cd73
|
||||
SHA512 (php-7.4.16.tar.xz) = a7845fe0a7c334829bfa9518d3f2947036e1b03c8f4346622f9ab37563ff3af03f6559878b83aa0e6ad69e9919b6478345a0cc6ec59161ef36c64a5073e83f84
|
||||
SHA512 (php-7.4.16.tar.xz.asc) = d988fa475e7590fc25e893f523e2879eb6a2d8e5ec076c1e4eb501153aaef2dc6fc2ee55345b49ec52b7ca25db65598002d848b7154032a46f56cd150734043f
|
||||
|
Loading…
Reference in New Issue
Block a user