update to 5.4.7
This commit is contained in:
parent
f8329d77b5
commit
4f00aa8e17
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ php.spec~
|
||||
/php-5.4.4.tar.bz2
|
||||
/php-5.4.5.tar.bz2
|
||||
/php-5.4.6.tar.bz2
|
||||
/php-5.4.7.tar.bz2
|
||||
|
@ -423,9 +423,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
|
||||
/* TODO: fix _zip_replace */
|
||||
if (cur_idx >= 0) {
|
||||
if (zip_delete(intern, cur_idx) == -1) {
|
||||
@@ -2868,7 +3100,11 @@ static PHP_MINFO_FUNCTION(zip)
|
||||
php_info_print_table_row(2, "Zip", "enabled");
|
||||
php_info_print_table_row(2, "Extension Version","$Id$");
|
||||
@@ -2870,5 +3098,9 @@ static PHP_MINFO_FUNCTION(zip)
|
||||
php_info_print_table_row(2, "Zip version", PHP_ZIP_VERSION_STRING);
|
||||
- php_info_print_table_row(2, "Libzip version", LIBZIP_VERSION);
|
||||
+#if defined(HAVE_LIBZIP)
|
||||
|
@ -1,68 +0,0 @@
|
||||
From c4b26cc1b0b0521c75e653fffec2a9e3b4bf8cbb Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Veillard <veillard@redhat.com>
|
||||
Date: Thu, 9 Aug 2012 14:02:33 -0400
|
||||
Subject: [PATCH] Update to work with libxml 2.9.0
|
||||
|
||||
---
|
||||
ext/dom/documenttype.c | 4 ++++
|
||||
ext/dom/node.c | 8 ++++++++
|
||||
ext/simplexml/simplexml.c | 4 ++++
|
||||
3 files changed, 16 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/ext/dom/documenttype.c b/ext/dom/documenttype.c
|
||||
index d61ba79..eee3b5f 100644
|
||||
--- a/ext/dom/documenttype.c
|
||||
+++ b/ext/dom/documenttype.c
|
||||
@@ -205,7 +205,11 @@ int dom_documenttype_internal_subset_read(dom_object *obj, zval **retval TSRMLS_
|
||||
if (buff != NULL) {
|
||||
xmlNodeDumpOutput (buff, NULL, (xmlNodePtr) intsubset, 0, 0, NULL);
|
||||
xmlOutputBufferFlush(buff);
|
||||
+#ifdef LIBXML2_NEW_BUFFER
|
||||
+ ZVAL_STRINGL(*retval, xmlOutputBufferGetContent(buff), xmlOutputBufferGetSize(buff), 1);
|
||||
+#else
|
||||
ZVAL_STRINGL(*retval, buff->buffer->content, buff->buffer->use, 1);
|
||||
+#endif
|
||||
(void)xmlOutputBufferClose(buff);
|
||||
return SUCCESS;
|
||||
}
|
||||
diff --git a/ext/dom/node.c b/ext/dom/node.c
|
||||
index 5bcb234..727d1bc 100644
|
||||
--- a/ext/dom/node.c
|
||||
+++ b/ext/dom/node.c
|
||||
@@ -1895,9 +1895,17 @@ static void dom_canonicalization(INTERNAL_FUNCTION_PARAMETERS, int mode) /* {{{
|
||||
RETVAL_FALSE;
|
||||
} else {
|
||||
if (mode == 0) {
|
||||
+#ifdef LIBXML2_NEW_BUFFER
|
||||
+ ret = xmlOutputBufferGetSize(buf);
|
||||
+#else
|
||||
ret = buf->buffer->use;
|
||||
+#endif
|
||||
if (ret > 0) {
|
||||
+#ifdef LIBXML2_NEW_BUFFER
|
||||
+ RETVAL_STRINGL((char *) xmlOutputBufferGetContent(buf), ret, 1);
|
||||
+#else
|
||||
RETVAL_STRINGL((char *) buf->buffer->content, ret, 1);
|
||||
+#endif
|
||||
} else {
|
||||
RETVAL_EMPTY_STRING();
|
||||
}
|
||||
diff --git a/ext/simplexml/simplexml.c b/ext/simplexml/simplexml.c
|
||||
index a379111..2368596 100644
|
||||
--- a/ext/simplexml/simplexml.c
|
||||
+++ b/ext/simplexml/simplexml.c
|
||||
@@ -1417,7 +1417,11 @@ SXE_METHOD(asXML)
|
||||
|
||||
xmlNodeDumpOutput(outbuf, (xmlDocPtr) sxe->document->ptr, node, 0, 0, ((xmlDocPtr) sxe->document->ptr)->encoding);
|
||||
xmlOutputBufferFlush(outbuf);
|
||||
+#ifdef LIBXML2_NEW_BUFFER
|
||||
+ RETVAL_STRINGL((char *)xmlOutputBufferGetContent(outbuf), xmlOutputBufferGetSize(outbuf), 1);
|
||||
+#else
|
||||
RETVAL_STRINGL((char *)outbuf->buffer->content, outbuf->buffer->use, 1);
|
||||
+#endif
|
||||
xmlOutputBufferClose(outbuf);
|
||||
}
|
||||
} else {
|
||||
--
|
||||
1.7.8
|
||||
|
12
php.spec
12
php.spec
@ -51,8 +51,8 @@
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.4.6
|
||||
Release: 2%{?dist}
|
||||
Version: 5.4.7
|
||||
Release: 1%{?dist}
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -83,9 +83,6 @@ Patch42: php-5.3.1-systzdata-v9.patch
|
||||
Patch43: php-5.4.0-phpize.patch
|
||||
# Use system libzip instead of bundled one
|
||||
Patch44: php-5.4.5-system-libzip.patch
|
||||
# Fix for libxml 2.9.0
|
||||
# http://git.php.net/?p=php-src.git;a=commitdiff;h=c4b26cc1b0b0521c75e653fffec2a9e3b4bf8cbb
|
||||
Patch45: php-5.4.6-libxml.patch
|
||||
|
||||
# Fixes for tests
|
||||
|
||||
@ -586,7 +583,6 @@ support for using the enchant library to PHP.
|
||||
%if %{with_libzip}
|
||||
%patch44 -p1 -b .systzip
|
||||
%endif
|
||||
%patch45 -p1 -b .libxml290
|
||||
|
||||
# Prevent %%doc confusion over LICENSE files
|
||||
cp Zend/LICENSE Zend/ZEND_LICENSE
|
||||
@ -1283,6 +1279,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Sep 14 2012 Remi Collet <remi@fedoraproject.org> 5.4.7-1
|
||||
- update to 5.4.6
|
||||
http://www.php.net/releases/5_4_6.php
|
||||
|
||||
* Mon Aug 20 2012 Remi Collet <remi@fedoraproject.org> 5.4.6-2
|
||||
- enable php-fpm on secondary arch (#849490)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user