fix installed headers
This commit is contained in:
parent
a5d6737443
commit
4c48f39c66
11
php-5.4.8-mysqli.patch
Normal file
11
php-5.4.8-mysqli.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- php-5.4.8/ext/mysqli/config.m4.orig 2012-10-25 14:36:21.560016333 +0200
|
||||
+++ php-5.4.8/ext/mysqli/config.m4 2012-10-25 14:37:04.706164258 +0200
|
||||
@@ -81,5 +81,8 @@
|
||||
if test "$PHP_MYSQLI" = "yes" || test "$PHP_MYSQLI" = "mysqlnd"; then
|
||||
PHP_ADD_EXTENSION_DEP(mysqli, mysqlnd)
|
||||
AC_DEFINE([MYSQLI_USE_MYSQLND], 1, [Whether mysqlnd is enabled])
|
||||
+ PHP_INSTALL_HEADERS([ext/mysqli/mysqli_mysqlnd.h])
|
||||
+ else
|
||||
+ PHP_INSTALL_HEADERS([ext/mysqli/mysqli_libmysql.h])
|
||||
fi
|
||||
fi
|
19
php.spec
19
php.spec
@ -52,7 +52,7 @@
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.4.8
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -73,6 +73,8 @@ Patch5: php-5.2.0-includedir.patch
|
||||
Patch6: php-5.2.4-embed.patch
|
||||
Patch7: php-5.3.0-recode.patch
|
||||
Patch8: php-5.4.7-libdb.patch
|
||||
# https://bugs.php.net/63361 - Header not installed
|
||||
Patch9: php-5.4.8-mysqli.patch
|
||||
|
||||
# Fixes for extension modules
|
||||
# https://bugs.php.net/63126 - DISABLE_AUTHENTICATOR ignores array
|
||||
@ -591,6 +593,7 @@ support for using the enchant library to PHP.
|
||||
%patch6 -p1 -b .embed
|
||||
%patch7 -p1 -b .recode
|
||||
%patch8 -p1 -b .libdb
|
||||
%patch9 -p1 -b .mysqliheaders
|
||||
|
||||
%patch20 -p1 -b .imap
|
||||
%patch21 -p1 -b .odbctimer
|
||||
@ -682,6 +685,17 @@ if test "$ver" != "%{jsonver}"; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
# https://bugs.php.net/63362 - Not needed but installed headers.
|
||||
# Drop some Windows specific headers to avoid installation,
|
||||
# before build to ensure they are really not needed.
|
||||
rm -f TSRM/tsrm_win32.h \
|
||||
TSRM/tsrm_config.w32.h \
|
||||
Zend/zend_config.w32.h \
|
||||
ext/mysqlnd/config-win.h \
|
||||
ext/standard/winver.h \
|
||||
main/win32_internal_function_disabled.h \
|
||||
main/win95nt.h
|
||||
|
||||
# Fix some bogus permissions
|
||||
find . -name \*.[ch] -exec chmod 644 {} \;
|
||||
chmod 644 README.*
|
||||
@ -1321,6 +1335,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 25 2012 Remi Collet <rcollet@redhat.com> 5.4.8-3
|
||||
- fix installed headers
|
||||
|
||||
* Tue Oct 23 2012 Joe Orton <jorton@redhat.com> - 5.4.8-2
|
||||
- use libldap_r for ldap extension
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user