PHP 5.3.7
This commit is contained in:
parent
99e70e5395
commit
49d95f97cb
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,4 +1,2 @@
|
||||
php-5.3.3.tar.bz2
|
||||
/php-5.3.4.tar.bz2
|
||||
/php-5.3.5.tar.bz2
|
||||
/php-5.3.6.tar.bz2
|
||||
php.spec~
|
||||
/php-5.3.7.tar.bz2
|
||||
|
@ -1,79 +0,0 @@
|
||||
diff -up php-5.3.6/configure.in.aconf26x php-5.3.6/configure.in
|
||||
--- php-5.3.6/configure.in.aconf26x 2011-03-17 17:53:52.309552690 +0100
|
||||
+++ php-5.3.6/configure.in 2011-03-17 17:55:00.223777508 +0100
|
||||
@@ -1,7 +1,7 @@
|
||||
## $Id: configure.in 309329 2011-03-17 07:48:29Z johannes $ -*- autoconf -*-
|
||||
dnl ## Process this file with autoconf to produce a configure script.
|
||||
|
||||
-divert(1)
|
||||
+divert(1001)
|
||||
|
||||
dnl ## Diversion 1 is the autoconf + automake setup phase. We also
|
||||
dnl ## set the PHP version, deal with platform-specific compile
|
||||
@@ -292,7 +292,7 @@ sinclude(TSRM/threads.m4)
|
||||
sinclude(TSRM/tsrm.m4)
|
||||
|
||||
|
||||
-divert(2)
|
||||
+divert(1002)
|
||||
|
||||
dnl ## Diversion 2 is where we set PHP-specific options and come up
|
||||
dnl ## with reasonable default values for them. We check for pthreads here
|
||||
@@ -331,7 +331,7 @@ if test "$enable_maintainer_zts" = "yes"
|
||||
PTHREADS_FLAGS
|
||||
fi
|
||||
|
||||
-divert(3)
|
||||
+divert(1003)
|
||||
|
||||
dnl ## In diversion 3 we check for compile-time options to the PHP
|
||||
dnl ## core and how to deal with different system dependencies.
|
||||
@@ -677,7 +677,7 @@ if test "x$php_crypt_r" = "x1"; then
|
||||
PHP_CRYPT_R_STYLE
|
||||
fi
|
||||
|
||||
-divert(4)
|
||||
+divert(1004)
|
||||
|
||||
dnl ## In diversion 4 we check user-configurable general settings.
|
||||
|
||||
@@ -918,7 +918,7 @@ else
|
||||
AC_MSG_RESULT([using system default])
|
||||
fi
|
||||
|
||||
-divert(5)
|
||||
+divert(1005)
|
||||
|
||||
dnl ## In diversion 5 we check which extensions should be compiled.
|
||||
dnl ## All of these are normally in the extension directories.
|
||||
diff -up php-5.3.6/ext/standard/config.m4.aconf26x php-5.3.6/ext/standard/config.m4
|
||||
--- php-5.3.6/ext/standard/config.m4.aconf26x 2010-06-17 12:22:03.000000000 +0200
|
||||
+++ php-5.3.6/ext/standard/config.m4 2011-03-17 17:52:45.793450887 +0100
|
||||
@@ -1,6 +1,6 @@
|
||||
dnl $Id: config.m4 300511 2010-06-17 10:22:03Z pajoye $ -*- autoconf -*-
|
||||
|
||||
-divert(3)dnl
|
||||
+divert(1003)dnl
|
||||
|
||||
dnl
|
||||
dnl Check if flush should be called explicitly after buffered io
|
||||
@@ -342,7 +342,7 @@ dnl
|
||||
AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan mempcpy strpncpy)
|
||||
AC_FUNC_FNMATCH
|
||||
|
||||
-divert(5)dnl
|
||||
+divert(1005)dnl
|
||||
|
||||
dnl
|
||||
dnl Check if there is a support means of creating a new process
|
||||
diff -up php-5.3.6/scripts/phpize.m4.aconf26x php-5.3.6/scripts/phpize.m4
|
||||
--- php-5.3.6/scripts/phpize.m4.aconf26x 2010-11-02 10:58:08.000000000 +0100
|
||||
+++ php-5.3.6/scripts/phpize.m4 2011-03-17 17:52:45.793450887 +0100
|
||||
@@ -1,6 +1,6 @@
|
||||
dnl This file becomes configure.in for self-contained extensions.
|
||||
|
||||
-divert(1)
|
||||
+divert(1001)
|
||||
|
||||
AC_PREREQ(2.13)
|
||||
AC_INIT(config.m4)
|
@ -1,115 +0,0 @@
|
||||
diff -up php-5.3.6RC1/configure.in.gnusrc php-5.3.6RC1/configure.in
|
||||
--- php-5.3.6RC1/configure.in.gnusrc 2011-02-16 21:20:33.000000000 +0100
|
||||
+++ php-5.3.6RC1/configure.in 2011-02-17 16:25:13.602809269 +0100
|
||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||
|
||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||
+
|
||||
dnl Setting up the PHP version based on the information above.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
diff -up php-5.3.6RC1/ext/interbase/interbase.c.gnusrc php-5.3.6RC1/ext/interbase/interbase.c
|
||||
--- php-5.3.6RC1/ext/interbase/interbase.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.6RC1/ext/interbase/interbase.c 2011-02-17 16:25:13.603809213 +0100
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
|
||||
diff -up php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c
|
||||
--- php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.6RC1/ext/pdo_firebird/firebird_driver.c 2011-02-17 16:25:13.604809156 +0100
|
||||
@@ -22,7 +22,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
#ifdef ZEND_ENGINE_2
|
||||
diff -up php-5.3.6RC1/ext/standard/file.c.gnusrc php-5.3.6RC1/ext/standard/file.c
|
||||
--- php-5.3.6RC1/ext/standard/file.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.6RC1/ext/standard/file.c 2011-02-17 16:25:13.605809100 +0100
|
||||
@@ -113,9 +113,6 @@ php_file_globals file_globals;
|
||||
#endif
|
||||
|
||||
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
|
||||
-# ifndef _GNU_SOURCE
|
||||
-# define _GNU_SOURCE
|
||||
-# endif
|
||||
# include <fnmatch.h>
|
||||
#endif
|
||||
|
||||
diff -up php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c
|
||||
--- php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.6RC1/ext/zlib/zlib_fopen_wrapper.c 2011-02-17 16:26:19.531428121 +0100
|
||||
@@ -19,8 +19,6 @@
|
||||
|
||||
/* $Id: zlib_fopen_wrapper.c 306939 2011-01-01 02:19:59Z felipe $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
-
|
||||
#include "php.h"
|
||||
#include "php_zlib.h"
|
||||
#include "fopen_wrappers.h"
|
||||
diff -up php-5.3.6RC1/main/php.h.gnusrc php-5.3.6RC1/main/php.h
|
||||
--- php-5.3.6RC1/main/php.h.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.6RC1/main/php.h 2011-02-17 16:25:13.606809044 +0100
|
||||
@@ -30,6 +30,7 @@
|
||||
#define PHP_HAVE_STREAMS
|
||||
#define YYDEBUG 0
|
||||
|
||||
+#include "php_config.h"
|
||||
#include "php_version.h"
|
||||
#include "zend.h"
|
||||
#include "zend_qsort.h"
|
||||
diff -up php-5.3.6RC1/main/streams/cast.c.gnusrc php-5.3.6RC1/main/streams/cast.c
|
||||
--- php-5.3.6RC1/main/streams/cast.c.gnusrc 2011-01-20 07:32:59.000000000 +0100
|
||||
+++ php-5.3.6RC1/main/streams/cast.c 2011-02-17 16:26:47.495972650 +0100
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: cast.c 307611 2011-01-20 06:32:59Z pajoye $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.3.6RC1/main/streams/memory.c.gnusrc php-5.3.6RC1/main/streams/memory.c
|
||||
--- php-5.3.6RC1/main/streams/memory.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.6RC1/main/streams/memory.c 2011-02-17 16:25:56.276628691 +0100
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: memory.c 306939 2011-01-01 02:19:59Z felipe $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
|
||||
PHPAPI int php_url_decode(char *str, int len);
|
||||
diff -up php-5.3.6RC1/main/streams/streams.c.gnusrc php-5.3.6RC1/main/streams/streams.c
|
||||
--- php-5.3.6RC1/main/streams/streams.c.gnusrc 2011-02-01 19:10:35.000000000 +0100
|
||||
+++ php-5.3.6RC1/main/streams/streams.c 2011-02-17 16:27:06.428980279 +0100
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
/* $Id: streams.c 307922 2011-02-01 18:10:35Z cataphract $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.3.6RC1/Zend/zend_language_parser.c.gnusrc php-5.3.6RC1/Zend/zend_language_parser.c
|
||||
--- php-5.3.6RC1/Zend/zend_language_parser.c.gnusrc 2011-02-16 21:30:44.000000000 +0100
|
||||
+++ php-5.3.6RC1/Zend/zend_language_parser.c 2011-02-17 16:25:13.608808931 +0100
|
||||
@@ -366,6 +366,8 @@
|
||||
#include "zend_API.h"
|
||||
#include "zend_constants.h"
|
||||
|
||||
+#include <string.h>
|
||||
+
|
||||
|
||||
#define YYERROR_VERBOSE
|
||||
#define YYSTYPE znode
|
195
php-5.3.7-aconf259.patch
Normal file
195
php-5.3.7-aconf259.patch
Normal file
@ -0,0 +1,195 @@
|
||||
diff -up php-5.3.7/build/buildcheck.sh.aconf259 php-5.3.7/build/buildcheck.sh
|
||||
--- php-5.3.7/build/buildcheck.sh.aconf259 2011-05-18 21:55:34.000000000 +0200
|
||||
+++ php-5.3.7/build/buildcheck.sh 2011-08-18 18:05:07.401955101 +0200
|
||||
@@ -28,33 +28,23 @@ if test -z "$PHP_AUTOCONF"; then
|
||||
PHP_AUTOCONF='autoconf'
|
||||
fi
|
||||
|
||||
-# autoconf 2.13 or newer
|
||||
+# autoconf 2.59 or newer
|
||||
ac_version=`$PHP_AUTOCONF --version 2>/dev/null|head -n 1|sed -e 's/^[^0-9]*//' -e 's/[a-z]* *$//'`
|
||||
if test -z "$ac_version"; then
|
||||
echo "buildconf: autoconf not found."
|
||||
-echo " You need autoconf version 2.13 or newer installed"
|
||||
+echo " You need autoconf version 2.59 or newer installed"
|
||||
echo " to build PHP from SVN."
|
||||
exit 1
|
||||
fi
|
||||
IFS=.; set $ac_version; IFS=' '
|
||||
-if test "$1" = "2" -a "$2" -lt "13" || test "$1" -lt "2"; then
|
||||
+if test "$1" = "2" -a "$2" -lt "59" || test "$1" -lt "2"; then
|
||||
echo "buildconf: autoconf version $ac_version found."
|
||||
-echo " You need autoconf version 2.13 or newer installed"
|
||||
+echo " You need autoconf version 2.59 or newer installed"
|
||||
echo " to build PHP from SVN."
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-if test "$1" = "2" -a "$2" -gt "59"; then
|
||||
- echo "buildconf: You need autoconf 2.59 or lower to build this version of PHP."
|
||||
- echo " You are currently trying to use $ac_version"
|
||||
- echo " Most distros have separate autoconf 2.13 or 2.59 packages."
|
||||
- echo " On Debian/Ubuntu both autoconf2.13 and autoconf2.59 packages exist."
|
||||
- echo " Install autoconf2.13 and set the PHP_AUTOCONF env var to "
|
||||
- echo " autoconf2.13 and try again."
|
||||
- exit 1
|
||||
-else
|
||||
- echo "buildconf: autoconf version $ac_version (ok)"
|
||||
-fi
|
||||
+echo "buildconf: autoconf version $ac_version (ok)"
|
||||
|
||||
if test "$1" = "2" -a "$2" -ge "50"; then
|
||||
./vcsclean
|
||||
diff -up php-5.3.7/configure.in.aconf259 php-5.3.7/configure.in
|
||||
--- php-5.3.7/configure.in.aconf259 2011-08-18 18:05:07.393955075 +0200
|
||||
+++ php-5.3.7/configure.in 2011-08-18 18:05:43.766072484 +0200
|
||||
@@ -1,28 +1,6 @@
|
||||
## $Id: configure.in 315066 2011-08-17 13:30:04Z iliaa $ -*- autoconf -*-
|
||||
dnl ## Process this file with autoconf to produce a configure script.
|
||||
|
||||
-divert(1)
|
||||
-
|
||||
-dnl ## Diversion 1 is the autoconf + automake setup phase. We also
|
||||
-dnl ## set the PHP version, deal with platform-specific compile
|
||||
-dnl ## options and check for the basic compile tools.
|
||||
-
|
||||
-dnl ## Diversion 2 is the initial checking of OS features, programs,
|
||||
-dnl ## libraries and so on.
|
||||
-
|
||||
-dnl ## In diversion 3 we check for compile-time options to the PHP
|
||||
-dnl ## core and how to deal with different system dependencies.
|
||||
-dnl ## This includes whether debugging or short tags are enabled
|
||||
-dnl ## and the default behaviour of php.ini options.
|
||||
-dnl ## This is also where an SAPI interface is selected (choosing between
|
||||
-dnl ## Apache module, CGI etc.)
|
||||
-
|
||||
-dnl ## In diversion 4 we check user-configurable general settings.
|
||||
-
|
||||
-dnl ## In diversion 5 we check which extensions should be compiled.
|
||||
-dnl ## All of these are normally in the extension directories.
|
||||
-dnl ## Diversion 5 is the last one. Here we generate files and clean up.
|
||||
-
|
||||
dnl include Zend specific macro definitions first
|
||||
dnl -------------------------------------------------------------------------
|
||||
sinclude(Zend/acinclude.m4)
|
||||
@@ -30,8 +8,10 @@ sinclude(Zend/acinclude.m4)
|
||||
dnl Basic autoconf + automake initialization, generation of config.nice.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
-AC_PREREQ(2.13)
|
||||
+AC_PREREQ(2.59)
|
||||
AC_INIT(README.SVN-RULES)
|
||||
+ifdef([AC_PRESERVE_HELP_ORDER], [AC_PRESERVE_HELP_ORDER], [])
|
||||
+
|
||||
|
||||
PHP_CONFIG_NICE(config.nice)
|
||||
|
||||
@@ -292,14 +272,6 @@ sinclude(TSRM/threads.m4)
|
||||
sinclude(TSRM/tsrm.m4)
|
||||
|
||||
|
||||
-divert(2)
|
||||
-
|
||||
-dnl ## Diversion 2 is where we set PHP-specific options and come up
|
||||
-dnl ## with reasonable default values for them. We check for pthreads here
|
||||
-dnl ## because the information is needed by the SAPI configuration.
|
||||
-dnl ## This is also where an SAPI interface is selected (choosing between
|
||||
-dnl ## Apache module, CGI etc.)
|
||||
-
|
||||
dnl .
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
@@ -331,13 +303,6 @@ if test "$enable_maintainer_zts" = "yes"
|
||||
PTHREADS_FLAGS
|
||||
fi
|
||||
|
||||
-divert(3)
|
||||
-
|
||||
-dnl ## In diversion 3 we check for compile-time options to the PHP
|
||||
-dnl ## core and how to deal with different system dependencies.
|
||||
-dnl ## This includes whether debugging or short tags are enabled
|
||||
-dnl ## and the default behaviour of php.ini options.
|
||||
-
|
||||
dnl Starting system checks.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
@@ -677,10 +642,6 @@ if test "x$php_crypt_r" = "x1"; then
|
||||
PHP_CRYPT_R_STYLE
|
||||
fi
|
||||
|
||||
-divert(4)
|
||||
-
|
||||
-dnl ## In diversion 4 we check user-configurable general settings.
|
||||
-
|
||||
dnl General settings.
|
||||
dnl -------------------------------------------------------------------------
|
||||
PHP_CONFIGURE_PART(General settings)
|
||||
@@ -918,11 +879,6 @@ else
|
||||
AC_MSG_RESULT([using system default])
|
||||
fi
|
||||
|
||||
-divert(5)
|
||||
-
|
||||
-dnl ## In diversion 5 we check which extensions should be compiled.
|
||||
-dnl ## All of these are normally in the extension directories.
|
||||
-
|
||||
dnl Extension configuration.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
diff -up php-5.3.7/ext/standard/config.m4.aconf259 php-5.3.7/ext/standard/config.m4
|
||||
--- php-5.3.7/ext/standard/config.m4.aconf259 2010-06-17 12:22:03.000000000 +0200
|
||||
+++ php-5.3.7/ext/standard/config.m4 2011-08-18 18:05:07.403955107 +0200
|
||||
@@ -1,7 +1,5 @@
|
||||
dnl $Id: config.m4 300511 2010-06-17 10:22:03Z pajoye $ -*- autoconf -*-
|
||||
|
||||
-divert(3)dnl
|
||||
-
|
||||
dnl
|
||||
dnl Check if flush should be called explicitly after buffered io
|
||||
dnl
|
||||
@@ -342,8 +340,6 @@ dnl
|
||||
AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan mempcpy strpncpy)
|
||||
AC_FUNC_FNMATCH
|
||||
|
||||
-divert(5)dnl
|
||||
-
|
||||
dnl
|
||||
dnl Check if there is a support means of creating a new process
|
||||
dnl and defining which handles it receives
|
||||
diff -up php-5.3.7/scripts/php-config.in.aconf259 php-5.3.7/scripts/php-config.in
|
||||
--- php-5.3.7/scripts/php-config.in.aconf259 2011-04-18 13:13:37.000000000 +0200
|
||||
+++ php-5.3.7/scripts/php-config.in 2011-08-18 18:05:07.404955110 +0200
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
SED="@SED@"
|
||||
prefix="@prefix@"
|
||||
+datarootdir="@datarootdir@"
|
||||
exec_prefix="@exec_prefix@"
|
||||
version="@PHP_VERSION@"
|
||||
vernum="@PHP_VERSION_ID@"
|
||||
diff -up php-5.3.7/scripts/phpize.in.aconf259 php-5.3.7/scripts/phpize.in
|
||||
--- php-5.3.7/scripts/phpize.in.aconf259 2011-08-18 18:05:07.390955065 +0200
|
||||
+++ php-5.3.7/scripts/phpize.in 2011-08-18 18:05:07.405955113 +0200
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
# Variable declaration
|
||||
prefix='@prefix@'
|
||||
+datarootdir='@datarootdir@'
|
||||
exec_prefix="`eval echo @exec_prefix@`"
|
||||
phpdir="@libdir@/php/build"
|
||||
includedir="`eval echo @includedir@`/php"
|
||||
diff -up php-5.3.7/scripts/phpize.m4.aconf259 php-5.3.7/scripts/phpize.m4
|
||||
--- php-5.3.7/scripts/phpize.m4.aconf259 2010-11-02 10:58:08.000000000 +0100
|
||||
+++ php-5.3.7/scripts/phpize.m4 2011-08-18 18:05:07.406955117 +0200
|
||||
@@ -1,9 +1,8 @@
|
||||
dnl This file becomes configure.in for self-contained extensions.
|
||||
|
||||
-divert(1)
|
||||
-
|
||||
-AC_PREREQ(2.13)
|
||||
+AC_PREREQ(2.59)
|
||||
AC_INIT(config.m4)
|
||||
+ifdef([AC_PRESERVE_HELP_ORDER], [AC_PRESERVE_HELP_ORDER], [])
|
||||
|
||||
PHP_CONFIG_NICE(config.nice)
|
||||
|
115
php-5.3.7-gnusrc.patch
Normal file
115
php-5.3.7-gnusrc.patch
Normal file
@ -0,0 +1,115 @@
|
||||
diff -up php-5.3.7RC3/configure.in.gnusrc php-5.3.7RC3/configure.in
|
||||
--- php-5.3.7RC3/configure.in.gnusrc 2011-07-14 14:01:37.000000000 +0200
|
||||
+++ php-5.3.7RC3/configure.in 2011-07-15 17:46:36.118082437 +0200
|
||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||
|
||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||
+
|
||||
dnl Setting up the PHP version based on the information above.
|
||||
dnl -------------------------------------------------------------------------
|
||||
|
||||
diff -up php-5.3.7RC3/ext/interbase/interbase.c.gnusrc php-5.3.7RC3/ext/interbase/interbase.c
|
||||
--- php-5.3.7RC3/ext/interbase/interbase.c.gnusrc 2011-02-24 03:42:38.000000000 +0100
|
||||
+++ php-5.3.7RC3/ext/interbase/interbase.c 2011-07-15 17:46:36.119082439 +0200
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
|
||||
diff -up php-5.3.7RC3/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.3.7RC3/ext/pdo_firebird/firebird_driver.c
|
||||
--- php-5.3.7RC3/ext/pdo_firebird/firebird_driver.c.gnusrc 2011-06-17 04:00:20.000000000 +0200
|
||||
+++ php-5.3.7RC3/ext/pdo_firebird/firebird_driver.c 2011-07-15 17:46:36.119082439 +0200
|
||||
@@ -22,7 +22,6 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
|
||||
#include "php.h"
|
||||
#ifdef ZEND_ENGINE_2
|
||||
diff -up php-5.3.7RC3/ext/standard/file.c.gnusrc php-5.3.7RC3/ext/standard/file.c
|
||||
--- php-5.3.7RC3/ext/standard/file.c.gnusrc 2011-06-19 16:50:44.000000000 +0200
|
||||
+++ php-5.3.7RC3/ext/standard/file.c 2011-07-15 17:46:36.120082441 +0200
|
||||
@@ -113,9 +113,6 @@ php_file_globals file_globals;
|
||||
#endif
|
||||
|
||||
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
|
||||
-# ifndef _GNU_SOURCE
|
||||
-# define _GNU_SOURCE
|
||||
-# endif
|
||||
# include <fnmatch.h>
|
||||
#endif
|
||||
|
||||
diff -up php-5.3.7RC3/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.3.7RC3/ext/zlib/zlib_fopen_wrapper.c
|
||||
--- php-5.3.7RC3/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.7RC3/ext/zlib/zlib_fopen_wrapper.c 2011-07-15 17:46:36.121082444 +0200
|
||||
@@ -19,8 +19,6 @@
|
||||
|
||||
/* $Id: zlib_fopen_wrapper.c 306939 2011-01-01 02:19:59Z felipe $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
-
|
||||
#include "php.h"
|
||||
#include "php_zlib.h"
|
||||
#include "fopen_wrappers.h"
|
||||
diff -up php-5.3.7RC3/main/php.h.gnusrc php-5.3.7RC3/main/php.h
|
||||
--- php-5.3.7RC3/main/php.h.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.7RC3/main/php.h 2011-07-15 17:46:36.122082447 +0200
|
||||
@@ -30,6 +30,7 @@
|
||||
#define PHP_HAVE_STREAMS
|
||||
#define YYDEBUG 0
|
||||
|
||||
+#include "php_config.h"
|
||||
#include "php_version.h"
|
||||
#include "zend.h"
|
||||
#include "zend_qsort.h"
|
||||
diff -up php-5.3.7RC3/main/streams/cast.c.gnusrc php-5.3.7RC3/main/streams/cast.c
|
||||
--- php-5.3.7RC3/main/streams/cast.c.gnusrc 2011-01-20 07:32:59.000000000 +0100
|
||||
+++ php-5.3.7RC3/main/streams/cast.c 2011-07-15 17:46:36.122082447 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: cast.c 307611 2011-01-20 06:32:59Z pajoye $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.3.7RC3/main/streams/memory.c.gnusrc php-5.3.7RC3/main/streams/memory.c
|
||||
--- php-5.3.7RC3/main/streams/memory.c.gnusrc 2011-01-01 03:19:59.000000000 +0100
|
||||
+++ php-5.3.7RC3/main/streams/memory.c 2011-07-15 17:46:36.123082450 +0200
|
||||
@@ -18,7 +18,6 @@
|
||||
|
||||
/* $Id: memory.c 306939 2011-01-01 02:19:59Z felipe $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
|
||||
PHPAPI int php_url_decode(char *str, int len);
|
||||
diff -up php-5.3.7RC3/main/streams/streams.c.gnusrc php-5.3.7RC3/main/streams/streams.c
|
||||
--- php-5.3.7RC3/main/streams/streams.c.gnusrc 2011-07-15 17:47:00.053139110 +0200
|
||||
+++ php-5.3.7RC3/main/streams/streams.c 2011-07-15 17:47:03.960148477 +0200
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
/* $Id: streams.c 312937 2011-07-05 16:09:06Z cataphract $ */
|
||||
|
||||
-#define _GNU_SOURCE
|
||||
#include "php.h"
|
||||
#include "php_globals.h"
|
||||
#include "php_network.h"
|
||||
diff -up php-5.3.7RC3/Zend/zend_language_parser.c.gnusrc php-5.3.7RC3/Zend/zend_language_parser.c
|
||||
--- php-5.3.7RC3/Zend/zend_language_parser.c.gnusrc 2011-07-14 10:39:30.000000000 +0200
|
||||
+++ php-5.3.7RC3/Zend/zend_language_parser.c 2011-07-15 17:46:36.126082456 +0200
|
||||
@@ -112,6 +112,8 @@
|
||||
#include "zend_API.h"
|
||||
#include "zend_constants.h"
|
||||
|
||||
+#include <string.h>
|
||||
+
|
||||
|
||||
#define YYERROR_VERBOSE
|
||||
#define YYSTYPE znode
|
48
php.spec
48
php.spec
@ -36,8 +36,8 @@
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.3.6
|
||||
Release: 4%{?dist}
|
||||
Version: 5.3.7
|
||||
Release: 1%{?dist}
|
||||
License: PHP
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -52,14 +52,16 @@ Source6: php-fpm.init
|
||||
Source7: php-fpm.logrotate
|
||||
|
||||
# Build fixes
|
||||
Patch1: php-5.3.6-gnusrc.patch
|
||||
Patch1: php-5.3.7-gnusrc.patch
|
||||
Patch2: php-5.3.0-install.patch
|
||||
Patch3: php-5.2.4-norpath.patch
|
||||
Patch4: php-5.3.0-phpize64.patch
|
||||
Patch5: php-5.2.0-includedir.patch
|
||||
Patch6: php-5.2.4-embed.patch
|
||||
Patch7: php-5.3.0-recode.patch
|
||||
Patch8: php-5.3.6-aconf26x.patch
|
||||
# from http://svn.php.net/viewvc?view=revision&revision=311042
|
||||
# and http://svn.php.net/viewvc?view=revision&revision=311908
|
||||
Patch8: php-5.3.7-aconf259.patch
|
||||
|
||||
# Fixes for extension modules
|
||||
Patch20: php-4.3.11-shutdown.patch
|
||||
@ -82,7 +84,12 @@ BuildRequires: httpd-devel >= 2.0.46-1, pam-devel
|
||||
BuildRequires: libstdc++-devel, openssl-devel, sqlite-devel >= 3.6.0
|
||||
BuildRequires: zlib-devel, pcre-devel >= 6.6, smtpdaemon, libedit-devel
|
||||
BuildRequires: bzip2, perl, libtool >= 1.4.3, gcc-c++
|
||||
Obsoletes: php-dbg, php3, phpfi, stronghold-php
|
||||
BuildRequires: libtool-ltdl-devel
|
||||
|
||||
Obsoletes: php-dbg, php3, phpfi, stronghold-php, php-zts < 5.3.7
|
||||
Provides: php-zts = %{version}-%{release}
|
||||
Provides: php-zts%{?_isa} = %{version}-%{release}
|
||||
|
||||
Requires: httpd-mmn = %{httpd_mmn}
|
||||
Provides: mod_php = %{version}-%{release}
|
||||
Requires: php-common%{?_isa} = %{version}-%{release}
|
||||
@ -93,10 +100,11 @@ Requires(pre): httpd
|
||||
|
||||
|
||||
# Don't provides extensions, which are not shared library, as .so
|
||||
%{?filter_setup:
|
||||
%filter_provides_in %{_libdir}/php/modules/.*\.so$
|
||||
%filter_setup
|
||||
}
|
||||
# RPM 4.8
|
||||
%{?filter_provides_in: %filter_provides_in %{_libdir}/php/modules/.*\.so$}
|
||||
%{?filter_setup}
|
||||
# RPM 4.9
|
||||
%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/php/modules/.*\\.so$
|
||||
|
||||
|
||||
%description
|
||||
@ -122,17 +130,6 @@ Provides: php-readline, php-readline%{?_isa}
|
||||
The php-cli package contains the command-line interface
|
||||
executing PHP scripts, /usr/bin/php, and the CGI interface.
|
||||
|
||||
%package zts
|
||||
Group: Development/Languages
|
||||
Summary: Thread-safe PHP interpreter for use with the Apache HTTP Server
|
||||
Requires: php-common%{?_isa} = %{version}-%{release}
|
||||
Requires: httpd-mmn = %{httpd_mmn}
|
||||
BuildRequires: libtool-ltdl-devel
|
||||
|
||||
%description zts
|
||||
The php-zts package contains a module for use with the Apache HTTP
|
||||
Server which can operate under a threaded server processing model.
|
||||
|
||||
%if %{with_fpm}
|
||||
%package fpm
|
||||
Group: Development/Languages
|
||||
@ -954,6 +951,7 @@ fi
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/httpd/modules/libphp5.so
|
||||
%{_libdir}/httpd/modules/libphp5-zts.so
|
||||
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
|
||||
%config(noreplace) %{_sysconfdir}/httpd/conf.d/php.conf
|
||||
%{contentdir}/icons/php.gif
|
||||
@ -985,10 +983,6 @@ fi
|
||||
%{_mandir}/man1/phpize.1*
|
||||
%doc sapi/cgi/README* sapi/cli/README
|
||||
|
||||
%files zts
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/httpd/modules/libphp5-zts.so
|
||||
|
||||
%if %{with_fpm}
|
||||
%files fpm
|
||||
%defattr(-,root,root)
|
||||
@ -1045,7 +1039,13 @@ fi
|
||||
%files interbase -f files.interbase
|
||||
%files enchant -f files.enchant
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 18 2011 Remi Collet <remi@fedoraproject.org> 5.3.7-1
|
||||
- update to 5.3.7
|
||||
http://www.php.net/ChangeLog-5.php#5.3.7
|
||||
- merge php-zts into php (#698084)
|
||||
|
||||
* Tue Jul 12 2011 Joe Orton <jorton@redhat.com> - 5.3.6-4
|
||||
- rebuild for net-snmp SONAME bump
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user