update to 8.0.8RC1
This commit is contained in:
parent
74f1892f62
commit
452bfe7855
2
.gitignore
vendored
2
.gitignore
vendored
@ -18,3 +18,5 @@ php-7.*.xz.asc
|
||||
/php-8.0.7RC1.tar.xz.asc
|
||||
/php-8.0.7.tar.xz
|
||||
/php-8.0.7.tar.xz.asc
|
||||
/php-8.0.8RC1.tar.xz
|
||||
/php-8.0.8RC1.tar.xz.asc
|
||||
|
@ -1,47 +0,0 @@
|
||||
From eb8fb56b9b91996912bf9f5765963bf1efea025a Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@remirepo.net>
|
||||
Date: Thu, 27 May 2021 14:20:07 +0200
|
||||
Subject: [PATCH] Fix snmp build without DES
|
||||
|
||||
---
|
||||
ext/snmp/snmp.c | 16 ++++++++++++++--
|
||||
1 file changed, 14 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ext/snmp/snmp.c b/ext/snmp/snmp.c
|
||||
index 35d19c8738828..d31995827880d 100644
|
||||
--- a/ext/snmp/snmp.c
|
||||
+++ b/ext/snmp/snmp.c
|
||||
@@ -955,19 +955,31 @@ static int netsnmp_session_set_auth_protocol(struct snmp_session *s, char *prot)
|
||||
Set the security protocol in the snmpv3 session */
|
||||
static int netsnmp_session_set_sec_protocol(struct snmp_session *s, char *prot)
|
||||
{
|
||||
+#ifndef NETSNMP_DISABLE_DES
|
||||
if (!strcasecmp(prot, "DES")) {
|
||||
s->securityPrivProto = usmDESPrivProtocol;
|
||||
s->securityPrivProtoLen = USM_PRIV_PROTO_DES_LEN;
|
||||
+ } else
|
||||
+#endif
|
||||
#ifdef HAVE_AES
|
||||
- } else if (!strcasecmp(prot, "AES128") || !strcasecmp(prot, "AES")) {
|
||||
+ if (!strcasecmp(prot, "AES128") || !strcasecmp(prot, "AES")) {
|
||||
s->securityPrivProto = usmAESPrivProtocol;
|
||||
s->securityPrivProtoLen = USM_PRIV_PROTO_AES_LEN;
|
||||
+ } else
|
||||
#endif
|
||||
- } else {
|
||||
+ {
|
||||
#ifdef HAVE_AES
|
||||
+#ifndef NETSNMP_DISABLE_DES
|
||||
zend_value_error("Security protocol must be one of \"DES\", \"AES128\", or \"AES\"");
|
||||
#else
|
||||
+ zend_value_error("Security protocol must be one of \"AES128\", or \"AES\"");
|
||||
+#endif
|
||||
+#else
|
||||
+#ifndef NETSNMP_DISABLE_DES
|
||||
zend_value_error("Security protocol must be \"DES\"");
|
||||
+#else
|
||||
+ zend_value_error("No security protocol supported");
|
||||
+#endif
|
||||
#endif
|
||||
return (-1);
|
||||
}
|
9
php.spec
9
php.spec
@ -56,8 +56,8 @@
|
||||
%bcond_with imap
|
||||
%bcond_without lmdb
|
||||
|
||||
%global upver 8.0.7
|
||||
#global rcver RC1
|
||||
%global upver 8.0.8
|
||||
%global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
@ -114,7 +114,6 @@ Patch45: php-7.4.0-ldap_r.patch
|
||||
Patch47: php-8.0.0-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-net-snmp.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -711,7 +710,6 @@ in pure PHP.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .nodes
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1523,6 +1521,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 8.0.8~RC1-1
|
||||
- update to 8.0.8RC1
|
||||
|
||||
* Wed Jun 2 2021 Remi Collet <remi@remirepo.net> - 8.0.7-1
|
||||
- Update to 8.0.7 - http://www.php.net/releases/8_0_7.php
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-8.0.7.tar.xz) = 54d0355977a69c3c466054e9e277147874eaab192bc384a199eb98582f9fcccebc685b370dabeb65d2de3bad4d2e4b2490c0164d2ce406af76b0e972ea67bbd0
|
||||
SHA512 (php-8.0.7.tar.xz.asc) = 22b664e51524031f1356053c3b7566cce3d3f2a6dca28bd529193fc6f8a637d06fca8ddfbee86baff430283ad5382157d85c013d7a36dc3e211146f12827ffb3
|
||||
SHA512 (php-8.0.8RC1.tar.xz) = 749e7ca9625776e9bd9e0b466f8ef59becc786f6364068efbe2933e222987a4d258aa114094582d8c2073d655d60dd359bf0e3500147ef81ded8433d2a52498b
|
||||
SHA512 (php-8.0.8RC1.tar.xz.asc) = b276f0dd0ffc908ce5dc5ff3a6b6cc357e06f1fe4a435d0bbee26a72a736cdd3d0f72271fa55cd4b8d1c3664a821be5a9f3078af373155f16c40061dd0b9ae0e
|
||||
|
Loading…
Reference in New Issue
Block a user