Update to 8.1.7 - http://www.php.net/releases/8_1_7.php
add upstream patch to initialize pcre before mbstring
This commit is contained in:
parent
b4e6f840ef
commit
44fd4ef0f2
2
.gitignore
vendored
2
.gitignore
vendored
@ -28,3 +28,5 @@ php-7.*.xz.asc
|
|||||||
/php-8.1.6.tar.xz.asc
|
/php-8.1.6.tar.xz.asc
|
||||||
/php-8.1.7RC1.tar.xz
|
/php-8.1.7RC1.tar.xz
|
||||||
/php-8.1.7RC1.tar.xz.asc
|
/php-8.1.7RC1.tar.xz.asc
|
||||||
|
/php-8.1.7.tar.xz
|
||||||
|
/php-8.1.7.tar.xz.asc
|
||||||
|
33
php-mbstring.patch
Normal file
33
php-mbstring.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
From 2eb2f9d74f22bf35a4915ec95afc53a47ebf1af9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Remi Collet <remi@remirepo.net>
|
||||||
|
Date: Thu, 2 Jun 2022 08:05:22 +0200
|
||||||
|
Subject: [PATCH] Fix GH-8685 mbstring requires pcre
|
||||||
|
|
||||||
|
---
|
||||||
|
ext/mbstring/mbstring.c | 11 ++++++++++-
|
||||||
|
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/ext/mbstring/mbstring.c b/ext/mbstring/mbstring.c
|
||||||
|
index 48f22a682a19..4a4088aed3fb 100644
|
||||||
|
--- a/ext/mbstring/mbstring.c
|
||||||
|
+++ b/ext/mbstring/mbstring.c
|
||||||
|
@@ -161,9 +161,18 @@ static const php_mb_nls_ident_list php_mb_default_identify_list[] = {
|
||||||
|
|
||||||
|
/* }}} */
|
||||||
|
|
||||||
|
+/* {{{ mbstring_deps[] */
|
||||||
|
+static const zend_module_dep mbstring_deps[] = {
|
||||||
|
+ ZEND_MOD_REQUIRED("pcre")
|
||||||
|
+ ZEND_MOD_END
|
||||||
|
+};
|
||||||
|
+/* }}} */
|
||||||
|
+
|
||||||
|
/* {{{ zend_module_entry mbstring_module_entry */
|
||||||
|
zend_module_entry mbstring_module_entry = {
|
||||||
|
- STANDARD_MODULE_HEADER,
|
||||||
|
+ STANDARD_MODULE_HEADER_EX,
|
||||||
|
+ NULL,
|
||||||
|
+ mbstring_deps,
|
||||||
|
"mbstring",
|
||||||
|
ext_functions,
|
||||||
|
PHP_MINIT(mbstring),
|
8
php.spec
8
php.spec
@ -65,7 +65,7 @@
|
|||||||
%bcond_without lmdb
|
%bcond_without lmdb
|
||||||
|
|
||||||
%global upver 8.1.7
|
%global upver 8.1.7
|
||||||
%global rcver RC1
|
#global rcver RC1
|
||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
@ -121,6 +121,7 @@ Patch45: php-7.4.0-ldap_r.patch
|
|||||||
Patch47: php-8.1.0-phpinfo.patch
|
Patch47: php-8.1.0-phpinfo.patch
|
||||||
|
|
||||||
# Upstream fixes (100+)
|
# Upstream fixes (100+)
|
||||||
|
Patch100: php-mbstring.patch
|
||||||
|
|
||||||
# Security fixes (200+)
|
# Security fixes (200+)
|
||||||
|
|
||||||
@ -722,6 +723,7 @@ in pure PHP.
|
|||||||
%patch47 -p1 -b .phpinfo
|
%patch47 -p1 -b .phpinfo
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
|
%patch100 -p1 -b .up
|
||||||
|
|
||||||
# security patches
|
# security patches
|
||||||
|
|
||||||
@ -1541,6 +1543,10 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 8 2022 Remi Collet <remi@remirepo.net> - 8.1.7-1
|
||||||
|
- Update to 8.1.7 - http://www.php.net/releases/8_1_7.php
|
||||||
|
- add upstream patch to initialize pcre before mbstring
|
||||||
|
|
||||||
* Wed May 25 2022 Remi Collet <remi@remirepo.net> - 8.1.7~RC1-1
|
* Wed May 25 2022 Remi Collet <remi@remirepo.net> - 8.1.7~RC1-1
|
||||||
- update to 8.1.7RC1
|
- update to 8.1.7RC1
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (php-8.1.7RC1.tar.xz) = 436290d09349f2a97bbf5d9425b54a3e63aa152104aef16509430f8f61aae0271587a4cf6a68d96cd8ede7d0b471a8c57e5ad4e99c99b5ae8c776bb3c03375e9
|
SHA512 (php-8.1.7.tar.xz) = 1d72db220f3485310e02b67c41dd6434c26b7118f673ba7f425ff6b79cc96c86fc45bfe9c90b302d719eb9b7a5334f363a92ac309c367aacc93ab31a72a63c45
|
||||||
SHA512 (php-8.1.7RC1.tar.xz.asc) = 80ce5fcebdc1468e3f03ce8a9c8d74b3bf089dbcc803ad5c5029f1d6f3f7f396b75fd44e92ef2dcd390409084e3feea8688aa43aa4df056d08e578697ee9c475
|
SHA512 (php-8.1.7.tar.xz.asc) = 9c34d74718261ed2a3375bb06a1e4d68b71d091c12558868bd0ab0325a5046e88af0b8a09fc4035169d681f98b14e108c04ea24053d7d80ca4a0cee5510054fa
|
||||||
|
Loading…
Reference in New Issue
Block a user