rebase to 8.3.15
Related: RHEL-55273
This commit is contained in:
parent
cdaeb26142
commit
41a2a6cac8
8
.gitignore
vendored
8
.gitignore
vendored
@ -1,6 +1,8 @@
|
||||
clog
|
||||
TODO
|
||||
*.md
|
||||
/php-7.4.*.tar.xz
|
||||
/php-7.4.*.tar.xz.asc
|
||||
/php-8.0.*.tar.xz
|
||||
/php-8.0.*.tar.xz.asc
|
||||
/php-8.1.*.tar.xz
|
||||
@ -9,7 +11,5 @@ TODO
|
||||
/php-8.2.*.tar.xz.asc
|
||||
/php-8.3.7.tar.xz
|
||||
/php-8.3.7.tar.xz.asc
|
||||
/php-8.3.10.tar.xz
|
||||
/php-8.3.10.tar.xz.asc
|
||||
/php-8.3.12.tar.xz
|
||||
/php-8.3.12.tar.xz.asc
|
||||
/php-8.3.15.tar.xz
|
||||
/php-8.3.15.tar.xz.asc
|
||||
|
@ -1,43 +0,0 @@
|
||||
#!/usr/bin/env php
|
||||
<?php
|
||||
if ($_SERVER['argc'] < 2) {
|
||||
die("Usage {$_SERVER['argv'][0]} /path/to/NEWS\n");
|
||||
}
|
||||
|
||||
$text = file_get_contents($_SERVER['argv'][1]);
|
||||
if (!$text) {
|
||||
die("Can't read {$_SERVER['argv'][1]}\n");
|
||||
}
|
||||
$debug = (isset($_SERVER['argv'][2]) && $_SERVER['argv'][2]==-'d');
|
||||
|
||||
$text = explode("\n", $text);
|
||||
$in=false;
|
||||
foreach ($text as $line) {
|
||||
if (preg_match('/(^[0-9]+ .* 20[0-9][0-9])[,]* PHP (.*)$/', $line, $reg)) {
|
||||
if ($in) {
|
||||
break;
|
||||
}
|
||||
printf("**PHP version %s** (%s)", $reg[2], $reg[1]);
|
||||
$in = true;
|
||||
continue;
|
||||
} else if (!$in) {
|
||||
if ($debug) echo "+ Ignore $line\n";
|
||||
continue;
|
||||
}
|
||||
$github = 'https://github.com/php/php-src';
|
||||
|
||||
$line = preg_replace('/(#[0-9]+)/', 'php\1', $line);
|
||||
$line = preg_replace('/(GH-([0-9]+))/', "[\\1]($github/issues/\\2)", $line);
|
||||
$line = preg_replace('/(GHSA-([^ ]+))/', "[\\1]($github/security/advisories/\\1)", $line);
|
||||
$line = preg_replace('/(CVE-[0-9]+-[0-9]+)/', '**\1**', $line);
|
||||
if (empty($line)) {
|
||||
echo "\n\n";
|
||||
} else if (substr($line, 0, 2) == '- ') {
|
||||
echo "**" . substr($line, 2) . "**\n";
|
||||
} else if (substr($line, 0, 4) == ' . ') {
|
||||
echo "\n* " . substr($line, 4);
|
||||
} else {
|
||||
echo " ".trim($line);
|
||||
}
|
||||
}
|
||||
|
@ -25,7 +25,7 @@ diff -up ./ext/standard/tests/general_functions/phpinfo.phpt.phpinfo ./ext/stand
|
||||
@@ -17,7 +17,6 @@ PHP Version => %s
|
||||
|
||||
System => %s
|
||||
Build Date => %s%a
|
||||
Build Date => %r(.+?)%r
|
||||
-Configure Command => %s
|
||||
Server API => Command Line Interface
|
||||
Virtual Directory Support => %s
|
16
php.spec
16
php.spec
@ -63,12 +63,12 @@
|
||||
%bcond_with imap
|
||||
%bcond_without lmdb
|
||||
|
||||
%global upver 8.3.12
|
||||
%global upver 8.3.15
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -117,7 +117,7 @@ Patch43: php-7.4.0-phpize.patch
|
||||
Patch45: php-7.4.0-ldap_r.patch
|
||||
# drop "Configure command" from phpinfo output
|
||||
# and only use gcc (instead of full version)
|
||||
Patch47: php-8.1.0-phpinfo.patch
|
||||
Patch47: php-8.3.13-phpinfo.patch
|
||||
# Always warn about missing curve_name
|
||||
# Both Fedora and RHEL do not support arbitrary EC parameters
|
||||
Patch48: php-8.3.0-openssl-ec-param.patch
|
||||
@ -161,6 +161,7 @@ BuildRequires: gcc-c++
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libtool-ltdl-devel
|
||||
BuildRequires: systemtap-sdt-devel
|
||||
BuildRequires: systemtap-sdt-dtrace
|
||||
# used for tests
|
||||
BuildRequires: %{_bindir}/ps
|
||||
BuildRequires: tzdata
|
||||
@ -741,7 +742,7 @@ cp TSRM/LICENSE TSRM_LICENSE
|
||||
cp Zend/asm/LICENSE BOOST_LICENSE
|
||||
cp sapi/fpm/LICENSE fpm_LICENSE
|
||||
cp ext/mbstring/libmbfl/LICENSE libmbfl_LICENSE
|
||||
# cp ext/fileinfo/libmagic/LICENSE libmagic_LICENSE
|
||||
cp ext/fileinfo/libmagic/LICENSE libmagic_LICENSE
|
||||
cp ext/bcmath/libbcmath/LICENSE libbcmath_LICENSE
|
||||
cp ext/date/lib/LICENSE.rst timelib_LICENSE
|
||||
|
||||
@ -1035,7 +1036,7 @@ build --enable-fpm \
|
||||
popd
|
||||
|
||||
# Build for inclusion as embedded script language into applications,
|
||||
# /usr/lib[64]/libphp7.so
|
||||
# /usr/lib[64]/libphp.so
|
||||
pushd build-embedded
|
||||
build --enable-embed \
|
||||
--without-mysqli --disable-pdo \
|
||||
@ -1418,7 +1419,7 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
%files common -f files.common
|
||||
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
|
||||
%license LICENSE TSRM_LICENSE ZEND_LICENSE BOOST_LICENSE
|
||||
#license libmagic_LICENSE
|
||||
%license libmagic_LICENSE
|
||||
%license timelib_LICENSE
|
||||
%doc php.ini-*
|
||||
%config(noreplace) %{_sysconfdir}/php.ini
|
||||
@ -1553,6 +1554,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 20 2025 Remi Collet <rcollet@redhat.com> - 8.3.15-1
|
||||
- rebase to 8.3.15
|
||||
|
||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 8.3.12-2
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
Resolves: RHEL-64018
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-8.3.12.tar.xz) = 2c4b440fa52950c75934559e977f39a179d1ad9edf8a17fe1b9ff89b58fbcafffb1bc1d59b6df46a9631554f0255c9271d906238c59287c799d195459be3e6a3
|
||||
SHA512 (php-8.3.12.tar.xz.asc) = c9b72a7d6dca695f3498aa720a4fbf18771e3b6132e432f4c8fc764a15bdb2b9d5db97f8b6064f1291f7e1ec1a59c3ddec3d79c8a1bbfe68d7bf29f666998f47
|
||||
SHA512 (php-8.3.15.tar.xz) = 43057cca0a6c2187f7991dfbf9743495784f0fa4d0336f08392036ecc2b6f83c7155737ebef3af6144a79eca557bf84cba4aedd34e0d19c701249ca4e8fa86d0
|
||||
SHA512 (php-8.3.15.tar.xz.asc) = 619023075dbf356057e7a2beed29d60228abc9e12cf1a8f569256e5bc4074347f4a5742769c974438e63787ced9227f6f842eabf258013d999f5d813c1f43399
|
||||
|
Loading…
Reference in New Issue
Block a user