Update to 5.6.13 http://www.php.net/releases/5_6_13.php
This commit is contained in:
parent
7b41b9cf7d
commit
3d18378937
1
.gitignore
vendored
1
.gitignore
vendored
@ -53,3 +53,4 @@ php-5.5.*.xz
|
|||||||
/php-5.6.11-strip.tar.xz
|
/php-5.6.11-strip.tar.xz
|
||||||
/php-5.6.12RC1-strip.tar.xz
|
/php-5.6.12RC1-strip.tar.xz
|
||||||
/php-5.6.12-strip.tar.xz
|
/php-5.6.12-strip.tar.xz
|
||||||
|
/php-5.6.13-strip.tar.xz
|
||||||
|
@ -20,9 +20,9 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
|
|||||||
r2: add filesystem trawl to set up name alias index
|
r2: add filesystem trawl to set up name alias index
|
||||||
r1: initial revision
|
r1: initial revision
|
||||||
|
|
||||||
diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/lib/parse_tz.c
|
diff -up php-5.6.13/ext/date/lib/parse_tz.c.systzdata php-5.6.13/ext/date/lib/parse_tz.c
|
||||||
--- php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata 2015-04-30 00:00:18.000000000 +0200
|
--- php-5.6.13/ext/date/lib/parse_tz.c.systzdata 2015-09-03 02:02:45.000000000 +0200
|
||||||
+++ php-5.6.9RC1/ext/date/lib/parse_tz.c 2015-04-30 06:36:47.019617321 +0200
|
+++ php-5.6.13/ext/date/lib/parse_tz.c 2015-09-03 12:50:52.555576944 +0200
|
||||||
@@ -20,6 +20,16 @@
|
@@ -20,6 +20,16 @@
|
||||||
|
|
||||||
#include "timelib.h"
|
#include "timelib.h"
|
||||||
@ -40,11 +40,10 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
|
|||||||
#include <stdio.h>
|
#include <stdio.h>
|
||||||
|
|
||||||
#ifdef HAVE_LOCALE_H
|
#ifdef HAVE_LOCALE_H
|
||||||
@@ -31,7 +41,12 @@
|
@@ -33,7 +43,11 @@
|
||||||
#else
|
|
||||||
#include <strings.h>
|
|
||||||
#endif
|
#endif
|
||||||
+
|
|
||||||
|
#define TIMELIB_SUPPORTS_V2DATA
|
||||||
+#ifndef HAVE_SYSTEM_TZDATA
|
+#ifndef HAVE_SYSTEM_TZDATA
|
||||||
#include "timezonedb.h"
|
#include "timezonedb.h"
|
||||||
+#endif
|
+#endif
|
||||||
@ -53,7 +52,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
|
|||||||
|
|
||||||
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
|
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
|
||||||
# if defined(__LITTLE_ENDIAN__)
|
# if defined(__LITTLE_ENDIAN__)
|
||||||
@@ -53,6 +68,10 @@ static int read_preamble(const unsigned
|
@@ -55,6 +69,10 @@ static int read_preamble(const unsigned
|
||||||
{
|
{
|
||||||
uint32_t version;
|
uint32_t version;
|
||||||
|
|
||||||
@ -64,7 +63,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
|
|||||||
/* read ID */
|
/* read ID */
|
||||||
version = (*tzf)[3] - '0';
|
version = (*tzf)[3] - '0';
|
||||||
*tzf += 4;
|
*tzf += 4;
|
||||||
@@ -296,7 +315,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
|
@@ -298,7 +316,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -484,7 +483,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
|
|||||||
{
|
{
|
||||||
int left = 0, right = tzdb->index_size - 1;
|
int left = 0, right = tzdb->index_size - 1;
|
||||||
#ifdef HAVE_SETLOCALE
|
#ifdef HAVE_SETLOCALE
|
||||||
@@ -335,21 +765,87 @@ static int seek_to_tz_position(const uns
|
@@ -337,21 +766,87 @@ static int seek_to_tz_position(const uns
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -573,7 +572,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
|
static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
|
||||||
@@ -374,24 +870,54 @@ static void read_64bit_header(const unsi
|
@@ -376,24 +871,54 @@ static void read_64bit_header(const unsi
|
||||||
timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
|
timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
|
||||||
{
|
{
|
||||||
const unsigned char *tzf;
|
const unsigned char *tzf;
|
||||||
@ -637,9 +636,9 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
|
|||||||
} else {
|
} else {
|
||||||
tmp = NULL;
|
tmp = NULL;
|
||||||
}
|
}
|
||||||
diff -up php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata php-5.6.9RC1/ext/date/lib/timelib.m4
|
diff -up php-5.6.13/ext/date/lib/timelib.m4.systzdata php-5.6.13/ext/date/lib/timelib.m4
|
||||||
--- php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata 2015-04-30 00:00:18.000000000 +0200
|
--- php-5.6.13/ext/date/lib/timelib.m4.systzdata 2015-09-03 02:02:45.000000000 +0200
|
||||||
+++ php-5.6.9RC1/ext/date/lib/timelib.m4 2015-04-30 06:32:08.549500385 +0200
|
+++ php-5.6.13/ext/date/lib/timelib.m4 2015-09-03 12:49:43.247226154 +0200
|
||||||
@@ -78,3 +78,17 @@ stdlib.h
|
@@ -78,3 +78,17 @@ stdlib.h
|
||||||
|
|
||||||
dnl Check for strtoll, atoll
|
dnl Check for strtoll, atoll
|
8
php.spec
8
php.spec
@ -69,7 +69,7 @@
|
|||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.6.12
|
Version: 5.6.13
|
||||||
%if 0%{?rcver:1}
|
%if 0%{?rcver:1}
|
||||||
Release: 0.%{rpmrel}.%{rcver}%{?dist}
|
Release: 0.%{rpmrel}.%{rcver}%{?dist}
|
||||||
%else
|
%else
|
||||||
@ -114,7 +114,7 @@ Patch21: php-5.4.7-odbctimer.patch
|
|||||||
|
|
||||||
# Functional changes
|
# Functional changes
|
||||||
Patch40: php-5.4.0-dlopen.patch
|
Patch40: php-5.4.0-dlopen.patch
|
||||||
Patch42: php-5.6.9-systzdata-v12.patch
|
Patch42: php-5.6.13-systzdata-v12.patch
|
||||||
# See http://bugs.php.net/53436
|
# See http://bugs.php.net/53436
|
||||||
Patch43: php-5.4.0-phpize.patch
|
Patch43: php-5.4.0-phpize.patch
|
||||||
# Use -lldap_r for OpenLDAP
|
# Use -lldap_r for OpenLDAP
|
||||||
@ -1484,6 +1484,10 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 3 2015 Remi Collet <remi@fedoraproject.org> 5.6.13-1
|
||||||
|
- Update to 5.6.13
|
||||||
|
http://www.php.net/releases/5_6_13.php
|
||||||
|
|
||||||
* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> 5.6.12-1
|
* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> 5.6.12-1
|
||||||
- Update to 5.6.12
|
- Update to 5.6.12
|
||||||
http://www.php.net/releases/5_6_12.php
|
http://www.php.net/releases/5_6_12.php
|
||||||
|
Loading…
Reference in New Issue
Block a user