Update to 5.6.7 http://www.php.net/releases/5_6_7.php
This commit is contained in:
parent
9e7e41a91b
commit
3bc0278791
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@ php-5.5.*.xz
|
||||
/php-5.6.6RC1-strip.tar.xz
|
||||
/php-5.6.6-strip.tar.xz
|
||||
/php-5.6.7RC1-strip.tar.xz
|
||||
/php-5.6.7-strip.tar.xz
|
||||
|
@ -1,40 +0,0 @@
|
||||
From 89f86119d612d539a4ec189aff4d3c077cb608a1 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Sun, 8 Mar 2015 07:34:51 +0100
|
||||
Subject: [PATCH] Fix odbc build as shared
|
||||
|
||||
Broken since a41aa46759d20e23af92df00b917ca66c6102412
|
||||
---
|
||||
ext/odbc/config.m4 | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/ext/odbc/config.m4 b/ext/odbc/config.m4
|
||||
index f79c461..9555efd 100644
|
||||
--- a/ext/odbc/config.m4
|
||||
+++ b/ext/odbc/config.m4
|
||||
@@ -99,6 +99,11 @@ AC_DEFUN([PHP_ODBC_FIND_EMPRESS_BCS_LIBS],[
|
||||
dnl
|
||||
dnl configure options
|
||||
dnl
|
||||
+
|
||||
+PHP_ARG_WITH(odbcver,,
|
||||
+[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
|
||||
+ Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
|
||||
+
|
||||
if test -z "$ODBC_TYPE"; then
|
||||
PHP_ARG_WITH(adabas,,
|
||||
[ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
|
||||
@@ -490,10 +495,6 @@ PHP_ARG_WITH(dbmaker,,
|
||||
fi
|
||||
fi
|
||||
|
||||
-PHP_ARG_WITH(odbcver,,
|
||||
-[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
|
||||
- Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
|
||||
-
|
||||
if test "no" != "$PHP_ODBCVER"; then
|
||||
if test "$PHP_ODBCVER" != "0"; then
|
||||
AC_DEFINE_UNQUOTED(ODBCVER, $PHP_ODBCVER, [ The highest supported ODBC version ])
|
||||
--
|
||||
2.1.4
|
||||
|
12
php.spec
12
php.spec
@ -57,12 +57,12 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
%global rcver RC1
|
||||
#global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.6.7
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -113,7 +113,6 @@ Patch46: php-5.6.3-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-odbc.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -717,7 +716,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .odbc
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1475,7 +1473,11 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Mar 8 2015 Remi Collet <remi@fedoraproject.org> 5.6.7-0.1.RC1
|
||||
* Fri Mar 20 2015 Remi Collet <remi@fedoraproject.org> 5.6.7-2
|
||||
- Update to 5.6.7
|
||||
http://www.php.net/releases/5_6_7.php
|
||||
|
||||
* Sun Mar 8 2015 Remi Collet <remi@fedoraproject.org> 5.6.7-1
|
||||
- update to 5.6.7RC1
|
||||
|
||||
* Thu Feb 19 2015 Remi Collet <remi@fedoraproject.org> 5.6.6-1
|
||||
|
Loading…
Reference in New Issue
Block a user