update to 5.3.2 - security and bugfix
This commit is contained in:
parent
3bd1eb2581
commit
3ba1d41318
@ -1 +1 @@
|
|||||||
php-5.3.1.tar.bz2
|
php-5.3.2.tar.bz2
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
diff -up ext/pdo_oci/config.m4.remi-oci8 ext/pdo_oci/config.m4
|
|
||||||
--- ext/pdo_oci/config.m4.remi-oci8 2008-10-22 22:35:52.000000000 +0200
|
|
||||||
+++ ext/pdo_oci/config.m4 2008-12-13 16:25:25.000000000 +0100
|
|
||||||
@@ -74,7 +74,10 @@ You need to tell me where to find your O
|
|
||||||
PDO_OCI_IC_PREFIX="`echo $PDO_OCI_DIR | cut -d, -f2`"
|
|
||||||
PDO_OCI_IC_VERS="`echo $PDO_OCI_DIR | cut -d, -f3`"
|
|
||||||
AC_MSG_CHECKING([for oci.h])
|
|
||||||
- if test -f $PDO_OCI_IC_PREFIX/include/oracle/$PDO_OCI_IC_VERS/client/oci.h ; then
|
|
||||||
+ if test -f $PDO_OCI_IC_PREFIX/include/oracle/$PDO_OCI_IC_VERS/client64/oci.h ; then
|
|
||||||
+ PHP_ADD_INCLUDE($PDO_OCI_IC_PREFIX/include/oracle/$PDO_OCI_IC_VERS/client64)
|
|
||||||
+ AC_MSG_RESULT($PDO_OCI_IC_PREFIX/include/oracle/$PDO_OCI_IC_VERS/client64)
|
|
||||||
+ elif test -f $PDO_OCI_IC_PREFIX/include/oracle/$PDO_OCI_IC_VERS/client/oci.h ; then
|
|
||||||
PHP_ADD_INCLUDE($PDO_OCI_IC_PREFIX/include/oracle/$PDO_OCI_IC_VERS/client)
|
|
||||||
AC_MSG_RESULT($PDO_OCI_IC_PREFIX/include/oracle/$PDO_OCI_IC_VERS/client)
|
|
||||||
elif test -f $PDO_OCI_IC_PREFIX/lib/oracle/$PDO_OCI_IC_VERS/client/include/oci.h ; then
|
|
||||||
@@ -91,6 +94,10 @@ You need to tell me where to find your O
|
|
||||||
fi
|
|
||||||
if test -f "$PDO_OCI_IC_PREFIX/lib/oracle/$PDO_OCI_IC_VERS/client/lib/libclntsh.so" ; then
|
|
||||||
PDO_OCI_LIB_DIR="$PDO_OCI_IC_PREFIX/lib/oracle/$PDO_OCI_IC_VERS/client/lib"
|
|
||||||
+ elif test -f "$PDO_OCI_IC_PREFIX/lib64/oracle/$PDO_OCI_IC_VERS/client64/lib/libclntsh.so" ; then
|
|
||||||
+ PDO_OCI_LIB_DIR="$PDO_OCI_IC_PREFIX/lib64/oracle/$PDO_OCI_IC_VERS/client64/lib"
|
|
||||||
+ elif test -f "$PDO_OCI_IC_PREFIX/lib64/oracle/$PDO_OCI_IC_VERS/client/lib/libclntsh.so" ; then
|
|
||||||
+ PDO_OCI_LIB_DIR="$PDO_OCI_IC_PREFIX/lib64/oracle/$PDO_OCI_IC_VERS/client/lib"
|
|
||||||
elif test -f "$PDO_OCI_IC_PREFIX/client/lib/libclntsh.so" ; then
|
|
||||||
PDO_OCI_LIB_DIR="$PDO_OCI_IC_PREFIX/client/lib"
|
|
||||||
elif test -f "$PDO_OCI_IC_PREFIX/libclntsh.so" ; then
|
|
||||||
--- ext/oci8/config.m4.remi-oci8 2009-03-13 00:52:37.000000000 +0100
|
|
||||||
+++ ext/oci8/config.m4 2009-03-24 20:42:39.000000000 +0100
|
|
||||||
@@ -306,6 +306,7 @@
|
|
||||||
|
|
||||||
dnl Header directory for Instant Client SDK RPM install
|
|
||||||
OCISDKRPMINC=`echo "$PHP_OCI8_INSTANT_CLIENT" | $PHP_OCI8_SED -e 's!^/usr/lib/oracle/\(.*\)/client\('${PHP_OCI8_IC_LIBDIR_SUFFIX}'\)*/lib[/]*$!/usr/include/oracle/\1/client\2!'`
|
|
||||||
+ OCISDKRPMINC=`echo "$PHP_OCI8_INSTANT_CLIENT" | $PHP_OCI8_SED -e 's!^/usr/\(lib64\|lib\)/oracle/\(.*\)/\(client64\|client\)/lib[/]*$!/usr/include/oracle/\2/\3!'`
|
|
||||||
|
|
||||||
dnl Header directory for Instant Client SDK zip file install
|
|
||||||
OCISDKZIPINC=$PHP_OCI8_INSTANT_CLIENT/sdk/include
|
|
@ -1,114 +0,0 @@
|
|||||||
diff -up php5.3-200908150630/configure.in.gnusrc php5.3-200908150630/configure.in
|
|
||||||
--- php5.3-200908150630/configure.in.gnusrc 2009-08-12 00:34:39.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/configure.in 2009-08-15 08:46:09.000000000 +0200
|
|
||||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
|
||||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
|
||||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
|
||||||
|
|
||||||
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
|
||||||
+
|
|
||||||
dnl Setting up the PHP version based on the information above.
|
|
||||||
dnl -------------------------------------------------------------------------
|
|
||||||
|
|
||||||
diff -up php5.3-200908150630/ext/interbase/interbase.c.gnusrc php5.3-200908150630/ext/interbase/interbase.c
|
|
||||||
--- php5.3-200908150630/ext/interbase/interbase.c.gnusrc 2009-07-17 14:23:09.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/ext/interbase/interbase.c 2009-08-15 08:46:09.000000000 +0200
|
|
||||||
@@ -24,7 +24,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
diff -up php5.3-200908150630/ext/pdo_firebird/firebird_driver.c.gnusrc php5.3-200908150630/ext/pdo_firebird/firebird_driver.c
|
|
||||||
--- php5.3-200908150630/ext/pdo_firebird/firebird_driver.c.gnusrc 2009-07-17 14:22:08.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/ext/pdo_firebird/firebird_driver.c 2009-08-15 08:46:09.000000000 +0200
|
|
||||||
@@ -22,7 +22,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
#ifdef ZEND_ENGINE_2
|
|
||||||
diff -up php5.3-200908150630/ext/standard/file.c.gnusrc php5.3-200908150630/ext/standard/file.c
|
|
||||||
--- php5.3-200908150630/ext/standard/file.c.gnusrc 2009-07-17 14:20:59.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/ext/standard/file.c 2009-08-15 08:46:09.000000000 +0200
|
|
||||||
@@ -123,9 +123,6 @@ php_file_globals file_globals;
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
|
|
||||||
-# ifndef _GNU_SOURCE
|
|
||||||
-# define _GNU_SOURCE
|
|
||||||
-# endif
|
|
||||||
# include <fnmatch.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
diff -up php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c.gnusrc php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c
|
|
||||||
--- php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2009-07-17 14:20:18.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/ext/zlib/zlib_fopen_wrapper.c 2009-08-15 08:47:43.000000000 +0200
|
|
||||||
@@ -19,8 +19,6 @@
|
|
||||||
|
|
||||||
/* $Id: zlib_fopen_wrapper.c 274034 2009-01-20 15:41:23Z felipe $ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
-
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_zlib.h"
|
|
||||||
#include "fopen_wrappers.h"
|
|
||||||
diff -up php5.3-200908150630/main/php.h.gnusrc php5.3-200908150630/main/php.h
|
|
||||||
--- php5.3-200908150630/main/php.h.gnusrc 2009-07-17 14:23:41.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/main/php.h 2009-08-15 08:46:09.000000000 +0200
|
|
||||||
@@ -30,6 +30,7 @@
|
|
||||||
#define PHP_HAVE_STREAMS
|
|
||||||
#define YYDEBUG 0
|
|
||||||
|
|
||||||
+#include "php_config.h"
|
|
||||||
#include "php_version.h"
|
|
||||||
#include "zend.h"
|
|
||||||
#include "zend_qsort.h"
|
|
||||||
diff -up php5.3-200908150630/main/streams/cast.c.gnusrc php5.3-200908150630/main/streams/cast.c
|
|
||||||
--- php5.3-200908150630/main/streams/cast.c.gnusrc 2009-07-17 14:23:41.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/main/streams/cast.c 2009-08-15 08:48:09.000000000 +0200
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id: cast.c 279036 2009-04-20 08:28:44Z pajoye $ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
||||||
diff -up php5.3-200908150630/main/streams/streams.c.gnusrc php5.3-200908150630/main/streams/streams.c
|
|
||||||
--- php5.3-200908150630/main/streams/streams.c.gnusrc 2009-07-17 14:23:40.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/main/streams/streams.c 2009-08-15 08:49:04.000000000 +0200
|
|
||||||
@@ -21,7 +21,6 @@
|
|
||||||
|
|
||||||
/* $Id: streams.c 280678 2009-05-17 14:58:10Z lbarnaud $ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
||||||
diff -up php5.3-200908150630/Zend/zend_language_parser.c.gnusrc php5.3-200908150630/Zend/zend_language_parser.c
|
|
||||||
--- php5.3-200908150630/Zend/zend_language_parser.c.gnusrc 2009-08-15 08:36:38.000000000 +0200
|
|
||||||
+++ php5.3-200908150630/Zend/zend_language_parser.c 2009-08-15 08:46:09.000000000 +0200
|
|
||||||
@@ -366,6 +366,8 @@
|
|
||||||
#include "zend_API.h"
|
|
||||||
#include "zend_constants.h"
|
|
||||||
|
|
||||||
+#include <string.h>
|
|
||||||
+
|
|
||||||
|
|
||||||
#define YYERROR_VERBOSE
|
|
||||||
#define YYSTYPE znode
|
|
||||||
--- php-5.3.1RC2/main/streams/memory.c.gnusrc 2009-10-09 19:45:03.000000000 +0200
|
|
||||||
+++ php-5.3.1RC2/main/streams/memory.c 2009-10-21 17:31:50.000000000 +0200
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id: memory.c 289437 2009-10-09 17:45:03Z pajoye $ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
PHPAPI int php_url_decode(char *str, int len);
|
|
@ -1,10 +1,11 @@
|
|||||||
|
|
||||||
Fix use of divert() to work with autoconf 2.6x.
|
Fix use of divert() to work with autoconf 2.6x.
|
||||||
|
|
||||||
--- php-5.3.1/configure.in.aconf26x
|
diff -up php-5.3.2/configure.in.aconf26x php-5.3.2/configure.in
|
||||||
+++ php-5.3.1/configure.in
|
--- php-5.3.2/configure.in.aconf26x 2010-03-06 07:55:20.000000000 +0100
|
||||||
|
+++ php-5.3.2/configure.in 2010-03-06 07:57:57.000000000 +0100
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
## $Id$ -*- autoconf -*-
|
## $Id: configure.in 295792 2010-03-03 16:36:07Z johannes $ -*- autoconf -*-
|
||||||
dnl ## Process this file with autoconf to produce a configure script.
|
dnl ## Process this file with autoconf to produce a configure script.
|
||||||
|
|
||||||
-divert(1)
|
-divert(1)
|
||||||
@ -12,7 +13,7 @@ Fix use of divert() to work with autoconf 2.6x.
|
|||||||
|
|
||||||
dnl ## Diversion 1 is the autoconf + automake setup phase. We also
|
dnl ## Diversion 1 is the autoconf + automake setup phase. We also
|
||||||
dnl ## set the PHP version, deal with platform-specific compile
|
dnl ## set the PHP version, deal with platform-specific compile
|
||||||
@@ -307,7 +307,7 @@ sinclude(TSRM/threads.m4)
|
@@ -292,7 +292,7 @@ sinclude(TSRM/threads.m4)
|
||||||
sinclude(TSRM/tsrm.m4)
|
sinclude(TSRM/tsrm.m4)
|
||||||
|
|
||||||
|
|
||||||
@ -21,7 +22,7 @@ Fix use of divert() to work with autoconf 2.6x.
|
|||||||
|
|
||||||
dnl ## Diversion 2 is where we set PHP-specific options and come up
|
dnl ## Diversion 2 is where we set PHP-specific options and come up
|
||||||
dnl ## with reasonable default values for them. We check for pthreads here
|
dnl ## with reasonable default values for them. We check for pthreads here
|
||||||
@@ -346,7 +346,7 @@ if test "$enable_maintainer_zts" = "yes"
|
@@ -331,7 +331,7 @@ if test "$enable_maintainer_zts" = "yes"
|
||||||
PTHREADS_FLAGS
|
PTHREADS_FLAGS
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -30,7 +31,7 @@ Fix use of divert() to work with autoconf 2.6x.
|
|||||||
|
|
||||||
dnl ## In diversion 3 we check for compile-time options to the PHP
|
dnl ## In diversion 3 we check for compile-time options to the PHP
|
||||||
dnl ## core and how to deal with different system dependencies.
|
dnl ## core and how to deal with different system dependencies.
|
||||||
@@ -693,7 +693,7 @@ if test "x$php_crypt_r" = "x1"; then
|
@@ -677,7 +677,7 @@ if test "x$php_crypt_r" = "x1"; then
|
||||||
PHP_CRYPT_R_STYLE
|
PHP_CRYPT_R_STYLE
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -39,7 +40,7 @@ Fix use of divert() to work with autoconf 2.6x.
|
|||||||
|
|
||||||
dnl ## In diversion 4 we check user-configurable general settings.
|
dnl ## In diversion 4 we check user-configurable general settings.
|
||||||
|
|
||||||
@@ -934,7 +934,7 @@ else
|
@@ -918,7 +918,7 @@ else
|
||||||
AC_MSG_RESULT([using system default])
|
AC_MSG_RESULT([using system default])
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -48,18 +49,19 @@ Fix use of divert() to work with autoconf 2.6x.
|
|||||||
|
|
||||||
dnl ## In diversion 5 we check which extensions should be compiled.
|
dnl ## In diversion 5 we check which extensions should be compiled.
|
||||||
dnl ## All of these are normally in the extension directories.
|
dnl ## All of these are normally in the extension directories.
|
||||||
--- php-5.3.1/ext/standard/config.m4.aconf26x
|
diff -up php-5.3.2/ext/standard/config.m4.aconf26x php-5.3.2/ext/standard/config.m4
|
||||||
+++ php-5.3.1/ext/standard/config.m4
|
--- php-5.3.2/ext/standard/config.m4.aconf26x 2010-02-22 01:34:22.000000000 +0100
|
||||||
|
+++ php-5.3.2/ext/standard/config.m4 2010-03-06 07:58:47.000000000 +0100
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
dnl $Id$ -*- autoconf -*-
|
dnl $Id: config.m4 295350 2010-02-22 00:34:22Z pajoye $ -*- autoconf -*-
|
||||||
|
|
||||||
-divert(3)dnl
|
-divert(3)dnl
|
||||||
+divert(1003)dnl
|
+divert(1003)dnl
|
||||||
|
|
||||||
dnl
|
dnl
|
||||||
dnl Check if flush should be called explicitly after buffered io
|
dnl Check if flush should be called explicitly after buffered io
|
||||||
@@ -220,7 +220,7 @@ dnl
|
@@ -333,7 +333,7 @@ dnl
|
||||||
AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
|
AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan mempcpy strpncpy)
|
||||||
AC_FUNC_FNMATCH
|
AC_FUNC_FNMATCH
|
||||||
|
|
||||||
-divert(5)dnl
|
-divert(5)dnl
|
||||||
@ -67,8 +69,9 @@ Fix use of divert() to work with autoconf 2.6x.
|
|||||||
|
|
||||||
dnl
|
dnl
|
||||||
dnl Check if there is a support means of creating a new process
|
dnl Check if there is a support means of creating a new process
|
||||||
--- php-5.3.1/scripts/phpize.m4.aconf26x
|
diff -up php-5.3.2/scripts/phpize.m4.aconf26x php-5.3.2/scripts/phpize.m4
|
||||||
+++ php-5.3.1/scripts/phpize.m4
|
--- php-5.3.2/scripts/phpize.m4.aconf26x 2009-12-02 18:42:58.000000000 +0100
|
||||||
|
+++ php-5.3.2/scripts/phpize.m4 2010-03-06 07:55:20.000000000 +0100
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
dnl This file becomes configure.in for self-contained extensions.
|
dnl This file becomes configure.in for self-contained extensions.
|
||||||
|
|
115
php-5.3.2-gnusrc.patch
Normal file
115
php-5.3.2-gnusrc.patch
Normal file
@ -0,0 +1,115 @@
|
|||||||
|
diff -up php-5.3.2RC2/configure.in.gnusrc php-5.3.2RC2/configure.in
|
||||||
|
--- php-5.3.2RC2/configure.in.gnusrc 2010-02-12 01:20:28.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/configure.in 2010-02-12 13:58:21.000000000 +0100
|
||||||
|
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||||
|
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||||
|
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||||
|
|
||||||
|
+AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
|
||||||
|
+
|
||||||
|
dnl Setting up the PHP version based on the information above.
|
||||||
|
dnl -------------------------------------------------------------------------
|
||||||
|
|
||||||
|
diff -up php-5.3.2RC2/ext/interbase/interbase.c.gnusrc php-5.3.2RC2/ext/interbase/interbase.c
|
||||||
|
--- php-5.3.2RC2/ext/interbase/interbase.c.gnusrc 2010-01-03 10:23:27.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/ext/interbase/interbase.c 2010-02-12 13:58:21.000000000 +0100
|
||||||
|
@@ -24,7 +24,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
diff -up php-5.3.2RC2/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.3.2RC2/ext/pdo_firebird/firebird_driver.c
|
||||||
|
--- php-5.3.2RC2/ext/pdo_firebird/firebird_driver.c.gnusrc 2010-02-03 20:48:04.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/ext/pdo_firebird/firebird_driver.c 2010-02-12 13:58:21.000000000 +0100
|
||||||
|
@@ -22,7 +22,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#ifdef ZEND_ENGINE_2
|
||||||
|
diff -up php-5.3.2RC2/ext/standard/file.c.gnusrc php-5.3.2RC2/ext/standard/file.c
|
||||||
|
--- php-5.3.2RC2/ext/standard/file.c.gnusrc 2010-02-11 19:03:57.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/ext/standard/file.c 2010-02-12 13:58:21.000000000 +0100
|
||||||
|
@@ -113,9 +113,6 @@ php_file_globals file_globals;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
|
||||||
|
-# ifndef _GNU_SOURCE
|
||||||
|
-# define _GNU_SOURCE
|
||||||
|
-# endif
|
||||||
|
# include <fnmatch.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
diff -up php-5.3.2RC2/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.3.2RC2/ext/zlib/zlib_fopen_wrapper.c
|
||||||
|
--- php-5.3.2RC2/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2010-01-03 10:23:27.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/ext/zlib/zlib_fopen_wrapper.c 2010-02-12 14:00:10.000000000 +0100
|
||||||
|
@@ -19,8 +19,6 @@
|
||||||
|
|
||||||
|
/* $Id: zlib_fopen_wrapper.c 293036 2010-01-03 09:23:27Z sebastian $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
-
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_zlib.h"
|
||||||
|
#include "fopen_wrappers.h"
|
||||||
|
diff -up php-5.3.2RC2/main/php.h.gnusrc php-5.3.2RC2/main/php.h
|
||||||
|
--- php-5.3.2RC2/main/php.h.gnusrc 2010-02-04 11:13:54.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/main/php.h 2010-02-12 13:58:21.000000000 +0100
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#define PHP_HAVE_STREAMS
|
||||||
|
#define YYDEBUG 0
|
||||||
|
|
||||||
|
+#include "php_config.h"
|
||||||
|
#include "php_version.h"
|
||||||
|
#include "zend.h"
|
||||||
|
#include "zend_qsort.h"
|
||||||
|
diff -up php-5.3.2RC2/main/streams/cast.c.gnusrc php-5.3.2RC2/main/streams/cast.c
|
||||||
|
--- php-5.3.2RC2/main/streams/cast.c.gnusrc 2010-02-03 21:49:03.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/main/streams/cast.c 2010-02-12 14:01:02.000000000 +0100
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id: cast.c 294462 2010-02-03 20:49:03Z pajoye $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
diff -up php-5.3.2RC2/main/streams/memory.c.gnusrc php-5.3.2RC2/main/streams/memory.c
|
||||||
|
--- php-5.3.2RC2/main/streams/memory.c.gnusrc 2010-01-03 10:23:27.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/main/streams/memory.c 2010-02-12 14:01:22.000000000 +0100
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id: memory.c 293036 2010-01-03 09:23:27Z sebastian $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
PHPAPI int php_url_decode(char *str, int len);
|
||||||
|
diff -up php-5.3.2RC2/main/streams/streams.c.gnusrc php-5.3.2RC2/main/streams/streams.c
|
||||||
|
--- php-5.3.2RC2/main/streams/streams.c.gnusrc 2010-02-05 01:39:31.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/main/streams/streams.c 2010-02-12 14:01:38.000000000 +0100
|
||||||
|
@@ -21,7 +21,6 @@
|
||||||
|
|
||||||
|
/* $Id: streams.c 294550 2010-02-05 00:39:31Z pajoye $ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
diff -up php-5.3.2RC2/Zend/zend_language_parser.c.gnusrc php-5.3.2RC2/Zend/zend_language_parser.c
|
||||||
|
--- php-5.3.2RC2/Zend/zend_language_parser.c.gnusrc 2010-02-12 01:26:13.000000000 +0100
|
||||||
|
+++ php-5.3.2RC2/Zend/zend_language_parser.c 2010-02-12 13:58:21.000000000 +0100
|
||||||
|
@@ -366,6 +366,8 @@
|
||||||
|
#include "zend_API.h"
|
||||||
|
#include "zend_constants.h"
|
||||||
|
|
||||||
|
+#include <string.h>
|
||||||
|
+
|
||||||
|
|
||||||
|
#define YYERROR_VERBOSE
|
||||||
|
#define YYSTYPE znode
|
15
php-5.3.2-phar.patch
Normal file
15
php-5.3.2-phar.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- php-5.3.2RC1/ext/phar/Makefile.frag.orig 2009-12-26 13:02:41.000000000 +0100
|
||||||
|
+++ php-5.3.2RC1/ext/phar/Makefile.frag 2009-12-26 13:03:17.000000000 +0100
|
||||||
|
@@ -19,11 +19,7 @@
|
||||||
|
else \
|
||||||
|
$(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
|
||||||
|
fi;`
|
||||||
|
-PHP_PHARCMD_BANG = `if test -x "$(PHP_EXECUTABLE)"; then \
|
||||||
|
- $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
|
||||||
|
- else \
|
||||||
|
- $(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)"; \
|
||||||
|
- fi; `
|
||||||
|
+PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
||||||
|
|
||||||
|
$(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
|
||||||
|
-@test -d $(builddir)/phar || mkdir $(builddir)/phar
|
29
php.spec
29
php.spec
@ -9,12 +9,15 @@
|
|||||||
%global zipver 1.9.1
|
%global zipver 1.9.1
|
||||||
%global jsonver 1.2.1
|
%global jsonver 1.2.1
|
||||||
|
|
||||||
%define httpd_mmn %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
|
%global httpd_mmn %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
|
||||||
|
|
||||||
|
# Regression tests take a long time, you can skip 'em with this
|
||||||
|
%{!?runselftest: %{expand: %%global runselftest 1}}
|
||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.3.1
|
Version: 5.3.2
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: PHP
|
License: PHP
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
URL: http://www.php.net/
|
URL: http://www.php.net/
|
||||||
@ -25,16 +28,16 @@ Source2: php.ini
|
|||||||
Source3: macros.php
|
Source3: macros.php
|
||||||
|
|
||||||
# Build fixes
|
# Build fixes
|
||||||
Patch1: php-5.3.1-gnusrc.patch
|
Patch1: php-5.3.2-gnusrc.patch
|
||||||
Patch2: php-5.3.0-install.patch
|
Patch2: php-5.3.0-install.patch
|
||||||
Patch3: php-5.2.4-norpath.patch
|
Patch3: php-5.2.4-norpath.patch
|
||||||
Patch4: php-5.3.0-phpize64.patch
|
Patch4: php-5.3.0-phpize64.patch
|
||||||
Patch5: php-5.2.0-includedir.patch
|
Patch5: php-5.2.0-includedir.patch
|
||||||
Patch6: php-5.2.4-embed.patch
|
Patch6: php-5.2.4-embed.patch
|
||||||
Patch7: php-5.3.0-recode.patch
|
Patch7: php-5.3.0-recode.patch
|
||||||
Patch8: php-5.3.1-aconf26x.patch
|
Patch8: php-5.3.2-aconf26x.patch
|
||||||
# Filed upstream: http://bugs.php.net/50209
|
# http://bugs.php.net/50578
|
||||||
Patch9: php-5.3.0-libedit.patch
|
Patch9: php-5.3.2-phar.patch
|
||||||
|
|
||||||
# Fixes for extension modules
|
# Fixes for extension modules
|
||||||
Patch20: php-4.3.11-shutdown.patch
|
Patch20: php-4.3.11-shutdown.patch
|
||||||
@ -432,7 +435,7 @@ support for using the enchant library to PHP.
|
|||||||
%patch6 -p1 -b .embed
|
%patch6 -p1 -b .embed
|
||||||
%patch7 -p1 -b .recode
|
%patch7 -p1 -b .recode
|
||||||
%patch8 -p1 -b .aconf26x
|
%patch8 -p1 -b .aconf26x
|
||||||
%patch9 -p1 -b .libedit
|
%patch9 -p1 -b .shebang
|
||||||
|
|
||||||
%patch20 -p1 -b .shutdown
|
%patch20 -p1 -b .shutdown
|
||||||
%patch21 -p1 -b .macropen
|
%patch21 -p1 -b .macropen
|
||||||
@ -572,7 +575,6 @@ ln -sf ../configure
|
|||||||
--enable-ucd-snmp-hack \
|
--enable-ucd-snmp-hack \
|
||||||
--enable-shmop \
|
--enable-shmop \
|
||||||
--enable-calendar \
|
--enable-calendar \
|
||||||
--without-mime-magic \
|
|
||||||
--without-sqlite \
|
--without-sqlite \
|
||||||
--with-libxml-dir=%{_prefix} \
|
--with-libxml-dir=%{_prefix} \
|
||||||
--enable-xml \
|
--enable-xml \
|
||||||
@ -669,6 +671,7 @@ popd
|
|||||||
### the last SAPI to be built.
|
### the last SAPI to be built.
|
||||||
|
|
||||||
%check
|
%check
|
||||||
|
%if %runselftest
|
||||||
cd build-apache
|
cd build-apache
|
||||||
# Run tests, using the CLI SAPI
|
# Run tests, using the CLI SAPI
|
||||||
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
|
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
|
||||||
@ -684,6 +687,7 @@ if ! make test; then
|
|||||||
#exit 1
|
#exit 1
|
||||||
fi
|
fi
|
||||||
unset NO_INTERACTION REPORT_EXIT_STATUS MALLOC_CHECK_
|
unset NO_INTERACTION REPORT_EXIT_STATUS MALLOC_CHECK_
|
||||||
|
%endif
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
||||||
@ -863,6 +867,13 @@ rm files.* macros.php
|
|||||||
%files enchant -f files.enchant
|
%files enchant -f files.enchant
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Mar 06 2010 Remi Collet <Fedora@famillecollet.com> 5.3.2-1
|
||||||
|
- PHP 5.3.2 Released!
|
||||||
|
- remove mime_magic option (now provided by fileinfo, by emu)
|
||||||
|
- add patch for http://bugs.php.net/50578
|
||||||
|
- remove patch for libedit (upstream)
|
||||||
|
- add runselftest option to allow build without test suite
|
||||||
|
|
||||||
* Fri Nov 27 2009 Joe Orton <jorton@redhat.com> - 5.3.1-3
|
* Fri Nov 27 2009 Joe Orton <jorton@redhat.com> - 5.3.1-3
|
||||||
- update to v7 of systzdata patch
|
- update to v7 of systzdata patch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user