- work around rpm %patch zero-fuzz for the time being
This commit is contained in:
parent
b1f466f628
commit
3244077310
@ -1,96 +1,5 @@
|
|||||||
--- php-5.2.4/Zend/zend_language_parser.c.gnusrc
|
--- php-5.2.6/configure.in.gnusrc
|
||||||
+++ php-5.2.4/Zend/zend_language_parser.c
|
+++ php-5.2.6/configure.in
|
||||||
@@ -356,6 +356,8 @@
|
|
||||||
#include "zend_API.h"
|
|
||||||
#include "zend_constants.h"
|
|
||||||
|
|
||||||
+#include <string.h>
|
|
||||||
+
|
|
||||||
|
|
||||||
#define YYERROR_VERBOSE
|
|
||||||
#define YYSTYPE znode
|
|
||||||
--- php-5.2.4/main/streams/streams.c.gnusrc
|
|
||||||
+++ php-5.2.4/main/streams/streams.c
|
|
||||||
@@ -21,7 +21,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
||||||
--- php-5.2.4/main/streams/cast.c.gnusrc
|
|
||||||
+++ php-5.2.4/main/streams/cast.c
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_globals.h"
|
|
||||||
#include "php_network.h"
|
|
||||||
--- php-5.2.4/main/streams/memory.c.gnusrc
|
|
||||||
+++ php-5.2.4/main/streams/memory.c
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
PHPAPI int php_url_decode(char *str, int len);
|
|
||||||
--- php-5.2.4/main/php.h.gnusrc
|
|
||||||
+++ php-5.2.4/main/php.h
|
|
||||||
@@ -30,6 +30,7 @@
|
|
||||||
#define PHP_HAVE_STREAMS
|
|
||||||
#define YYDEBUG 0
|
|
||||||
|
|
||||||
+#include "php_config.h"
|
|
||||||
#include "php_version.h"
|
|
||||||
#include "zend.h"
|
|
||||||
#include "zend_qsort.h"
|
|
||||||
--- php-5.2.4/ext/standard/file.c.gnusrc
|
|
||||||
+++ php-5.2.4/ext/standard/file.c
|
|
||||||
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
|
||||||
|
|
||||||
#ifdef HAVE_FNMATCH
|
|
||||||
#ifndef _GNU_SOURCE
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
#endif
|
|
||||||
#include <fnmatch.h>
|
|
||||||
#endif
|
|
||||||
--- php-5.2.4/ext/pdo_firebird/firebird_driver.c.gnusrc
|
|
||||||
+++ php-5.2.4/ext/pdo_firebird/firebird_driver.c
|
|
||||||
@@ -22,7 +22,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_ini.h"
|
|
||||||
--- php-5.2.4/ext/zlib/zlib_fopen_wrapper.c.gnusrc
|
|
||||||
+++ php-5.2.4/ext/zlib/zlib_fopen_wrapper.c
|
|
||||||
@@ -19,7 +19,6 @@
|
|
||||||
|
|
||||||
/* $Id$ */
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
#include "php_zlib.h"
|
|
||||||
--- php-5.2.4/ext/interbase/interbase.c.gnusrc
|
|
||||||
+++ php-5.2.4/ext/interbase/interbase.c
|
|
||||||
@@ -24,7 +24,6 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define _GNU_SOURCE
|
|
||||||
|
|
||||||
#include "php.h"
|
|
||||||
|
|
||||||
--- php-5.2.4/configure.in.gnusrc
|
|
||||||
+++ php-5.2.4/configure.in
|
|
||||||
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
|
||||||
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
|
||||||
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
|
||||||
@ -100,3 +9,94 @@
|
|||||||
dnl Setting up the PHP version based on the information above.
|
dnl Setting up the PHP version based on the information above.
|
||||||
dnl -------------------------------------------------------------------------
|
dnl -------------------------------------------------------------------------
|
||||||
|
|
||||||
|
--- php-5.2.6/ext/interbase/interbase.c.gnusrc
|
||||||
|
+++ php-5.2.6/ext/interbase/interbase.c
|
||||||
|
@@ -24,7 +24,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
--- php-5.2.6/ext/pdo_firebird/firebird_driver.c.gnusrc
|
||||||
|
+++ php-5.2.6/ext/pdo_firebird/firebird_driver.c
|
||||||
|
@@ -22,7 +22,6 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_ini.h"
|
||||||
|
--- php-5.2.6/ext/standard/file.c.gnusrc
|
||||||
|
+++ php-5.2.6/ext/standard/file.c
|
||||||
|
@@ -118,7 +118,6 @@ php_file_globals file_globals;
|
||||||
|
|
||||||
|
#ifdef HAVE_FNMATCH
|
||||||
|
#ifndef _GNU_SOURCE
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#endif
|
||||||
|
#include <fnmatch.h>
|
||||||
|
#endif
|
||||||
|
--- php-5.2.6/ext/zlib/zlib_fopen_wrapper.c.gnusrc
|
||||||
|
+++ php-5.2.6/ext/zlib/zlib_fopen_wrapper.c
|
||||||
|
@@ -19,7 +19,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_zlib.h"
|
||||||
|
--- php-5.2.6/main/php.h.gnusrc
|
||||||
|
+++ php-5.2.6/main/php.h
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#define PHP_HAVE_STREAMS
|
||||||
|
#define YYDEBUG 0
|
||||||
|
|
||||||
|
+#include "php_config.h"
|
||||||
|
#include "php_version.h"
|
||||||
|
#include "zend.h"
|
||||||
|
#include "zend_qsort.h"
|
||||||
|
--- php-5.2.6/main/streams/cast.c.gnusrc
|
||||||
|
+++ php-5.2.6/main/streams/cast.c
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
--- php-5.2.6/main/streams/memory.c.gnusrc
|
||||||
|
+++ php-5.2.6/main/streams/memory.c
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
|
||||||
|
PHPAPI int php_url_decode(char *str, int len);
|
||||||
|
--- php-5.2.6/main/streams/streams.c.gnusrc
|
||||||
|
+++ php-5.2.6/main/streams/streams.c
|
||||||
|
@@ -21,7 +21,6 @@
|
||||||
|
|
||||||
|
/* $Id$ */
|
||||||
|
|
||||||
|
-#define _GNU_SOURCE
|
||||||
|
#include "php.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "php_network.h"
|
||||||
|
--- php-5.2.6/Zend/zend_language_parser.c.gnusrc
|
||||||
|
+++ php-5.2.6/Zend/zend_language_parser.c
|
||||||
|
@@ -356,6 +356,8 @@
|
||||||
|
#include "zend_API.h"
|
||||||
|
#include "zend_constants.h"
|
||||||
|
|
||||||
|
+#include <string.h>
|
||||||
|
+
|
||||||
|
|
||||||
|
#define YYERROR_VERBOSE
|
||||||
|
#define YYSTYPE znode
|
4
php.spec
4
php.spec
@ -3,6 +3,8 @@
|
|||||||
%define zendver 20060613
|
%define zendver 20060613
|
||||||
%define pdover 20060511
|
%define pdover 20060511
|
||||||
|
|
||||||
|
%define _default_patch_fuzz 2
|
||||||
|
|
||||||
Summary: The PHP HTML-embedded scripting language
|
Summary: The PHP HTML-embedded scripting language
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.2.6
|
Version: 5.2.6
|
||||||
@ -16,7 +18,7 @@ Source1: php.conf
|
|||||||
Source2: php.ini
|
Source2: php.ini
|
||||||
Source3: macros.php
|
Source3: macros.php
|
||||||
|
|
||||||
Patch1: php-5.2.4-gnusrc.patch
|
Patch1: php-5.2.6-gnusrc.patch
|
||||||
Patch2: php-4.3.3-install.patch
|
Patch2: php-4.3.3-install.patch
|
||||||
Patch3: php-5.2.4-norpath.patch
|
Patch3: php-5.2.4-norpath.patch
|
||||||
Patch5: php-5.0.2-phpize64.patch
|
Patch5: php-5.0.2-phpize64.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user