* Fri May 4 2007 Joe Orton <jorton@redhat.com> 5.2.2-2
- update to 5.2.2 - synch changes from upstream recommended php.ini
This commit is contained in:
parent
91b6bae951
commit
2d398717f8
@ -6,30 +6,22 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
- passed to run-tests.php to ensure it's passed when running each test case
|
||||
- in cases where the PHP executable is run by a test case
|
||||
|
||||
--- php-5.2.0/Makefile.global.tests-dashn
|
||||
+++ php-5.2.0/Makefile.global
|
||||
@@ -79,7 +79,7 @@
|
||||
TEST_PHP_EXECUTABLE=$(top_builddir)/$(SAPI_CLI_PATH) \
|
||||
TEST_PHP_SRCDIR=$(top_srcdir) \
|
||||
CC="$(CC)" \
|
||||
- $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php $(TESTS); \
|
||||
+ $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php -n $(TESTS); \
|
||||
else \
|
||||
echo "ERROR: Cannot run tests without CLI sapi."; \
|
||||
fi
|
||||
--- php-5.2.0/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
||||
+++ php-5.2.0/ext/standard/tests/file/bug26938.phpt
|
||||
@@ -5,7 +5,7 @@
|
||||
--- php-5.2.2/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
||||
+++ php-5.2.2/ext/standard/tests/file/bug26615.phpt
|
||||
@@ -7,9 +7,9 @@
|
||||
$out = array();
|
||||
$status = -1;
|
||||
$php = getenv('TEST_PHP_EXECUTABLE');
|
||||
-exec($php . ' -r \''
|
||||
+exec($php . ' -n -r \''
|
||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||
. 'foreach($lengths as $length) {'
|
||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||
--- php-5.2.0/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
||||
+++ php-5.2.0/ext/standard/tests/file/proc_open01.phpt
|
||||
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
||||
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
|
||||
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
|
||||
} else {
|
||||
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
|
||||
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
|
||||
}
|
||||
print_r($out);
|
||||
?>
|
||||
--- php-5.2.2/ext/standard/tests/file/proc_open01.phpt.tests-dashn
|
||||
+++ php-5.2.2/ext/standard/tests/file/proc_open01.phpt
|
||||
@@ -9,7 +9,7 @@
|
||||
die("no php executable defined");
|
||||
}
|
||||
@ -39,14 +31,33 @@ and hence the installed (old) shared extensions are not loaded.
|
||||
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
|
||||
$pipes
|
||||
);
|
||||
--- php-5.2.0/ext/standard/tests/file/bug26615.phpt.tests-dashn
|
||||
+++ php-5.2.0/ext/standard/tests/file/bug26615.phpt
|
||||
@@ -6,7 +6,7 @@
|
||||
<?php
|
||||
$out = array();
|
||||
--- php-5.2.2/ext/standard/tests/file/bug26938.phpt.tests-dashn
|
||||
+++ php-5.2.2/ext/standard/tests/file/bug26938.phpt
|
||||
@@ -6,14 +6,14 @@
|
||||
$status = -1;
|
||||
-exec($_ENV['TEST_PHP_EXECUTABLE'].' -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
|
||||
+exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
|
||||
print_r($out);
|
||||
?>
|
||||
--EXPECT--
|
||||
$php = getenv('TEST_PHP_EXECUTABLE');
|
||||
if (substr(PHP_OS, 0, 3) != 'WIN') {
|
||||
- exec($php . ' -r \''
|
||||
+ exec($php . ' -n -r \''
|
||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||
. 'foreach($lengths as $length) {'
|
||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||
. ' print "\n";'
|
||||
. '}\'', $out, $status);
|
||||
} else {
|
||||
- exec($php . ' -r "'
|
||||
+ exec($php . ' -n -r "'
|
||||
. '$lengths = array(10,20000,10000,5,10000,3);'
|
||||
. 'foreach($lengths as $length) {'
|
||||
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
|
||||
--- php-5.2.2/Makefile.global.tests-dashn
|
||||
+++ php-5.2.2/Makefile.global
|
||||
@@ -79,7 +79,7 @@
|
||||
TEST_PHP_EXECUTABLE=$(top_builddir)/$(SAPI_CLI_PATH) \
|
||||
TEST_PHP_SRCDIR=$(top_srcdir) \
|
||||
CC="$(CC)" \
|
||||
- $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php $(TESTS); \
|
||||
+ $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php -n $(TESTS); \
|
||||
else \
|
||||
echo "ERROR: Cannot run tests without CLI sapi."; \
|
||||
fi
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- php-5.2.1/ext/standard/string.c.strreplace
|
||||
+++ php-5.2.1/ext/standard/string.c
|
||||
@@ -3148,7 +3148,7 @@
|
||||
}
|
||||
|
||||
Z_STRLEN_P(result) = len + (char_count * (to_len - 1));
|
||||
- Z_STRVAL_P(result) = target = safe_emalloc(char_count, to_len, len);
|
||||
+ Z_STRVAL_P(result) = target = safe_emalloc(char_count, to_len, len + 1);
|
||||
Z_TYPE_P(result) = IS_STRING;
|
||||
|
||||
if (case_sensitivity) {
|
8
php.ini
8
php.ini
@ -655,9 +655,15 @@ default_socket_timeout = 60
|
||||
;xmlrpc_errors = 0
|
||||
|
||||
[Pcre]
|
||||
;pcre.recursion_limit=100000
|
||||
;PCRE library backtracking limit.
|
||||
;pcre.backtrack_limit=100000
|
||||
|
||||
;PCRE library recursion limit.
|
||||
;Please note that if you set this value to a high number you may consume all
|
||||
;the available process stack and eventually crash PHP (due to reaching the
|
||||
;stack size limit imposed by the Operating System).
|
||||
;pcre.recursion_limit=100000
|
||||
|
||||
[Syslog]
|
||||
; Whether or not to define the various syslog variables (e.g. $LOG_PID,
|
||||
; $LOG_CRON, etc.). Turning it off is a good idea performance-wise. In
|
||||
|
10
php.spec
10
php.spec
@ -5,8 +5,8 @@
|
||||
|
||||
Summary: The PHP HTML-embedded scripting language
|
||||
Name: php
|
||||
Version: 5.2.1
|
||||
Release: 5
|
||||
Version: 5.2.2
|
||||
Release: 2
|
||||
License: The PHP License v3.01
|
||||
Group: Development/Languages
|
||||
URL: http://www.php.net/
|
||||
@ -21,7 +21,6 @@ Patch2: php-4.3.3-install.patch
|
||||
Patch3: php-5.0.4-norpath.patch
|
||||
Patch5: php-5.0.2-phpize64.patch
|
||||
Patch8: php-5.2.0-includedir.patch
|
||||
Patch9: php-5.2.1-strreplace.patch
|
||||
|
||||
# Fixes for extension modules
|
||||
Patch21: php-4.3.1-odbc.patch
|
||||
@ -296,7 +295,6 @@ support for using the DBA database abstraction layer to PHP.
|
||||
%patch3 -p1 -b .norpath
|
||||
%patch5 -p1 -b .phpize64
|
||||
%patch8 -p1 -b .includedir
|
||||
%patch9 -p1 -b .strreplace
|
||||
|
||||
%patch21 -p1 -b .odbc
|
||||
%patch22 -p1 -b .shutdown
|
||||
@ -633,6 +631,10 @@ rm files.* macros.php
|
||||
%files pdo -f files.pdo
|
||||
|
||||
%changelog
|
||||
* Fri May 4 2007 Joe Orton <jorton@redhat.com> 5.2.2-2
|
||||
- update to 5.2.2
|
||||
- synch changes from upstream recommended php.ini
|
||||
|
||||
* Thu Mar 29 2007 Joe Orton <jorton@redhat.com> 5.2.1-5
|
||||
- enable SASL support in LDAP extension (#205772)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user