update patch for libzip
This commit is contained in:
parent
7839e2a782
commit
2b5968ad35
@ -1,6 +1,6 @@
|
|||||||
diff -up php-5.4.0RC6/ext/zip/config.m4.systzip php-5.4.0RC6/ext/zip/config.m4
|
diff -up php-5.4.1/ext/zip/config.m4.systzip php-5.4.1/ext/zip/config.m4
|
||||||
--- php-5.4.0RC6/ext/zip/config.m4.systzip 2008-08-08 11:47:15.000000000 +0200
|
--- php-5.4.1/ext/zip/config.m4.systzip 2012-04-24 18:47:33.000000000 +0200
|
||||||
+++ php-5.4.0RC6/ext/zip/config.m4 2012-01-27 16:29:51.644828525 +0100
|
+++ php-5.4.1/ext/zip/config.m4 2012-04-27 18:54:23.478299744 +0200
|
||||||
@@ -13,88 +13,129 @@ fi
|
@@ -13,88 +13,129 @@ fi
|
||||||
PHP_ARG_WITH(pcre-dir, pcre install prefix,
|
PHP_ARG_WITH(pcre-dir, pcre install prefix,
|
||||||
[ --with-pcre-dir ZIP: pcre install prefix], no, no)
|
[ --with-pcre-dir ZIP: pcre install prefix], no, no)
|
||||||
@ -196,9 +196,9 @@ diff -up php-5.4.0RC6/ext/zip/config.m4.systzip php-5.4.0RC6/ext/zip/config.m4
|
|||||||
|
|
||||||
dnl so we always include the known-good working hack.
|
dnl so we always include the known-good working hack.
|
||||||
PHP_ADD_MAKEFILE_FRAGMENT
|
PHP_ADD_MAKEFILE_FRAGMENT
|
||||||
diff -up php-5.4.0RC6/ext/zip/php_zip.c.systzip php-5.4.0RC6/ext/zip/php_zip.c
|
diff -up php-5.4.1/ext/zip/php_zip.c.systzip php-5.4.1/ext/zip/php_zip.c
|
||||||
--- php-5.4.0RC6/ext/zip/php_zip.c.systzip 2012-01-01 14:15:04.000000000 +0100
|
--- php-5.4.1/ext/zip/php_zip.c.systzip 2012-04-24 18:47:33.000000000 +0200
|
||||||
+++ php-5.4.0RC6/ext/zip/php_zip.c 2012-01-27 16:36:31.815846485 +0100
|
+++ php-5.4.1/ext/zip/php_zip.c 2012-04-27 18:56:31.797302815 +0200
|
||||||
@@ -29,8 +29,232 @@
|
@@ -29,8 +29,232 @@
|
||||||
#include "ext/standard/php_string.h"
|
#include "ext/standard/php_string.h"
|
||||||
#include "ext/pcre/php_pcre.h"
|
#include "ext/pcre/php_pcre.h"
|
||||||
@ -456,7 +456,7 @@ diff -up php-5.4.0RC6/ext/zip/php_zip.c.systzip php-5.4.0RC6/ext/zip/php_zip.c
|
|||||||
if (zip_delete(intern, cur_idx) == -1) {
|
if (zip_delete(intern, cur_idx) == -1) {
|
||||||
@@ -2863,7 +3095,11 @@ static PHP_MINFO_FUNCTION(zip)
|
@@ -2863,7 +3095,11 @@ static PHP_MINFO_FUNCTION(zip)
|
||||||
php_info_print_table_row(2, "Zip", "enabled");
|
php_info_print_table_row(2, "Zip", "enabled");
|
||||||
php_info_print_table_row(2, "Extension Version","$Id: php_zip.c 321634 2012-01-01 13:15:04Z felipe $");
|
php_info_print_table_row(2, "Extension Version","$Id$");
|
||||||
php_info_print_table_row(2, "Zip version", PHP_ZIP_VERSION_STRING);
|
php_info_print_table_row(2, "Zip version", PHP_ZIP_VERSION_STRING);
|
||||||
- php_info_print_table_row(2, "Libzip version", "0.9.0");
|
- php_info_print_table_row(2, "Libzip version", "0.9.0");
|
||||||
+#if defined(HAVE_LIBZIP)
|
+#if defined(HAVE_LIBZIP)
|
||||||
@ -467,9 +467,9 @@ diff -up php-5.4.0RC6/ext/zip/php_zip.c.systzip php-5.4.0RC6/ext/zip/php_zip.c
|
|||||||
|
|
||||||
php_info_print_table_end();
|
php_info_print_table_end();
|
||||||
}
|
}
|
||||||
diff -up php-5.4.0RC6/ext/zip/php_zip.h.systzip php-5.4.0RC6/ext/zip/php_zip.h
|
diff -up php-5.4.1/ext/zip/php_zip.h.systzip php-5.4.1/ext/zip/php_zip.h
|
||||||
--- php-5.4.0RC6/ext/zip/php_zip.h.systzip 2012-01-01 14:15:04.000000000 +0100
|
--- php-5.4.1/ext/zip/php_zip.h.systzip 2012-04-24 18:47:33.000000000 +0200
|
||||||
+++ php-5.4.0RC6/ext/zip/php_zip.h 2012-01-27 16:29:51.646828525 +0100
|
+++ php-5.4.1/ext/zip/php_zip.h 2012-04-27 18:54:23.479299744 +0200
|
||||||
@@ -28,7 +28,11 @@ extern zend_module_entry zip_module_entr
|
@@ -28,7 +28,11 @@ extern zend_module_entry zip_module_entr
|
||||||
#include "TSRM.h"
|
#include "TSRM.h"
|
||||||
#endif
|
#endif
|
||||||
@ -482,9 +482,33 @@ diff -up php-5.4.0RC6/ext/zip/php_zip.h.systzip php-5.4.0RC6/ext/zip/php_zip.h
|
|||||||
|
|
||||||
#define PHP_ZIP_VERSION_STRING "1.9.1"
|
#define PHP_ZIP_VERSION_STRING "1.9.1"
|
||||||
|
|
||||||
diff -up php-5.4.0RC6/ext/zip/zip_stream.c.systzip php-5.4.0RC6/ext/zip/zip_stream.c
|
diff -up php-5.4.1/ext/zip/tests/bug38943.phpt.systzip php-5.4.1/ext/zip/tests/bug38943.phpt
|
||||||
--- php-5.4.0RC6/ext/zip/zip_stream.c.systzip 2011-02-01 15:43:52.000000000 +0100
|
--- php-5.4.1/ext/zip/tests/bug38943.phpt.systzip 2012-04-24 18:47:33.000000000 +0200
|
||||||
+++ php-5.4.0RC6/ext/zip/zip_stream.c 2012-01-27 16:29:51.647828525 +0100
|
+++ php-5.4.1/ext/zip/tests/bug38943.phpt 2012-04-27 18:54:23.480299744 +0200
|
||||||
|
@@ -27,7 +27,7 @@ array(1) {
|
||||||
|
[0]=>
|
||||||
|
int(1)
|
||||||
|
}
|
||||||
|
-object(myZip)#1 (%d) {
|
||||||
|
+object(myZip)#%d (%d) {
|
||||||
|
["test":"myZip":private]=>
|
||||||
|
int(0)
|
||||||
|
["testp"]=>
|
||||||
|
diff -up php-5.4.1/ext/zip/tests/pecl12414.phpt.systzip php-5.4.1/ext/zip/tests/pecl12414.phpt
|
||||||
|
--- php-5.4.1/ext/zip/tests/pecl12414.phpt.systzip 2012-04-24 18:47:33.000000000 +0200
|
||||||
|
+++ php-5.4.1/ext/zip/tests/pecl12414.phpt 2012-04-27 18:54:23.481299744 +0200
|
||||||
|
@@ -5,6 +5,8 @@ Bug #12414 ( extracting files from damag
|
||||||
|
/*$ */
|
||||||
|
if(!extension_loaded('zip')) die('skip');
|
||||||
|
?>
|
||||||
|
+--XFAIL--
|
||||||
|
+Doesn't work with system libzip (zip_readfile could not read from ...)
|
||||||
|
--FILE--
|
||||||
|
<?php
|
||||||
|
$filename = 'MYLOGOV2.GFX';
|
||||||
|
diff -up php-5.4.1/ext/zip/zip_stream.c.systzip php-5.4.1/ext/zip/zip_stream.c
|
||||||
|
--- php-5.4.1/ext/zip/zip_stream.c.systzip 2012-04-24 18:47:33.000000000 +0200
|
||||||
|
+++ php-5.4.1/ext/zip/zip_stream.c 2012-04-27 18:54:23.479299744 +0200
|
||||||
@@ -6,7 +6,11 @@
|
@@ -6,7 +6,11 @@
|
||||||
#if HAVE_ZIP
|
#if HAVE_ZIP
|
||||||
#ifdef ZEND_ENGINE_2
|
#ifdef ZEND_ENGINE_2
|
||||||
@ -497,27 +521,3 @@ diff -up php-5.4.0RC6/ext/zip/zip_stream.c.systzip php-5.4.0RC6/ext/zip/zip_stre
|
|||||||
|
|
||||||
#include "php_streams.h"
|
#include "php_streams.h"
|
||||||
#include "ext/standard/file.h"
|
#include "ext/standard/file.h"
|
||||||
diff -up php-5.4.0RC6/ext/zip/tests/bug38943.phpt.systzip php-5.4.0RC6/ext/zip/tests/bug38943.phpt
|
|
||||||
--- php-5.4.0RC6/ext/zip/tests/bug38943.phpt.systzip 2012-01-27 17:12:40.717943831 +0100
|
|
||||||
+++ php-5.4.0RC6/ext/zip/tests/bug38943.phpt 2012-01-27 17:14:53.645949787 +0100
|
|
||||||
@@ -27,7 +27,7 @@ array(1) {
|
|
||||||
[0]=>
|
|
||||||
int(1)
|
|
||||||
}
|
|
||||||
-object(myZip)#1 (%d) {
|
|
||||||
+object(myZip)#%d (%d) {
|
|
||||||
["test":"myZip":private]=>
|
|
||||||
int(0)
|
|
||||||
["testp"]=>
|
|
||||||
diff -up php-5.4.0RC6/ext/zip/tests/pecl12414.phpt.systzip php-5.4.0RC6/ext/zip/tests/pecl12414.phpt
|
|
||||||
--- php-5.4.0RC6/ext/zip/tests/pecl12414.phpt.systzip 2012-01-27 17:18:29.077959450 +0100
|
|
||||||
+++ php-5.4.0RC6/ext/zip/tests/pecl12414.phpt 2012-01-27 17:19:02.679960964 +0100
|
|
||||||
@@ -5,6 +5,8 @@ Bug #12414 ( extracting files from damag
|
|
||||||
/*$ */
|
|
||||||
if(!extension_loaded('zip')) die('skip');
|
|
||||||
?>
|
|
||||||
+--XFAIL--
|
|
||||||
+Doesn't work with system libzip (zip_readfile could not read from ...)
|
|
||||||
--FILE--
|
|
||||||
<?php
|
|
||||||
$filename = 'MYLOGOV2.GFX';
|
|
2
php.spec
2
php.spec
@ -86,7 +86,7 @@ Patch42: php-5.3.1-systzdata-v8.patch
|
|||||||
# See http://bugs.php.net/53436
|
# See http://bugs.php.net/53436
|
||||||
Patch43: php-5.4.0-phpize.patch
|
Patch43: php-5.4.0-phpize.patch
|
||||||
# Use system libzip instead of bundled one
|
# Use system libzip instead of bundled one
|
||||||
Patch44: php-5.4.0-system-libzip.patch
|
Patch44: php-5.4.1-system-libzip.patch
|
||||||
|
|
||||||
# Fixes for tests
|
# Fixes for tests
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user