- update to 5.4.10
- remove patches merged upstream
This commit is contained in:
parent
a03d00ffc4
commit
27d9f1b2fa
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ php-5.3*.bz2
|
|||||||
/php-5.4.8.tar.bz2
|
/php-5.4.8.tar.bz2
|
||||||
/php-5.4.9RC1.tar.bz2
|
/php-5.4.9RC1.tar.bz2
|
||||||
/php-5.4.9.tar.bz2
|
/php-5.4.9.tar.bz2
|
||||||
|
/php-5.4.10.tar.bz2
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- php-5.4.7/ext/imap/php_imap.c.orig 2012-09-22 09:00:39.661043173 +0200
|
|
||||||
+++ php-5.4.7/ext/imap/php_imap.c 2012-09-22 09:01:13.606053829 +0200
|
|
||||||
@@ -1191,7 +1191,7 @@
|
|
||||||
if (zend_hash_index_find(Z_ARRVAL_PP(disabled_auth_method), i, (void **) &z_auth_method) == SUCCESS) {
|
|
||||||
if (Z_TYPE_PP(z_auth_method) == IS_STRING) {
|
|
||||||
if (Z_STRLEN_PP(z_auth_method) > 1) {
|
|
||||||
- mail_parameters (NIL, DISABLE_AUTHENTICATOR, (void *)Z_STRVAL_PP(disabled_auth_method));
|
|
||||||
+ mail_parameters (NIL, DISABLE_AUTHENTICATOR, (void *)Z_STRVAL_PP(z_auth_method));
|
|
||||||
}
|
|
||||||
} else {
|
|
||||||
php_error_docref(NULL TSRMLS_CC, E_WARNING, "Invalid argument, expect string or array of strings");
|
|
@ -1,27 +0,0 @@
|
|||||||
From 05b9b50f09e10038230e1edab43b86afb67c14a8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Remi Collet <fedora@famillecollet.com>
|
|
||||||
Date: Mon, 24 Sep 2012 13:53:59 +0200
|
|
||||||
Subject: [PATCH] Fix Bug #63149, check sqlite3_column_table_name availability
|
|
||||||
with system SQLite
|
|
||||||
|
|
||||||
---
|
|
||||||
ext/sqlite3/config0.m4 | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
|
|
||||||
index ac58b35..1365def 100644
|
|
||||||
--- a/ext/sqlite3/config0.m4
|
|
||||||
+++ b/ext/sqlite3/config0.m4
|
|
||||||
@@ -50,6 +50,9 @@ if test $PHP_SQLITE3 != "no"; then
|
|
||||||
PHP_CHECK_LIBRARY(sqlite3,sqlite3_key,[
|
|
||||||
AC_DEFINE(HAVE_SQLITE3_KEY, 1, [have commercial sqlite3 with crypto support])
|
|
||||||
])
|
|
||||||
+ PHP_CHECK_LIBRARY(sqlite3,sqlite3_column_table_name,[
|
|
||||||
+ AC_DEFINE(SQLITE_ENABLE_COLUMN_METADATA, 1, [have sqlite3 with column metadata enabled])
|
|
||||||
+ ])
|
|
||||||
|
|
||||||
PHP_CHECK_LIBRARY(sqlite3,sqlite3_load_extension,
|
|
||||||
[],
|
|
||||||
--
|
|
||||||
1.7.10
|
|
||||||
|
|
@ -1,50 +0,0 @@
|
|||||||
From 100bb87f5517484d75191ff4cdbbc1fdf579791d Mon Sep 17 00:00:00 2001
|
|
||||||
From: jjacky <i.am.jack.mail@gmail.com>
|
|
||||||
Date: Fri, 11 May 2012 22:38:05 +0200
|
|
||||||
Subject: [PATCH] CGI/FPM process could crash when using libxml, fixes #61557
|
|
||||||
|
|
||||||
Since d8bddb9665637d96f20dc4a2ae5668ba376f3b17 some SAPI would only setup/reset
|
|
||||||
callbacks to libxml once, instead of for each request processed. However, this
|
|
||||||
also included a callback for structured errors, which should remain per request
|
|
||||||
(as it can be defined through PHP's libxml_use_internal_errors).
|
|
||||||
|
|
||||||
As a result, after the internal handler was set in a request, processing another
|
|
||||||
request would result in the handler being triggered while the memory associated
|
|
||||||
with it (LIBXML(error_list)) had been free-d/reset, leading to the process
|
|
||||||
segfaulting.
|
|
||||||
|
|
||||||
This reset the handler for structured errors after each request.
|
|
||||||
|
|
||||||
(see #61325 also possibly the same bug)
|
|
||||||
---
|
|
||||||
ext/libxml/libxml.c | 3 +--
|
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ext/libxml/libxml.c b/ext/libxml/libxml.c
|
|
||||||
index e42d845..92c1099 100644
|
|
||||||
--- a/ext/libxml/libxml.c
|
|
||||||
+++ b/ext/libxml/libxml.c
|
|
||||||
@@ -851,7 +851,6 @@ static PHP_MSHUTDOWN_FUNCTION(libxml)
|
|
||||||
{
|
|
||||||
if (!_php_libxml_per_request_initialization) {
|
|
||||||
xmlSetGenericErrorFunc(NULL, NULL);
|
|
||||||
- xmlSetStructuredErrorFunc(NULL, NULL);
|
|
||||||
|
|
||||||
xmlParserInputBufferCreateFilenameDefault(NULL);
|
|
||||||
xmlOutputBufferCreateFilenameDefault(NULL);
|
|
||||||
@@ -867,11 +866,11 @@ static int php_libxml_post_deactivate()
|
|
||||||
/* reset libxml generic error handling */
|
|
||||||
if (_php_libxml_per_request_initialization) {
|
|
||||||
xmlSetGenericErrorFunc(NULL, NULL);
|
|
||||||
- xmlSetStructuredErrorFunc(NULL, NULL);
|
|
||||||
|
|
||||||
xmlParserInputBufferCreateFilenameDefault(NULL);
|
|
||||||
xmlOutputBufferCreateFilenameDefault(NULL);
|
|
||||||
}
|
|
||||||
+ xmlSetStructuredErrorFunc(NULL, NULL);
|
|
||||||
|
|
||||||
if (LIBXML(stream_context)) {
|
|
||||||
/* the steam_context resource will be released by resource list destructor */
|
|
||||||
--
|
|
||||||
1.7.10.1
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
--- php-5.4.8/ext/mysqli/config.m4.orig 2012-10-25 14:36:21.560016333 +0200
|
|
||||||
+++ php-5.4.8/ext/mysqli/config.m4 2012-10-25 14:37:04.706164258 +0200
|
|
||||||
@@ -81,5 +81,8 @@
|
|
||||||
if test "$PHP_MYSQLI" = "yes" || test "$PHP_MYSQLI" = "mysqlnd"; then
|
|
||||||
PHP_ADD_EXTENSION_DEP(mysqli, mysqlnd)
|
|
||||||
AC_DEFINE([MYSQLI_USE_MYSQLND], 1, [Whether mysqlnd is enabled])
|
|
||||||
+ PHP_INSTALL_HEADERS([ext/mysqli/mysqli_mysqlnd.h])
|
|
||||||
+ else
|
|
||||||
+ PHP_INSTALL_HEADERS([ext/mysqli/mysqli_libmysql.h])
|
|
||||||
fi
|
|
||||||
fi
|
|
20
php.spec
20
php.spec
@ -57,8 +57,8 @@
|
|||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: 5.4.9
|
Version: 5.4.10
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
# All files licensed under PHP version 3.01, except
|
# All files licensed under PHP version 3.01, except
|
||||||
# Zend is licensed under Zend
|
# Zend is licensed under Zend
|
||||||
# TSRM is licensed under BSD
|
# TSRM is licensed under BSD
|
||||||
@ -82,18 +82,10 @@ Patch5: php-5.2.0-includedir.patch
|
|||||||
Patch6: php-5.2.4-embed.patch
|
Patch6: php-5.2.4-embed.patch
|
||||||
Patch7: php-5.3.0-recode.patch
|
Patch7: php-5.3.0-recode.patch
|
||||||
Patch8: php-5.4.7-libdb.patch
|
Patch8: php-5.4.7-libdb.patch
|
||||||
# https://bugs.php.net/63361 - Header not installed
|
|
||||||
Patch9: php-5.4.8-mysqli.patch
|
|
||||||
|
|
||||||
# Fixes for extension modules
|
# Fixes for extension modules
|
||||||
# https://bugs.php.net/63126 - DISABLE_AUTHENTICATOR ignores array
|
|
||||||
Patch20: php-5.4.7-imap.patch
|
|
||||||
# https://bugs.php.net/63171 no odbc call during timeout
|
# https://bugs.php.net/63171 no odbc call during timeout
|
||||||
Patch21: php-5.4.7-odbctimer.patch
|
Patch21: php-5.4.7-odbctimer.patch
|
||||||
# https://bugs.php.net/63149 check sqlite3_column_table_name
|
|
||||||
Patch22: php-5.4.7-sqlite.patch
|
|
||||||
# https://bugs.php.net/61557 crash in libxml
|
|
||||||
Patch23: php-5.4.8-libxml.patch
|
|
||||||
|
|
||||||
# Functional changes
|
# Functional changes
|
||||||
Patch40: php-5.4.0-dlopen.patch
|
Patch40: php-5.4.0-dlopen.patch
|
||||||
@ -664,12 +656,8 @@ support for using the enchant library to PHP.
|
|||||||
%patch6 -p1 -b .embed
|
%patch6 -p1 -b .embed
|
||||||
%patch7 -p1 -b .recode
|
%patch7 -p1 -b .recode
|
||||||
%patch8 -p1 -b .libdb
|
%patch8 -p1 -b .libdb
|
||||||
%patch9 -p1 -b .mysqliheaders
|
|
||||||
|
|
||||||
%patch20 -p1 -b .imap
|
|
||||||
%patch21 -p1 -b .odbctimer
|
%patch21 -p1 -b .odbctimer
|
||||||
%patch22 -p1 -b .tablename
|
|
||||||
%patch23 -p1 -b .libxmlcrash
|
|
||||||
|
|
||||||
%patch40 -p1 -b .dlopen
|
%patch40 -p1 -b .dlopen
|
||||||
%patch41 -p1 -b .easter
|
%patch41 -p1 -b .easter
|
||||||
@ -1415,6 +1403,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 19 2012 Remi Collet <rcollet@redhat.com> 5.4.10-1
|
||||||
|
- update to 5.4.10
|
||||||
|
- remove patches merged upstream
|
||||||
|
|
||||||
* Tue Dec 11 2012 Remi Collet <rcollet@redhat.com> 5.4.9-3
|
* Tue Dec 11 2012 Remi Collet <rcollet@redhat.com> 5.4.9-3
|
||||||
- drop "Configure Command" from phpinfo output
|
- drop "Configure Command" from phpinfo output
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user