no odbc call during timeout
This commit is contained in:
parent
d412b26cac
commit
250e9e4289
58
php-5.4.7-odbctimer.patch
Normal file
58
php-5.4.7-odbctimer.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
From 657494235eafe048e9fa6a19dcdb3c73a0cbe6ec Mon Sep 17 00:00:00 2001
|
||||||
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
|
Date: Thu, 27 Sep 2012 13:45:32 +0200
|
||||||
|
Subject: [PATCH] Fixed bug #63171, script hangs if odbc call during timeout
|
||||||
|
|
||||||
|
---
|
||||||
|
ext/odbc/php_odbc.c | 21 ++++++++++++++-------
|
||||||
|
1 file changed, 14 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/ext/odbc/php_odbc.c b/ext/odbc/php_odbc.c
|
||||||
|
index 52d46b2..2169e65 100644
|
||||||
|
--- a/ext/odbc/php_odbc.c
|
||||||
|
+++ b/ext/odbc/php_odbc.c
|
||||||
|
@@ -431,7 +431,8 @@ static void _free_odbc_result(zend_rsrc_list_entry *rsrc TSRMLS_DC)
|
||||||
|
efree(res->values);
|
||||||
|
res->values = NULL;
|
||||||
|
}
|
||||||
|
- if (res->stmt) {
|
||||||
|
+ /* If aborted via timer expiration, don't try to call any unixODBC function */
|
||||||
|
+ if (res->stmt && !(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
|
||||||
|
#if defined(HAVE_SOLID) || defined(HAVE_SOLID_30) || defined(HAVE_SOLID_35)
|
||||||
|
SQLTransact(res->conn_ptr->henv, res->conn_ptr->hdbc,
|
||||||
|
(SQLUSMALLINT) SQL_COMMIT);
|
||||||
|
@@ -484,9 +485,12 @@ static void _close_odbc_conn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- safe_odbc_disconnect(conn->hdbc);
|
||||||
|
- SQLFreeConnect(conn->hdbc);
|
||||||
|
- SQLFreeEnv(conn->henv);
|
||||||
|
+ /* If aborted via timer expiration, don't try to call any unixODBC function */
|
||||||
|
+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
|
||||||
|
+ safe_odbc_disconnect(conn->hdbc);
|
||||||
|
+ SQLFreeConnect(conn->hdbc);
|
||||||
|
+ SQLFreeEnv(conn->henv);
|
||||||
|
+ }
|
||||||
|
efree(conn);
|
||||||
|
ODBCG(num_links)--;
|
||||||
|
}
|
||||||
|
@@ -512,9 +516,12 @@ static void _close_odbc_pconn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- safe_odbc_disconnect(conn->hdbc);
|
||||||
|
- SQLFreeConnect(conn->hdbc);
|
||||||
|
- SQLFreeEnv(conn->henv);
|
||||||
|
+ /* If aborted via timer expiration, don't try to call any unixODBC function */
|
||||||
|
+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
|
||||||
|
+ safe_odbc_disconnect(conn->hdbc);
|
||||||
|
+ SQLFreeConnect(conn->hdbc);
|
||||||
|
+ SQLFreeEnv(conn->henv);
|
||||||
|
+ }
|
||||||
|
free(conn);
|
||||||
|
|
||||||
|
ODBCG(num_links)--;
|
||||||
|
--
|
||||||
|
1.7.10
|
||||||
|
|
4
php.spec
4
php.spec
@ -76,6 +76,8 @@ Patch8: php-5.4.7-libdb.patch
|
|||||||
|
|
||||||
# Fixes for extension modules
|
# Fixes for extension modules
|
||||||
Patch20: php-5.4.7-imap.patch
|
Patch20: php-5.4.7-imap.patch
|
||||||
|
# https://bugs.php.net/63171 no odbc call during timeout
|
||||||
|
Patch21: php-5.4.7-odbctimer.patch
|
||||||
|
|
||||||
# Functional changes
|
# Functional changes
|
||||||
Patch40: php-5.4.0-dlopen.patch
|
Patch40: php-5.4.0-dlopen.patch
|
||||||
@ -582,6 +584,7 @@ support for using the enchant library to PHP.
|
|||||||
%patch8 -p1 -b .libdb
|
%patch8 -p1 -b .libdb
|
||||||
|
|
||||||
%patch20 -p1 -b .imap
|
%patch20 -p1 -b .imap
|
||||||
|
%patch21 -p1 -b .odbctimer
|
||||||
|
|
||||||
%patch40 -p1 -b .dlopen
|
%patch40 -p1 -b .dlopen
|
||||||
%patch41 -p1 -b .easter
|
%patch41 -p1 -b .easter
|
||||||
@ -1295,6 +1298,7 @@ fi
|
|||||||
%changelog
|
%changelog
|
||||||
* Fri Sep 28 2012 Remi Collet <rcollet@redhat.com> 5.4.7-8
|
* Fri Sep 28 2012 Remi Collet <rcollet@redhat.com> 5.4.7-8
|
||||||
- systemd integration, https://bugs.php.net/63085
|
- systemd integration, https://bugs.php.net/63085
|
||||||
|
- no odbc call during timeout, https://bugs.php.net/63171
|
||||||
|
|
||||||
* Mon Sep 24 2012 Remi Collet <rcollet@redhat.com> 5.4.7-7
|
* Mon Sep 24 2012 Remi Collet <rcollet@redhat.com> 5.4.7-7
|
||||||
- most failed tests explained (i386, x86_64)
|
- most failed tests explained (i386, x86_64)
|
||||||
|
Loading…
Reference in New Issue
Block a user