rebase to 8.2.25
Resolves: RHEL-65837
This commit is contained in:
parent
0a4c072aaa
commit
1be7efd6d0
16
.gitignore
vendored
16
.gitignore
vendored
@ -1,10 +1,10 @@
|
||||
/php-8.1.6.tar.xz
|
||||
/php-8.1.6.tar.xz.asc
|
||||
/php-8.1.7.tar.xz
|
||||
/php-8.1.7.tar.xz.asc
|
||||
/php-8.1.8.tar.xz
|
||||
/php-8.1.8.tar.xz.asc
|
||||
/php-8.1.14.tar.xz
|
||||
/php-8.1.14.tar.xz.asc
|
||||
/php-8.0.*.tar.xz
|
||||
/php-8.0.*.tar.xz.asc
|
||||
/php-8.1.*.tar.xz
|
||||
/php-8.1.*.tar.xz.asc
|
||||
/php-8.3.*.tar.xz
|
||||
/php-8.3.*.tar.xz.asc
|
||||
/php-8.2.13.tar.xz
|
||||
/php-8.2.13.tar.xz.asc
|
||||
/php-8.2.25.tar.xz
|
||||
/php-8.2.25.tar.xz.asc
|
||||
|
@ -40,7 +40,7 @@ diff --git a/ext/date/config0.m4 b/ext/date/config0.m4
|
||||
index 6b803bf33e..53c3cdb3f4 100644
|
||||
--- a/ext/date/config0.m4
|
||||
+++ b/ext/date/config0.m4
|
||||
@@ -4,6 +4,19 @@ AC_CHECK_HEADERS([io.h])
|
||||
@@ -4,6 +4,19 @@
|
||||
dnl Check for strtoll, atoll
|
||||
AC_CHECK_FUNCS(strtoll atoll)
|
||||
|
||||
@ -57,9 +57,9 @@ index 6b803bf33e..53c3cdb3f4 100644
|
||||
+ fi
|
||||
+fi
|
||||
+
|
||||
PHP_DATE_CFLAGS="-Wno-implicit-fallthrough -I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
|
||||
timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c lib/parse_posix.c
|
||||
lib/timelib.c lib/tm2unixtime.c lib/unixtime2tm.c lib/parse_iso_intervals.c lib/interval.c"
|
||||
AX_CHECK_COMPILE_FLAG([-Wno-implicit-fallthrough],
|
||||
[PHP_DATE_CFLAGS="$PHP_DATE_CFLAGS -Wno-implicit-fallthrough"],,
|
||||
[-Werror])
|
||||
diff --git a/ext/date/lib/parse_tz.c b/ext/date/lib/parse_tz.c
|
||||
index c7f93580d7..ec196a98b6 100644
|
||||
--- a/ext/date/lib/parse_tz.c
|
@ -9,7 +9,7 @@ Replace full GCC name by gcc in php -v output
|
||||
diff -up ./ext/standard/info.c.phpinfo ./ext/standard/info.c
|
||||
--- ./ext/standard/info.c.phpinfo 2020-07-21 10:49:31.000000000 +0200
|
||||
+++ ./ext/standard/info.c 2020-07-21 11:41:56.295633523 +0200
|
||||
@@ -805,9 +805,6 @@ PHPAPI ZEND_COLD void php_print_info(int
|
||||
@@ -834,9 +834,6 @@ PHPAPI ZEND_COLD void php_print_info(int
|
||||
#ifdef PHP_BUILD_ARCH
|
||||
php_info_print_table_row(2, "Architecture", PHP_BUILD_ARCH);
|
||||
#endif
|
||||
@ -25,7 +25,7 @@ diff -up ./ext/standard/tests/general_functions/phpinfo.phpt.phpinfo ./ext/stand
|
||||
@@ -17,7 +17,6 @@ PHP Version => %s
|
||||
|
||||
System => %s
|
||||
Build Date => %s%a
|
||||
Build Date => %r(.+?)%r
|
||||
-Configure Command => %s
|
||||
Server API => Command Line Interface
|
||||
Virtual Directory Support => %s
|
||||
@ -33,7 +33,7 @@ diff -up ./ext/standard/tests/general_functions/phpinfo.phpt.phpinfo ./ext/stand
|
||||
diff -up ./sapi/cli/php_cli.c.phpinfo ./sapi/cli/php_cli.c
|
||||
--- ./sapi/cli/php_cli.c.phpinfo 2020-07-21 11:43:38.812475300 +0200
|
||||
+++ ./sapi/cli/php_cli.c 2020-07-21 11:43:45.783464540 +0200
|
||||
@@ -645,7 +645,7 @@ static int do_cli(int argc, char **argv)
|
||||
@@ -644,7 +644,7 @@ static int do_cli(int argc, char **argv)
|
||||
"NTS"
|
||||
#endif
|
||||
#ifdef PHP_BUILD_COMPILER
|
10
php.spec
10
php.spec
@ -64,8 +64,7 @@
|
||||
%bcond_with imap
|
||||
%bcond_without lmdb
|
||||
|
||||
%global upver 8.2.13
|
||||
#global rcver RC1
|
||||
%global upver 8.2.25
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
@ -111,14 +110,14 @@ Patch8: php-8.1.0-libdb.patch
|
||||
# Use system nikic/php-parser
|
||||
Patch41: php-8.2.0-parser.patch
|
||||
# use system tzdata
|
||||
Patch42: php-8.1.0-systzdata-v24.patch
|
||||
Patch42: php-8.2.23-systzdata-v24.patch
|
||||
# See http://bugs.php.net/53436
|
||||
Patch43: php-7.4.0-phpize.patch
|
||||
# Use -lldap_r for OpenLDAP
|
||||
Patch45: php-7.4.0-ldap_r.patch
|
||||
# drop "Configure command" from phpinfo output
|
||||
# and only use gcc (instead of full version)
|
||||
Patch47: php-8.1.0-phpinfo.patch
|
||||
Patch47: php-8.2.25-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
|
||||
@ -1542,6 +1541,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 8 2024 Remi Collet <rcollet@redhat.com> - 8.2.25-1
|
||||
- rebase to 8.2.25 RHEL-65837
|
||||
|
||||
* Fri Nov 24 2023 Remi Collet <rcollet@redhat.com> - 8.2.13-1
|
||||
- rebase to 8.2.13 RHEL-14699
|
||||
- add %%__phpize and %%__phpconfig macros
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-8.2.13.tar.xz) = 8031e33d148c5acbfbb3ed00d7a266813c8919db86ba260ba65e1837d6db8d0bd66d8ddef66884466dd3fe51ece7882b03f8d8db6ff4383f80a68b7beafc03af
|
||||
SHA512 (php-8.2.13.tar.xz.asc) = 0e4e665ba134222e342f2c5d2456ebf6f2d06e82a513c5d9ab02f720581d0eb4f537757d4fc3c86d941d9d0140546c1f37334feff6b4e8d6fd37878346c9e66c
|
||||
SHA512 (php-8.2.25.tar.xz) = 47a4a6ea8e77c4e5965c385a016755e8b6700acc8e3fa728b0596efcf72dc9bb39a1c68a10733c4106fdad1f037d1582fd42856778a3d3224a9b15b9665bc360
|
||||
SHA512 (php-8.2.25.tar.xz.asc) = 0760b40366484c19cf10a2d8f79f36c5bed3222b5d8f60d9263dab30a47cfb25edfce69c19f6d179d3a167579b0a979a101c3c63646aca997e36852fc09061ba
|
||||
|
Loading…
Reference in New Issue
Block a user