Update to 7.4.15 - http://www.php.net/releases/7_4_15.php
add upstream patch for https://bugs.php.net/80682 fix opcache doesn't honour pcre.jit option
This commit is contained in:
parent
0ee7f58473
commit
1bcd8f70d4
30
php-bug80682.patch
Normal file
30
php-bug80682.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 067f7e4150d8f9bddf6b198c9c7826565ee549b0 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Thu, 28 Jan 2021 16:24:39 +0100
|
||||
Subject: [PATCH] Fix #80682 opcache doesn't honour pcre.jit option
|
||||
|
||||
---
|
||||
ext/opcache/zend_accelerator_blacklist.c | 10 ++++++----
|
||||
1 file changed, 6 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/ext/opcache/zend_accelerator_blacklist.c b/ext/opcache/zend_accelerator_blacklist.c
|
||||
index 889fcabd7988..5c6bd76821a5 100644
|
||||
--- a/ext/opcache/zend_accelerator_blacklist.c
|
||||
+++ b/ext/opcache/zend_accelerator_blacklist.c
|
||||
@@ -185,10 +185,12 @@ static void zend_accel_blacklist_update_regexp(zend_blacklist *blacklist)
|
||||
return;
|
||||
}
|
||||
#ifdef HAVE_PCRE_JIT_SUPPORT
|
||||
- if (0 > pcre2_jit_compile(it->re, PCRE2_JIT_COMPLETE)) {
|
||||
- /* Don't return here, even JIT could fail to compile, the pattern is still usable. */
|
||||
- pcre2_get_error_message(errnumber, pcre_error, sizeof(pcre_error));
|
||||
- zend_accel_error(ACCEL_LOG_WARNING, "Blacklist JIT compilation failed, %s\n", pcre_error);
|
||||
+ if (PCRE_G(jit)) {
|
||||
+ if (0 > pcre2_jit_compile(it->re, PCRE2_JIT_COMPLETE)) {
|
||||
+ /* Don't return here, even JIT could fail to compile, the pattern is still usable. */
|
||||
+ pcre2_get_error_message(errnumber, pcre_error, sizeof(pcre_error));
|
||||
+ zend_accel_error(ACCEL_LOG_WARNING, "Blacklist JIT compilation failed, %s\n", pcre_error);
|
||||
+ }
|
||||
}
|
||||
#endif
|
||||
/* prepare for the next iteration */
|
11
php.spec
11
php.spec
@ -56,12 +56,12 @@
|
||||
%endif
|
||||
|
||||
%global upver 7.4.15
|
||||
%global rcver RC2
|
||||
#global rcver RC2
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -108,6 +108,7 @@ Patch45: php-7.4.0-ldap_r.patch
|
||||
Patch47: php-7.4.8-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-bug80682.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -732,6 +733,7 @@ in pure PHP.
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .bug80682
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1537,6 +1539,11 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 2 2021 Remi Collet <remi@remirepo.net> - 7.4.15-1
|
||||
- Update to 7.4.15 - http://www.php.net/releases/7_4_15.php
|
||||
- add upstream patch for https://bugs.php.net/80682
|
||||
fix opcache doesn't honour pcre.jit option
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 7.4.15~RC2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-7.4.15RC2.tar.xz) = 8fe8ff4d633b757fce9043d7d665eb50750c43d430d25028f9dee1710c233834ab4022390f8a158dd46836192b1e1ba336103baa58cbc7ceb8716339a98205a0
|
||||
SHA512 (php-7.4.15RC2.tar.xz.asc) = 97a3a1ff6641dabe6a152fd000e4be77b9f4b5dcea1e6d1cceb47f8d3e6f95e7f49704ad8773f1dd03d186f3b0b1ef1f6c34388c60857fe4e5b880df3bf976c8
|
||||
SHA512 (php-7.4.15.tar.xz) = 51a815852c08518d6706fc719e3bafd214889580cc5ca0e5049ae7e8f6173e83b9486bc9a69afd1ea4ab1778bb2879bd917595cd04cbcc50b182a10230f08175
|
||||
SHA512 (php-7.4.15.tar.xz.asc) = d5502e77753888a4b5d98b6f3cd01ae7e7a7b94700375017e0783ba19462c117e12bd156b51462d426c1101c318be0ef9fa04d5b5eed476fc4d686693896cd73
|
||||
|
Loading…
Reference in New Issue
Block a user