add temporary patch for GCC 14
This commit is contained in:
parent
3625bd7234
commit
17dfd8e3a8
22
php-gcc14.patch
Normal file
22
php-gcc14.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From bee67f5c37a6aee20f8bae7f14e64417f87d6b92 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@remirepo.net>
|
||||
Date: Mon, 22 Jan 2024 10:01:25 +0100
|
||||
Subject: [PATCH] Fix GH-13215 GCC 14 build
|
||||
|
||||
---
|
||||
Zend/zend_atomic.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Zend/zend_atomic.h b/Zend/zend_atomic.h
|
||||
index 617cde0ec5640..8aab3f11ada00 100644
|
||||
--- a/Zend/zend_atomic.h
|
||||
+++ b/Zend/zend_atomic.h
|
||||
@@ -23,7 +23,7 @@
|
||||
((__GNUC__ == (x) && __GNUC_MINOR__ >= (y)) || (__GNUC__ > (x)))
|
||||
|
||||
/* Builtins are used to avoid library linkage */
|
||||
-#if __has_feature(c_atomic)
|
||||
+#if __has_feature(c_atomic) && defined(__clang__)
|
||||
#define HAVE_C11_ATOMICS 1
|
||||
#elif ZEND_GCC_PREREQ(4, 7)
|
||||
#define HAVE_GNUC_ATOMICS 1
|
5
php.spec
5
php.spec
@ -106,6 +106,7 @@ Patch1: php-7.4.0-httpd.patch
|
||||
Patch5: php-7.2.0-includedir.patch
|
||||
Patch6: php-8.0.0-embed.patch
|
||||
Patch8: php-8.1.0-libdb.patch
|
||||
Patch9: php-gcc14.patch
|
||||
|
||||
# Functional changes
|
||||
# Use system nikic/php-parser
|
||||
@ -718,6 +719,7 @@ in pure PHP.
|
||||
%patch -P5 -p1 -b .includedir
|
||||
%patch -P6 -p1 -b .embed
|
||||
%patch -P8 -p1 -b .libdb
|
||||
%patch -P9 -p1 -b .gcc14
|
||||
|
||||
%patch -P41 -p1 -b .syslib
|
||||
%patch -P42 -p1 -b .systzdata
|
||||
@ -1552,6 +1554,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 22 2024 Remi Collet <remi@remirepo.net> - 8.3.2-2
|
||||
- add temporary patch for GCC 14
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user