retrieve tzdata version #2056611
This commit is contained in:
parent
54f28c61e6
commit
1229fe513f
@ -5,6 +5,7 @@ Add support for use of the system timezone database, rather
|
|||||||
than embedding a copy. Discussed upstream but was not desired.
|
than embedding a copy. Discussed upstream but was not desired.
|
||||||
|
|
||||||
History:
|
History:
|
||||||
|
r22: retrieve tzdata version from /usr/share/zoneinfo/tzdata.zi
|
||||||
r21: adapt for timelib 2021.03 (in 8.1.0)
|
r21: adapt for timelib 2021.03 (in 8.1.0)
|
||||||
r20: adapt for timelib 2020.03 (in 8.0.10RC1)
|
r20: adapt for timelib 2020.03 (in 8.0.10RC1)
|
||||||
r19: adapt for timelib 2020.02 (in 8.0.0beta2)
|
r19: adapt for timelib 2020.02 (in 8.0.0beta2)
|
||||||
@ -32,9 +33,10 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
|
|||||||
r2: add filesystem trawl to set up name alias index
|
r2: add filesystem trawl to set up name alias index
|
||||||
r1: initial revision
|
r1: initial revision
|
||||||
|
|
||||||
diff -up php-8.0.0beta3/ext/date/config0.m4.systzdata php-8.0.0beta3/ext/date/config0.m4
|
diff --git a/ext/date/config0.m4 b/ext/date/config0.m4
|
||||||
--- php-8.0.0beta3/ext/date/config0.m4.systzdata 2020-09-01 19:13:26.000000000 +0200
|
index 18b8106bd2..3d1f63c758 100644
|
||||||
+++ php-8.0.0beta3/ext/date/config0.m4 2020-09-02 08:07:51.039979873 +0200
|
--- a/ext/date/config0.m4
|
||||||
|
+++ b/ext/date/config0.m4
|
||||||
@@ -4,6 +4,19 @@ AC_CHECK_HEADERS([io.h])
|
@@ -4,6 +4,19 @@ AC_CHECK_HEADERS([io.h])
|
||||||
dnl Check for strtoll, atoll
|
dnl Check for strtoll, atoll
|
||||||
AC_CHECK_FUNCS(strtoll atoll)
|
AC_CHECK_FUNCS(strtoll atoll)
|
||||||
@ -55,9 +57,10 @@ diff -up php-8.0.0beta3/ext/date/config0.m4.systzdata php-8.0.0beta3/ext/date/co
|
|||||||
PHP_DATE_CFLAGS="-Wno-implicit-fallthrough -I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
|
PHP_DATE_CFLAGS="-Wno-implicit-fallthrough -I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
|
||||||
timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c lib/parse_posix.c
|
timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c lib/parse_posix.c
|
||||||
lib/timelib.c lib/tm2unixtime.c lib/unixtime2tm.c lib/parse_iso_intervals.c lib/interval.c"
|
lib/timelib.c lib/tm2unixtime.c lib/unixtime2tm.c lib/parse_iso_intervals.c lib/interval.c"
|
||||||
diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/date/lib/parse_tz.c
|
diff --git a/ext/date/lib/parse_tz.c b/ext/date/lib/parse_tz.c
|
||||||
--- php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata 2020-09-01 19:13:26.000000000 +0200
|
index e41315efdb..4b6547c0a3 100644
|
||||||
+++ php-8.0.0beta3/ext/date/lib/parse_tz.c 2020-09-02 08:07:51.039979873 +0200
|
--- a/ext/date/lib/parse_tz.c
|
||||||
|
+++ b/ext/date/lib/parse_tz.c
|
||||||
@@ -26,9 +26,22 @@
|
@@ -26,9 +26,22 @@
|
||||||
#include "timelib.h"
|
#include "timelib.h"
|
||||||
#include "timelib_private.h"
|
#include "timelib_private.h"
|
||||||
@ -81,7 +84,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
|
|
||||||
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
|
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
|
||||||
# if defined(__LITTLE_ENDIAN__)
|
# if defined(__LITTLE_ENDIAN__)
|
||||||
@@ -95,6 +108,11 @@ static int read_php_preamble(const unsig
|
@@ -95,6 +108,11 @@ static int read_php_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
|
||||||
{
|
{
|
||||||
uint32_t version;
|
uint32_t version;
|
||||||
|
|
||||||
@ -93,7 +96,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
/* read ID */
|
/* read ID */
|
||||||
version = (*tzf)[3] - '0';
|
version = (*tzf)[3] - '0';
|
||||||
*tzf += 4;
|
*tzf += 4;
|
||||||
@@ -577,7 +595,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
|
@@ -577,7 +595,467 @@ void timelib_dump_tzinfo(timelib_tzinfo *tz)
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -323,6 +326,44 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
+ return timelib_strcasecmp(alpha->id, beta->id);
|
+ return timelib_strcasecmp(alpha->id, beta->id);
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
|
+/* Retrieve tzdata version. */
|
||||||
|
+static void retrieve_zone_version(timelib_tzdb *db)
|
||||||
|
+{
|
||||||
|
+ static char buf[30];
|
||||||
|
+ char path[PATH_MAX];
|
||||||
|
+ FILE *fp;
|
||||||
|
+
|
||||||
|
+ strncpy(path, ZONEINFO_PREFIX "/tzdata.zi", sizeof(path));
|
||||||
|
+
|
||||||
|
+ fp = fopen(path, "r");
|
||||||
|
+ if (fp) {
|
||||||
|
+ if (fgets(buf, sizeof(buf), fp)) {
|
||||||
|
+ if (!memcmp(buf, "# version ", 10) &&
|
||||||
|
+ isdigit(buf[10]) &&
|
||||||
|
+ isdigit(buf[11]) &&
|
||||||
|
+ isdigit(buf[12]) &&
|
||||||
|
+ isdigit(buf[13]) &&
|
||||||
|
+ islower(buf[14])) {
|
||||||
|
+ if (buf[14] >= 't') { /* 2022t = 2022.20 */
|
||||||
|
+ buf[17] = 0;
|
||||||
|
+ buf[16] = buf[14] - 't' + '0';
|
||||||
|
+ buf[15] = '2';
|
||||||
|
+ } else if (buf[14] >= 'j') { /* 2022j = 2022.10 */
|
||||||
|
+ buf[17] = 0;
|
||||||
|
+ buf[16] = buf[14] - 'j' + '0';
|
||||||
|
+ buf[15] = '1';
|
||||||
|
+ } else { /* 2022a = 2022.1 */
|
||||||
|
+ buf[16] = 0;
|
||||||
|
+ buf[15] = buf[14] - 'a' + '1';
|
||||||
|
+ }
|
||||||
|
+ buf[14] = '.';
|
||||||
|
+ db->version = buf+10;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+ fclose(fp);
|
||||||
|
+ }
|
||||||
|
+}
|
||||||
|
+
|
||||||
+
|
+
|
||||||
+/* Create the zone identifier index by trawling the filesystem. */
|
+/* Create the zone identifier index by trawling the filesystem. */
|
||||||
+static void create_zone_index(timelib_tzdb *db)
|
+static void create_zone_index(timelib_tzdb *db)
|
||||||
@ -524,7 +565,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
{
|
{
|
||||||
int left = 0, right = tzdb->index_size - 1;
|
int left = 0, right = tzdb->index_size - 1;
|
||||||
|
|
||||||
@@ -603,9 +1043,48 @@ static int seek_to_tz_position(const uns
|
@@ -603,9 +1081,49 @@ static int seek_to_tz_position(const unsigned char **tzf, const char *timezone,
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -561,6 +602,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
+ tmp->version = "0.system";
|
+ tmp->version = "0.system";
|
||||||
+ tmp->data = NULL;
|
+ tmp->data = NULL;
|
||||||
+ create_zone_index(tmp);
|
+ create_zone_index(tmp);
|
||||||
|
+ retrieve_zone_version(tmp);
|
||||||
+ system_location_table = create_location_table();
|
+ system_location_table = create_location_table();
|
||||||
+ fake_data_segment(tmp, system_location_table);
|
+ fake_data_segment(tmp, system_location_table);
|
||||||
+ timezonedb_system = tmp;
|
+ timezonedb_system = tmp;
|
||||||
@ -573,7 +615,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
}
|
}
|
||||||
|
|
||||||
const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(const timelib_tzdb *tzdb, int *count)
|
const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(const timelib_tzdb *tzdb, int *count)
|
||||||
@@ -617,7 +1096,30 @@ const timelib_tzdb_index_entry *timelib_
|
@@ -617,7 +1135,30 @@ const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(const timelib_
|
||||||
int timelib_timezone_id_is_valid(const char *timezone, const timelib_tzdb *tzdb)
|
int timelib_timezone_id_is_valid(const char *timezone, const timelib_tzdb *tzdb)
|
||||||
{
|
{
|
||||||
const unsigned char *tzf;
|
const unsigned char *tzf;
|
||||||
@ -605,7 +647,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
}
|
}
|
||||||
|
|
||||||
static int skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
|
static int skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
|
||||||
@@ -662,6 +1164,8 @@ static timelib_tzinfo* timelib_tzinfo_ct
|
@@ -662,6 +1203,8 @@ static timelib_tzinfo* timelib_tzinfo_ctor(const char *name)
|
||||||
timelib_tzinfo *timelib_parse_tzfile(const char *timezone, const timelib_tzdb *tzdb, int *error_code)
|
timelib_tzinfo *timelib_parse_tzfile(const char *timezone, const timelib_tzdb *tzdb, int *error_code)
|
||||||
{
|
{
|
||||||
const unsigned char *tzf;
|
const unsigned char *tzf;
|
||||||
@ -614,7 +656,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
timelib_tzinfo *tmp;
|
timelib_tzinfo *tmp;
|
||||||
int version;
|
int version;
|
||||||
int transitions_result, types_result;
|
int transitions_result, types_result;
|
||||||
@@ -669,7 +1173,7 @@ timelib_tzinfo *timelib_parse_tzfile(con
|
@@ -669,7 +1212,7 @@ timelib_tzinfo *timelib_parse_tzfile(const char *timezone, const timelib_tzdb *t
|
||||||
|
|
||||||
*error_code = TIMELIB_ERROR_NO_ERROR;
|
*error_code = TIMELIB_ERROR_NO_ERROR;
|
||||||
|
|
||||||
@ -623,7 +665,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
tmp = timelib_tzinfo_ctor(timezone);
|
tmp = timelib_tzinfo_ctor(timezone);
|
||||||
|
|
||||||
version = read_preamble(&tzf, tmp, &type);
|
version = read_preamble(&tzf, tmp, &type);
|
||||||
@@ -712,11 +1216,36 @@ timelib_tzinfo *timelib_parse_tzfile(con
|
@@ -712,11 +1255,36 @@ timelib_tzinfo *timelib_parse_tzfile(const char *timezone, const timelib_tzdb *t
|
||||||
return NULL;
|
return NULL;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -660,3 +702,19 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
|
|||||||
} else {
|
} else {
|
||||||
*error_code = TIMELIB_ERROR_NO_SUCH_TIMEZONE;
|
*error_code = TIMELIB_ERROR_NO_SUCH_TIMEZONE;
|
||||||
tmp = NULL;
|
tmp = NULL;
|
||||||
|
diff --git a/ext/date/php_date.c b/ext/date/php_date.c
|
||||||
|
index cf4a11b8a2..cd49abc78d 100644
|
||||||
|
--- a/ext/date/php_date.c
|
||||||
|
+++ b/ext/date/php_date.c
|
||||||
|
@@ -457,7 +457,11 @@ PHP_MINFO_FUNCTION(date)
|
||||||
|
php_info_print_table_row(2, "date/time support", "enabled");
|
||||||
|
php_info_print_table_row(2, "timelib version", TIMELIB_ASCII_VERSION);
|
||||||
|
php_info_print_table_row(2, "\"Olson\" Timezone Database Version", tzdb->version);
|
||||||
|
+#ifdef HAVE_SYSTEM_TZDATA
|
||||||
|
+ php_info_print_table_row(2, "Timezone Database", "system");
|
||||||
|
+#else
|
||||||
|
php_info_print_table_row(2, "Timezone Database", php_date_global_timezone_db_enabled ? "external" : "internal");
|
||||||
|
+#endif
|
||||||
|
php_info_print_table_row(2, "Default timezone", guess_timezone(tzdb));
|
||||||
|
php_info_print_table_end();
|
||||||
|
|
7
php.spec
7
php.spec
@ -70,7 +70,7 @@
|
|||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
Version: %{upver}%{?rcver:~%{rcver}}
|
Version: %{upver}%{?rcver:~%{rcver}}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
# All files licensed under PHP version 3.01, except
|
# All files licensed under PHP version 3.01, except
|
||||||
# Zend is licensed under Zend
|
# Zend is licensed under Zend
|
||||||
# TSRM is licensed under BSD
|
# TSRM is licensed under BSD
|
||||||
@ -111,7 +111,7 @@ Patch8: php-8.1.0-libdb.patch
|
|||||||
# Use system nikic/php-parser
|
# Use system nikic/php-parser
|
||||||
Patch41: php-8.1.0-parser.patch
|
Patch41: php-8.1.0-parser.patch
|
||||||
# use system tzdata
|
# use system tzdata
|
||||||
Patch42: php-8.1.0-systzdata-v21.patch
|
Patch42: php-8.1.0-systzdata-v22.patch
|
||||||
# See http://bugs.php.net/53436
|
# See http://bugs.php.net/53436
|
||||||
Patch43: php-7.4.0-phpize.patch
|
Patch43: php-7.4.0-phpize.patch
|
||||||
# Use -lldap_r for OpenLDAP
|
# Use -lldap_r for OpenLDAP
|
||||||
@ -1541,6 +1541,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 23 2022 Remi Collet <remi@remirepo.net> - 8.1.3-2
|
||||||
|
- retrieve tzdata version #2056611
|
||||||
|
|
||||||
* Wed Feb 16 2022 Remi Collet <remi@remirepo.net> - 8.1.3-1
|
* Wed Feb 16 2022 Remi Collet <remi@remirepo.net> - 8.1.3-1
|
||||||
- Update to 8.1.3 - http://www.php.net/releases/8_1_3.php
|
- Update to 8.1.3 - http://www.php.net/releases/8_1_3.php
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user