check sqlite3_column_table_name
This commit is contained in:
parent
250e9e4289
commit
11b30d5b39
27
php-5.4.7-sqlite.patch
Normal file
27
php-5.4.7-sqlite.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 05b9b50f09e10038230e1edab43b86afb67c14a8 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <fedora@famillecollet.com>
|
||||
Date: Mon, 24 Sep 2012 13:53:59 +0200
|
||||
Subject: [PATCH] Fix Bug #63149, check sqlite3_column_table_name availability
|
||||
with system SQLite
|
||||
|
||||
---
|
||||
ext/sqlite3/config0.m4 | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
|
||||
index ac58b35..1365def 100644
|
||||
--- a/ext/sqlite3/config0.m4
|
||||
+++ b/ext/sqlite3/config0.m4
|
||||
@@ -50,6 +50,9 @@ if test $PHP_SQLITE3 != "no"; then
|
||||
PHP_CHECK_LIBRARY(sqlite3,sqlite3_key,[
|
||||
AC_DEFINE(HAVE_SQLITE3_KEY, 1, [have commercial sqlite3 with crypto support])
|
||||
])
|
||||
+ PHP_CHECK_LIBRARY(sqlite3,sqlite3_column_table_name,[
|
||||
+ AC_DEFINE(SQLITE_ENABLE_COLUMN_METADATA, 1, [have sqlite3 with column metadata enabled])
|
||||
+ ])
|
||||
|
||||
PHP_CHECK_LIBRARY(sqlite3,sqlite3_load_extension,
|
||||
[],
|
||||
--
|
||||
1.7.10
|
||||
|
4
php.spec
4
php.spec
@ -78,6 +78,8 @@ Patch8: php-5.4.7-libdb.patch
|
||||
Patch20: php-5.4.7-imap.patch
|
||||
# https://bugs.php.net/63171 no odbc call during timeout
|
||||
Patch21: php-5.4.7-odbctimer.patch
|
||||
# https://bugs.php.net/63149 check sqlite3_column_table_name
|
||||
Patch22: php-5.4.7-sqlite.patch
|
||||
|
||||
# Functional changes
|
||||
Patch40: php-5.4.0-dlopen.patch
|
||||
@ -585,6 +587,7 @@ support for using the enchant library to PHP.
|
||||
|
||||
%patch20 -p1 -b .imap
|
||||
%patch21 -p1 -b .odbctimer
|
||||
%patch22 -p1 -b .tablename
|
||||
|
||||
%patch40 -p1 -b .dlopen
|
||||
%patch41 -p1 -b .easter
|
||||
@ -1299,6 +1302,7 @@ fi
|
||||
* Fri Sep 28 2012 Remi Collet <rcollet@redhat.com> 5.4.7-8
|
||||
- systemd integration, https://bugs.php.net/63085
|
||||
- no odbc call during timeout, https://bugs.php.net/63171
|
||||
- check sqlite3_column_table_name, https://bugs.php.net/63149
|
||||
|
||||
* Mon Sep 24 2012 Remi Collet <rcollet@redhat.com> 5.4.7-7
|
||||
- most failed tests explained (i386, x86_64)
|
||||
|
Loading…
Reference in New Issue
Block a user