update to 8.3.3RC1
drop GCC 14 patch merged upstream
This commit is contained in:
parent
51ee621d0b
commit
0956c6b8cf
2
.gitignore
vendored
2
.gitignore
vendored
@ -23,3 +23,5 @@ TODO
|
||||
/php-8.3.2RC1.tar.xz.asc
|
||||
/php-8.3.2.tar.xz
|
||||
/php-8.3.2.tar.xz.asc
|
||||
/php-8.3.3RC1.tar.xz
|
||||
/php-8.3.3RC1.tar.xz.asc
|
||||
|
@ -11,6 +11,6 @@ diff -up ./build/gen_stub.php.syslib ./build/gen_stub.php
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
$version = "5.0.0alpha3";
|
||||
$version = "5.0.0";
|
||||
$phpParserDir = __DIR__ . "/PHP-Parser-$version";
|
||||
if (!is_dir($phpParserDir)) {
|
@ -1,22 +0,0 @@
|
||||
From bee67f5c37a6aee20f8bae7f14e64417f87d6b92 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@remirepo.net>
|
||||
Date: Mon, 22 Jan 2024 10:01:25 +0100
|
||||
Subject: [PATCH] Fix GH-13215 GCC 14 build
|
||||
|
||||
---
|
||||
Zend/zend_atomic.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Zend/zend_atomic.h b/Zend/zend_atomic.h
|
||||
index 617cde0ec5640..8aab3f11ada00 100644
|
||||
--- a/Zend/zend_atomic.h
|
||||
+++ b/Zend/zend_atomic.h
|
||||
@@ -23,7 +23,7 @@
|
||||
((__GNUC__ == (x) && __GNUC_MINOR__ >= (y)) || (__GNUC__ > (x)))
|
||||
|
||||
/* Builtins are used to avoid library linkage */
|
||||
-#if __has_feature(c_atomic)
|
||||
+#if __has_feature(c_atomic) && defined(__clang__)
|
||||
#define HAVE_C11_ATOMICS 1
|
||||
#elif ZEND_GCC_PREREQ(4, 7)
|
||||
#define HAVE_GNUC_ATOMICS 1
|
16
php.spec
16
php.spec
@ -64,13 +64,13 @@
|
||||
%bcond_with imap
|
||||
%bcond_without lmdb
|
||||
|
||||
%global upver 8.3.2
|
||||
#global rcver RC1
|
||||
%global upver 8.3.3
|
||||
%global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: %{upver}%{?rcver:~%{rcver}}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -106,11 +106,10 @@ Patch1: php-7.4.0-httpd.patch
|
||||
Patch5: php-7.2.0-includedir.patch
|
||||
Patch6: php-8.0.0-embed.patch
|
||||
Patch8: php-8.1.0-libdb.patch
|
||||
Patch9: php-gcc14.patch
|
||||
|
||||
# Functional changes
|
||||
# Use system nikic/php-parser
|
||||
Patch41: php-8.3.0-parser.patch
|
||||
Patch41: php-8.3.3-parser.patch
|
||||
# use system tzdata
|
||||
Patch42: php-8.3.0-systzdata-v24.patch
|
||||
# See http://bugs.php.net/53436
|
||||
@ -326,7 +325,7 @@ Requires: zlib-devel%{?_isa}
|
||||
Provides: php-zts-devel = %{version}-%{release}
|
||||
Provides: php-zts-devel%{?_isa} = %{version}-%{release}
|
||||
%endif
|
||||
Recommends: php-nikic-php-parser5 >= 5.0.0~alpha3
|
||||
Recommends: php-nikic-php-parser5 >= 5.0.0
|
||||
|
||||
|
||||
%description devel
|
||||
@ -719,7 +718,6 @@ in pure PHP.
|
||||
%patch -P5 -p1 -b .includedir
|
||||
%patch -P6 -p1 -b .embed
|
||||
%patch -P8 -p1 -b .libdb
|
||||
%patch -P9 -p1 -b .gcc14
|
||||
|
||||
%patch -P41 -p1 -b .syslib
|
||||
%patch -P42 -p1 -b .systzdata
|
||||
@ -1554,6 +1552,10 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 31 2024 Remi Collet <remi@remirepo.net> - 8.3.2~RC1-1
|
||||
- update to 8.3.3RC1
|
||||
- drop GCC 14 patch merged upstream
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (php-8.3.2.tar.xz) = acf9013d35ae639558fd4816d12dcae03f8af7944c2639f33cd33517503c6170d30101da6c72ebdaf5542bcaf858a54a22ecc8f86822a128f52938bd6ea9606c
|
||||
SHA512 (php-8.3.2.tar.xz.asc) = eac9bf054d6dbbcc7cc276be141deb1805c5638c65816f753cc30445a2216cf00e7563520c4b6e9a662c41ce86ccbce612847db3131a7d8ffa278f9a0734bdfc
|
||||
SHA512 (php-8.3.3RC1.tar.xz) = be802a7e9eb328add2e8b2a6d3fab3f9012469d43b3a5d6feacb9feed02ce446b617bb3fc7807697cd54f2935cbe4048a0356cc19f0f5b8e43b54877ab0719c9
|
||||
SHA512 (php-8.3.3RC1.tar.xz.asc) = 6a91cc39aeeea7cd6e8c93d152b05fc0afe3f25cac16443fcab5e193a650df51e8d6af7dc519f7b7aecbbd49b323fb073de77b6ff176acce64acc85438a801ff
|
||||
|
Loading…
Reference in New Issue
Block a user