- Update to 5.6.15 http://www.php.net/releases/5_6_15.php
- php-config: reports all built sapis
This commit is contained in:
parent
ba707d77ec
commit
040acf5d42
1
.gitignore
vendored
1
.gitignore
vendored
@ -57,3 +57,4 @@ php-5.5.*.xz
|
||||
/php-5.6.14RC1-strip.tar.xz
|
||||
/php-5.6.14-strip.tar.xz
|
||||
/php-5.6.15RC1-strip.tar.xz
|
||||
/php-5.6.15-strip.tar.xz
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- php-5.2.4/sapi/embed/config.m4.embed
|
||||
+++ php-5.2.4/sapi/embed/config.m4
|
||||
@@ -12,7 +12,8 @@ if test "$PHP_EMBED" != "no"; then
|
||||
case "$PHP_EMBED" in
|
||||
yes|shared)
|
||||
PHP_EMBED_TYPE=shared
|
||||
- INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(prefix)/lib; \$(INSTALL) -m 0755 $SAPI_SHARED \$(INSTALL_ROOT)\$(prefix)/lib"
|
||||
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS -release \$(PHP_MAJOR_VERSION).\$(PHP_MINOR_VERSION)"
|
||||
+ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(libdir); \$(LIBTOOL) --mode=install \$(INSTALL) -m 0755 \$(OVERALL_TARGET) \$(INSTALL_ROOT)\$(libdir)"
|
||||
;;
|
||||
static)
|
||||
PHP_EMBED_TYPE=static
|
24
php-5.6.3-embed.patch
Normal file
24
php-5.6.3-embed.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- php-5.6.3/sapi/embed/config.m4.embed
|
||||
+++ php-5.6.3/sapi/embed/config.m4
|
||||
@@ -12,7 +12,8 @@ if test "$PHP_EMBED" != "no"; then
|
||||
case "$PHP_EMBED" in
|
||||
yes|shared)
|
||||
PHP_EMBED_TYPE=shared
|
||||
- INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(prefix)/lib; \$(INSTALL) -m 0755 $SAPI_SHARED \$(INSTALL_ROOT)\$(prefix)/lib"
|
||||
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS -release \$(PHP_MAJOR_VERSION).\$(PHP_MINOR_VERSION)"
|
||||
+ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(libdir); \$(LIBTOOL) --mode=install \$(INSTALL) -m 0755 \$(OVERALL_TARGET) \$(INSTALL_ROOT)\$(libdir)"
|
||||
;;
|
||||
static)
|
||||
PHP_EMBED_TYPE=static
|
||||
diff -up php-5.5.30/scripts/php-config.in.old php-5.5.30/scripts/php-config.in
|
||||
--- php-5.5.30/scripts/php-config.in.old 2015-10-19 15:17:31.944747715 +0200
|
||||
+++ php-5.5.30/scripts/php-config.in 2015-10-19 15:17:58.278858083 +0200
|
||||
@@ -18,7 +18,7 @@ exe_extension="@EXEEXT@"
|
||||
php_cli_binary=NONE
|
||||
php_cgi_binary=NONE
|
||||
configure_options="@CONFIGURE_OPTIONS@"
|
||||
-php_sapis="@PHP_INSTALLED_SAPIS@"
|
||||
+php_sapis="apache2handler embed fpm @PHP_INSTALLED_SAPIS@"
|
||||
|
||||
# Set php_cli_binary and php_cgi_binary if available
|
||||
for sapi in $php_sapis; do
|
15
php.spec
15
php.spec
@ -64,16 +64,16 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
%global rcver RC1
|
||||
#global rcver RC1
|
||||
%global rpmrel 1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.6.15
|
||||
%if 0%{?rcver:1}
|
||||
Release: 0.%{rpmrel}.%{rcver}%{?dist}.1
|
||||
Release: 0.%{rpmrel}.%{rcver}%{?dist}
|
||||
%else
|
||||
Release: %{rpmrel}%{?dist}.1
|
||||
Release: %{rpmrel}%{?dist}
|
||||
%endif
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
@ -104,7 +104,7 @@ Source51: opcache-default.blacklist
|
||||
|
||||
# Build fixes
|
||||
Patch5: php-5.6.3-includedir.patch
|
||||
Patch6: php-5.2.4-embed.patch
|
||||
Patch6: php-5.6.3-embed.patch
|
||||
Patch7: php-5.3.0-recode.patch
|
||||
Patch8: php-5.6.3-libdb.patch
|
||||
|
||||
@ -1483,10 +1483,11 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
%config(noreplace) %{_sysconfdir}/php-zts.d/opcache-default.blacklist
|
||||
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 28 2015 David Tardon <dtardon@redhat.com> - 5.6.15-0.1.RC1.1
|
||||
- rebuild for ICU 56.1
|
||||
* Thu Oct 29 2015 Remi Collet <remi@fedoraproject.org> 5.6.15-1
|
||||
- Update to 5.6.15
|
||||
http://www.php.net/releases/5_6_15.php
|
||||
- php-config: reports all built sapis
|
||||
|
||||
* Thu Oct 15 2015 Remi Collet <remi@fedoraproject.org> 5.6.15-0.1.RC1
|
||||
- update to 5.6.15RC1
|
||||
|
Loading…
Reference in New Issue
Block a user