Import rpm: ea7af42136a779cd8767c3fa8aa047d3b440a58d
This commit is contained in:
commit
51b5b27df8
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/zip-1.19.2.tgz
|
8
gating.yaml
Normal file
8
gating.yaml
Normal file
@ -0,0 +1,8 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier1.functional}
|
||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.acceptance-tier.functional}
|
||||
|
298
php-pecl-zip.spec
Normal file
298
php-pecl-zip.spec
Normal file
@ -0,0 +1,298 @@
|
||||
# RHEL / Fedora spec file for php-pecl-zip
|
||||
#
|
||||
# Copyright (c) 2013-2021 Remi Collet
|
||||
# License: CC-BY-SA
|
||||
# http://creativecommons.org/licenses/by-sa/4.0/
|
||||
#
|
||||
# Please, preserve the changelog entries
|
||||
#
|
||||
|
||||
# we don't want -z defs linker flag
|
||||
%undefine _strict_symbol_defs_build
|
||||
|
||||
%global pecl_name zip
|
||||
%global with_zts 0%{?__ztsphp:1}
|
||||
%global ini_name 40-%{pecl_name}.ini
|
||||
|
||||
%global upstream_version 1.19.2
|
||||
#global upstream_prever RC6
|
||||
|
||||
Summary: A ZIP archive management extension
|
||||
Summary(fr): Une extension de gestion des ZIP
|
||||
Name: php-pecl-zip
|
||||
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
|
||||
Release: 1%{?dist}
|
||||
License: PHP
|
||||
URL: https://pecl.php.net/package/zip
|
||||
|
||||
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: php-devel
|
||||
BuildRequires: pkgconfig(libzip) >= 1.0.0
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: php-pear
|
||||
|
||||
Requires: php(zend-abi) = %{php_zend_api}
|
||||
Requires: php(api) = %{php_core_api}
|
||||
|
||||
Provides: php-pecl(%{pecl_name}) = %{version}
|
||||
Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
|
||||
Provides: php-%{pecl_name} = %{version}-%{release}
|
||||
Provides: php-%{pecl_name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
|
||||
%description
|
||||
Zip is an extension to create and read zip files.
|
||||
|
||||
%description -l fr
|
||||
Zip est une extension pour créer et lire les archives au format ZIP.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -c -q
|
||||
mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
|
||||
|
||||
# Don't install/register tests
|
||||
sed -e 's/role="test"/role="src"/' \
|
||||
-e '/LICENSE/s/role="doc"/role="src"/' \
|
||||
-i package.xml
|
||||
|
||||
cd NTS
|
||||
# Sanity check, really often broken
|
||||
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php8/php_zip.h)
|
||||
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
|
||||
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
|
||||
exit 1
|
||||
fi
|
||||
|
||||
cd ..
|
||||
: Create the configuration file
|
||||
cat >%{ini_name} << 'EOF'
|
||||
; Enable ZIP extension module
|
||||
extension=%{pecl_name}.so
|
||||
EOF
|
||||
|
||||
%if %{with_zts}
|
||||
: Duplicate sources tree for ZTS build
|
||||
cp -pr NTS ZTS
|
||||
%endif
|
||||
|
||||
|
||||
%build
|
||||
cd NTS
|
||||
%{_bindir}/phpize
|
||||
%configure \
|
||||
--with-libzip \
|
||||
--with-libdir=%{_lib} \
|
||||
--with-php-config=%{_bindir}/php-config
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%if %{with_zts}
|
||||
cd ../ZTS
|
||||
%{_bindir}/zts-phpize
|
||||
%configure \
|
||||
--with-libzip \
|
||||
--with-libdir=%{_lib} \
|
||||
--with-php-config=%{_bindir}/zts-php-config
|
||||
|
||||
make %{?_smp_mflags}
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
make -C NTS install INSTALL_ROOT=%{buildroot}
|
||||
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
|
||||
|
||||
# Install XML package description
|
||||
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
|
||||
|
||||
%if %{with_zts}
|
||||
make -C ZTS install INSTALL_ROOT=%{buildroot}
|
||||
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
|
||||
%endif
|
||||
|
||||
# Documentation
|
||||
cd NTS
|
||||
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
|
||||
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
|
||||
done
|
||||
|
||||
|
||||
%check
|
||||
cd NTS
|
||||
: minimal load test of NTS extension
|
||||
%{_bindir}/php --no-php-ini \
|
||||
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
|
||||
--modules | grep %{pecl_name}
|
||||
|
||||
: upstream test suite for NTS extension
|
||||
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
|
||||
TEST_PHP_EXECUTABLE=%{_bindir}/php \
|
||||
%{_bindir}/php -n run-tests.php -q --show-diff
|
||||
|
||||
%if %{with_zts}
|
||||
cd ../ZTS
|
||||
: minimal load test of ZTS extension
|
||||
%{_bindir}/zts-php --no-php-ini \
|
||||
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
|
||||
--modules | grep %{pecl_name}
|
||||
|
||||
: upstream test suite for ZTS extension
|
||||
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
|
||||
TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
|
||||
%{_bindir}/zts-php -n run-tests.php -q --show-diff
|
||||
%endif
|
||||
|
||||
|
||||
%files
|
||||
%license NTS/LICENSE
|
||||
%doc %{pecl_docdir}/%{pecl_name}
|
||||
%{pecl_xmldir}/%{name}.xml
|
||||
|
||||
%config(noreplace) %{php_inidir}/%{ini_name}
|
||||
%{php_extdir}/%{pecl_name}.so
|
||||
|
||||
%if %{with_zts}
|
||||
%config(noreplace) %{php_ztsinidir}/%{ini_name}
|
||||
%{php_ztsextdir}/%{pecl_name}.so
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 14 2021 Remi Collet <rcollet@redhat.com> - 1.19.2-1
|
||||
- update to 1.19.2
|
||||
|
||||
* Thu May 14 2020 Remi Collet <rcollet@redhat.com> - 1.18.2-1
|
||||
- update to 1.18.2
|
||||
|
||||
* Tue May 7 2019 Remi Collet <remi@remirepo.net> - 1.15.4-1
|
||||
- Update to 1.15.4
|
||||
|
||||
* Tue Jun 12 2018 Remi Collet <remi@remirepo.net> - 1.15.3-1
|
||||
- Update to 1.15.3
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Jan 26 2018 Remi Collet <remi@remirepo.net> - 1.15.2-2
|
||||
- undefine _strict_symbol_defs_build
|
||||
|
||||
* Tue Dec 19 2017 Remi Collet <remi@fedoraproject.org> - 1.15.2-1
|
||||
- Update to 1.15.2
|
||||
|
||||
* Tue Oct 03 2017 Remi Collet <remi@fedoraproject.org> - 1.15.1-4
|
||||
- rebuild for https://fedoraproject.org/wiki/Changes/php72
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Jul 11 2017 Remi Collet <remi@remirepo.net> - 1.15.1-1
|
||||
- Update to 1.15.1
|
||||
|
||||
* Mon Jul 10 2017 Remi Collet <remi@remirepo.net> - 1.15.0-1
|
||||
- Update to 1.15.0
|
||||
|
||||
* Wed Apr 5 2017 Remi Collet <remi@remirepo.net> - 1.14.0-1
|
||||
- Update to 1.14.0
|
||||
|
||||
* Tue Feb 28 2017 Remi Collet <remi@fedoraproject.org> - 1.13.5-4
|
||||
- rebuild for new libzip
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Nov 14 2016 Remi Collet <remi@fedoraproject.org> - 1.13.5-2
|
||||
- rebuild for https://fedoraproject.org/wiki/Changes/php71
|
||||
|
||||
* Fri Oct 14 2016 Remi Collet <remi@fedoraproject.org> - 1.13.5-1
|
||||
- Update to 1.13.5
|
||||
|
||||
* Thu Jul 21 2016 Remi Collet <remi@fedoraproject.org> - 1.13.4-1
|
||||
- Update to 1.13.4
|
||||
|
||||
* Mon Jun 27 2016 Remi Collet <remi@fedoraproject.org> - 1.13.3-2
|
||||
- rebuild for https://fedoraproject.org/wiki/Changes/php70
|
||||
|
||||
* Thu Jun 23 2016 Remi Collet <remi@fedoraproject.org> - 1.13.3-1
|
||||
- Update to 1.13.3
|
||||
|
||||
* Tue Mar 1 2016 Remi Collet <remi@fedoraproject.org> - 1.13.2-1
|
||||
- Update to 1.13.2
|
||||
- fix license management
|
||||
|
||||
* Wed Feb 10 2016 Remi Collet <remi@fedoraproject.org> - 1.13.1-3
|
||||
- drop scriptlets (replaced file triggers in php-pear)
|
||||
- ignore 1 test (change in php, FTBFS detected by Koschei)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Sep 10 2015 Remi Collet <remi@fedoraproject.org> - 1.13.1-1
|
||||
- Update to 1.13.1 (no change)
|
||||
|
||||
* Mon Sep 7 2015 Remi Collet <remi@fedoraproject.org> - 1.13.0-1
|
||||
- Update to 1.13.0
|
||||
- raise dependency on libzip 1.0.0
|
||||
- don't install/register tests
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed May 06 2015 Remi Collet <remi@fedoraproject.org> - 1.12.5-2
|
||||
- rebuild for new libzip
|
||||
|
||||
* Thu Apr 16 2015 Remi Collet <remi@fedoraproject.org> - 1.12.5-1
|
||||
- Update to 1.12.5 (stable)
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Thu Jun 19 2014 Remi Collet <rcollet@redhat.com> - 1.12.4-4
|
||||
- rebuild for https://fedoraproject.org/wiki/Changes/Php56
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Apr 24 2014 Remi Collet <rcollet@redhat.com> - 1.12.4-2
|
||||
- add numerical prefix to extension configuration file
|
||||
|
||||
* Wed Jan 29 2014 Remi Collet <remi@fedoraproject.org> - 1.12.4-1
|
||||
- Update to 1.12.4 (stable) for libzip 0.11.2
|
||||
|
||||
* Thu Dec 12 2013 Remi Collet <remi@fedoraproject.org> - 1.12.3-1
|
||||
- Update to 1.12.3 (stable)
|
||||
- drop merged patch
|
||||
|
||||
* Thu Oct 24 2013 Remi Collet <remi@fedoraproject.org> 1.12.2-2
|
||||
- upstream patch, don't use any libzip private struct
|
||||
- drop LICENSE_libzip when system version is used
|
||||
- always build ZTS extension
|
||||
|
||||
* Wed Oct 23 2013 Remi Collet <remi@fedoraproject.org> 1.12.2-1
|
||||
- update to 1.12.2 (beta)
|
||||
- drop merged patches
|
||||
- install doc in pecl doc_dir
|
||||
- install tests in pecl test_dir
|
||||
|
||||
* Thu Aug 22 2013 Remi Collet <rcollet@redhat.com> 1.12.1-5
|
||||
- really really fix all spurious-executable-perm
|
||||
|
||||
* Thu Aug 22 2013 Remi Collet <rcollet@redhat.com> 1.12.1-4
|
||||
- really fix all spurious-executable-perm
|
||||
|
||||
* Thu Aug 22 2013 Remi Collet <rcollet@redhat.com> 1.12.1-3
|
||||
- fixes from review comments #999313: clarify License
|
||||
- drop execution right from sources
|
||||
- BR libzip-devel always needed
|
||||
|
||||
* Tue Aug 20 2013 Remi Collet <rcollet@redhat.com> 1.12.1-2
|
||||
- refresh our merged patches from upstream git
|
||||
|
||||
* Thu Aug 08 2013 Remi Collet <rcollet@redhat.com> 1.12.1-1
|
||||
- New spec for version 1.12.1 (beta)
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA1 (zip-1.19.2.tgz) = c912f7eae400d5f23f20b28cdc9c4337140219e0
|
42
zip-php8.patch
Normal file
42
zip-php8.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From a6154ce1512755b061848bc1e549118279765dc1 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@remirepo.net>
|
||||
Date: Fri, 5 Jun 2020 17:08:21 +0200
|
||||
Subject: [PATCH] encode param is optional
|
||||
|
||||
---
|
||||
php8/php_zip.stub.php | 4 ++--
|
||||
php8/php_zip_arginfo.h | 4 ++--
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/php8/php_zip.stub.php b/php8/php_zip.stub.php
|
||||
index da8e373..f85464a 100644
|
||||
--- a/php8/php_zip.stub.php
|
||||
+++ b/php8/php_zip.stub.php
|
||||
@@ -194,9 +194,9 @@ public function registerCancelCallback(callable $callback) {}
|
||||
|
||||
#ifdef HAVE_METHOD_SUPPORTED
|
||||
/** @return bool */
|
||||
- public static function isCompressionMethodSupported(int $method, bool $enc): bool {}
|
||||
+ public static function isCompressionMethodSupported(int $method, bool $enc = true): bool {}
|
||||
|
||||
/** @return bool */
|
||||
- public static function isEncryptionMethodSupported(int $method, bool $enc): bool {}
|
||||
+ public static function isEncryptionMethodSupported(int $method, bool $enc = true): bool {}
|
||||
#endif
|
||||
}
|
||||
diff --git a/php8/php_zip_arginfo.h b/php8/php_zip_arginfo.h
|
||||
index c1e8f24..5f150b9 100644
|
||||
--- a/php8/php_zip_arginfo.h
|
||||
+++ b/php8/php_zip_arginfo.h
|
||||
@@ -271,9 +271,9 @@ ZEND_END_ARG_INFO()
|
||||
#endif
|
||||
|
||||
#if defined(HAVE_METHOD_SUPPORTED)
|
||||
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_class_ZipArchive_isCompressionMethodSupported, 0, 2, _IS_BOOL, 0)
|
||||
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_class_ZipArchive_isCompressionMethodSupported, 0, 1, _IS_BOOL, 0)
|
||||
ZEND_ARG_TYPE_INFO(0, method, IS_LONG, 0)
|
||||
- ZEND_ARG_TYPE_INFO(0, enc, _IS_BOOL, 0)
|
||||
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, enc, _IS_BOOL, 0, "true")
|
||||
ZEND_END_ARG_INFO()
|
||||
#endif
|
||||
|
Loading…
Reference in New Issue
Block a user