This commit is contained in:
Remi Collet 2020-06-08 09:07:02 +02:00
parent ff86d9eee1
commit 3f78557ccd
4 changed files with 52 additions and 2 deletions

1
.gitignore vendored
View File

@ -27,3 +27,4 @@ php-pecl-zip.spec~
/zip-1.18.0.tgz
/zip-1.18.1.tgz
/zip-1.18.2.tgz
/zip-1.19.0.tgz

View File

@ -14,7 +14,7 @@
%global with_zts 0%{?__ztsphp:1}
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 1.18.2
%global upstream_version 1.19.0
#global upstream_prever RC6
Summary: A ZIP archive management extension
@ -27,6 +27,8 @@ URL: https://pecl.php.net/package/zip
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
Patch0: %{pecl_name}-php8.patch
BuildRequires: php-devel
BuildRequires: pkgconfig(libzip) >= 1.0.0
BuildRequires: zlib-devel
@ -58,6 +60,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
%patch0 -p1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php5/php_zip.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@ -164,6 +168,9 @@ TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
%changelog
* Mon Jun 8 2020 Remi Collet <remi@remirepo.net> - 1.19.0-1
- update to 1.19.0
* Fri Mar 20 2020 Remi Collet <remi@remirepo.net> - 1.18.2-1
- update to 1.18.2

View File

@ -1 +1 @@
SHA512 (zip-1.18.2.tgz) = e4cb14084094d673e9674d6991f26bbb25d58efb2fe86e56bb04c941cd8b1c11421d42d002b97f84c595eaf8300480e2f8c2f957c3a961474e0194c81fbc4631
SHA512 (zip-1.19.0.tgz) = 7113f005a8d78d55a4cbae0013f681ab6e30f0595292e7a8064ac32d30947bad1c38033dd113efb9be7b9171e77302888ef8fb4543c48edb4de4f8ffa46b6062

42
zip-php8.patch Normal file
View File

@ -0,0 +1,42 @@
From a6154ce1512755b061848bc1e549118279765dc1 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Fri, 5 Jun 2020 17:08:21 +0200
Subject: [PATCH] encode param is optional
---
php8/php_zip.stub.php | 4 ++--
php8/php_zip_arginfo.h | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/php8/php_zip.stub.php b/php8/php_zip.stub.php
index da8e373..f85464a 100644
--- a/php8/php_zip.stub.php
+++ b/php8/php_zip.stub.php
@@ -194,9 +194,9 @@ public function registerCancelCallback(callable $callback) {}
#ifdef HAVE_METHOD_SUPPORTED
/** @return bool */
- public static function isCompressionMethodSupported(int $method, bool $enc): bool {}
+ public static function isCompressionMethodSupported(int $method, bool $enc = true): bool {}
/** @return bool */
- public static function isEncryptionMethodSupported(int $method, bool $enc): bool {}
+ public static function isEncryptionMethodSupported(int $method, bool $enc = true): bool {}
#endif
}
diff --git a/php8/php_zip_arginfo.h b/php8/php_zip_arginfo.h
index c1e8f24..5f150b9 100644
--- a/php8/php_zip_arginfo.h
+++ b/php8/php_zip_arginfo.h
@@ -271,9 +271,9 @@ ZEND_END_ARG_INFO()
#endif
#if defined(HAVE_METHOD_SUPPORTED)
-ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_class_ZipArchive_isCompressionMethodSupported, 0, 2, _IS_BOOL, 0)
+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_class_ZipArchive_isCompressionMethodSupported, 0, 1, _IS_BOOL, 0)
ZEND_ARG_TYPE_INFO(0, method, IS_LONG, 0)
- ZEND_ARG_TYPE_INFO(0, enc, _IS_BOOL, 0)
+ ZEND_ARG_TYPE_INFO_WITH_DEFAULT_VALUE(0, enc, _IS_BOOL, 0, "true")
ZEND_END_ARG_INFO()
#endif