diff --git a/pear-proxy.patch b/pear-proxy.patch
new file mode 100644
index 0000000..d5d7685
--- /dev/null
+++ b/pear-proxy.patch
@@ -0,0 +1,26 @@
+From 798621dda8328228a6cccfc09a7b7cce77ba3424 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 30 Mar 2016 11:45:21 +0200
+Subject: [PATCH] fix https connection via proxy
+
+---
+ PEAR/REST.php | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/PEAR/REST.php b/PEAR/REST.php
+index 1e472b7..00129ba 100644
+--- a/PEAR/REST.php
++++ b/PEAR/REST.php
+@@ -360,11 +360,7 @@ function downloadHttp($url, $lastmodified = null, $accept = false, $channel = fa
+         if ($this->config->get('http_proxy')&&
+               $proxy = parse_url($this->config->get('http_proxy'))
+         ) {
+-            $proxy_host = isset($proxy['host']) ? $proxy['host'] : null;
+-            if ($schema === 'https') {
+-                $proxy_host = 'ssl://' . $proxy_host;
+-            }
+-
++            $proxy_host   = isset($proxy['host']) ? $proxy['host'] : null;
+             $proxy_port   = isset($proxy['port']) ? $proxy['port'] : 8080;
+             $proxy_user   = isset($proxy['user']) ? urldecode($proxy['user']) : null;
+             $proxy_pass   = isset($proxy['pass']) ? urldecode($proxy['pass']) : null;
diff --git a/php-pear.spec b/php-pear.spec
index c29b513..656c18d 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -27,7 +27,7 @@
 Summary: PHP Extension and Application Repository framework
 Name: php-pear
 Version: 1.10.1
-Release: 6%{?dist}
+Release: 7%{?dist}
 Epoch: 1
 # PEAR, PEAR_Manpages, Archive_Tar, XML_Util, Console_Getopt are BSD
 # Structures_Graph is LGPLv3+
@@ -48,6 +48,9 @@ Source23: http://pear.php.net/get/Structures_Graph-%{structver}.tgz
 Source24: http://pear.php.net/get/XML_Util-%{xmlutil}.tgz
 Source25: http://pear.php.net/get/PEAR_Manpages-%{manpages}.tgz
 
+# https://github.com/pear/pear-core/pull/51
+Patch0:   pear-proxy.patch
+
 BuildArch: noarch
 BuildRequires: php(language) > 5.4
 BuildRequires: php-cli
@@ -118,7 +121,7 @@ done
 cp %{SOURCE1} .
 
 # apply patches on used PEAR during install
-# None \o/
+# Patch0 applied on installation tree
 
 sed -e 's:@BINDIR@:%{_bindir}:' \
     -e 's:@LIBDIR@:%{_localstatedir}/lib:' \
@@ -183,7 +186,7 @@ install -m 644 -D macros.pear \
 
 # apply patches on installed PEAR tree
 pushd $RPM_BUILD_ROOT%{peardir} 
-# none
+patch --no-backup --fuzz 0 -p1 < %{PATCH0}
 popd
 
 # Why this file here ?
@@ -233,12 +236,10 @@ exit $ret
 echo 'Test suite disabled (missing "--with tests" option)'
 %endif
 
-## TODO: silent the pecl commands
-
 # Register newly installed PECL packages
 %transfiletriggerin -- %{pecl_xmldir}
 while read file; do
-  %{_bindir}/pecl install --nodeps --soft --force --register-only --nobuild "$file" || :
+  %{_bindir}/pecl install --nodeps --soft --force --register-only --nobuild "$file" >/dev/null || :
 done
 
 # Unregister to be removed PECL packages
@@ -254,7 +255,7 @@ while ($file=fgets(STDIN)) {
     fputs(STDERR, "Bad pecl package file ($file)\n");
   }
 }' | while read  name; do
-  %{_bindir}/pecl uninstall --nodeps --ignore-errors --register-only "$name" || :
+  %{_bindir}/pecl uninstall --nodeps --ignore-errors --register-only "$name" >/dev/null || :
 done
 
 
@@ -292,6 +293,11 @@ fi
 
 
 %changelog
+* Fri Sep 30 2016 Remi Collet <remi@fedoraproject.org> 1:1.10.1-7
+- fix https connection via a proxy
+  patch from https://github.com/pear/pear-core/pull/51
+- silent the new scriplets
+
 * Fri Aug  5 2016 Remi Collet <remi@fedoraproject.org> 1:1.10.1-6
 - improve default config, to avoid change in scriptlet
 - spec cleanup and remove unneeded scriplets