perl/perl-5.8.8-rpath-make.patch
2006-02-01 15:55:58 +00:00

33 lines
944 B
Diff

--- perl-5.8.8-RC1/Makefile.SH.makerpath 2006-01-20 16:41:26.000000000 -0500
+++ perl-5.8.8-RC1/Makefile.SH 2006-01-20 16:41:57.000000000 -0500
@@ -125,26 +125,10 @@
esac
case "$osname" in
- linux)
- # If there is a pre-existing $libperl from a previous
- # installation, Linux needs to use LD_PRELOAD to
- # override the LD_LIBRARY_PATH setting. See the
- # INSTALL file, under "Building a shared perl library".
- # If there is no pre-existing $libperl, we don't need
- # to do anything further.
- if test -f $archlib/CORE/$libperl; then
- rm -f preload
- cat <<'EOT' > preload
-#! /bin/sh
-lib=$1
-shift
-test -r $lib && export LD_PRELOAD="$lib $LD_PRELOAD"
-exec "$@"
-EOT
- chmod 755 preload
- ldlibpth="$ldlibpth `pwd`/preload `pwd`/$libperl"
- fi
+ linux*)
+ ldlibpth="LD_PRELOAD=`pwd`/libperl.so $ldlibpth"
;;
+
os390) test -f /bin/env && ldlibpth="/bin/env $ldlibpth"
;;
esac