Remove or update patches
This commit is contained in:
parent
6071c95c73
commit
fb0d177f72
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@ perl-5.12.1.tar.gz
|
|||||||
/perl-5.20.0.tar.bz2
|
/perl-5.20.0.tar.bz2
|
||||||
/perl-5.20.1.tar.bz2
|
/perl-5.20.1.tar.bz2
|
||||||
/perl-5.20.2.tar.bz2
|
/perl-5.20.2.tar.bz2
|
||||||
|
/perl-5.22.0.tar.bz2
|
||||||
|
@ -5,8 +5,8 @@ diff -up perl-5.10.0/Configure.didi perl-5.10.0/Configure
|
|||||||
: set usesocks on the Configure command line to enable socks.
|
: set usesocks on the Configure command line to enable socks.
|
||||||
: List of libraries we want.
|
: List of libraries we want.
|
||||||
: If anyone needs extra -lxxx, put those in a hint file.
|
: If anyone needs extra -lxxx, put those in a hint file.
|
||||||
-libswanted="socket bind inet nsl nm ndbm gdbm dbm db malloc dl ld sun"
|
-libswanted="cl pthread socket bind inet nsl nm ndbm gdbm dbm db malloc dl ld"
|
||||||
+libswanted="socket resolv inet nsl nm ndbm gdbm dbm db malloc dl ld sun"
|
+libswanted="cl pthread socket resolv inet nsl nm ndbm gdbm dbm db malloc dl ld"
|
||||||
libswanted="$libswanted m crypt sec util c cposix posix ucb bsd BSD"
|
libswanted="$libswanted sun m crypt sec util c cposix posix ucb bsd BSD"
|
||||||
: We probably want to search /usr/shlib before most other libraries.
|
: We probably want to search /usr/shlib before most other libraries.
|
||||||
: This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
|
: This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
|
||||||
|
@ -5,8 +5,8 @@ diff -up perl-5.10.0/t/io/fs.t.BAD perl-5.10.0/t/io/fs.t
|
|||||||
isnt($mtime, 500000000 + $delta, 'mtime');
|
isnt($mtime, 500000000 + $delta, 'mtime');
|
||||||
|
|
||||||
SKIP: {
|
SKIP: {
|
||||||
- skip "no futimes", 4 unless ($Config{d_futimes} || "") eq "define";
|
- skip "no futimes", 6 unless ($Config{d_futimes} || "") eq "define";
|
||||||
+ skip "no futimes", 4;
|
+ skip "no futimes", 6;
|
||||||
open(my $fh, "<", 'b');
|
open(my $fh, "<", 'b');
|
||||||
$foo = (utime 500000000,500000000 + $delta, $fh);
|
$foo = (utime 500000000,500000000 + $delta, $fh);
|
||||||
is($foo, 1, "futime");
|
is($foo, 1, "futime");
|
||||||
|
@ -38,10 +38,10 @@ index a8b172f..a3fbce2 100644
|
|||||||
@@ -941,6 +942,11 @@ $(INST_DYNAMIC): $(OBJECT) $(MYEXTLIB) $(BOOTSTRAP) $(INST_ARCHAUTODIR)$(DFSEP).
|
@@ -941,6 +942,11 @@ $(INST_DYNAMIC): $(OBJECT) $(MYEXTLIB) $(BOOTSTRAP) $(INST_ARCHAUTODIR)$(DFSEP).
|
||||||
# The Android linker will not recognize symbols from
|
# The Android linker will not recognize symbols from
|
||||||
# libperl unless the module explicitly depends on it.
|
# libperl unless the module explicitly depends on it.
|
||||||
$libs .= ' -L$(PERL_INC) -lperl';
|
$libs .= ' "-L$(PERL_INC)" -lperl';
|
||||||
+ } else {
|
+ } else {
|
||||||
+ if ($ENV{PERL_CORE}) {
|
+ if ($ENV{PERL_CORE}) {
|
||||||
+ $libs .= ' -L$(PERL_INC)';
|
+ $libs .= ' "-L$(PERL_INC)"';
|
||||||
+ }
|
+ }
|
||||||
+ $libs .= ' -lperl';
|
+ $libs .= ' -lperl';
|
||||||
}
|
}
|
||||||
|
@ -1,54 +0,0 @@
|
|||||||
From 8de0fd45cde4826951842f80b6ce109988d47f4f Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
|
||||||
Date: Mon, 7 Apr 2014 12:31:28 +0200
|
|
||||||
Subject: [PATCH] t/op/crypt.t: Perform SHA-256 algorithm if default one is
|
|
||||||
disabled
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
The crypt(3) call may return NULL. This is the case of FIPS-enabled
|
|
||||||
platforms. Then "salt makes a difference" test would fail.
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
t/op/crypt.t | 14 ++++++++++----
|
|
||||||
1 file changed, 10 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/t/op/crypt.t b/t/op/crypt.t
|
|
||||||
index 27c878f..6c43992 100644
|
|
||||||
--- a/t/op/crypt.t
|
|
||||||
+++ b/t/op/crypt.t
|
|
||||||
@@ -28,19 +28,25 @@ BEGIN {
|
|
||||||
# bets, given alternative encryption/hashing schemes like MD5,
|
|
||||||
# C2 (or higher) security schemes, and non-UNIX platforms.
|
|
||||||
|
|
||||||
+# Platforms implementing FIPS mode return undef on weak crypto algorithms.
|
|
||||||
+my $alg = ''; # Use default algorithm
|
|
||||||
+if ( !defined(crypt("ab", "cd")) ) {
|
|
||||||
+ $alg = '$5$'; # Use SHA-256
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
SKIP: {
|
|
||||||
skip ("VOS crypt ignores salt.", 1) if ($^O eq 'vos');
|
|
||||||
- ok(substr(crypt("ab", "cd"), 2) ne substr(crypt("ab", "ce"), 2), "salt makes a difference");
|
|
||||||
+ ok(substr(crypt("ab", $alg . "cd"), 2) ne substr(crypt("ab", $alg. "ce"), 2), "salt makes a difference");
|
|
||||||
}
|
|
||||||
|
|
||||||
$a = "a\xFF\x{100}";
|
|
||||||
|
|
||||||
-eval {$b = crypt($a, "cd")};
|
|
||||||
+eval {$b = crypt($a, $alg . "cd")};
|
|
||||||
like($@, qr/Wide character in crypt/, "wide characters ungood");
|
|
||||||
|
|
||||||
chop $a; # throw away the wide character
|
|
||||||
|
|
||||||
-eval {$b = crypt($a, "cd")};
|
|
||||||
+eval {$b = crypt($a, $alg . "cd")};
|
|
||||||
is($@, '', "downgrade to eight bit characters");
|
|
||||||
-is($b, crypt("a\xFF", "cd"), "downgrade results agree");
|
|
||||||
+is($b, crypt("a\xFF", $alg . "cd"), "downgrade results agree");
|
|
||||||
|
|
||||||
--
|
|
||||||
1.9.0
|
|
||||||
|
|
@ -1,71 +0,0 @@
|
|||||||
From 93d77ec43f0de26bc9ead97d204a680a902d59e1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
|
||||||
Date: Wed, 11 Feb 2015 15:46:37 +0100
|
|
||||||
Subject: [PATCH] Fix Errno.pm generation for gcc-5.0
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
gcc-5.0 -E interleaves now line numbers with expended macros, so that
|
|
||||||
the generated errno.c will be preprocessed to
|
|
||||||
|
|
||||||
EBFONT => [[
|
|
||||||
59
|
|
||||||
]]
|
|
||||||
|
|
||||||
which is hard to parse in in line-based reader.
|
|
||||||
|
|
||||||
So use -P option with gcc >= 5.0. Global -P usage would break makedepend,
|
|
||||||
global -ftrack-macro-expansion=0 would break lib/h2ph.t.
|
|
||||||
|
|
||||||
RT#123784
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
ext/Errno/Errno_pm.PL | 23 +++++++++++++++++------
|
|
||||||
1 file changed, 17 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ext/Errno/Errno_pm.PL b/ext/Errno/Errno_pm.PL
|
|
||||||
index 55ad01a..63b5916 100644
|
|
||||||
--- a/ext/Errno/Errno_pm.PL
|
|
||||||
+++ b/ext/Errno/Errno_pm.PL
|
|
||||||
@@ -225,20 +225,31 @@ sub write_errno_pm {
|
|
||||||
{ # BeOS (support now removed) did not enter this block
|
|
||||||
# invoke CPP and read the output
|
|
||||||
|
|
||||||
+ my $inhibit_linemarkers = '';
|
|
||||||
+ if ($Config{gccversion} =~ /\A(\d+)\./ and $1 >= 5) {
|
|
||||||
+ # GCC 5.0 interleaves expanded macros with line numbers breaking
|
|
||||||
+ # each line into multiple lines. RT#123784
|
|
||||||
+ $inhibit_linemarkers = ' -P';
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
if ($^O eq 'VMS') {
|
|
||||||
- my $cpp = "$Config{cppstdin} $Config{cppflags} $Config{cppminus}";
|
|
||||||
+ my $cpp = "$Config{cppstdin} $Config{cppflags}" .
|
|
||||||
+ $inhibit_linemarkers . " $Config{cppminus}";
|
|
||||||
$cpp =~ s/sys\$input//i;
|
|
||||||
open(CPPO,"$cpp errno.c |") or
|
|
||||||
die "Cannot exec $Config{cppstdin}";
|
|
||||||
} elsif ($IsMSWin32 || $^O eq 'NetWare') {
|
|
||||||
- open(CPPO,"$Config{cpprun} $Config{cppflags} errno.c |") or
|
|
||||||
- die "Cannot run '$Config{cpprun} $Config{cppflags} errno.c'";
|
|
||||||
+ my $cpp = "$Config{cpprun} $Config{cppflags}" .
|
|
||||||
+ $inhibit_linemarkers;
|
|
||||||
+ open(CPPO,"$cpp errno.c |") or
|
|
||||||
+ die "Cannot run '$cpp errno.c'";
|
|
||||||
} elsif ($IsSymbian) {
|
|
||||||
- my $cpp = "gcc -E -I$ENV{SDK}\\epoc32\\include\\libc -";
|
|
||||||
+ my $cpp = "gcc -E -I$ENV{SDK}\\epoc32\\include\\libc" .
|
|
||||||
+ $inhibit_linemarkers ." -";
|
|
||||||
open(CPPO,"$cpp < errno.c |")
|
|
||||||
or die "Cannot exec $cpp";
|
|
||||||
} else {
|
|
||||||
- my $cpp = default_cpp();
|
|
||||||
+ my $cpp = default_cpp() . $inhibit_linemarkers;
|
|
||||||
open(CPPO,"$cpp < errno.c |")
|
|
||||||
or die "Cannot exec $cpp";
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
@ -1,44 +0,0 @@
|
|||||||
From e2ce0950e5e4b86c6fcbc488c37dd61d082b3e0d Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
|
||||||
Date: Fri, 21 Nov 2014 10:48:51 +0100
|
|
||||||
Subject: [PATCH] Report inaccesible file on failed require
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Commit 2433d39e6 (require should die if a file exists but can't be
|
|
||||||
read) made first failed opened file fatal as request in
|
|
||||||
[perl #113422]. However error message produced in that case is not
|
|
||||||
much helpful in identifying which file ound not been accessed:
|
|
||||||
|
|
||||||
$ LANG=C perl -I/root -e 'require strict'
|
|
||||||
Can't locate strict.pm: Permission denied at -e line 1.
|
|
||||||
|
|
||||||
This patch adds the name of the failed file to the message to help
|
|
||||||
identify which @INC directory is erroneous:
|
|
||||||
|
|
||||||
$ LANG=C ./perl -I/root -I./lib -e 'require strict'
|
|
||||||
Can't locate strict.pm: /root/strict.pm: Permission denied at -e line 1.
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
pp_ctl.c | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/pp_ctl.c b/pp_ctl.c
|
|
||||||
index 4b16e14..4f1c480 100644
|
|
||||||
--- a/pp_ctl.c
|
|
||||||
+++ b/pp_ctl.c
|
|
||||||
@@ -4048,7 +4048,8 @@ PP(pp_require)
|
|
||||||
if (PL_op->op_type == OP_REQUIRE) {
|
|
||||||
if(saved_errno == EMFILE || saved_errno == EACCES) {
|
|
||||||
/* diag_listed_as: Can't locate %s */
|
|
||||||
- DIE(aTHX_ "Can't locate %s: %s", name, Strerror(saved_errno));
|
|
||||||
+ DIE(aTHX_ "Can't locate %s: %s: %s",
|
|
||||||
+ name, tryname, Strerror(saved_errno));
|
|
||||||
} else {
|
|
||||||
if (namesv) { /* did we lookup @INC? */
|
|
||||||
AV * const ar = GvAVn(PL_incgv);
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
@ -1,47 +0,0 @@
|
|||||||
From 0a370b8f77bd4b1be3f776257869e5c85eb9e8e2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
|
||||||
Date: Mon, 1 Dec 2014 15:28:36 +0100
|
|
||||||
Subject: [PATCH] t/op/taint.t: Perform SHA-256 algorithm by crypt() if default
|
|
||||||
one is disabled
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
The crypt(3) call may return NULL. This is the case on FIPS-enabled
|
|
||||||
platforms. Then "tainted crypt" test would fail.
|
|
||||||
|
|
||||||
See RT#121591 for similar fix in t/op/crypt.t.
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
t/op/taint.t | 14 +++++++++++++-
|
|
||||||
1 file changed, 13 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/t/op/taint.t b/t/op/taint.t
|
|
||||||
index f9e8331..a13fde4 100644
|
|
||||||
--- a/t/op/taint.t
|
|
||||||
+++ b/t/op/taint.t
|
|
||||||
@@ -1967,7 +1967,19 @@ foreach my $ord (78, 163, 256) {
|
|
||||||
SKIP: {
|
|
||||||
skip 'No crypt function, skipping crypt tests', 4 if(!$Config{d_crypt});
|
|
||||||
# 59998
|
|
||||||
- sub cr { my $x = crypt($_[0], $_[1]); $x }
|
|
||||||
+ sub cr {
|
|
||||||
+ # On platforms implementing FIPS mode, using a weak algorithm
|
|
||||||
+ # (including the default triple-DES algorithm) causes crypt(3) to
|
|
||||||
+ # return a null pointer, which Perl converts into undef. We assume
|
|
||||||
+ # for now that all such platforms support glibc-style selection of
|
|
||||||
+ # a different hashing algorithm.
|
|
||||||
+ my $alg = ''; # Use default algorithm
|
|
||||||
+ if ( !defined(crypt("ab", "cd")) ) {
|
|
||||||
+ $alg = '$5$'; # Use SHA-256
|
|
||||||
+ }
|
|
||||||
+ my $x = crypt($_[0], $alg . $_[1]);
|
|
||||||
+ $x
|
|
||||||
+ }
|
|
||||||
sub co { my $x = ~$_[0]; $x }
|
|
||||||
my ($a, $b);
|
|
||||||
$a = cr('hello', 'foo' . $TAINT);
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
@ -1,67 +0,0 @@
|
|||||||
From 3bea78d24634e630b610f59957e7a019205a67b2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tony Cook <tony@develop-help.com>
|
|
||||||
Date: Mon, 16 Feb 2015 15:57:00 +1100
|
|
||||||
Subject: [PATCH 2/2] h2ph: correct handling of hex constants for the preamble
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Previously they were treated as identifiers resulting in code
|
|
||||||
generated like C< &0xFFF >.
|
|
||||||
|
|
||||||
We also try to prevent compile-time warnings from large hex integers,
|
|
||||||
the user isn't responsible for the generated code, so we delay those
|
|
||||||
warnings to run-time.
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
utils/h2ph.PL | 19 ++++++++++++++++++-
|
|
||||||
1 file changed, 18 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/utils/h2ph.PL b/utils/h2ph.PL
|
|
||||||
index 9a8b14d..d082f22 100644
|
|
||||||
--- a/utils/h2ph.PL
|
|
||||||
+++ b/utils/h2ph.PL
|
|
||||||
@@ -769,7 +769,7 @@ sub inc_dirs
|
|
||||||
sub build_preamble_if_necessary
|
|
||||||
{
|
|
||||||
# Increment $VERSION every time this function is modified:
|
|
||||||
- my $VERSION = 3;
|
|
||||||
+ my $VERSION = 4;
|
|
||||||
my $preamble = "$Dest_dir/_h2ph_pre.ph";
|
|
||||||
|
|
||||||
# Can we skip building the preamble file?
|
|
||||||
@@ -788,6 +788,11 @@ sub build_preamble_if_necessary
|
|
||||||
|
|
||||||
open PREAMBLE, ">$preamble" or die "Cannot open $preamble: $!";
|
|
||||||
print PREAMBLE "# This file was created by h2ph version $VERSION\n";
|
|
||||||
+ # Prevent non-portable hex constants from warning.
|
|
||||||
+ #
|
|
||||||
+ # We still produce an overflow warning if we can't represent
|
|
||||||
+ # a hex constant as an integer.
|
|
||||||
+ print PREAMBLE "no warnings qw(portable);\n";
|
|
||||||
|
|
||||||
foreach (sort keys %define) {
|
|
||||||
if ($opt_D) {
|
|
||||||
@@ -814,6 +819,18 @@ DEFINE
|
|
||||||
# integer:
|
|
||||||
print PREAMBLE
|
|
||||||
"unless (defined &$_) { sub $_() { $1 } }\n\n";
|
|
||||||
+ } elsif ($define{$_} =~ /^([+-]?0x[\da-f]+)U?L{0,2}$/i) {
|
|
||||||
+ # hex integer
|
|
||||||
+ # Special cased, since perl warns on hex integers
|
|
||||||
+ # that can't be represented in a UV.
|
|
||||||
+ #
|
|
||||||
+ # This way we get the warning at time of use, so the user
|
|
||||||
+ # only gets the warning if they happen to use this
|
|
||||||
+ # platform-specific definition.
|
|
||||||
+ my $code = $1;
|
|
||||||
+ $code = "hex('$code')" if length $code > 10;
|
|
||||||
+ print PREAMBLE
|
|
||||||
+ "unless (defined &$_) { sub $_() { $code } }\n\n";
|
|
||||||
} elsif ($define{$_} =~ /^\w+$/) {
|
|
||||||
my $def = $define{$_};
|
|
||||||
if ($isatype{$def}) {
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,39 +0,0 @@
|
|||||||
From ae54661bfad51c56e0d5c01bace60d44513a77e2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
|
||||||
Date: Tue, 17 Feb 2015 13:11:00 +0100
|
|
||||||
Subject: [PATCH] lib/h2ph.t to test generated t/_h2ph_pre.ph instead of the
|
|
||||||
system one
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
The lib/h2ph.t test executes a t/lib/h2ph.pht which requires
|
|
||||||
'_h2ph_pre.ph'. This should find and exercise generated t/_h2ph_pre.ph
|
|
||||||
file. However, it found a loaded _h2ph_pre.ph from system because the
|
|
||||||
interpreter has the './' directory after the system paths in the @INC by
|
|
||||||
default.
|
|
||||||
|
|
||||||
This patch adds '-I./' to the runperl() invocation to prefer the
|
|
||||||
_h2ph_pre.ph generated at build time.
|
|
||||||
|
|
||||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
|
||||||
---
|
|
||||||
lib/h2ph.t | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/h2ph.t b/lib/h2ph.t
|
|
||||||
index 2b58f6a..64d9dc0 100644
|
|
||||||
--- a/lib/h2ph.t
|
|
||||||
+++ b/lib/h2ph.t
|
|
||||||
@@ -48,7 +48,7 @@ $result = runperl( progfile => '_h2ph_pre.ph',
|
|
||||||
stderr => 1 );
|
|
||||||
like( $result, qr/syntax OK$/, "preamble compiles");
|
|
||||||
|
|
||||||
-$result = runperl( switches => ["-w"],
|
|
||||||
+$result = runperl( switches => ['-I.', "-w"],
|
|
||||||
stderr => 1,
|
|
||||||
prog => <<'PROG' );
|
|
||||||
$SIG{__WARN__} = sub { die $_[0] }; require q(lib/h2ph.pht);
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -42,8 +42,8 @@ index 2f30261..825496e 100755
|
|||||||
- xxx="-Wl,-rpath,$shrpdir"
|
- xxx="-Wl,-rpath,$shrpdir"
|
||||||
+ # We want standard path
|
+ # We want standard path
|
||||||
;;
|
;;
|
||||||
next)
|
hpux*)
|
||||||
# next doesn't like the default...
|
# hpux doesn't like the default, either.
|
||||||
diff --git a/Makefile.SH b/Makefile.SH
|
diff --git a/Makefile.SH b/Makefile.SH
|
||||||
index 7733a32..a481183 100755
|
index 7733a32..a481183 100755
|
||||||
--- a/Makefile.SH
|
--- a/Makefile.SH
|
||||||
@ -59,4 +59,3 @@ index 7733a32..a481183 100755
|
|||||||
man1ext = $man1ext
|
man1ext = $man1ext
|
||||||
--
|
--
|
||||||
1.8.1.4
|
1.8.1.4
|
||||||
|
|
@ -17,9 +17,9 @@ diff -up perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.usem perl
|
|||||||
--- perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.usem 2011-05-08 05:10:08.000000000 +0200
|
--- perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm.usem 2011-05-08 05:10:08.000000000 +0200
|
||||||
+++ perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm 2011-05-17 13:39:26.912586030 +0200
|
+++ perl-5.14.0/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm 2011-05-17 13:39:26.912586030 +0200
|
||||||
@@ -278,7 +278,7 @@ sub full_setup {
|
@@ -278,7 +278,7 @@ sub full_setup {
|
||||||
PERL_SRC PERM_DIR PERM_RW PERM_RWX MAGICXS
|
PERM_DIR PERM_RW PERM_RWX MAGICXS
|
||||||
PL_FILES PM PM_FILTER PMLIBDIRS PMLIBPARENTDIRS POLLUTE PPM_INSTALL_EXEC PPM_UNINSTALL_EXEC
|
PL_FILES PM PM_FILTER PMLIBDIRS PMLIBPARENTDIRS POLLUTE
|
||||||
PPM_INSTALL_SCRIPT PPM_UNINSTALL_SCRIPT PREREQ_FATAL PREREQ_PM PREREQ_PRINT PRINT_PREREQ
|
PREREQ_FATAL PREREQ_PM PREREQ_PRINT PRINT_PREREQ
|
||||||
- SIGN SKIP TEST_REQUIRES TYPEMAPS UNINST VERSION VERSION_FROM XS XSOPT XSPROTOARG
|
- SIGN SKIP TEST_REQUIRES TYPEMAPS UNINST VERSION VERSION_FROM XS XSOPT XSPROTOARG
|
||||||
+ SIGN SKIP TEST_REQUIRES TYPEMAPS UNINST USE_MM_LD_RUN_PATH VERSION VERSION_FROM XS XSOPT XSPROTOARG
|
+ SIGN SKIP TEST_REQUIRES TYPEMAPS UNINST USE_MM_LD_RUN_PATH VERSION VERSION_FROM XS XSOPT XSPROTOARG
|
||||||
XS_VERSION clean depend dist dynamic_lib linkext macro realclean
|
XS_VERSION clean depend dist dynamic_lib linkext macro realclean
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up perl-5.12.0/cpan/libnet/Net/Config.pm.disable perl-5.12.0/cpan/libnet/Net/Config.pm
|
diff -up perl-5.12.0/cpan/libnet/lib/Net/Config.pm.disable perl-5.12.0/cpan/libnet/Net/Config.pm
|
||||||
--- perl-5.12.0/cpan/libnet/Net/Config.pm.disable 2010-01-18 19:52:49.000000000 +0100
|
--- perl-5.12.0/cpan/libnet/lib/Net/Config.pm.disable 2010-01-18 19:52:49.000000000 +0100
|
||||||
+++ perl-5.12.0/cpan/libnet/Net/Config.pm 2010-04-13 16:03:50.090770813 +0200
|
+++ perl-5.12.0/cpan/libnet/lib/Net/Config.pm 2010-04-13 16:03:50.090770813 +0200
|
||||||
@@ -29,7 +29,7 @@ eval { local $SIG{__DIE__}; require Net:
|
@@ -29,7 +29,7 @@ eval { local $SIG{__DIE__}; require Net:
|
||||||
ftp_firewall => undef,
|
ftp_firewall => undef,
|
||||||
ftp_ext_passive => 1,
|
ftp_ext_passive => 1,
|
||||||
|
40
perl.spec
40
perl.spec
@ -83,36 +83,15 @@ Patch8: perl-5.14.1-offtest.patch
|
|||||||
Patch15: perl-5.16.3-create_libperl_soname.patch
|
Patch15: perl-5.16.3-create_libperl_soname.patch
|
||||||
|
|
||||||
# Install libperl.so to -Dshrpdir value
|
# Install libperl.so to -Dshrpdir value
|
||||||
Patch16: perl-5.20.2-Install-libperl.so-to-shrpdir-on-Linux.patch
|
Patch16: perl-5.22.0-Install-libperl.so-to-shrpdir-on-Linux.patch
|
||||||
|
|
||||||
# Document Math::BigInt::CalcEmu requires Math::BigInt, rhbz#959096,
|
# Document Math::BigInt::CalcEmu requires Math::BigInt, rhbz#959096,
|
||||||
# CPAN RT#85015
|
# CPAN RT#85015
|
||||||
Patch22: perl-5.18.1-Document-Math-BigInt-CalcEmu-requires-Math-BigInt.patch
|
Patch22: perl-5.18.1-Document-Math-BigInt-CalcEmu-requires-Math-BigInt.patch
|
||||||
|
|
||||||
# Use stronger algorithm needed for FIPS in t/op/crypt.t, bug #1128032,
|
|
||||||
# RT#121591, accepted after 5.21.4
|
|
||||||
Patch25: perl-5.18.2-t-op-crypt.t-Perform-SHA-256-algorithm-if-default-on.patch
|
|
||||||
|
|
||||||
# Make *DBM_File desctructors thread-safe, bug #1107543, RT#61912
|
# Make *DBM_File desctructors thread-safe, bug #1107543, RT#61912
|
||||||
Patch26: perl-5.18.2-Destroy-GDBM-NDBM-ODBM-SDBM-_File-objects-only-from-.patch
|
Patch26: perl-5.18.2-Destroy-GDBM-NDBM-ODBM-SDBM-_File-objects-only-from-.patch
|
||||||
|
|
||||||
# Report inaccesible file on failed require, bug #1166504, RT#123270,
|
|
||||||
# in upstream after 5.21.6
|
|
||||||
Patch27: perl-5.21.6-Report-inaccesible-file-on-failed-require.patch
|
|
||||||
|
|
||||||
# Use stronger algorithm needed for FIPS in t/op/taint.t, bug #1128032,
|
|
||||||
# RT#123338, in upstream after 5.21.6
|
|
||||||
Patch28: perl-5.21.6-t-op-taint.t-Perform-SHA-256-algorithm-by-crypt-if-d.patch
|
|
||||||
|
|
||||||
# Fix Errno.pm generation for GCC 5.0, RT#123784, in upstream after 5.21.8
|
|
||||||
Patch29: perl-5.20.2-Fix-Errno.pm-generation-for-gcc-5.0.patch
|
|
||||||
|
|
||||||
# Handle hexadecimal constants by h2ph, RT#123784, in upstream after 5.21.8
|
|
||||||
Patch30: perl-5.21.8-h2ph-correct-handling-of-hex-constants-for-the-pream.patch
|
|
||||||
|
|
||||||
# Do not use _h2ph_pre.ph from system at tests, RT#123784,
|
|
||||||
# in upstream after 5.21.9
|
|
||||||
Patch31: perl-5.21.8-lib-h2ph.t-to-test-generated-t-_h2ph_pre.ph-instead-.patch
|
|
||||||
|
|
||||||
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
|
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
|
||||||
Patch200: perl-5.16.3-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
|
Patch200: perl-5.16.3-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
|
||||||
@ -1853,13 +1832,7 @@ Perl extension for Version Objects
|
|||||||
%patch15 -p1
|
%patch15 -p1
|
||||||
%patch16 -p1
|
%patch16 -p1
|
||||||
%patch22 -p1
|
%patch22 -p1
|
||||||
%patch25 -p1
|
|
||||||
%patch26 -p1
|
%patch26 -p1
|
||||||
%patch27 -p1
|
|
||||||
%patch28 -p1
|
|
||||||
%patch29 -p1
|
|
||||||
%patch30 -p1
|
|
||||||
%patch31 -p1
|
|
||||||
%patch200 -p1
|
%patch200 -p1
|
||||||
%patch201 -p1
|
%patch201 -p1
|
||||||
|
|
||||||
@ -1877,13 +1850,7 @@ perl -x patchlevel.h \
|
|||||||
'Fedora Patch15: Define SONAME for libperl.so' \
|
'Fedora Patch15: Define SONAME for libperl.so' \
|
||||||
'Fedora Patch16: Install libperl.so to -Dshrpdir value' \
|
'Fedora Patch16: Install libperl.so to -Dshrpdir value' \
|
||||||
'Fedora Patch22: Document Math::BigInt::CalcEmu requires Math::BigInt (CPAN RT#85015)' \
|
'Fedora Patch22: Document Math::BigInt::CalcEmu requires Math::BigInt (CPAN RT#85015)' \
|
||||||
'Fedora Patch25: Use stronger algorithm needed for FIPS in t/op/crypt.t (RT#121591)' \
|
|
||||||
'Fedora Patch26: Make *DBM_File desctructors thread-safe (RT#61912)' \
|
'Fedora Patch26: Make *DBM_File desctructors thread-safe (RT#61912)' \
|
||||||
'Fedora Patch27: Report inaccesible file on failed require (RT#123270)' \
|
|
||||||
'Fedora Patch28: Use stronger algorithm needed for FIPS in t/op/taint.t (RT#123338)' \
|
|
||||||
'Fedora Patch29: Fix Errno.pm generation for GCC 5.0 (RT#123784)' \
|
|
||||||
'Fedora Patch30: Handle hexadecimal constants by h2ph (RT#123784)' \
|
|
||||||
'Fedora Patch31: Do not use _h2ph_pre.ph from system at tests (RT#123784)' \
|
|
||||||
'Fedora Patch200: Link XS modules to libperl.so with EU::CBuilder on Linux' \
|
'Fedora Patch200: Link XS modules to libperl.so with EU::CBuilder on Linux' \
|
||||||
'Fedora Patch201: Link XS modules to libperl.so with EU::MM on Linux' \
|
'Fedora Patch201: Link XS modules to libperl.so with EU::MM on Linux' \
|
||||||
%{nil}
|
%{nil}
|
||||||
@ -3637,7 +3604,10 @@ popd
|
|||||||
* Mon Jun 01 2015 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.22.0-241
|
* Mon Jun 01 2015 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.22.0-241
|
||||||
- 5.22.0 bump (see <http://search.cpan.org/dist/perl-5.22.0/pod/perldelta.pod>
|
- 5.22.0 bump (see <http://search.cpan.org/dist/perl-5.22.0/pod/perldelta.pod>
|
||||||
for release notes)
|
for release notes)
|
||||||
- Updated sub-packages and erased the removed modules from the core
|
- Update sub-packages and erase the removed modules from the core
|
||||||
|
- Clean patches, not needed with new version
|
||||||
|
- Update patches to work with new version
|
||||||
|
|
||||||
|
|
||||||
* Wed Apr 15 2015 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.20.2-328
|
* Wed Apr 15 2015 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.20.2-328
|
||||||
- Sub-package perl-CGI-Fast and perl-Module-Build-Deprecated
|
- Sub-package perl-CGI-Fast and perl-Module-Build-Deprecated
|
||||||
|
Loading…
Reference in New Issue
Block a user