Update pod2html(1) documentation
This commit is contained in:
parent
4248355e98
commit
d2fae9f219
@ -0,0 +1,191 @@
|
|||||||
|
From 9b9923c633797a232ac871903c3c14833036aa28 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||||
|
Date: Sun, 9 Jun 2013 14:14:24 -0400
|
||||||
|
Subject: [PATCH] Synchronize pod2html usage output and its POD text
|
||||||
|
|
||||||
|
|
||||||
|
Petr Pisar: Port to perl-5.16.3.
|
||||||
|
|
||||||
|
diff --git a/ext/Pod-Html/bin/pod2html b/ext/Pod-Html/bin/pod2html
|
||||||
|
index c422ebf..b022859 100644
|
||||||
|
--- a/ext/Pod-Html/bin/pod2html
|
||||||
|
+++ b/ext/Pod-Html/bin/pod2html
|
||||||
|
@@ -6,10 +6,14 @@ pod2html - convert .pod files to .html files
|
||||||
|
|
||||||
|
=head1 SYNOPSIS
|
||||||
|
|
||||||
|
- pod2html --help --htmlroot=<name> --infile=<name> --outfile=<name>
|
||||||
|
+ pod2html --help --htmldir=<name> --htmlroot=<URL>
|
||||||
|
+ --infile=<name> --outfile=<name>
|
||||||
|
--podpath=<name>:...:<name> --podroot=<name>
|
||||||
|
- --recurse --norecurse --verbose
|
||||||
|
- --index --noindex --title=<name>
|
||||||
|
+ --cachedir=<name> --flush --recurse --norecurse
|
||||||
|
+ --quiet --noquiet --verbose --noverbose
|
||||||
|
+ --index --noindex --backlink --nobacklink
|
||||||
|
+ --header --noheader --poderrors --nopoderrors
|
||||||
|
+ --css=<URL> --title=<name>
|
||||||
|
|
||||||
|
=head1 DESCRIPTION
|
||||||
|
|
||||||
|
@@ -27,12 +31,27 @@ pod2html takes the following arguments:
|
||||||
|
|
||||||
|
Displays the usage message.
|
||||||
|
|
||||||
|
+=item htmldir
|
||||||
|
+
|
||||||
|
+ --htmldir=name
|
||||||
|
+
|
||||||
|
+Sets the directory to which all cross references in the resulting HTML file
|
||||||
|
+will be relative. Not passing this causes all links to be absolute since this
|
||||||
|
+is the value that tells Pod::Html the root of the documentation tree.
|
||||||
|
+
|
||||||
|
+Do not use this and --htmlroot in the same call to pod2html; they are mutually
|
||||||
|
+exclusive.
|
||||||
|
+
|
||||||
|
=item htmlroot
|
||||||
|
|
||||||
|
- --htmlroot=name
|
||||||
|
+ --htmlroot=URL
|
||||||
|
+
|
||||||
|
+Sets the base URL for the HTML files. When cross-references are made, the
|
||||||
|
+HTML root is prepended to the URL.
|
||||||
|
+
|
||||||
|
+Do not use this if relative links are desired: use --htmldir instead.
|
||||||
|
|
||||||
|
-Sets the base URL for the HTML files. When cross-references are made,
|
||||||
|
-the HTML root is prepended to the URL.
|
||||||
|
+Do not pass both this and --htmldir to pod2html; they are mutually exclusive.
|
||||||
|
|
||||||
|
=item infile
|
||||||
|
|
||||||
|
@@ -61,6 +80,59 @@ Specify the base directory for finding library pods.
|
||||||
|
Specify which subdirectories of the podroot contain pod files whose
|
||||||
|
HTML converted forms can be linked-to in cross-references.
|
||||||
|
|
||||||
|
+=item cachedir
|
||||||
|
+
|
||||||
|
+ --cachedir=name
|
||||||
|
+
|
||||||
|
+Specify which directory is used for storing cache. Default directory is the
|
||||||
|
+current working directory.
|
||||||
|
+
|
||||||
|
+=item flush
|
||||||
|
+
|
||||||
|
+ --flush
|
||||||
|
+
|
||||||
|
+Flush the cache.
|
||||||
|
+
|
||||||
|
+=item backlink
|
||||||
|
+
|
||||||
|
+ --backlink
|
||||||
|
+
|
||||||
|
+Turn =head1 directives into links pointing to the top of the HTML file.
|
||||||
|
+
|
||||||
|
+=item nobacklink
|
||||||
|
+
|
||||||
|
+ --nobacklink
|
||||||
|
+
|
||||||
|
+Do not turn =head1 directives into links pointing to the top of the HTML file
|
||||||
|
+(default behaviour).
|
||||||
|
+
|
||||||
|
+=item header
|
||||||
|
+
|
||||||
|
+ --header
|
||||||
|
+
|
||||||
|
+Create header and footer blocks containing the text of the "NAME" section.
|
||||||
|
+
|
||||||
|
+=item noheader
|
||||||
|
+
|
||||||
|
+ --noheader
|
||||||
|
+
|
||||||
|
+Do not create header and footer blocks containing the text of the "NAME"
|
||||||
|
+section (default behaviour).
|
||||||
|
+
|
||||||
|
+=item poderrors
|
||||||
|
+
|
||||||
|
+ --poderrors
|
||||||
|
+
|
||||||
|
+Include a "POD ERRORS" section in the outfile if there were any POD errors in
|
||||||
|
+the infile (default behaviour).
|
||||||
|
+
|
||||||
|
+=item nopoderrors
|
||||||
|
+
|
||||||
|
+ --nopoderrors
|
||||||
|
+
|
||||||
|
+Do not include a "POD ERRORS" section in the outfile if there were any POD
|
||||||
|
+errors in the infile.
|
||||||
|
+
|
||||||
|
=item index
|
||||||
|
|
||||||
|
--index
|
||||||
|
@@ -86,18 +158,44 @@ Recurse into subdirectories specified in podpath (default behaviour).
|
||||||
|
|
||||||
|
Do not recurse into subdirectories specified in podpath.
|
||||||
|
|
||||||
|
+=item css
|
||||||
|
+
|
||||||
|
+ --css=URL
|
||||||
|
+
|
||||||
|
+Specify the URL of cascading style sheet to link from resulting HTML file.
|
||||||
|
+Default is none style sheet.
|
||||||
|
+
|
||||||
|
=item title
|
||||||
|
|
||||||
|
--title=title
|
||||||
|
|
||||||
|
Specify the title of the resulting HTML file.
|
||||||
|
|
||||||
|
+=item quiet
|
||||||
|
+
|
||||||
|
+ --quiet
|
||||||
|
+
|
||||||
|
+Don't display mostly harmless warning messages.
|
||||||
|
+
|
||||||
|
+=item noquiet
|
||||||
|
+
|
||||||
|
+ --noquiet
|
||||||
|
+
|
||||||
|
+Display mostly harmless warning messages (default behaviour). But this is not
|
||||||
|
+the same as "verbose" mode.
|
||||||
|
+
|
||||||
|
=item verbose
|
||||||
|
|
||||||
|
--verbose
|
||||||
|
|
||||||
|
Display progress messages.
|
||||||
|
|
||||||
|
+=item noverbose
|
||||||
|
+
|
||||||
|
+ --noverbose
|
||||||
|
+
|
||||||
|
+Do not display progress messages (default behaviour).
|
||||||
|
+
|
||||||
|
=back
|
||||||
|
|
||||||
|
=head1 AUTHOR
|
||||||
|
diff --git a/ext/Pod-Html/lib/Pod/Html.pm b/ext/Pod-Html/lib/Pod/Html.pm
|
||||||
|
index 72b37c2..3feb812 100644
|
||||||
|
--- a/ext/Pod-Html/lib/Pod/Html.pm
|
||||||
|
+++ b/ext/Pod-Html/lib/Pod/Html.pm
|
||||||
|
@@ -447,9 +447,14 @@ sub usage {
|
||||||
|
my $podfile = shift;
|
||||||
|
warn "$0: $podfile: @_\n" if @_;
|
||||||
|
die <<END_OF_USAGE;
|
||||||
|
-Usage: $0 --help --htmlroot=<name> --infile=<name> --outfile=<name>
|
||||||
|
- --podpath=<name>:...:<name> --podroot=<name> --cachedir=<name>
|
||||||
|
- --recurse --verbose --index --norecurse --noindex
|
||||||
|
+Usage: $0 --help --htmldir=<name> --htmlroot=<URL>
|
||||||
|
+ --infile=<name> --outfile=<name>
|
||||||
|
+ --podpath=<name>:...:<name> --podroot=<name>
|
||||||
|
+ --cachedir=<name> --flush --recurse --norecurse
|
||||||
|
+ --quiet --noquiet --verbose --noverbose
|
||||||
|
+ --index --noindex --backlink --nobacklink
|
||||||
|
+ --header --noheader --poderrors --nopoderrors
|
||||||
|
+ --css=<URL> --title=<name>
|
||||||
|
|
||||||
|
--[no]backlink - turn =head1 directives into links pointing to the top of
|
||||||
|
the page (off by default).
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
@ -129,6 +129,9 @@ Patch26: perl-5.16.3-Remove-PERL_ASYNC_CHECK-from-Perl_leave_scope.patch
|
|||||||
# Update h2ph(1) documentation, rhbz#948538, RT#117647
|
# Update h2ph(1) documentation, rhbz#948538, RT#117647
|
||||||
Patch27: perl-5.19.0-Synchronize-h2ph-POD-text-with-usage-output.patch
|
Patch27: perl-5.19.0-Synchronize-h2ph-POD-text-with-usage-output.patch
|
||||||
|
|
||||||
|
# Update pod2html(1) documentation, rhbz#948538, RT#117623
|
||||||
|
Patch28: perl-5.16.3-Synchronize-pod2html-usage-output-and-its-POD-text.patch
|
||||||
|
|
||||||
# Update some of the bundled modules
|
# Update some of the bundled modules
|
||||||
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
|
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
|
||||||
|
|
||||||
@ -1934,6 +1937,7 @@ tarball from perl.org.
|
|||||||
%patch25 -p1
|
%patch25 -p1
|
||||||
%patch26 -p1
|
%patch26 -p1
|
||||||
%patch27 -p1
|
%patch27 -p1
|
||||||
|
%patch28 -p1
|
||||||
|
|
||||||
#copy the example script
|
#copy the example script
|
||||||
cp -a %{SOURCE5} .
|
cp -a %{SOURCE5} .
|
||||||
@ -2151,6 +2155,7 @@ pushd %{build_archlib}/CORE/
|
|||||||
'Fedora Patch25: Fix dead lock in PerlIO after fork from thread (RT106212)' \
|
'Fedora Patch25: Fix dead lock in PerlIO after fork from thread (RT106212)' \
|
||||||
'Fedora Patch26: Make regexp safe in a signal handler (RT#114878)' \
|
'Fedora Patch26: Make regexp safe in a signal handler (RT#114878)' \
|
||||||
'Fedora Patch27: Update h2ph(1) documentation (RT#117647)' \
|
'Fedora Patch27: Update h2ph(1) documentation (RT#117647)' \
|
||||||
|
'Fedora Patch28: Update pod2html(1) documentation (RT#117623)' \
|
||||||
%{nil}
|
%{nil}
|
||||||
|
|
||||||
rm patchlevel.bak
|
rm patchlevel.bak
|
||||||
@ -3644,6 +3649,7 @@ sed \
|
|||||||
- Update SystemTap scripts to recognize new phase__change marker and new probe
|
- Update SystemTap scripts to recognize new phase__change marker and new probe
|
||||||
arguments (bug #971094)
|
arguments (bug #971094)
|
||||||
- Update h2ph(1) documentation (bug #948538)
|
- Update h2ph(1) documentation (bug #948538)
|
||||||
|
- Update pod2html(1) documentation (bug #948538)
|
||||||
|
|
||||||
* Tue Jun 11 2013 Petr Pisar <ppisar@redhat.com> - 4:5.16.3-277
|
* Tue Jun 11 2013 Petr Pisar <ppisar@redhat.com> - 4:5.16.3-277
|
||||||
- Move CPANPLUS-Dist-Build files from perl-CPANPLUS
|
- Move CPANPLUS-Dist-Build files from perl-CPANPLUS
|
||||||
|
Loading…
Reference in New Issue
Block a user