- remove Tar.pm from Archive-Extract
- fix version of Test::Simple in spec - update Test::Simple - update Archive::Tar to 1.38
This commit is contained in:
parent
9b40170328
commit
d26f9c16ba
58
perl-5.10.0-ArchiveTar1.38.patch
Normal file
58
perl-5.10.0-ArchiveTar1.38.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
diff -urN perl-5.10.0/lib/Archive/Tar.old/t/04_resolved_issues.t perl-5.10.0/lib/Archive/Tar/t/04_resolved_issues.t
|
||||||
|
--- perl-5.10.0/lib/Archive/Tar.old/t/04_resolved_issues.t 2007-12-18 11:47:07.000000000 +0100
|
||||||
|
+++ perl-5.10.0/lib/Archive/Tar/t/04_resolved_issues.t 2007-11-15 12:47:43.000000000 +0100
|
||||||
|
@@ -121,7 +121,6 @@
|
||||||
|
" Renamed to '$out_file'" );
|
||||||
|
|
||||||
|
### first, test with strict extract permissions on
|
||||||
|
-TODO:
|
||||||
|
{ local $Archive::Tar::INSECURE_EXTRACT_MODE = 0;
|
||||||
|
|
||||||
|
### we quell the error on STDERR
|
||||||
|
@@ -135,20 +134,14 @@
|
||||||
|
ok( ! -e $out_file, " File '$out_file' does not exist" );
|
||||||
|
|
||||||
|
ok( $tar->error, " Error message stored" );
|
||||||
|
-
|
||||||
|
- local $TODO = 'Exposed unrelated filespec handling bugs on VMS' if $^O eq 'VMS';
|
||||||
|
-
|
||||||
|
like( $tar->error, qr/attempting to leave/,
|
||||||
|
" Proper violation detected" );
|
||||||
|
}
|
||||||
|
|
||||||
|
### now disable those
|
||||||
|
-TODO:
|
||||||
|
{ local $Archive::Tar::INSECURE_EXTRACT_MODE = 1;
|
||||||
|
ok( 1, " Extracting in insecure mode" );
|
||||||
|
|
||||||
|
- local $TODO = 'Exposed unrelated filespec handling bugs on VMS' if $^O eq 'VMS';
|
||||||
|
-
|
||||||
|
ok( $tar->extract_file( $out_file ),
|
||||||
|
" File extracted" );
|
||||||
|
ok( -e $out_file, " File '$out_file' exists" );
|
||||||
|
diff -urN perl-5.10.0/lib/Archive/Tar.old/t/99_pod.t perl-5.10.0/lib/Archive/Tar/t/99_pod.t
|
||||||
|
--- perl-5.10.0/lib/Archive/Tar.old/t/99_pod.t 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ perl-5.10.0/lib/Archive/Tar/t/99_pod.t 2007-03-06 15:30:04.000000000 +0100
|
||||||
|
@@ -0,0 +1,22 @@
|
||||||
|
+use Test::More;
|
||||||
|
+use File::Spec;
|
||||||
|
+use File::Find;
|
||||||
|
+use strict;
|
||||||
|
+
|
||||||
|
+BEGIN { chdir 't' if -d 't' };
|
||||||
|
+
|
||||||
|
+eval 'use Test::Pod';
|
||||||
|
+plan skip_all => "Test::Pod v0.95 required for testing POD"
|
||||||
|
+ if $@ || $Test::Pod::VERSION < 0.95;
|
||||||
|
+
|
||||||
|
+my @files;
|
||||||
|
+find( sub { push @files, File::Spec->catfile(
|
||||||
|
+ File::Spec->splitdir( $File::Find::dir ), $_
|
||||||
|
+ ) if /\.p(?:l|m|od)$/ }, File::Spec->catdir(qw(.. blib lib) ));
|
||||||
|
+
|
||||||
|
+plan tests => scalar @files;
|
||||||
|
+for my $file ( @files ) {
|
||||||
|
+ pod_file_ok( $file );
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+
|
17
perl.spec
17
perl.spec
@ -7,7 +7,7 @@
|
|||||||
|
|
||||||
Name: perl
|
Name: perl
|
||||||
Version: %{perl_version}
|
Version: %{perl_version}
|
||||||
Release: 43%{?dist}
|
Release: 44%{?dist}
|
||||||
Epoch: %{perl_epoch}
|
Epoch: %{perl_epoch}
|
||||||
Summary: The Perl programming language
|
Summary: The Perl programming language
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -88,6 +88,9 @@ Patch21: perl-5.10.0-CGI.patch
|
|||||||
# 462444 update Test::Simple to 0.80
|
# 462444 update Test::Simple to 0.80
|
||||||
Patch22: perl-5.10.0-TestSimple0.80.patch
|
Patch22: perl-5.10.0-TestSimple0.80.patch
|
||||||
|
|
||||||
|
# Archive::Tar update to 1.38 version
|
||||||
|
Patch23: perl-5.10.0-ArchiveTar1.38.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{perl_version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{perl_version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: tcsh, dos2unix, man, groff
|
BuildRequires: tcsh, dos2unix, man, groff
|
||||||
BuildRequires: gdbm-devel, db4-devel, zlib-devel
|
BuildRequires: gdbm-devel, db4-devel, zlib-devel
|
||||||
@ -241,8 +244,7 @@ Summary: A module for Perl manipulation of .tar files
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: GPL+ or Artistic
|
License: GPL+ or Artistic
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
# It's really 1.37_01, but we drop the _01.
|
Version: 1.38
|
||||||
Version: 1.37
|
|
||||||
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
|
Requires: perl = %{perl_epoch}:%{perl_version}-%{release}
|
||||||
Requires: perl(Compress::Zlib), perl(IO::Zlib)
|
Requires: perl(Compress::Zlib), perl(IO::Zlib)
|
||||||
|
|
||||||
@ -818,6 +820,7 @@ upstream tarball from perl.org.
|
|||||||
%patch20 -p1
|
%patch20 -p1
|
||||||
%patch21 -p1
|
%patch21 -p1
|
||||||
%patch22 -p1
|
%patch22 -p1
|
||||||
|
%patch23 -p1
|
||||||
|
|
||||||
#
|
#
|
||||||
# Candidates for doc recoding (need case by case review):
|
# Candidates for doc recoding (need case by case review):
|
||||||
@ -1041,6 +1044,7 @@ perl -x patchlevel.h 'Fedora Patch19: Update Test::Harness to 3.12'
|
|||||||
perl -x patchlevel.h 'Fedora Patch20: pos function handle unicode correct'
|
perl -x patchlevel.h 'Fedora Patch20: pos function handle unicode correct'
|
||||||
perl -x patchlevel.h 'Fedora Patch21: CGI.pm bug in exists() on tied param hash'
|
perl -x patchlevel.h 'Fedora Patch21: CGI.pm bug in exists() on tied param hash'
|
||||||
perl -x patchlevel.h 'Fedora Patch22: Update Test::Simple to 0.80'
|
perl -x patchlevel.h 'Fedora Patch22: Update Test::Simple to 0.80'
|
||||||
|
perl -x patchlevel.h 'Fedora Patch23: Update Archive::Tar 1.38'
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -1360,7 +1364,7 @@ make test
|
|||||||
|
|
||||||
%files Archive-Extract
|
%files Archive-Extract
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_prefix}/lib/perl5/%{perl_version}/Archive/
|
%{_prefix}/lib/perl5/%{perl_version}/Archive/Extract.pm
|
||||||
%{_mandir}/man3/Archive::Extract.3*
|
%{_mandir}/man3/Archive::Extract.3*
|
||||||
|
|
||||||
%files Archive-Tar
|
%files Archive-Tar
|
||||||
@ -1649,7 +1653,10 @@ make test
|
|||||||
# Old changelog entries are preserved in CVS.
|
# Old changelog entries are preserved in CVS.
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Sep 17 2008 Marcela Maslanova <mmaslano@redhat.com> 4:5.10.0-44.fc10
|
* Wed Sep 17 2008 Marcela Maslanova <mmaslano@redhat.com> 4:5.10.0-44.fc10
|
||||||
- forgot to update versions in subpackages - Test::Simple and Test::Harness
|
- remove Tar.pm from Archive-Extract
|
||||||
|
- fix version of Test::Simple in spec
|
||||||
|
- update Test::Simple
|
||||||
|
- update Archive::Tar to 1.38
|
||||||
|
|
||||||
* Tue Sep 16 2008 Marcela Maslanova <mmaslano@redhat.com> 4:5.10.0-43.fc10
|
* Tue Sep 16 2008 Marcela Maslanova <mmaslano@redhat.com> 4:5.10.0-43.fc10
|
||||||
- 462444 update Test::Simple to 0.80
|
- 462444 update Test::Simple to 0.80
|
||||||
|
Loading…
Reference in New Issue
Block a user