Add NAME headings to CPAN modules
This commit is contained in:
parent
9b55999125
commit
c1f404d101
@ -0,0 +1,80 @@
|
||||
From a6a40029a3cbad2c7d9b39cec86b9dc4baf428a9 Mon Sep 17 00:00:00 2001
|
||||
From: Dominic Hargreaves <dom@earth.li>
|
||||
Date: Tue, 20 Dec 2011 22:19:45 +0000
|
||||
Subject: [PATCH 1/4] cpan/CPAN: add NAME headings in modules with POD
|
||||
|
||||
This fixes the Debian Lintian warning about missing NAME sections in
|
||||
manpages.
|
||||
|
||||
Bug-Debian: http://bugs.debian.org/650448
|
||||
|
||||
Patch-Name: fixes/manpage_name_CPAN.diff
|
||||
---
|
||||
cpan/CPAN/lib/CPAN/Debug.pm | 4 ++++
|
||||
cpan/CPAN/lib/CPAN/HandleConfig.pm | 6 ++++++
|
||||
cpan/CPAN/lib/CPAN/Queue.pm | 4 ++++
|
||||
cpan/CPAN/lib/CPAN/Tarzip.pm | 4 ++++
|
||||
4 files changed, 18 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/cpan/CPAN/lib/CPAN/Debug.pm b/cpan/CPAN/lib/CPAN/Debug.pm
|
||||
index 23c4a36..48e394b 100644
|
||||
--- a/cpan/CPAN/lib/CPAN/Debug.pm
|
||||
+++ b/cpan/CPAN/lib/CPAN/Debug.pm
|
||||
@@ -71,6 +71,10 @@ sub debug {
|
||||
|
||||
__END__
|
||||
|
||||
+=head1 NAME
|
||||
+
|
||||
+CPAN::Debug - internal debugging for CPAN.pm
|
||||
+
|
||||
=head1 LICENSE
|
||||
|
||||
This program is free software; you can redistribute it and/or
|
||||
diff --git a/cpan/CPAN/lib/CPAN/HandleConfig.pm b/cpan/CPAN/lib/CPAN/HandleConfig.pm
|
||||
index 58ccbe5..bab607d 100644
|
||||
--- a/cpan/CPAN/lib/CPAN/HandleConfig.pm
|
||||
+++ b/cpan/CPAN/lib/CPAN/HandleConfig.pm
|
||||
@@ -6,6 +6,12 @@ use File::Spec ();
|
||||
use File::Basename ();
|
||||
use Carp ();
|
||||
|
||||
+=head1 NAME
|
||||
+
|
||||
+CPAN::HandleConfig - internal configuration handling for CPAN.pm
|
||||
+
|
||||
+=cut
|
||||
+
|
||||
$VERSION = "5.5003"; # see also CPAN::Config::VERSION at end of file
|
||||
|
||||
%can = (
|
||||
diff --git a/cpan/CPAN/lib/CPAN/Queue.pm b/cpan/CPAN/lib/CPAN/Queue.pm
|
||||
index e5d88ce..1222b37 100644
|
||||
--- a/cpan/CPAN/lib/CPAN/Queue.pm
|
||||
+++ b/cpan/CPAN/lib/CPAN/Queue.pm
|
||||
@@ -201,6 +201,10 @@ sub reqtype_of {
|
||||
|
||||
__END__
|
||||
|
||||
+=head1 NAME
|
||||
+
|
||||
+CPAN::Queue - internal queue support for CPAN.pm
|
||||
+
|
||||
=head1 LICENSE
|
||||
|
||||
This program is free software; you can redistribute it and/or
|
||||
diff --git a/cpan/CPAN/lib/CPAN/Tarzip.pm b/cpan/CPAN/lib/CPAN/Tarzip.pm
|
||||
index 972df6c..cf8aad4 100644
|
||||
--- a/cpan/CPAN/lib/CPAN/Tarzip.pm
|
||||
+++ b/cpan/CPAN/lib/CPAN/Tarzip.pm
|
||||
@@ -450,6 +450,10 @@ END
|
||||
|
||||
__END__
|
||||
|
||||
+=head1 NAME
|
||||
+
|
||||
+CPAN::Tarzip - internal handling of tar archives for CPAN.pm
|
||||
+
|
||||
=head1 LICENSE
|
||||
|
||||
This program is free software; you can redistribute it and/or
|
@ -112,6 +112,9 @@ Patch19: perl-5.16.1-perl-115206-Don-t-crash-when-vivifying.patch
|
||||
# Fix CVE-2012-6329, rhbz#884354
|
||||
Patch20: perl-5.17.6-Fix-misparsing-of-maketext-strings.patch
|
||||
|
||||
# Add NAME heading into CPAN PODs, rhbz#908113, CPANRT#73396
|
||||
Patch21: perl-5.16.2-cpan-CPAN-add-NAME-headings-in-modules-with-POD.patch
|
||||
|
||||
# Update some of the bundled modules
|
||||
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
|
||||
|
||||
@ -1579,6 +1582,7 @@ tarball from perl.org.
|
||||
%patch18 -p1
|
||||
%patch19 -p1
|
||||
%patch20 -p1
|
||||
%patch21 -p1
|
||||
|
||||
#copy the example script
|
||||
cp -a %{SOURCE5} .
|
||||
@ -1790,6 +1794,7 @@ pushd %{build_archlib}/CORE/
|
||||
'Fedora Patch18: Extend stack in File::Glob::glob, (RT#114984)' \
|
||||
'Fedora Patch19: Do not crash when vivifying $|' \
|
||||
'Fedora Patch20: Fix misparsing of maketext strings (CVE-2012-6329)' \
|
||||
'Fedora Patch21: Add NAME headings to CPAN modules (CPANRT#73396)' \
|
||||
%{nil}
|
||||
|
||||
rm patchlevel.bak
|
||||
@ -3069,8 +3074,9 @@ sed \
|
||||
|
||||
# Old changelog entries are preserved in CVS.
|
||||
%changelog
|
||||
* Fri Feb 15 2013 Petr Pisar <ppisar@redhat.com> - 4:5.16.2-259
|
||||
* Mon Feb 18 2013 Petr Pisar <ppisar@redhat.com> - 4:5.16.2-259
|
||||
- Sub-package autodie (bug #911226)
|
||||
- Add NAME headings to CPAN modules (bug #908113)
|
||||
|
||||
* Thu Feb 14 2013 Petr Pisar <ppisar@redhat.com> - 4:5.16.2-258
|
||||
- Fix perl-Encode-devel dependency declaration
|
||||
|
Loading…
Reference in New Issue
Block a user