Install libperl.so to -Dshrpdir value

This commit is contained in:
Petr Písař 2013-07-02 09:46:43 +02:00
parent bd3c2bdecb
commit bbd2a6e275
2 changed files with 68 additions and 0 deletions

View File

@ -0,0 +1,62 @@
From 9644657c410326749fd321d9c24944ec25afad2f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Thu, 20 Jun 2013 15:22:53 +0200
Subject: [PATCH] Install libperl.so to shrpdir on Linux
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Configure | 7 ++++---
Makefile.SH | 2 +-
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/Configure b/Configure
index 2f30261..825496e 100755
--- a/Configure
+++ b/Configure
@@ -8249,7 +8249,9 @@ esac
# Detect old use of shrpdir via undocumented Configure -Dshrpdir
case "$shrpdir" in
-'') ;;
+'')
+shrpdir=$archlibexp/CORE
+;;
*) $cat >&4 <<EOM
WARNING: Use of the shrpdir variable for the installation location of
the shared $libperl is not supported. It was never documented and
@@ -8279,7 +8281,6 @@ esac
# Add $xxx to ccdlflags.
# If we can't figure out a command-line option, use $shrpenv to
# set env LD_RUN_PATH. The main perl makefile uses this.
-shrpdir=$archlibexp/CORE
xxx=''
tmp_shrpenv=''
if "$useshrplib"; then
@@ -8294,7 +8295,7 @@ if "$useshrplib"; then
xxx="-Wl,-R$shrpdir"
;;
bsdos|linux|irix*|dec_osf|gnu*)
- xxx="-Wl,-rpath,$shrpdir"
+ # We want standard path
;;
next)
# next doesn't like the default...
diff --git a/Makefile.SH b/Makefile.SH
index 7733a32..a481183 100755
--- a/Makefile.SH
+++ b/Makefile.SH
@@ -266,7 +266,7 @@ ranlib = $ranlib
# installman commandline.
bin = $installbin
scriptdir = $scriptdir
-shrpdir = $archlibexp/CORE
+shrpdir = $shrpdir
privlib = $installprivlib
man1dir = $man1dir
man1ext = $man1ext
--
1.8.1.4

View File

@ -99,6 +99,9 @@ Patch14: perl-5.18.0-Suppress-system-Term-ReadLine-Gnu.patch
# Define SONAME for libperl.so
Patch15: perl-5.16.3-create_libperl_soname.patch
# Install libperl.so to -Dshrpdir value
Patch16: perl-5.16.3-Install-libperl.so-to-shrpdir-on-Linux.patch
# Update some of the bundled modules
# see http://fedoraproject.org/wiki/Perl/perl.spec for instructions
@ -1880,6 +1883,7 @@ tarball from perl.org.
%patch13 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%if !%{defined perl_bootstrap}
# Local patch tracking
@ -1899,6 +1903,7 @@ perl -x patchlevel.h \
'Fedora Patch13: Fix regmatch pointer 32-bit wraparound regression (RT#118175)' \
'Fedora Patch14: Do not use system Term::ReadLine::Gnu in tests (RT#118821)' \
'Fedora Patch15: Define SONAME for libperl.so' \
'Fedora Patch16: Install libperl.so to -Dshrpdir value' \
%{nil}
%endif
@ -1967,6 +1972,7 @@ perl regen.pl -v
/bin/sh Configure -des -Doptimize="$RPM_OPT_FLAGS" \
-Dccdlflags="-Wl,--enable-new-dtags" \
-Dlddlflags="-shared $RPM_OPT_FLAGS $RPM_LD_FLAGS" \
-Dshrpdir="%{_libdir}" \
-DDEBUGGING=-g \
-Dversion=%{perl_version} \
-Dmyhostname=localhost \