fix bug 171111
This commit is contained in:
parent
cdadfa3278
commit
9a56419abf
23
perl-5.8.7-IOC_SIZE.patch
Normal file
23
perl-5.8.7-IOC_SIZE.patch
Normal file
@ -0,0 +1,23 @@
|
||||
--- perl-5.8.7/perl.h.IOC_SIZE 2005-05-07 16:11:45.000000000 -0400
|
||||
+++ perl-5.8.7/perl.h 2005-10-25 16:56:10.000000000 -0400
|
||||
@@ -2508,11 +2508,17 @@
|
||||
|
||||
#ifndef IOCPARM_LEN
|
||||
# ifdef IOCPARM_MASK
|
||||
- /* on BSDish systes we're safe */
|
||||
+ /* on BSDish systems we're safe */
|
||||
# define IOCPARM_LEN(x) (((x) >> 16) & IOCPARM_MASK)
|
||||
# else
|
||||
- /* otherwise guess at what's safe */
|
||||
-# define IOCPARM_LEN(x) 256
|
||||
+# ifdef _IOC_SIZE
|
||||
+ /* on Linux systems we're safe */
|
||||
+# define IOCPARM_LEN(x) _IOC_SIZE(x)
|
||||
+# else
|
||||
+ /* otherwise guess at what's safe (we're UNSAFE!) */
|
||||
+# warning "unsafe assumption of IOCPARM_LEN=256"
|
||||
+# define IOCPARM_LEN(x) 256
|
||||
+# endif
|
||||
# endif
|
||||
#endif
|
||||
|
11
perl.spec
11
perl.spec
@ -5,7 +5,7 @@
|
||||
%define multilib_64_archs x86_64 s390x ppc64 sparc64
|
||||
|
||||
%define perlver 5.8.7
|
||||
%define perlrel 0.5.fc5
|
||||
%define perlrel 0.6.fc5
|
||||
%define perlepoch 3
|
||||
|
||||
Provides: perl(:WITH_PERLIO)
|
||||
@ -97,6 +97,9 @@ Patch30: perl-5.8.6-filter-simple-update.patch
|
||||
# Disable -DDEBUGGING and allow -g to do its job (#156113)
|
||||
Patch31: perl-5.8.7-no-debugging.patch
|
||||
|
||||
# Fix for bug 171111: missing IOCPARM_LEN
|
||||
Patch32: perl-5.8.7-IOC_SIZE.patch
|
||||
|
||||
# arch-specific patches
|
||||
Patch100: perl-5.8.1-fpic.patch
|
||||
Patch101: perl-5.8.0-libdir64.patch
|
||||
@ -242,6 +245,8 @@ more secure running of setuid perl scripts.
|
||||
%patch30 -p1
|
||||
%patch31 -p1
|
||||
|
||||
%patch32 -p1
|
||||
|
||||
%patch100 -p1
|
||||
%ifarch %{multilib_64_archs}
|
||||
%patch101 -p1
|
||||
@ -455,6 +460,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 25 2005 Jason Vas Dias <jvdias@redhat.com> - 3.5.8.7-0.6
|
||||
- fix bug 171111 : define ioctl length macro IOCPARM_LEN(x)
|
||||
macro to be _IOC_SIZE(x), not 256 - upstream bug raised.
|
||||
|
||||
* Sun Oct 09 2005 Warren Togami <wtogami@redhat.com> - 3:5.8.7-0.4
|
||||
- rebuild for db4 (#170235)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user