5.30.2 bump
This commit is contained in:
parent
003b5fe19a
commit
9881007ed4
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,3 +32,4 @@ perl-5.12.1.tar.gz
|
||||
/perl-5.28.2.tar.xz
|
||||
/perl-5.30.0.tar.xz
|
||||
/perl-5.30.1.tar.xz
|
||||
/perl-5.30.2.tar.xz
|
||||
|
@ -66,7 +66,7 @@ Provides: perl(B) = 1.76 \
|
||||
Provides: perl(B::Concise) = 1.004 \
|
||||
Provides: perl(B::Deparse) = 1.49 \
|
||||
Provides: perl(B::OBJECT) \
|
||||
Provides: perl(B::Op_private) = 5.030001 \
|
||||
Provides: perl(B::Op_private) = 5.030002 \
|
||||
Provides: perl(B::Showlex) = 1.05 \
|
||||
Provides: perl(B::Terse) = 1.09 \
|
||||
Provides: perl(B::Xref) = 1.07 \
|
||||
@ -255,7 +255,7 @@ Requires: perl(bytes) \
|
||||
Requires: perl(constant) \
|
||||
Requires: perl(strict) \
|
||||
Requires: perl(warnings) \
|
||||
Provides: perl(Compress::Raw::Bzip2) = 2.084 \
|
||||
Provides: perl(Compress::Raw::Bzip2) = 2.089 \
|
||||
%{nil}
|
||||
%global gendep_perl_Compress_Raw_Bzip2_debuginfo \
|
||||
%{nil}
|
||||
@ -1204,8 +1204,8 @@ Requires: perl(Module::CoreList) \
|
||||
Requires: perl(strict) \
|
||||
Requires: perl(version) \
|
||||
Requires: perl(warnings) \
|
||||
Provides: perl(Module::CoreList) = 5.20191110 \
|
||||
Provides: perl(Module::CoreList::Utils) = 5.20191110 \
|
||||
Provides: perl(Module::CoreList) = 5.20200314 \
|
||||
Provides: perl(Module::CoreList::Utils) = 5.20200314 \
|
||||
%{nil}
|
||||
%global gendep_perl_Module_CoreList_tools \
|
||||
Requires: perl(Getopt::Long) \
|
||||
@ -2176,7 +2176,7 @@ Provides: perl(constant) = 1.33 \
|
||||
%global gendep_perl_debugger \
|
||||
Requires: perl(strict) \
|
||||
Provides: perl(DB) = 1.08 \
|
||||
Provides: perl(dumpvar.pl) = 5.30.1 \
|
||||
Provides: perl(dumpvar.pl) = 5.30.2 \
|
||||
Provides: perl(perl5db.pl) = 1.55 \
|
||||
%{nil}
|
||||
%global gendep_perl_debuginfo \
|
||||
@ -2319,14 +2319,15 @@ Requires: perl(warnings) \
|
||||
Requires: perl(warnings::register) \
|
||||
Provides: perl(:MODULE_COMPAT_5.30.0) \
|
||||
Provides: perl(:MODULE_COMPAT_5.30.1) \
|
||||
Provides: perl(:VERSION) = 5.30.1 \
|
||||
Provides: perl(:MODULE_COMPAT_5.30.2) \
|
||||
Provides: perl(:VERSION) = 5.30.2 \
|
||||
Provides: perl(:WITH_64BIT) \
|
||||
Provides: perl(:WITH_ITHREADS) \
|
||||
Provides: perl(:WITH_LARGEFILES) \
|
||||
Provides: perl(:WITH_PERLIO) \
|
||||
Provides: perl(:WITH_THREADS) \
|
||||
Provides: perl(AnyDBM_File) = 1.01 \
|
||||
Provides: perl(Config) = 5.030001 \
|
||||
Provides: perl(Config) = 5.030002 \
|
||||
Provides: perl(File::Glob) = 1.32 \
|
||||
Provides: perl(PerlIO) = 1.10 \
|
||||
Provides: perl(PerlIO::encoding) = 0.27 \
|
||||
@ -2366,7 +2367,7 @@ Provides: perl(locale) = 1.09 \
|
||||
%global gendep_perl_meta_notation \
|
||||
Requires: perl(strict) \
|
||||
Requires: perl(warnings) \
|
||||
Provides: perl(meta_notation) = 5.30.1 \
|
||||
Provides: perl(meta_notation) = 5.30.2 \
|
||||
%{nil}
|
||||
%global gendep_perl_mro \
|
||||
Requires: perl(XSLoader) \
|
||||
@ -2401,9 +2402,9 @@ Requires: perl(warnings) \
|
||||
Provides: perl(perlfaq) = 5.20190126 \
|
||||
%{nil}
|
||||
%global gendep_perl_ph \
|
||||
Provides: perl(sys/ioctl.ph) = 5.30.1 \
|
||||
Provides: perl(sys/syscall.ph) = 5.30.1 \
|
||||
Provides: perl(syscall.ph) = 5.30.1 \
|
||||
Provides: perl(sys/ioctl.ph) = 5.30.2 \
|
||||
Provides: perl(sys/syscall.ph) = 5.30.2 \
|
||||
Provides: perl(syscall.ph) = 5.30.2 \
|
||||
%{nil}
|
||||
%global gendep_perl_podlators \
|
||||
Requires: perl(:VERSION) >= 5.6.0 \
|
||||
|
@ -56,7 +56,7 @@ diff --git a/t/op/sprintf2.t b/t/op/sprintf2.t
|
||||
index 84259a4afd..5fee8efede 100644
|
||||
--- a/t/op/sprintf2.t
|
||||
+++ b/t/op/sprintf2.t
|
||||
@@ -1153,4 +1153,11 @@ foreach(
|
||||
@@ -1153,6 +1153,14 @@ foreach(
|
||||
is sprintf("%.0f", $_), sprintf("%-.0f", $_), "special-case %.0f on $_";
|
||||
}
|
||||
|
||||
@ -67,7 +67,10 @@ index 84259a4afd..5fee8efede 100644
|
||||
+ like($@, qr/^Numeric format result too large at /,
|
||||
+ "croak for very large numeric format results");
|
||||
+}
|
||||
done_testing();
|
||||
+
|
||||
{
|
||||
# gh #17221
|
||||
my ($off1, $off2);
|
||||
--
|
||||
2.20.1
|
||||
|
||||
|
51
perl.spec
51
perl.spec
@ -1,4 +1,4 @@
|
||||
%global perl_version 5.30.1
|
||||
%global perl_version 5.30.2
|
||||
%global perl_epoch 4
|
||||
%global perl_arch_stem -thread-multi
|
||||
%global perl_archname %{_arch}-%{_os}%{perl_arch_stem}
|
||||
@ -100,7 +100,7 @@ License: GPL+ or Artistic
|
||||
Epoch: %{perl_epoch}
|
||||
Version: %{perl_version}
|
||||
# release number must be even higher, because dual-lived modules will be broken otherwise
|
||||
Release: 451%{?dist}
|
||||
Release: 452%{?dist}
|
||||
Summary: Practical Extraction and Report Language
|
||||
Url: https://www.perl.org/
|
||||
Source0: https://www.cpan.org/src/5.0/perl-%{perl_version}.tar.xz
|
||||
@ -164,9 +164,6 @@ Patch12: perl-5.27.8-hints-linux-Add-lphtread-to-lddlflags.patch
|
||||
# Pass the correct CFLAGS to dtrace
|
||||
Patch13: perl-5.28.0-Pass-CFLAGS-to-dtrace.patch
|
||||
|
||||
# Do not panic when outputting a warning, RT#134059, fixed after 5.31.0
|
||||
Patch15: perl-5.31.0-PATCH-perl-134059-panic-outputting-a-warning.patch
|
||||
|
||||
# Fix memory handling when parsing string literals, fixed after 5.31.0
|
||||
Patch16: perl-5.31.0-S_scan_const-Properly-test-if-need-to-grow.patch
|
||||
|
||||
@ -262,11 +259,6 @@ Patch54: perl-5.31.3-regcomp.c-Fix-wrong-limit-test.patch
|
||||
# fixed after 5.31.3
|
||||
Patch56: perl-5.31.3-perl-134230-don-t-interpret-0x-0b-when-numifying-str.patch
|
||||
|
||||
# Fix a buffer overflow when compiling a regular expression with many
|
||||
# branches, RT#134329, fixed after 5.31.3
|
||||
# This is a binary patch and requires git.
|
||||
Patch58: perl-5.30.0-PATCH-perl-134329-Use-after-free-in-regcomp.c.patch
|
||||
|
||||
# Correct a misspelling in perlrebackslash documentation, RT#134395,
|
||||
# fixed after 5.31.3
|
||||
Patch59: perl-5.31.3-Supply-missing-right-brace-in-regex-example.patch
|
||||
@ -303,14 +295,6 @@ Patch70: perl-5.31.5-prevent-a-race-between-name-based-stat-and-an-open-m
|
||||
# in upstream after 5.31.5
|
||||
Patch71: perl-5.30.1-handle-s-being-updated-without-len-being-updated.patch
|
||||
|
||||
# Fix GCC 10 version detection, <https://github.com/Perl/perl5/pull/17295>,
|
||||
# in upstream after 5.31.5
|
||||
Patch72: perl-5.31.5-Adapt-Configure-to-GCC-version-10.patch
|
||||
|
||||
# Fix a memory leak when compiling a regular expression with a non-word class,
|
||||
# GH#17218, in upsream after 5.31.5
|
||||
Patch73: perl-5.31.5-PATCH-gh-17218-memory-leak.patch
|
||||
|
||||
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
|
||||
Patch200: perl-5.16.3-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
|
||||
|
||||
@ -328,8 +312,6 @@ BuildRequires: gcc
|
||||
%if %{with gdbm}
|
||||
BuildRequires: gdbm-devel
|
||||
%endif
|
||||
# git for PATCH-perl-134329-Use-after-free-in-regcomp.c.patch
|
||||
BuildRequires: git-core
|
||||
# glibc-common for iconv
|
||||
BuildRequires: glibc-common
|
||||
%if %{with perl_enables_groff}
|
||||
@ -370,7 +352,7 @@ BuildRequires: rsyslog
|
||||
|
||||
|
||||
# compat macro needed for rebuild
|
||||
%global perl_compat perl(:MODULE_COMPAT_5.30.1)
|
||||
%global perl_compat perl(:MODULE_COMPAT_5.30.2)
|
||||
|
||||
Requires: %perl_compat
|
||||
Requires: perl-interpreter%{?_isa} = %{perl_epoch}:%{perl_version}-%{release}
|
||||
@ -554,6 +536,7 @@ License: (GPL+ or Artistic) and BSD and HSRL and MIT and UCD and Public d
|
||||
# Compat provides
|
||||
Provides: %perl_compat
|
||||
Provides: perl(:MODULE_COMPAT_5.30.0)
|
||||
Provides: perl(:MODULE_COMPAT_5.30.1)
|
||||
# Interpreter version to fulfil required genersted from "require 5.006;"
|
||||
Provides: perl(:VERSION) = %{perl_version}
|
||||
# Integeres are 64-bit on all platforms
|
||||
@ -953,7 +936,7 @@ Perl 5 class that implements a struct-like data structure.
|
||||
Summary: Low-Level Interface to bzip2 compression library
|
||||
License: GPL+ or Artistic
|
||||
Epoch: 0
|
||||
Version: 2.084
|
||||
Version: 2.089
|
||||
Requires: perl(Exporter), perl(File::Temp)
|
||||
%if %{defined perl_bootstrap}
|
||||
%gendep_perl_Compress_Raw_Bzip2
|
||||
@ -2847,7 +2830,7 @@ encoder/decoder. These encoding methods are specified in RFC 2045 - MIME
|
||||
Summary: What modules are shipped with versions of perl
|
||||
License: GPL+ or Artistic
|
||||
Epoch: 1
|
||||
Version: 5.20191110
|
||||
Version: 5.20200314
|
||||
Requires: %perl_compat
|
||||
Requires: perl(List::Util)
|
||||
Requires: perl(version) >= 0.88
|
||||
@ -2865,7 +2848,7 @@ are shipped with each version of perl.
|
||||
Summary: Tool for listing modules shipped with perl
|
||||
License: GPL+ or Artistic
|
||||
Epoch: 1
|
||||
Version: 5.20191110
|
||||
Version: 5.20200314
|
||||
Requires: %perl_compat
|
||||
Requires: perl(feature)
|
||||
Requires: perl(version) >= 0.88
|
||||
@ -4325,7 +4308,6 @@ you're not running VMS, this module does nothing.
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch15 -p1
|
||||
%patch16 -p1
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
@ -4358,15 +4340,6 @@ you're not running VMS, this module does nothing.
|
||||
%patch53 -p1
|
||||
%patch54 -p1
|
||||
%patch56 -p1
|
||||
# PATCH-perl-134329-Use-after-free-in-regcomp.c.patch is a binary patch
|
||||
git init-db .
|
||||
git config --replace-all gc.auto 0 # Prevent from racing with "rm -rf .git"
|
||||
git config --replace-all user.email '<nobody@localhost>'
|
||||
git config --replace-all user.name 'Nobody'
|
||||
git add .
|
||||
git commit --message 'Import'
|
||||
git am < %{PATCH58}
|
||||
rm -rf .git # Perl tests examine a git repository
|
||||
%patch59 -p1
|
||||
%patch61 -p1
|
||||
%patch62 -p1
|
||||
@ -4379,8 +4352,6 @@ rm -rf .git # Perl tests examine a git repository
|
||||
%patch69 -p1
|
||||
%patch70 -p1
|
||||
%patch71 -p1
|
||||
%patch72 -p1
|
||||
%patch73 -p1
|
||||
%patch200 -p1
|
||||
%patch201 -p1
|
||||
|
||||
@ -4401,7 +4372,6 @@ perl -x patchlevel.h \
|
||||
'Fedora Patch11: Replace EU::MakeMaker dependency with EU::MM::Utils in IPC::Cmd (bug #1129443)' \
|
||||
'Fedora Patch12: Link XS modules to pthread library to fix linking with -z defs' \
|
||||
'Fedora Patch13: Pass the correct CFLAGS to dtrace' \
|
||||
'Fedora Patch15: Do not panic when outputting a warning (RT#134059)' \
|
||||
'Fedora Patch16: Fix memory handling when parsing string literals' \
|
||||
'Fedora Patch17: Fix an undefined behavior in shifting IV variables' \
|
||||
'Fedora Patch18: Fix an undefined behavior in shifting IV variables' \
|
||||
@ -4434,7 +4404,6 @@ perl -x patchlevel.h \
|
||||
'Fedora Patch53: Do not run File-Find tests in parallel' \
|
||||
'Fedora Patch54: Fix parsing a Unicode property name when compiling a regular expression' \
|
||||
'Fedora Patch56: Do not interpret 0x and 0b prefixes when numifying strings (RT#134230)' \
|
||||
'Fedora Patch58: Fix a buffer overflow when compiling a regular expression with many branches (RT#134329)' \
|
||||
'Fedora Patch59: Correct a misspelling in perlrebackslash documentation (RT#134395)' \
|
||||
'Fedora Patch61: Fix a detection for futimes (RT#134432)' \
|
||||
'Fedora Patch62: Fix a detection for futimes (RT#134432)' \
|
||||
@ -4447,8 +4416,6 @@ perl -x patchlevel.h \
|
||||
'Fedora Patch69: Fix an unintended upgrade to UTF-8 in the middle of a transliteration' \
|
||||
'Fedora Patch70: Fix a race in File::stat() tests (GH#17234)' \
|
||||
'Fedora Patch71: Fix a buffer overread when parsing a number (GH#17279)' \
|
||||
'Fedora Patch72: Fix GCC 10 version detection (GH#17295)' \
|
||||
'Fedora Patch73: Fix a memory leak when compiling a regular expression with a non-word class (GH#17218)' \
|
||||
'Fedora Patch200: Link XS modules to libperl.so with EU::CBuilder on Linux' \
|
||||
'Fedora Patch201: Link XS modules to libperl.so with EU::MM on Linux' \
|
||||
%{nil}
|
||||
@ -7205,6 +7172,10 @@ popd
|
||||
|
||||
# Old changelog entries are preserved in CVS.
|
||||
%changelog
|
||||
* Mon Mar 16 2020 Jitka Plesnikova <jplesnik@redhat.com> - 4:5.30.2-452
|
||||
- 5.30.2 bump (see <https://metacpan.org/pod/release/SHAY/perl-5.30.2/pod/perldelta.pod>
|
||||
for release notes)
|
||||
|
||||
* Mon Feb 03 2020 Petr Pisar <ppisar@redhat.com> - 4:5.30.1-451
|
||||
- Subpackage AutoLoader and AutoSplit
|
||||
- Subpackage ExtUtils-Constant
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (perl-5.30.1.tar.xz) = 8f3339efdcd1bb58fa58a90042181bef86bb09e4598c737e446ed43b56d2ab23d67eced5e36fb08fc61e076acfdb572a12e46a1277f5299a3f412054df0b88bf
|
||||
SHA512 (perl-5.30.2.tar.xz) = b945c95f44a58b9cc920c926e23017c4270c0dc8daf0bf8169cd7c8f6b8f980f1780bee4fbd525df518edc50f08364ba65988cb17e72a1667f50226459b65087
|
||||
|
Loading…
Reference in New Issue
Block a user