- 455410 http://rt.perl.org/rt3/Public/Bug/Display.html?id=54934 Attempt to
free unreferenced scalar fiddling with the symbol table Keep the refcount of the globs generated by PerlIO::via balanced.
This commit is contained in:
parent
e3bdec83b4
commit
7e2d107a0d
24
perl-5.10.0-PerlIO-via-change34025.patch
Normal file
24
perl-5.10.0-PerlIO-via-change34025.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
Change 34025 by rgs@scipion on 2008/06/08 14:00:59
|
||||||
|
|
||||||
|
Fix for bug [perl #54934] Attempt to free unreferenced scalar
|
||||||
|
fiddling with the symbol table
|
||||||
|
Keep the refcount of the globs generated by PerlIO::via balanced.
|
||||||
|
|
||||||
|
Affected files ...
|
||||||
|
|
||||||
|
... //depot/perl/ext/PerlIO/via/via.pm#9 edit
|
||||||
|
... //depot/perl/ext/PerlIO/via/via.xs#17 edit
|
||||||
|
|
||||||
|
Differences ...
|
||||||
|
diff -up perl-5.10.0/ext/PerlIO/via/via.xs.34025 perl-5.10.0/ext/PerlIO/via/via.xs
|
||||||
|
--- perl-5.10.0/ext/PerlIO/via/via.xs.34025 2007-12-18 11:47:07.000000000 +0100
|
||||||
|
+++ perl-5.10.0/ext/PerlIO/via/via.xs 2009-01-19 09:15:46.000000000 +0100
|
||||||
|
@@ -89,7 +89,7 @@ PerlIOVia_method(pTHX_ PerlIO * f, char
|
||||||
|
if (!s->fh) {
|
||||||
|
GV *gv = newGVgen(HvNAME_get(s->stash));
|
||||||
|
GvIOp(gv) = newIO();
|
||||||
|
- s->fh = newRV_noinc((SV *) gv);
|
||||||
|
+ s->fh = newRV((SV *) gv);
|
||||||
|
s->io = GvIOp(gv);
|
||||||
|
}
|
||||||
|
IoIFP(s->io) = PerlIONext(f);
|
10
perl.spec
10
perl.spec
@ -7,7 +7,7 @@
|
|||||||
|
|
||||||
Name: perl
|
Name: perl
|
||||||
Version: %{perl_version}
|
Version: %{perl_version}
|
||||||
Release: 53%{?dist}
|
Release: 54%{?dist}
|
||||||
Epoch: %{perl_epoch}
|
Epoch: %{perl_epoch}
|
||||||
Summary: Practical Extraction and Report Language
|
Summary: Practical Extraction and Report Language
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -123,6 +123,7 @@ Patch30: perl-5.10.0-Change33896.patch
|
|||||||
Patch31: perl-5.10.0-Change33897.patch
|
Patch31: perl-5.10.0-Change33897.patch
|
||||||
|
|
||||||
Patch32: perl-5.10.0-ArchiveTar1.40.patch
|
Patch32: perl-5.10.0-ArchiveTar1.40.patch
|
||||||
|
Patch33: perl-5.10.0-PerlIO-via-change34025.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{perl_version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{perl_version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: tcsh, dos2unix, man, groff
|
BuildRequires: tcsh, dos2unix, man, groff
|
||||||
@ -863,6 +864,7 @@ upstream tarball from perl.org.
|
|||||||
%patch30 -p1
|
%patch30 -p1
|
||||||
%patch31 -p1
|
%patch31 -p1
|
||||||
%patch32 -p1
|
%patch32 -p1
|
||||||
|
%patch33 -p1
|
||||||
|
|
||||||
#
|
#
|
||||||
# Candidates for doc recoding (need case by case review):
|
# Candidates for doc recoding (need case by case review):
|
||||||
@ -1097,6 +1099,7 @@ perl -x patchlevel.h '33881 Integrate Changes 33825, 33826, 33829'
|
|||||||
perl -x patchlevel.h '33896 Eliminate POSIX::int_macro_int, and all the complex AUTOLOAD fandango'
|
perl -x patchlevel.h '33896 Eliminate POSIX::int_macro_int, and all the complex AUTOLOAD fandango'
|
||||||
perl -x patchlevel.h '33897 Replaced the WEXITSTATUS, WIFEXITED, WIFSIGNALED, WIFSTOPPED, WSTOPSIG'
|
perl -x patchlevel.h '33897 Replaced the WEXITSTATUS, WIFEXITED, WIFSIGNALED, WIFSTOPPED, WSTOPSIG'
|
||||||
perl -x patchlevel.h 'Fedora Patch32: CVE-2007-4829 Update Archive::Tar to 1.40'
|
perl -x patchlevel.h 'Fedora Patch32: CVE-2007-4829 Update Archive::Tar to 1.40'
|
||||||
|
perl -x patchlevel.h '54934 Change 34025 refcount of the globs generated by PerlIO::via balanced'
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -1704,6 +1707,11 @@ make test
|
|||||||
|
|
||||||
# Old changelog entries are preserved in CVS.
|
# Old changelog entries are preserved in CVS.
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.10.0-54
|
||||||
|
- 455410 http://rt.perl.org/rt3/Public/Bug/Display.html?id=54934
|
||||||
|
Attempt to free unreferenced scalar fiddling with the symbol table
|
||||||
|
Keep the refcount of the globs generated by PerlIO::via balanced.
|
||||||
|
|
||||||
* Mon Dec 22 2008 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.10.0-53
|
* Mon Dec 22 2008 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.10.0-53
|
||||||
- add missing XHTML.pm into Pod::Simple
|
- add missing XHTML.pm into Pod::Simple
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user